Beams & Shells

• The features in the Concept menu are used to create and modify line bodies and/or surface bodies which become FE beam or shell models

• Features in Tools menu, like Mid-Surface and Joint, are used extensively for modeling Shells

• To model Beams and Shells, you can also use:
  – Create line or surface bodies using the features in the Draw toolbox to design a 2D sketch and/or generate a 3D model
  – Use the Import external geometry file feature
  – Extract beams and shells from solids
  – Other tools like Thin, Extrude, etc.

• Line bodies
  – Lines from points
  – Lines from sketches
  – Lines from edges

• Surface bodies
  – Surfaces from line bodies
  – Surfaces from sketches
  – Surfaces from 3D edges
  – Mid-Surface
  – Joint
Creating Line Bodies (1)

Lines From Points

[Main Menu] Concept → Lines From Points

- Points can be any 2D sketch points, 3D model vertices or Point Feature (PF) points.
- A point segment is a straight line connecting two selected points.
- The feature can produce multiple Line Bodies, depending on the connectivity of the chosen point segments.
- The Operation field allows Add or Add Frozen choices for line bodies.
Creating Line Bodies (2)

Lines From Sketches

[Main Menu] Concept ➔ Lines From Sketches

- Line bodies created based on sketches and planes from faces
- Multiple Line Bodies may be created depending on the connectivity of the edges within the base objects
- Select sketches or planes in the feature tree then “Apply” in the detail window
- Multiple sketches, planes, and combinations of sketches and planes can be used as the base object for the creation of line bodies
Creating Line Bodies (3)

Lines From Edges

[Main Menu] Concept → Lines From Edges

– Creates line bodies based on existing 2D and 3D model edges
– Can produce multiple line bodies depending on the connectivity of the selected edges and faces
– Can select edges and/or faces through two fields in the detail window then “Apply”
Split Edges

Split Line Body

[Main Menu] Concept → Split Edges

– Splits line body edges into two pieces
– Split location is controlled by the Fraction property (e.g. 0.5 = split in half).
– Other Options:
  • Split by Delta: Distance between each split is given by Delta along the edge
  • Split by N: Number of Divisions of the Edge

Selected line

Fraction = 0.5

Fraction = 0.25
Cross Sections

- Cross sections are attributes assigned to line bodies to define beam properties in the FE simulation
- In DM, cross sections are represented by sketches and are controlled by a set of dimensions
  - Note: Design-Modeler uses a different coordinate system for cross sections than the one used in the ANSYS environment (described later)
Cross Sections (2)

- Cross sections are selected from the Concept menu
- A cross section branch is inserted in the tree where each chosen cross section is listed
Cross Sections (3)

Highlight the cross section in the Tree to modify dimensions in the Details window.
Cross Sections (4)

Dimension Editing

– Cross section dimensions can be repositioned via a RMB and choosing Move Dimensions
Cross Sections (5)

Assigning a cross section to a line body:

– Highlight the line body in the Tree
– A cross section property appears in the detail window
– Click in this field and choose the desired cross section from the drop down list
Cross Sections (6)

- A User Integrated section can be defined in DM
- The cross section is not sketched, rather the cross section’s properties are placed in the details window

- \( A \) = Area of section.
- \( I_{xx} \) = Moment of inertia about the x axis.
- \( I_{xy} \) = Product of inertia.
- \( I_{yy} \) = Moment of inertia about the y axis.
- \( I_w \) = Warping constant.
- \( J \) = Torsional constant.
- \( CG_x \) = X coordinate of centroid.
- \( CG_y \) = Y coordinate of centroid.
- \( SH_x \) = X coordinate of shear center.
- \( SH_y \) = Y coordinate of shear center.
Cross Sections (8)

Steps for creating a User Defined Cross Section:

- Select Cross Section → User Defined from Concept Menu
- A Cross Section node with an empty sketch will be added in the tree outline
- Click Sketching tab to draw the required sketch (Must be a closed Sketch)
- Click Generate. DM will compute the Cross Section properties and show them in the details view. These properties cannot be changed.
Cross Section Alignment (1)

- As shown below, in Design-Modeler the cross section lies in the XY plane
- Cross section alignment is defined by:
  - A local or cross section +Y direction
    - Default alignment is with the global +Y direction unless that would result in an invalid alignment in which case +Z is used
  - Note: In the ANSYS Classic Environment, the cross section lies in the YZ plane and uses the X direction as the edge tangent. This difference in orientation has no bearing on the analysis.
Cross Section Alignment (2)

A color code is used to indicate cross section status for line bodies in the Viewer

- Violet: no cross section assigned
- Black: cross section assigned with valid alignment
- Red: cross section assigned with invalid alignment

The line body icons in the tree have similar visual aids

- Green: cross section assigned with valid cross section alignment
- Yellow: no cross section assigned or default alignment
- Red: invalid cross section alignment
Cross Section Alignment (3)

Checking alignment can be done graphically using the View menu

– Choose “Show Cross Section Alignments”
  • Green arrow = +Y, blue arrow = edge tangent of cross section

– Or choose “Cross Section Solids”
Cross Section Alignment (4)

- Because a default alignment is chosen, Cross Section orientation will almost always need to be modified.

- There are 2 methods for modifying the Cross section alignment, “Selection” and “Vector”:
  - The selection method uses existing geometry (edges, points, etc.) as alignment reference.
  - The vector method uses input according to X, Y, Z coordinate directions.
  - For either method a rotation angle can be input and/or the orientation reversed.

### Selection Method

<table>
<thead>
<tr>
<th>Alignment Mode</th>
<th>Cross Section Alignment</th>
<th>Alignment X</th>
<th>Alignment Y</th>
<th>Alignment Z</th>
<th>Rotate</th>
<th>Reverse Orientation?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selection</td>
<td>None (+Z by default)</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0°</td>
<td>No</td>
</tr>
</tbody>
</table>

### Vector Method

<table>
<thead>
<tr>
<th>Alignment Mode</th>
<th>Cross Section Alignment</th>
<th>Alignment X</th>
<th>Alignment Y</th>
<th>Alignment Z</th>
<th>Rotate</th>
<th>Reverse Orientation?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vector</td>
<td>Vector</td>
<td>0</td>
<td>0</td>
<td>1</td>
<td>0°</td>
<td>No</td>
</tr>
</tbody>
</table>

- To access the Alignment Mode Details, click on the Line Body in the Tree.
- RMB in the Viewer and Choose “Select All.”
- Alignment Mode details show up.
Cross Section Alignment (5)

Modifying the Cross Section orientation by vector

- Switch to “Vector” alignment mode
- Enter the desired coordinate values
- Enter rotation angle if desired
- Reverse orientation if desired
Cross Section Alignment (6)

Modifying the cross section orientation by selection

1. Select the line body to be aligned in graphics window

2. With “Selection” method active click in the alignment field

3. Select the geometry to be used for alignment
Cross Section Alignment (7)

Alignment using lines or axes

- Line chosen for alignment
- Axis chosen for alignment
- Edge Tangent
- Y
Cross Section Alignment (8)

Alignment using face normal
Cross Section Alignment (9)

Alignment using sketch points

Note: The order of point selection determines cross section alignment
Cross Section Offset

After assigning a cross section to a line body, the Detail property allows users to specify the type of offset to use with the cross section:

- **Centroid**: The cross section is centered on the line body according to its centroid (default)
- **Shear Center**: The cross section is centered on the line body according to its shear center
  - Note the graphical display for centroid and shear center appear the same however. When analyzed, the shear center is used
- **Origin**: The cross section is not offset and is taken exactly as it appears in its sketch
- **User Defined**: User specifies cross section’s X and Y offsets
Cross Section Offset (2)

Line Body with cross section displayed

Origin offset (no offset)

Line Body

Centroid/Shear Center offset
Surfaces From Edges

[Main Menu] Concept → Surfaces from Edges

- Creates surface body using line body edges as the boundary
- Line body edges must form non-intersecting closed loops
- Each closed loop creates a frozen Surface Body
- The loops should form a shape such that a simple surface can be inserted into the model:
  - Planes, cylinders, tori, cones, spheres and simple twisted surfaces

Details window:
- Flip surface normals
- Input thickness which will be transferred to the FE model
Surfaces From Edges (2)

- Creates surfaces from existing body edges
- Can be solid or line body edges
- Edges must produce non-intersecting closed loops

Existing solid body edges are selected for new surface boundary.

New, frozen, surface body generated (note, solid body is hidden).
Surfaces From Edges (3)

- A line body with no cross section can be used to tie together surface models.
- In this case, the line body acts merely as a mechanism to insure a continuous mesh at the surface boundaries.

Line Body (no cross section)

Result is continuous FE mesh at surface interface
Surfaces From Sketches

[Main Menu] Concept → Surfaces from Sketches
- Creates surface bodies using sketches as boundaries (single or multiple sketches are OK)
- Base sketches must be closed profiles which are not self intersecting
- May choose to “Add” or “Add Frozen” operations
- Can reverse normal direction “No” in Orient With Plane Normal field
- Can enter thickness which will be used in creating the FE model
Mid-Surface

- Extracts surface body that is midway between existing solid body faces
- Two Options:
  - Manual: Operates only on user specified face pairs
  - Automatic: Provides option to search for other matching face pairs

Details View of Mid-Surface

Mid-Surface created for a pipe geometry
Mid-Surface: Manual (1)

Manual Method

- Set the Selection Method to “Manual”
- Select pair of faces, one pair at a time, in Face Pairs input
- The order of selection determines the surface normal direction
- Notice the first surface picked is displayed in purple, the second is shown in pink
- When the selection is finalized the selected pairs are displayed in dark and light blue colors
Mid-Surface: Manual (2)

- Multiple surface pairs may be selected for a single mid-surface operation, however they must be selected as opposing pairs.
- The correct order of selection of faces for the previous example can be as in the image shown on right hand side here.
- Adjacent face pairs will be grouped together if within the “Thickness Tolerance” (see below).

If $|T1 - T2| < \text{Thickness Tolerance}$: surfaces are grouped.
Mid-Surface: Automatic (1)

Automatic Method

• Switching the Selection Method from “Manual” to “Automatic” exposes several additional options
  – Bodies to search: Limits search to visible bodies, selected bodies or all bodies
  – Minimum and maximum threshold sets search range (thickness) for face pairs
• Options like Extra Trimming are very useful with “Automatic” method
  – Provides options for situations where trimming problems with surface bodies occur
• Preserve Bodies? allows you to save the solid bodies from which surfaces are created (default is No)
Mid-Surface: Automatic (2)

• When the search is complete, the number of pairs detected is listed in the details and displayed graphically.

• Mid surface creation is completed by Generating the surface body.
Mid-Surface: Trimming (1)

Trimming Options

• In cases where trimming problems occur there are several options available to attempt corrections

• Example:
  – Using the previous model we generate the surface model without removing the unwanted face pairs
  – Since the pairs created result in T junctions, trimming problems occur
  – Notice the mid-surface branch in the tree is displayed with a yellow check indicating there is a problem
Mid-Surface: Trimming (2)

- Using the RMB option we can “Show Problematic Geometry”
- The resulting plot shows regions where trimming problems have occurred
  - The default behavior is to intersect any untrimmed surfaces with the original solid body
  - Other options:

![Diagram showing options for trimming and geometry issues]

- Delete Untrimmed
- No Extra Trimming
Mid-Surface: Effects of Maximum Threshold

- In this case, **Maximum Threshold** was increased to intentionally detect unwanted surfaces.
- Clicking in the **Face Pairs** field activates selection mode.
- RMB in the graphics window provides the optional selection modes.
- In this case, we can choose “Remove Face Pairs”. then select one of the faces to be removed.
- When selection is complete, press **Generate** to update the model.
- Please note that in above steps, when removing face pairs, selecting one of the faces will remove the pair.
Mid-Surface: Sewing Tolerance

Sewing Tolerance

• If gaps exist in adjacent face pairs, they will be sewn together within the Sewing Tolerance
• If Gap < Sewing Tolerance, Surfaces are grouped and connected (Conformal Mesh between them)
Mid Surface: Selection Tolerance

Selection Tolerance
- Tolerance is used to detect face pairs in case of imperfect offsets
- Selecting an undetected pair manually, provides feedback on tolerance value required, which can be used for automated selection
- Default value is set to zero

Without Selection Tolerance
Selection tolerance value is suggested to user
All the pairs detected successfully with Selection tolerance
Joint

- Joins surface bodies together such that their contact regions share common edge
  - Prerequisite for conformal meshes
- Takes two or more surface bodies as input
- Imprints edges on all bodies where they make contact
Edge Joints (1)

- Edge Joints are the glue that holds together bodies where a continuous mesh is desired.
- Creating surface and/or line multi-body parts with coincident edges results in automatic creation of edge joints.
- Joints can be created manually ([Main Menu] Tools → Joint) where no coincident topology exists.
Edge Joints (2)

- Edge Joints can be viewed by turning on the Edge Joints option in the View menu.
- Edge joints are displayed in either blue or red.
  - Blue: edge joint is contained in properly defined multi-body part
  - Red: edge joint not grouped into the same part

![No Edge Joint](image1)

![With Edge Joint](image2)

*View menu screenshot showing the 'Edge Joints' option highlighted.*
Workshop 6 – Beam & Shell Modeling