Copyright and Trademark Information

© 2017 ANSYS, Inc. Unauthorized use, distribution or duplication is prohibited.

ANSYS, ANSYS Workbench, AUTODYN, CFX, FLUENT and any and all ANSYS, Inc. brand, product, service and feature names, logos and slogans are registered trademarks or trademarks of ANSYS, Inc. or its subsidiaries located in the United States or other countries. ICEM CFD is a trademark used by ANSYS, Inc. under license. CFX is a trademark of Sony Corporation in Japan. All other brand, product, service and feature names or trademarks are the property of their respective owners. FLEXlm and FLEXnet are trademarks of Flexera Software LLC.

Disclaimer Notice

THIS ANSYS SOFTWARE PRODUCT AND PROGRAM DOCUMENTATION INCLUDE TRADE SECRETS AND ARE CONFIDENTIAL AND PROPRIETARY PRODUCTS OF ANSYS, INC., ITS SUBSIDIARIES, OR LICENSORS. The software products and documentation are furnished by ANSYS, Inc., its subsidiaries, or affiliates under a software license agreement that contains provisions concerning non-disclosure, copying, length and nature of use, compliance with exporting laws, warranties, disclaimers, limitations of liability, and remedies, and other provisions. The software products and documentation may be used, disclosed, transferred, or copied only in accordance with the terms and conditions of that software license agreement.

ANSYS, Inc. and ANSYS Europe, Ltd. are UL registered ISO 9001: 2008 companies.

U.S. Government Rights

For U.S. Government users, except as specifically granted by the ANSYS, Inc. software license agreement, the use, duplication, or disclosure by the United States Government is subject to restrictions stated in the ANSYS, Inc. software license agreement and FAR 12.212 (for non-DOD licenses).

Third-Party Software

See the legal information in the product help files for the complete Legal Notice for ANSYS proprietary software and third-party software. If you are unable to access the Legal Notice, contact ANSYS, Inc.

Published in the U.S.A.
# Table of Contents

Overview ..................................................................................................................................................... 1
The ANSYS Product Improvement Program ............................................................................................ 1
Interacting with Project Objects .................................................................................................................. 5
Workbench Tabs and Views .......................................................................................................................... 5
The Project Tab ........................................................................................................................................... 7
  The Toolbox in the Project Tab .................................................................................................................. 8
  The Project Schematic ............................................................................................................................. 9
    Systems and Cells in the Project Schematic ......................................................................................... 9
    Project Schematic Links ....................................................................................................................... 10
    Project Schematic Workflow ............................................................................................................... 11
Configuring ANSYS Workbench ........................................................................................................... 13
Configuring the Toolbox .......................................................................................................................... 13
Configuring Units in Workbench ............................................................................................................. 13
Setting ANSYS Workbench Options ........................................................................................................ 16
  Project Management ............................................................................................................................. 17
  Appearance ......................................................................................................................................... 17
  Regional and Language Options ........................................................................................................... 19
  Graphics Interaction ............................................................................................................................. 19
  Journals and Logs ................................................................................................................................. 19
  Project Reporting ................................................................................................................................. 21
  Solution Process .................................................................................................................................. 21
  Extensions ........................................................................................................................................... 23
  Mechanical APDL ................................................................................................................................ 23
  CFX ....................................................................................................................................................... 24
  Design Exploration Options ................................................................................................................... 24
  Repository .......................................................................................................................................... 25
  Fluent ................................................................................................................................................... 25
  Mechanical ........................................................................................................................................ 27
  Engineering Data ................................................................................................................................. 28
  Microsoft Office Excel Options ............................................................................................................ 28
  TurboSystem ...................................................................................................................................... 28
  Meshing ............................................................................................................................................... 28
Geometry Import ........................................................................................................................................ 29
Using Software Licensing in ANSYS Workbench ...................................................................................... 31
Configuring External Solvers for Use with ANSYS Workbench ............................................................... 33
  Configuring Samcef ............................................................................................................................. 33
    The Samcef Result Storage Configuration File .................................................................................. 34
    The Samcef Postprocessing Configuration File ............................................................................... 35
  Configuring ABAQUS ........................................................................................................................... 39
    The ABAQUS Result Storage Configuration File ............................................................................. 40
    The ABAQUS Postprocessing Configuration File ............................................................................ 41
Customizing Workbench with ANSYS ACT ............................................................................................. 46
Working in the ANSYS Workbench Project Tab ......................................................................................... 47
  Adding Systems to the Project Schematic ............................................................................................. 47
  Naming and Renaming Systems ............................................................................................................ 50
  Working through a System ..................................................................................................................... 51
    Defining your Simulation Geometry ................................................................................................. 52
    Basic Mechanical Analysis Workflow .............................................................................................. 53
    Basic Fluid Flow Analysis Workflow ............................................................................................... 54
    Basic Fluid Flow Analysis, Starting from Geometry ......................................................................... 55

Release 18.2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Parameters and Design Points</td>
<td>123</td>
</tr>
<tr>
<td>Parameters</td>
<td>123</td>
</tr>
<tr>
<td>Custom Parameters</td>
<td>124</td>
</tr>
<tr>
<td>Expressions, Quantities, and Units</td>
<td>125</td>
</tr>
<tr>
<td>Working with Parameters in the Parameters Tab</td>
<td>131</td>
</tr>
<tr>
<td>Working with Design Points</td>
<td>134</td>
</tr>
<tr>
<td>Updating Design Points</td>
<td>136</td>
</tr>
<tr>
<td>Design Point Update Settings</td>
<td>137</td>
</tr>
<tr>
<td>Retaining Design Point Data and Exporting Design Points</td>
<td>139</td>
</tr>
<tr>
<td>Retaining Design Point Data</td>
<td>140</td>
</tr>
<tr>
<td>Reviewing the Retained Data Column</td>
<td>140</td>
</tr>
<tr>
<td>Setting a Different Design Point as Current</td>
<td>141</td>
</tr>
<tr>
<td>Exporting Design Points to New Projects</td>
<td>141</td>
</tr>
<tr>
<td>Exporting Design Point Parameter Values to a CSV File</td>
<td>142</td>
</tr>
<tr>
<td>Performing and Retaining Partial (Geometry-Only) Updates</td>
<td>143</td>
</tr>
<tr>
<td>Updating Design Points via ANSYS Remote Solve Manager or an EKM Portal</td>
<td>144</td>
</tr>
<tr>
<td>Performing a Pre-RSM Geometry Update</td>
<td>148</td>
</tr>
<tr>
<td>Aborting or Interrupting an RSM Design Point Update</td>
<td>149</td>
</tr>
<tr>
<td>Exiting a Project during an RSM Design Point Update</td>
<td>149</td>
</tr>
<tr>
<td>Suspending and Resuming Collection of RSM Design Point Results</td>
<td>150</td>
</tr>
<tr>
<td>Product-Specific Limitations</td>
<td>150</td>
</tr>
<tr>
<td>Reserving Licenses for a Design Point Update</td>
<td>151</td>
</tr>
<tr>
<td>Tracking Licenses</td>
<td>153</td>
</tr>
<tr>
<td>Returning Reserved Licenses</td>
<td>154</td>
</tr>
<tr>
<td>Using HPC Parametric Pack Licenses</td>
<td>154</td>
</tr>
<tr>
<td>Design Point Update Data</td>
<td>155</td>
</tr>
<tr>
<td>Design Point States</td>
<td>155</td>
</tr>
<tr>
<td>Working with ANSYS Workbench and EKM</td>
<td>157</td>
</tr>
<tr>
<td>Creating a Connection to an EKM Portal</td>
<td>157</td>
</tr>
<tr>
<td>Launching EKM with a Web Browser</td>
<td>159</td>
</tr>
<tr>
<td>Working with Existing EKM Connections</td>
<td>159</td>
</tr>
<tr>
<td>Working with ANSYS Workbench Projects Saved in an EKM Repository</td>
<td>161</td>
</tr>
<tr>
<td>Saving Projects and Files to an EKM Repository</td>
<td>162</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Vista CPD</td>
<td>299</td>
</tr>
<tr>
<td>Vista RTD</td>
<td>300</td>
</tr>
<tr>
<td>Vista TF</td>
<td>300</td>
</tr>
<tr>
<td>Custom Systems</td>
<td>300</td>
</tr>
<tr>
<td>Design Exploration</td>
<td>302</td>
</tr>
<tr>
<td>External Connection Systems</td>
<td>303</td>
</tr>
<tr>
<td>ANSYS Workbench Interface Reference</td>
<td>305</td>
</tr>
<tr>
<td>Tabs within Workbench</td>
<td>305</td>
</tr>
<tr>
<td>Views within Tabs</td>
<td>305</td>
</tr>
<tr>
<td>Project Schematic View</td>
<td>305</td>
</tr>
<tr>
<td>Common Views</td>
<td>306</td>
</tr>
<tr>
<td>Toolbox View</td>
<td>306</td>
</tr>
<tr>
<td>Toolbox Customization View</td>
<td>307</td>
</tr>
<tr>
<td>Files View</td>
<td>307</td>
</tr>
<tr>
<td>Outline View</td>
<td>308</td>
</tr>
<tr>
<td>Properties View</td>
<td>309</td>
</tr>
<tr>
<td>Table View</td>
<td>310</td>
</tr>
<tr>
<td>Chart View</td>
<td>310</td>
</tr>
<tr>
<td>Scene View</td>
<td>310</td>
</tr>
<tr>
<td>Solution Information View</td>
<td>310</td>
</tr>
<tr>
<td>Persistent Views</td>
<td>311</td>
</tr>
<tr>
<td>Messages View</td>
<td>311</td>
</tr>
<tr>
<td>Progress View</td>
<td>311</td>
</tr>
<tr>
<td>Job Monitor</td>
<td>312</td>
</tr>
<tr>
<td>Cells in Workbench</td>
<td>312</td>
</tr>
<tr>
<td>Types of Cells</td>
<td>312</td>
</tr>
<tr>
<td>Engineering Data</td>
<td>313</td>
</tr>
<tr>
<td>Geometry</td>
<td>313</td>
</tr>
<tr>
<td>Model/Mesh</td>
<td>314</td>
</tr>
<tr>
<td>Setup</td>
<td>314</td>
</tr>
<tr>
<td>Solution</td>
<td>314</td>
</tr>
<tr>
<td>Results</td>
<td>315</td>
</tr>
<tr>
<td>Understanding Cell States</td>
<td>315</td>
</tr>
<tr>
<td>Typical Cell States</td>
<td>316</td>
</tr>
<tr>
<td>Solution-Specific States</td>
<td>316</td>
</tr>
<tr>
<td>Failure States</td>
<td>318</td>
</tr>
<tr>
<td>Cell Properties</td>
<td>318</td>
</tr>
<tr>
<td>Common Cell Properties</td>
<td>319</td>
</tr>
<tr>
<td>Menus in Workbench</td>
<td>319</td>
</tr>
<tr>
<td>Menu Bar</td>
<td>319</td>
</tr>
<tr>
<td>File Menu</td>
<td>320</td>
</tr>
<tr>
<td>View Menu</td>
<td>323</td>
</tr>
<tr>
<td>Tools Menu</td>
<td>323</td>
</tr>
<tr>
<td>Units Menu</td>
<td>325</td>
</tr>
<tr>
<td>Extensions Menu</td>
<td>325</td>
</tr>
<tr>
<td>Jobs Menu</td>
<td>326</td>
</tr>
<tr>
<td>Help Menu</td>
<td>326</td>
</tr>
<tr>
<td>Context Menus</td>
<td>326</td>
</tr>
<tr>
<td>Common Context Menu Options</td>
<td>327</td>
</tr>
<tr>
<td>Transfer Context Menu Options</td>
<td>330</td>
</tr>
<tr>
<td>Tab Context Menu Options</td>
<td>331</td>
</tr>
<tr>
<td>System Header Context Menu Options</td>
<td>332</td>
</tr>
</tbody>
</table>
Project Schematic Context Menu Options ................................................................. 333
Link Context Menu Options ...................................................................................... 335
ANSYS Workbench Tutorials ..................................................................................... 337
Glossary ..................................................................................................................... 339
A. Product Improvement Program ............................................................................. 341
Index ......................................................................................................................... 343
Overview

ANSYS Workbench combines the strength of our core simulation tools with the tools necessary to manage your projects. You will work with your ANSYS Workbench project on the main project workspace, called the Project tab. To build an analysis, you add building blocks called systems to the Project Schematic. These systems make up a flowchart-like diagram that represent the data flow through your project. Each system is a block of one or more components called cells, which represent the sequential steps necessary for the specific type of analysis. Once you have added your systems, you can link them together to share and/or transfer data between systems.

From the cells in the Project Schematic, you can work with various ANSYS applications and analysis tasks; some of these open in tabs within the Workbench environment, while others open independently in their own windows.

ANSYS applications enable you to define analysis characteristics such as geometry dimensions, material properties, and boundary conditions as parameters. You can manage parameters at the project-level in the Workbench environment.

To perform your analysis, you will work through the cells of each system in order—typically from top to bottom—defining inputs, specifying project parameters, running your simulation, and investigating the results.

Workbench enables you to easily investigate design alternatives. You can modify any part of an analysis or vary one or more parameters, and then automatically update the project to see the effect of the change on the simulation result.

Related Topics:
- The ANSYS Product Improvement Program
- Interacting with Project Objects
- Workbench Tabs and Views
- The Project Tab

The ANSYS Product Improvement Program

This product is covered by the ANSYS Product Improvement Program, which enables ANSYS, Inc., to collect and analyze anonymous usage data reported by our software without affecting your work or product performance. Analyzing product usage data helps us to understand customer usage trends and patterns, interests, and quality or performance issues. The data enable us to develop or enhance product features that better address your needs.

How to Participate

The program is voluntary. To participate, select Yes when the Product Improvement Program dialog appears. Only then will collection of data for this product begin.
How the Program Works

After you agree to participate, the product collects anonymous usage data during each session. When you end the session, the collected data is sent to a secure server accessible only to authorized ANSYS employees. After ANSYS receives the data, various statistical measures such as distributions, counts, means, medians, modes, etc., are used to understand and analyze the data.

Data We Collect

The data we collect under the ANSYS Product Improvement Program are limited. The types and amounts of collected data vary from product to product. Typically, the data fall into the categories listed here:

**Hardware:** Information about the hardware on which the product is running, such as the:

- brand and type of CPU
- number of processors available
- amount of memory available
- brand and type of graphics card

**System:** Configuration information about the system the product is running on, such as the:

- operating system and version
- country code
- time zone
- language used
- values of environment variables used by the product

**Session:** Characteristics of the session, such as the:

- interactive or batch setting
- time duration
- total CPU time used
- product license and license settings being used
- product version and build identifiers
- command line options used
- number of processors used
- amount of memory used
- errors and warnings issued

**Session Actions:** Counts of certain user actions during a session, such as the number of:
• project saves
• restarts
• meshing, solving, postprocessing, etc., actions
• times the Help system is used
• times wizards are used
• toolbar selections

Model: Statistics of the model used in the simulation, such as the:
• number and types of entities used, such as nodes, elements, cells, surfaces, primitives, etc.
• number of material types, loading types, boundary conditions, species, etc.
• number and types of coordinate systems used
• system of units used
• dimensionality (1-D, 2-D, 3-D)

Analysis: Characteristics of the analysis, such as the:
• physics types used
• linear and nonlinear behaviors
• time and frequency domains (static, steady-state, transient, modal, harmonic, etc.)
• analysis options used

Solution: Characteristics of the solution performed, including:
• the choice of solvers and solver options
• the solution controls used, such as convergence criteria, precision settings, and tuning options
• solver statistics such as the number of equations, number of load steps, number of design points, etc.

Specialty: Special options or features used, such as:
• user-provided plug-ins and routines
• coupling of analyses with other ANSYS products

Data We Do Not Collect

The Product Improvement Program does not collect any information that can identify you personally, your company, or your intellectual property. This includes, but is not limited to:
• names, addresses, or usernames
• file names, part names, or other user-supplied labels
• geometry- or design-specific inputs, such as coordinate values or locations, thicknesses, or other dimensional values

• actual values of material properties, loadings, or any other real-valued user-supplied data

In addition to collecting only anonymous data, we make no record of where we collect data from. We therefore cannot associate collected data with any specific customer, company, or location.

**Opting Out of the Program**

You may stop your participation in the program any time you wish. To do so, select **ANSYS Product Improvement Program** from the Help menu. A dialog appears and asks if you want to continue participating in the program. Select No and then click OK. Data will no longer be collected or sent.

**The ANSYS, Inc., Privacy Policy**

All ANSYS products are covered by the ANSYS, Inc., Privacy Policy, which you can read here.

**Frequently Asked Questions**

1. *Am I required to participate in this program?*

   No, your participation is voluntary. We encourage you to participate, however, as it helps us create products that will better meet your future needs.

2. *Am I automatically enrolled in this program?*

   No. You are not enrolled unless you explicitly agree to participate.

3. *Does participating in this program put my intellectual property at risk of being collected or discovered by ANSYS?*

   No. We do not collect any project-specific, company-specific, or model-specific information.

4. *Can I stop participating even after I agree to participate?*

   Yes, you can stop participating at any time. To do so, select **ANSYS Product Improvement Program** from the Help menu. A dialog appears and asks if you want to continue participating in the program. Select No and then click OK. Data will no longer be collected or sent.

5. *Will participation in the program slow the performance of the product?*

   No, the data collection does not affect the product performance in any significant way. The amount of data collected is very small.

6. *How frequently is data collected and sent to ANSYS servers?*

   The data is collected during each use session of the product. The collected data is sent to a secure server once per session, when you exit the product.

7. *Is this program available in all ANSYS products?*

   Not at this time, although we are adding it to more of our products at each release. The program is available in a product only if this **ANSYS Product Improvement Program** description appears in the product documentation, as it does here for this product.
8. If I enroll in the program for this product, am I automatically enrolled in the program for the other ANSYS products I use on the same machine?

Yes. Your enrollment choice applies to all ANSYS products you use on the same machine. Similarly, if you end your enrollment in the program for one product, you end your enrollment for all ANSYS products on that machine.

9. How is enrollment in the Product Improvement Program determined if I use ANSYS products in a cluster?

In a cluster configuration, the Product Improvement Program enrollment is determined by the host machine setting.

Interacting with Project Objects

In ANSYS Workbench, a Toolbox on the left side of the Project tab contains analysis systems, component systems, and other types of project objects. The Project Schematic view will contain the system(s) that you have added, with each system made up of one or more cells. You can interact with these project objects in a number of different ways:

• Single-click: Single-click an object to select it. This does not modify data or initiate any action.

• Double-click: Double-click an object to initiate the default action. This allows users who are familiar with ANSYS Workbench to quickly move through basic or common operations.

• Right-click: Right-click to display a context menu applicable to the current state of the selected object. From the context menu, you can select from multiple actions. The default action is shown in bold and is the action that will occur if you double-click the object.

• Drag-and-drop: Drag-and-drop an object to preview possible locations for it on the Project Schematic. A drag-and-drop operation can have multiple alternative targets, depending on context and schematic complexity. Holding down the mouse button, hover over any target to see details of how the target location would be implemented (for example, what components would be connected after the operation is completed).

To cancel a drag-and-drop operation, press the Esc key while holding down the mouse button.

Workbench Tabs and Views

When working in the Workbench environment, you will be dealing primarily with interface elements called tabs and views.

Workbench Tabs

In Workbench, tabs serve as workspaces that allow you to interact with different parts of your project. In addition to the Project tab, other tabs can be opened for other workspaces; for example, you can open the Parameter Set tab by double-clicking on the Parameter Set bar on the Project Schematic. Workspace tabs can be accessed either by double-clicking the associated cell, or by right-clicking it and selecting Edit.

Each cell that does not launch an external application has a single workspace that can be opened inside Workbench. In some cases, it may be possible to open multiple tabs of the same type; for instance, if you have three Engineering Data cells in three separate systems, you could have three Engineering Data tabs open at the same time.
Tabs in Workbench are made up of multiple **views** containing information relevant to portion of the analysis shown in the tab. Each tab also has a context-specific toolbar containing buttons for the operations that are available, given the current state of the project.

You can right-click tabs to **Close Tab**, **Close Other Tabs**, and **Close All**. You can also close individual tabs by clicking the "x" icon. Only the **Project** tab cannot be closed.

For more information, see [Tabs within Workbench (p. 305)](#).

### Workbench Views

Tabs in Workbench are made up of multiple **views** that can be reconfigured according what information you want to be shown in the tab.

Some views are common to multiple tabs, while others are tab-specific. Some views are only shown in the tab for which they’ve been enabled, while others, once enabled, are shown across all the tabs either until you either disable them or reset the tab layout.

The configuration and persistence of the views across tabs varies to give you the maximum flexibility in customizing the information you see on each tab. The header bar of each view contains icons and context menus that allow you to control view attributes such as visibility, size, and floating/docked state. You can access the context menu either by clicking the down-arrow or by right-clicking in the header.

- To open a view, select it from the **View** menu. For example, if you’re in the **Project** tab and select **View → Outline**, the **Outline** view will be shown in the **Project** tab. Once the view is open, it will update its content according to what you’ve selected; by selecting different objects, you can view or edit the associated properties of those objects.

- To close a view, deselect it from the **View** menu, select **Close** from the header bar context menu, or click the “x” icon in its header bar.

- To change how the view displays, use the **Minimize**, **Maximize**, and **Restore** context options.
  - When you minimize a view, it appears as a tab in the bottom left corner of the ANSYS Workbench window. You can only maximize a floating view; you cannot maximize a docked view.
  - After you have maximized a view, use the **Restore** option on the **Windowing** drop-down menu to return the view to its pre-maximized size and location.

- To resize a view, you can use your mouse to drag its edges to the desired size.

- You can also “float” and “redock” views. By default, most views are “docked,” or embedded in their tab. You can choose to separate a view from its tab, so it can be moved outside of the Workbench window. When you redock a view, it returns to its place on its usual tab.

When you float a view, you separate it from its tab, so it is still available when you switch tabs. This is especially useful when you want to see a view that is not available as part of a tab. For example, the **Files** view is not visible in the **Parameter Set** tab, but you can float the **Files** view so you can see it while working with project parameters.

- To float a view, select the **Float** context option or the thumbtack icon in the view header. You can also “tear” the view from its dock by dragging the header with your mouse.
To redock a view, select the **Redock** context option or the thumbtack icon in the view header. When you redock a view, it will return to its normal tab and may not be visible in the current tab. You can also select the **View → Reset Workspace** menu option, which resets the views in the current tab to their default positions.

You can reset the views for one tab or for all the tabs.

- To reset all the views in the current tab to their default position, select **View → Reset Workspace**.
- To reset all the views in the project, select **View → Reset Window Layout**. This resets the views in all tabs to their default positions and opens the **Project** tab.

Some views—for example, the **Table**, **Chart**, **Outline**, and **Properties** views—are defined per tab, so that changes to a view are specific to that tab. For example, if you resize and float the **Chart** view in the **Parameter Set** tab and then switch to the **Response Surface** tab in a DesignXplorer system, you’ll find that the **Chart** view in the new tab will not be resized and floated. (The DX **Chart** view contains different data, and so does not reflect the changes made to the **Chart** view elsewhere.) When you return to the **Parameter Set** tab, you’ll see that the **Chart** view there is resized and floated, as before.

For more information on specific views, see **Views within Tabs** (p. 305).

**The Project Tab**

When you open a project in ANSYS Workbench, it opens to the **Project** tab. The **Project** tab is just one of many tabs that can be opened in Workbench, but it is the main workspace in which you will build your analysis.

Like all tabs, the **Project** tab is made up of different views that can be reconfigured according the information you want to see. By default, the **Project** tab has the **Toolbox** view and the **Project Schematic** view.

![Unsaved Project - Workbench](image)

**Related Topics:**
The Toolbox in the Project Tab

The Workbench Toolbox view contains the types of data you can add to your project.

In the Project tab, the Toolbox contains the different types of systems you can add to the Project Schematic. Systems are divided into categories which can be expanded or collapsed to show or hide the systems in that category. You can select systems from the following categories:

- Analysis Systems (p. 179)
- Component Systems (p. 199)
- Custom Systems (p. 300)
- Design Exploration (p. 302)
- External Connection Systems (p. 303)

The contents of each category are determined by which products you have installed and what licenses are available. If you do not have a particular product installed or do not have an available license, the individual systems corresponding to that product will not be shown in the Toolbox. Additionally, you can customize the Toolbox further, specifying that only some of the available systems are visible.

The Toolbox view persists across tabs. It contains systems on the Project tab, but on other tabs it will contain other sorts of information, such as charts, engineering materials, etc.

For information on customizing the Toolbox on the Project tab, see Configuring the Toolbox (p. 13).

For detailed information on system categories and individual systems, see ANSYS Workbench Systems (p. 179).
The Project Schematic

When you interact with a simulation project, you will work primarily in the Project Schematic view of the Project tab, adding systems from the Toolbox to the project and then working with those systems.

Projects can vary in complexity, from a single system representing all the necessary steps for a desired analysis, to a complex set of connected (linked) systems representing coupled analyses or variations in modeling approaches.

Note

It is recommended that a given project contains only systems that are relevant to a specific analysis or coupled analysis with a well-defined focus. Adding systems for multiple unrelated analyses to the same project can have an adverse effect on performance and cause corruption with portions of the project.

Related Topics:
Systems and Cells in the Project Schematic
Project Schematic Links
Project Schematic Workflow

Systems and Cells in the Project Schematic

Each system placed on the Project Schematic is made up of one or more analysis components called cells. Once all of your systems are in place, you're ready to start defining the details of your analysis. To do so, you generally interact with systems at the cell level. Right-click the system header or cell to see a menu of available options; double-click to perform the default action (bolded in the context menu).

You can interact with a cell to perform any of the following actions:

• Launch an application that opens independently of Workbench
• Open a tab inside Workbench
• Add connecting systems, either upstream or downstream
• Assign input or reference files
• Assign properties to components of your analysis

Each cell has either an application or a tab associated with it. Some cells are associated with an application that launches in a separate window, such as Fluent or Mechanical; in some cases, multiple cells in a system can be associated with the same application. Other cells, such as the Parameters cell or a cell in a System Coupling system, are associated with tabs that open inside Workbench.

Note

The Project Schematic may reflect actions you take in applications that open independently of Workbench.

To add a system to your project, you can drag a system from the Toolbox and drop it on the Project Schematic; alternatively, you can double-click the desired system in the Toolbox. Once you've added
To the Project Schematic, you can create links between cells to transfer and/or share data. For information on building and linking systems, see Working in the ANSYS Workbench Project Tab (p. 47).

Icons for each cell indicate the state of that particular cell—for example, whether the cell needs attention, is up-to-date, and so on. For more information, see Understanding Cell States (p. 315).

To display a quick help panel for the cell, click the blue triangle in the lower right corner of the cell (where available). The quick help message that displays explains any immediate action that must be taken and may include links to more detailed help.

**Project Schematic Links**

Links connecting systems represent data sharing or data transfer between the systems. The primary kinds of links that may be shown in the Project Schematic include:

- Links indicating that data is shared between systems. These links are shown with square terminators; see the figure below.

- Links indicating data is transferred from an upstream system to a downstream system. These links are shown with round terminators; see the figure below.

- Links indicating a system is consuming input parameters. These links connect systems to the Parameter Set bar and are drawn with arrows going into the system, as shown in the figure below.

- Links indicating a system is providing output parameters. These links connect systems to the Parameter Set bar and are drawn with arrows coming out of the system, as shown in the figure below.

- Links that indicate a Design Exploration system is connected to project parameters. These links connect Design Exploration systems to the Parameter Set bar, as shown with the Design Exploration systems in the figure below.

- Links indicating that data is transferred from a Design Exploration Response Surface to a Parameters Correlation, as shown with systems E and F in the figure below.

- Links indicating that design point data is transferred from a Design Exploration component to a Design Exploration Direct Optimization system. For more information, see Transferring Design Point Data for Direct Optimization in the DesignXplorer User’s Guide.

Additional information on working with links can be found in Creating and Linking to a Second System (p. 56) and Moving, Deleting, and Replacing Systems (p. 61).
Working with Shared Data Links

Links that are drawn with a square terminator indicate that data is shared between the two systems. Only one instance of the data exists and it is shared between the connected systems. In order to edit the details of that data, you must edit the cell on the upstream system connected via these links. In the example shown in the figure above, the Geometry cell from system A is shared with the Geometry cell in system B, which is in turn shared with the Geometry cell of system C. In order to edit the geometry for ANY of these systems, you must initiate the edit operation from the Geometry cell in system A (by double-clicking on the cell or right-clicking on the cell and selecting Edit from the context menu).

In many cases, it is possible to delete shared data links by right-clicking on the link and selecting Delete from the context menu. The data associated with the cell in the upstream system will be copied to the downstream system so the cells can be edited independently.

In some cases, you will not be able to delete links. In these cases, the linked cells in the downstream system will be shown with a gray background (as shown in systems C and E, above).

**Project Schematic Workflow**

To complete your analysis, you will work downward through each cell in order. In general, data flows downstream (from top-to-bottom within systems and from left-to-right across systems). Output data from upstream component cells is provided as the input data for downstream cells. Output data from certain types of cells in one system can also be transferred and/or shared with cells in another system.

The following example shows two systems in the Project Schematic, a Fluid Flow (Fluent) system (system A) and a Static Structural system (system B). In this example:
• The geometry from the **Geometry** cell in system A becomes the input for the **Mesh** cell that is downstream in that system. The mesh generated in the **Mesh** cell of the system, in turn, becomes input to the downstream **Setup** cell, and so on.

• There is also data-flow between system A and system B, as follows:
  
  – They share the same geometry, as indicated by the connector with the square terminator between the **Geometry** cell in system A and the **Geometry** in system B.
  
  – Solution data from System A is provided to the **Setup** cell of system B, as indicated by the connector with the round terminator.

At a glance, you can see the data relationship between the two types of analysis systems.
Configuring ANSYS Workbench

Information about configuring ANSYS Workbench can be found in the following sections:
- Configuring the Toolbox
- Configuring Units in Workbench
- Setting ANSYS Workbench Options
- Using Software Licensing in ANSYS Workbench
- Configuring External Solvers for Use with ANSYS Workbench
- Customizing Workbench with ANSYS ACT

Configuring the Toolbox

When you open ANSYS Workbench, the Toolbox view on the Project tab contains the systems available to you. These are the products you have installed and for which licenses are available.

To configure the Toolbox to show only the systems you use, rather than all available systems:

1. Click the View All / Customize button at the bottom of the Toolbox.
2. In the Toolbox Customization view, deselect systems you want to hide.
3. When you are finished, close the Toolbox Customization view by clicking << Back at the bottom of the Toolbox.

Configuring Units in Workbench

ANSYS Workbench provides:

- Predefined unit systems that contain the most commonly used sets of units.
- The ability to define Custom Unit Systems (p. 16) based on the predefined unit systems. (You cannot edit or delete predefined unit systems.)
The ability to display the following project data using the project unit system:
- Engineering data
- Parameters
- Charts.

The ability to share the unit system between users via **Import** and **Export** options.

---

**Note**

Unit settings in ANSYS Workbench are not passed to Fluid Flow analysis systems; to CFX, Fluent, **Results**, or TurboGrid systems; or to FSI: Fluid Flow custom systems.

To access the **Unit Systems** dialog box, choose **Units → Unit Systems**.

![Unit Systems dialog box](image)

The **Unit Systems** dialog box appears and has the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active Project</td>
<td>Sets unit system for active project.</td>
</tr>
<tr>
<td>Default</td>
<td>Sets default unit system. This will be default unit system for every project.</td>
</tr>
<tr>
<td>Suppress/Unsuppress</td>
<td>Hides/displays unit system menu item. Only 15 unit systems can be unsuppressed and displayed as in the <strong>Units</strong> menu.</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Creates a custom unit system based on selected unit system.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes unit system. The following unit systems cannot be deleted:</td>
</tr>
<tr>
<td></td>
<td>- Predefined Unit System</td>
</tr>
<tr>
<td></td>
<td>- Active Project Unit System</td>
</tr>
<tr>
<td></td>
<td>- Default Unit System</td>
</tr>
<tr>
<td>Import</td>
<td>Imports a units file (* .xml).</td>
</tr>
<tr>
<td>Export</td>
<td>Exports the active project unit system as a units file (* .xml).</td>
</tr>
</tbody>
</table>
**Units**

A unit system is a collection of the preferred unit for the base, common, and other quantity types.

- **Base Units**: All other units are derived from these units.
  - Angle
  - Chemical Amount
  - Current
  - Length
  - Luminance
  - Mass
  - Solid Angle
  - Time
  - Temperature

- **Common Units**: These are units which are derived from the base units and are typically used as base units for other units.
  - Electric Charge
  - Energy
  - Force
  - Power
  - Pressure
  - Voltage

- **Other Units**: Several other units are derived from base and common units.

For a detailed description on how units are used in expressions, see *Expressions, Quantities, and Units* (p. 125).

**Predefined Unit Systems**

ANSYS Workbench offers the following predefined unit systems:

- Metric (kg, m, s, °C, A, N, V) (default unit system)
- Metric (tonne, mm, s, °C, mA, N, mV)
- U.S. Customary (lbm, in, s, °F, A, lbf, V)
- SI (kg, m, s, K, A, N, V)
- U.S. Engineering (lbm, in, s, R, A, lbf, V)

You cannot edit or delete predefined unit systems.

ANSYS Workbench also provides the following additional unit systems. These are suppressed by default.

- Metric (g, cm, s, °C, A, dyne, V)
- Metric (kg, mm, s, °C, mA, N, mV)
- Metric (kg, μm, s, °C, mA, μN, V)
- Metric (decatonne, mm, s, °C, mA, N, mV)
- U.S. Customary (lbm, ft, s, F, A, lbf, V)
- Consistent CGS
- Consistent NMM
- Consistent μMKS
- Consistent BIN
- Consistent BFT
For a detailed description of unit systems for the Mechanical application, see Solving Units.

You can also display values as defined and display values in project units. See Units Menu (p. 325) for more information on using these options.

**Custom Unit Systems**

Use the Duplicate option to create a custom unit system based on a predefined unit system.

- The default name for the new Unit system is Custom Unit System. You can change the name.
- You can change the units for any quantity type from the available list.
- The list of units that are available are either consistent with SI or US Customary, depending on the original unit system. This to assure that a consistent unit system can be constructed for solution purposes.
- Changing base units can automatically change Common and Other derived units if appropriate. For example, if the mass unit is kg, the length unit is m, and the force unit is N, then changing mass to g and length to cm will automatically change force to dyne.

**Unit Limitations**

"Sound Pressure Level" and "A Weighted Sound Pressure Level" are dimensionless quantities with units dB and dBA, respectively.

- Math operations between these two units or either of these and a numerical value will result in a value with no unit. For example, 10 db x 10 = 100. (no unit)
- Math operations between either of these units and a dimensional unit will result in a value with the dimensional unit. For example, 10 db x 10 m = 100 m.

**Setting ANSYS Workbench Options**

To set your preferences for ANSYS Workbench, select Tools → Options. The preferences you set here are local settings, affecting only you. Some changes made via the Options dialog take place immediately, while others take place after you restart ANSYS Workbench.

Use the Restore Defaults button to reset the settings visible on the current page to their default values; settings on other pages will remain unchanged.

You can set user preferences in the following categories:

- Project Management
- Appearance
- Regional and Language Options
- Graphics Interaction
- Journals and Logs
- Project Reporting
- Solution Process
- Extensions
- Mechanical APDL
- CFX
- Design Exploration Options
- Repository
- Fluent
An IT manager can place a site-wide configuration file into the installation directory of each client machine to ensure that the Workbench software preferences are configured as the company requires. To force a preference to be set to a particular value at startup, edit \Program Files\ANSYS Inc\18.2\Framework\Site\SiteStartup.wbjn.

**Project Management**

From **Tools → Options → Project Management** you can specify the following:

**File Locations** Specify default folders for permanent and temporary file locations. You can specify two settings:

**Default Folder for Permanent Files**
Controls the location where a project save/open will occur. When you choose a different location for a project via a dialog in the user interface, ANSYS Workbench remembers the folder location for subsequent operations for the rest of the session; however, upon starting a new session, the default will be the location specified here.

**Folder for Temporary Files**
Controls where most temporary files are written. The directory specified here holds project files that are generated before the project is saved. Once a project is saved, files are written to the project directory (see **Project Directories** (p. 100) for more information).

**Project Archive** Enables you to specify your preferences for archiving projects.

- **.wbpz Compression Level**: Allows you to specify a file compression level for archiving projects to the .wbpz format. Defaults to 3. Possible values are 0 through 9, with 0 as no compression and 9 as maximum compression. For more information on archiving, see **Archiving Projects** (p. 104).

**Appearance**

From **Tools → Options → Appearance** you can specify the following:

**Graphics Style** Controls the graphics style of the ANSYS Workbench, DesignModeler, Meshing, and Mechanical applications.

- **Background Style**: Sets a solid graphic background or a gradient background that varies from top to bottom, left to right, or diagonally. The default is the top to bottom gradient.

- **Background Color**: Sets a graphic background color from the built-in color palette. The default color is blue.

- **Background Color2**: Sets a second graphic background color from the built-in color palette. The second color is used for gradient background displays. For example, if you want a top-bottom gradient that starts
out white and ends up black, **Background Color** should be set to white and **Background Color2** should be set to black. The default color is white.

- **Text Color**: Sets the color of all text from the built-in color palette. The default color is black.

- **Edge Thickness**: Sets the relative thickness display of all edges to **Thin** (default), **Medium Thick**, or **Thick** provided the View menu is set to either **Wireframe** or **Shaded Exterior and Edges**, and **Edge Color Option** is not set to **Body Color**.

- **Edge Colors**: Sets the colors for the **Graphics Options** feature from the built-in color palette.

  - **Meshed**: Sets the colors of all meshed edges from the built-in color palette. The default color is black.

**Display** Controls how ANSYS Workbench displays information.

- **Number of Significant Digits**: Sets the number of digits that appear for numbers in ANSYS simulation environments. The default is 5 and the range is from 3 to 10. This setting affects only the numbers that are displayed. It does not imply any numerical round-off of internal calculations.

  When a user-entered number has a decimal halfway between two integers, the number will be rounded to the nearest even integer. For example, a value of **20.5** will be rounded down to **20**, while a value of **21.5** will be rounded up to **22**.

- **Number of Files in Recently Used Files List**: Sets the number of files that will appear in both the File menu and the context menus’ Recently Used Files lists. The default is 4 files and the maximum number of files that you can display is 20. If the number specified here exceeds the number of recently used files that are available, the list will show the available number. This setting is applied to the current ANSYS Workbench session.

- **Beta Options**: Allows testing of unreleased ANSYS Workbench features. If selected, beta features will be displayed with the word beta in parenthesis. The default is to not show beta features. Beta features remain untested in this release and therefore are neither documented nor supported and may result in unpredictable behavior. The beta option on Linux for Mechanical Explicit Dynamics is not passed to the solver and as such has no effect for solver related beta functionality.

- **Text on Toolbars**: Allows you to turn the text labels on the toolbars on or off. Labels are on by default. This option applies to the ANSYS Workbench interface, the Mechanical application, the Meshing application, FE Modeler, and DesignModeler only.

- **Connections are Bundled at Startup**: Shows connections between systems as a single link. The label will indicate all bundled connections. For example, linked systems that shared Engineering Data, Geometry, and Model cells would show a single link with the notation “2:4”, indicating that cells 2 (Engineering Data) through 4 (Model) are connected. Default is off. This setting defines the initial default for all projects and can be overridden within each project using View → Show Connections Bundled, or by selecting this option from the context menu on the schematic. Use of this option affects only newly created projects.

- **System Coordinates are Shown at Startup**: Shows the system label letters and numbers. Default is on. This setting defines the initial default for all projects and can be overridden within each project using View → Show System Coordinates or by selecting this option from the context menu on the schematic.

- **Quick Help Icons in System Cells**: Shows the quick help icon in cells where quick help is available. The icon appears as a small blue triangle in the lower right corner of the cell. Default is on.

- **Word-wrap Text in Tables**: Allows text in tables to wrap within the cells. Default is on.
Regional and Language Options

From **Tools → Options → Regional and Language Options** you can specify the following:

**Language**  Specify the language to be used for ANSYS Workbench text and messages.

You can choose to use English, German, French, or Japanese, if localized files are available. ANSYS Workbench defines the language via the languagesettings.txt file, the language selected at installation, or the language specified via this option. You can also manually edit the languagesettings.txt file to specify the language. If you manually edit the languagesettings.txt file, the ANSYS Workbench user interface will display in the language you specify upon startup.

You must exit ANSYS Workbench and start a new session for changes to the language option to take effect.

ANSYS Workbench will look for the languagesettings.txt file in the following locations, in order:

1. `%appdata%\Ansys\v182` on Windows or `$HOME/.ansys/v182` on Linux
2. `<install_dir>\Ansys Inc\v182\commonfiles\Language (Windows)` or `<install_dir>/ansys_inc/v182/commonfiles/language (Linux)

Be aware that not all external applications may be translated; therefore, you may see some applications' text and messages in English even if you have specified a different language.

Graphics Interaction

From **Tools → Options → Graphics Interaction** you can specify the following:

The **Mouse Button Assignments** category includes options for setting the various button controls on the mouse as well as button combinations with the Shift and Ctrl keys.

The **Pan, Rotate and Zoom** category’s **To Zoom in Closer** option enables you to set the preference of whether to zoom on a model by moving the mouse in or out. With **Dynamic Viewing**, if you make a standard view change (such as front, back, left, right, bottom, top, isometric, and Look At Face/Plane/Sketch), a short animation shows the model moving/twisting toward its final pose. Turn off dynamic viewing if you are using an older graphics card. The **Use Spaceball** setting enables the use of the Spaceball 3D import device (not supported in UNIX).

The **Selection** category’s **Extend Selection Angle Limit** sets a limit in degrees for what kind of face and edge angles the system considers “smooth”. This affects the **Extend to Adjacent** and **Extend to Limits** Extend Selection toolbar buttons in DesignModeler. **Extend Selection buttons** are also present in the Mechanical application. The default value is 20° and the range is from 0° to 90°. The **Angle increment for configure tool** sets the angular increment of the Configure tool when defining a joint.

Journals and Logs

From **Tools → Options → Journals and Logs** you can specify the following:

**Journal Files**  Specify your preferences for journal files:

- **Record Journal File**: Specify if a journal file should be recorded. If this check box is selected, ANSYS Workbench writes a journal file (.wbyn) for each ANSYS Workbench session and the following options are enabled:
Journal File Directory: Select the directory to which journal files should be written.

On Windows, the directory preference defaults to %TEMP%\WorkbenchJournals.

On Linux, the directory preference defaults to the following, in order:
1. $TEMP/WorkbenchJournals
2. $TMP/WorkbenchJournals
3. $HOME/.ansys/WorkbenchJournals

If you record a session (File → Scripting → Record Journal) for future playback, the same information is written to both the location specified here and to the file specified when you begin recording.

Days to Keep Journal File: Specify the number of days to keep journal files. Defaults to 7 days.

When running a journal file, pause after each command: Specify whether there should be a pause after each command when running a journal file. If this check box is selected, the following option is enabled:

Seconds to Pause: Specify the number of seconds to pause between commands. Defaults to 1 second.

Workbench Log Files Specify your preferences for Workbench log files:

Write Workbench Log Files: Specify whether Workbench log files should be written. If this check box is selected, ANSYS Workbench writes two log files for each ANSYS Workbench session. The two files are:

UIEvents<procID>.log
CoreEvents<procID>.log

where <procID> is the process ID of the ANSYS Workbench session. To identify the log file of the most recent session, it is most convenient to sort the directory by date. The log file will contain information that is useful to technical support whenever an error is encountered.

Other applications may continue to write log files to their own directories, even if launched from ANSYS Workbench.

When this check box is selected, the following options are enabled:

Workbench Log Files Directory: Select the directory to which Workbench log files should be written.

On Windows, the directory preference defaults to %TEMP%\WorkbenchLogs.

On Linux, the directory preference defaults to the following, in order:
1. $TEMP/WorkbenchLogs
2. $TMP/WorkbenchLogs
3. $HOME/.ansys/WorkbenchLogs

The log file directory preference takes effect immediately when the Options dialog is closed.
- **Days to Keep Workbench Log File**: Specify the number of days to keep Workbench log files. Defaults to 7 days.

### Project Reporting

From **Tools → Options → Project Reporting**, select **After exporting report, automatically open in default browser** to launch your default browser and load the report immediately upon generation. If you do not select this option, you will need to navigate to the report file (in `user_files` in the project directory by default) and open the `.html/.htm` file manually after exporting the report.

### Solution Process

From **Tools → Options → Solution Process** you can control the defaults for many of the **Solution Process** properties of **Solution** cells. For projects with parametric design points, these settings also control the defaults for the **Design Point Update Process** setting for the **Parameter Set** bar. For more information on using the **Solution Process** properties to submit a job to RSM, see Submitting Solutions (p. 71).

Specify the following solution process options:

**Default Update Option:** You can choose:

- **Run in Foreground** - The solution runs within the current ANSYS Workbench session.

- **Run in Background** - The solution runs in the background on the local machine. This option is available only for **Solution** cells that support background execution.

- **Submit to Remote Solve Manager** - The solution runs in the background either on the local computer or, if Remote Solve Manager is configured, on one or more different computers. If you submit to RSM, the solution continues to run even if you close the current ANSYS Workbench session.

  If you have not defined Cluster Configurations in RSM, refer to the **RSM Overview** in the Remote Solve Manager User's Guide.

- **Submit to Portal** - Sends the solve task to an EKM Portal using a connection that you have previously defined. If you have not defined a connection, refer to **Creating a Connection to an EKM Portal** (p. 157). EKM then sends the task to Remote Solve Manager for handling. When using the **Submit to Portal** option, the solution will continue to run even if you close the current ANSYS Workbench session, and you can monitor the task remotely using the EKM web application.

  If you select **Submit to Remote Solve Manager** or **Submit to Portal**, you also have the following options:

  - **Default RSM Queue** - You can select from the queues that you have already defined for RSM.

  - **Download Progress Information** - Controls whether the solver monitor periodically queries RSM for output files in order to display progress (where applicable).

  - **Default Job Name** - Sets the default name that appears in the **Job Name** field. The name must start with an alphanumerical character, must not contain spaces or the characters `! @ $ * ? \` and must not be longer than 15 characters.
Default Progress Download Interval - Specifies the time interval between solver queries to RSM in order to display progress. Default is 30 seconds. Setting this value to zero (0) results in continuous queries; that is, as soon as files are downloaded from the compute server, ANSYS Workbench will immediately query again. This option is available for CFX systems only.

Default Execution Mode - Specifies if you want the solution to run in serial or parallel mode. Default is serial. The parallel option is available only if the selected solver supports parallel execution mode.

Default Number of Processes - Specifies the default number of processes to use if you choose to run in parallel mode. Must be set to 2 or greater.

Pre-RSM Foreground Update - Indicates if you want to do a local geometry-only update prior to submitting design point update to RSM. Select Geometry to update your geometry locally before submitting design point updates to RSM.

Default Job Submission - Determines how design point updates are handled if submitted to RSM. Select one of the following options:

→ One Job for All Design Points - All design points are submitted as a single job to RSM.

→ One Job for Each Design Point - Each design point is submitted as a separate job to RSM (simultaneous parallel updates).

→ Specify Number of Jobs - Design points are divided into groups and submitted in multiple jobs, up to the specified maximum number of jobs. (You can look at the RSM List view to determine which design points are assigned to each job.) If you select this option, the Maximum of Jobs property is enabled, allowing you to specify the maximum number of jobs that can be created.

If you have not defined Cluster Configurations in RSM, see RSM Overview in the Remote Solve Manager User's Guide. If using the Submit to Portal update option, refer to Managing Queues in the EKM Administration Guide.

Default Design Point Update Order: Specify the starting condition of each design point for design point updates. By default, when each design point is updated, the design point is initialized with the data of the design point designated as Current (except for retained design points with valid retained data, which do not require initialization data). However, in some cases it may be more efficient to update each design point starting from the data of the previously updated design point, rather than restarting from Current each time.

• Update From Current – This is the default value. Causes each design point to be initialized from the Current design point.

• Update Design Points in Order – Causes each design point to be initialized from the previous design point.

If you selected One Job for Each Design Point in the Default Job Submission field, the Default Design Point Update Order is applicable ONLY if you also selected Geometry in the Pre-RSM Foreground Update field.

This setting will take effect the next time you create a new project. See Design Point Update Settings (p. 137) for more information.

Show Advanced Solver Options: Makes the Interconnect and MPI Type Parallel Run Settings available for Fluent RSM runs. Note that these settings require you to ensure that the remote Compute
Servers can accept the Interconnect and MPI Type that you specify; there is no automatic checking for such compatibility.

**Retained Design Point:** Specifies how an update will be performed for retained design points. Select one of the following options:

- **Update parameters** - This is the default value. Only parameters are updated for retained design points. If a component is not needed to get the value of an output parameter, it will not be updated.

- **Update full project** - Full project is updated for retained design points. Use this setting if you want to generate reports, or other content, from components that do not produce output parameters.

**Extensions**

From **Tools** → **Options** → **Extensions** you can specify extension-handling settings for ANSYS ACT.

Under **General Options**, the following options are available:

**Additional Extension Folders**  By default, ACT searches the user's **Application Data** folder. Define additional folders in which ACT will search from extensions in order to expose them to the **Extension Manager**. The **Extension Manager** contains any extensions located in these folders.

**Save Binary Extensions with Project**  Specify if extensions should be saved when the project is saved. Select from the following options:

- **Never**: The current loaded extensions are not saved within the project.

- **Copied but locked to the project**: The extensions are saved within the project, but are limited to that project.

- **Always**: The extensions are saved within the project with no restrictions as to their use in other projects.

**Journal Wizard Actions**  Specifies whether to automatically create a journal file when a wizard extension is run.

Under **Development**, select the **Debug Mode** check box to activate debugging mode in the Mechanical application.

For more detailed information on extensions options, see the **ANSYS ACT Developer's Guide**.

**Mechanical APDL**

From **Tools** → **Options** → **Mechanical APDL** you can specify the following:

- Startup command line options
- Default memory sizes for the database and the workspace
- Number of processors to be used for parallel processing
- Default job name
- Default license level
- Graphics device
- **Start.ans usage**
- Custom executable path
- Download Distributed Files
These items are described in detail in the ANSYS Launcher > File Management Tab documentation in the Operations Guide for the Mechanical APDL application.

In addition to the above Mechanical APDL application options, you can also specify the GPU Accelerator option. The GPU Accelerator option provides access to the Graphics Processing Unit (GPU) acceleration capability offered in the Project Schematic and inside Mechanical APDL. Three options are available, None, NVIDIA and Intel. By default, None is selected. If NVIDIA or Intel is selected, specify the Number of GPUs per Machine in the row below. By default, this number is set to 1. Choosing this option from Options → Mechanical APDL will apply the setting to all newly added systems in the Project Schematic. You can override these settings by changing the GPU Accelerator selection on individual systems by right-clicking Analysis and editing the properties.

**CFX**

From Tools → Options → CFX you can specify the following:

**Keep Latest Solution Data Only**

See the description for “Keep Latest Solution Data Only” in Properties View in the CFX Introduction.

**Cache Solution Data**

See the description for “Cache Solution Data” in Properties View in the CFX Introduction.

**Initialization Option**

See the description for “Initialization Option” in Properties View in the CFX Introduction.

**Execution Control Conflict Option**

See the description for “Execution Control Conflict Option” in Properties View in the CFX Introduction.

### Resolving Execution Control Conflicts

If you add or change Execution Control in ANSYS CFX-Pre in a way that conflicts with the Execution Control settings stored in the Solution cell, an error message appears when you attempt to update the Solution cell and provides you a set of options:

- The Using execution control from Setup cell and Using execution control from Solution cell options enable you to decide how to resolve the conflict on a case-by-case basis.

- The Using execution control from Setup cell always and Using execution control from Solution cell always options change your Workbench Options for CFX.

To reset that choice, go to Tools → Options → CFX and change the value of the Execution Control Conflict Option to one of the settings described in “Execution Control Conflict Option” in Properties View in the CFX Introduction.

**Design Exploration Options**

From Tools → Options → Design Exploration you can specify the following:

- Default DesignXplorer options: the settings that will be used by default when new design exploration systems are created.

- General DesignXplorer options: the settings that are used for all design exploration systems. Once defined, they take effect immediately on all existing systems.
For a detailed explanation of default options for design exploration and local options for Design of Experiments, Response Surface, and Sampling and Optimization, see Design Exploration Options in the DesignXplorer User's Guide.

Repository

From Tools → Options → Repository you can specify the following settings for managing simulation data in an ANSYS Engineering Knowledge Manager (EKM) repository.

Check for update upon opening a repository project

- Specify whether Workbench, upon opening a project that is saved to an EKM repository, will check for changes to the project.
- Possible values are Always Ask, Always Check, and Never Check.

Check for update of imported repository files upon opening a project

- Specify whether Workbench, upon opening a project containing files that are saved to an EKM repository, will check for changes to the files.
- Possible values are Always Ask, Always Check, and Never Check.

Send project changes to repository upon closing a project

- Specify whether Workbench, upon closing a project that is saved to an EKM repository, will send project changes to the repository.
- Possible values are Always Ask, Always Send, and Never Send.

Note

If you select Always Ask for any of these settings, in future interactions with an EKM repository a message dialog box will give you the option of Save my choice and don't ask this question again. That change will be reflected in the settings here in Tools → Options → Repository.

Fluent

From Tools → Options → Fluent you can specify the following:

- General Options are applicable to all new and pre-existing projects.
- Launcher Options are the default value for any new Fluent-based system that you create.

General Options

These options apply to all Fluent-based systems in the Workbench project, regardless of whether the system was created before, or after, the option is enabled. Note that these options are not saved with the project, and the settings are always applied to the currently loaded project.

Show Warning on Editing Setup if Solution Has Current or Initial Data

Allows you to determine whether a warning message should appear when solution data exists and you attempt to open ANSYS Fluent from the Setup cell. When you open Fluent from the Setup cell,
the mesh and settings file associated with the **Setup** cell are loaded into Fluent which may or may not be what you want. When this option is selected, the warning dialog is shown. Default: Enabled.

**Automatically Delete Old Solutions On Start Of New Calculation**
Specifies whether old solution data is automatically removed when starting a new computation. Default: Enabled.

**Reuse Fluent Session for Design Points**
Specifies whether the Fluent session should be reused for other design point calculations. Default: Disabled. This option works with foreground parametric updates only.

**Default Options for New Fluent System**
Once set, these options apply to all newly created Fluent-based systems in the Workbench project. They can be overridden by editing the properties specified for the **Setup** and **Solution** cell. The settings specified in the **Setup** and **Solution** cell properties are always respected and saved with the Workbench project. Therefore, for previously saved projects, these saved settings are used.

**Launcher Options**
These options apply to Fluent Launcher for new Fluent–based systems.

**Show Launcher at Startup**
Allows you to show or hide Fluent Launcher when Fluent starts. Default: Enabled.

**Display Mesh After Reading**
Allows you to show or hide the mesh after the mesh or case/data is read into Fluent. Default: Enabled.

**Embed Graphics Windows**
Allows you to embed the graphics windows in the Fluent application window, or to have them free-standing. Default: Enabled.

**Use Workbench Color Scheme**
Sets the graphics window to use either the Workbench color scheme or the classic black background color. Default: Enabled.

**Set up Compilation Environment for UDF**
Allows you to specify compiler settings for compiling user-defined functions (UDFs) with Fluent. Default: Enabled.

**Precision**
Sets either the single-precision or the double-precision solver.

**Setup Cell**
The option applies to the **Setup** cell for new Fluent–based systems.

**Enable Generation of Setup Output Case File**
Allows you to bypass loading the mesh and setting files and reapplying the pre-set mesh operations every time the **Setup** cell is edited, resulting in faster runs. This option is especially beneficial when computing simulations across multiple design points involving ANSYS Fluent-related parametric changes. The Fluent solver automatically generates the output case file, `name-Setup-Output.cas`, every time you modify the mesh, set mesh operations prior to running the simulation in ANSYS Fluent, or start a Fluent session with a mesh file only.

The generated output case file is used when launching the next Fluent session from the **Setup** cell if the regular case file is out-of-date or not available. Default: Enabled.
### Solution Cell

These options apply to the **Solution** cell for new Fluent–based systems.

**Enable Solution Monitoring**

Allows you to be able to graphically view Fluent solution convergence and monitor data without having Fluent open. Once this option is enabled, you can use the **Show Solution Monitoring** option in the **Solution** cell context menu to display convergence and monitor charts. Default: Enabled.

**Enable Generation of Interpolation File**

Instructs the Fluent solver to automatically generate an interpolation file, *.*ip, at the end of the run. Unlike *.*dat file, the *.*ip file can be used to restart the Fluent session, even if the mesh has been modified. Default: Enabled.

### Mechanical

From **Tools → Options → Mechanical** you can specify the following:

**Auto Detect Contact On Attach**

Controls whether contact detection is computed upon geometry import into Mechanical. Default: Enabled.

**Save Mesh Data In Separate File**

Controls the default setting for the **Save Mesh Data In Separate File** property in Mechanical systems (such as Static Structural) for subsequently created Mechanical systems. The property setting controls whether mesh data is stored in a separate .acmo file for the current system.

Saving the mesh data in a separate file reduces the overall file space required and reduces the possibility of disc corruption in very large database files on Linux systems.

**Release License for Pending Jobs**

Specifies when the Mechanical application is to release its license when running in batch mode:

- **On Demand** When the **Solution** cell for a Mechanical system is in the pending state during a batch run, the right-click menu has a **Release License** option. This closes the Mechanical application but does not interfere with the completion of the run. (Default)

- **Always** Causes the Mechanical application to automatically close and release its license during batch runs when the **Solution** cell is in the pending state.

- **Design Point Run Only** Causes the Mechanical application to automatically close and release its license during **Update All Design Points** runs when the **Solution** cell is in the pending state.

**Enable Legacy Solve**

Causes Mechanical to revert to an older method of launching the Mechanical APDL solver. This mode may have incompatibilities with newer features and will not affect jobs submitted to RSM. It is provided only as a diagnostic tool for troubleshooting.

**Maximize Design Point Performance**

For Mechanical simulations, causes ANSYS Workbench not to copy design point results data when parameters are changed, as the design point will be re-evaluated in those cases. Note that no working directory files (such as macros) are copied, so to use this setting you must move any files that you have put into the working directory (the solver files directory) to the **user_files** directory.

**Design Points**

During a design point update, periodically restart the Mechanical application

Directs the Mechanical application to automatically restart after the specified number of design points when running in batch mode.
Each restart resets the Mechanical application and slightly lengthens the processing time, but can improve overall system performance (memory and CPU) when the generation steps of each design point (geometry, mesh, solve, post processing) are long. In such cases, specify a low number (minimum is 1) of design points before restarts.

In cases where the generation steps for each design point are short, reduce processing time by increasing the number of design points before restarts or prevent restarts completely by disabling this preference.

**Parallel Processing**  
Limit Number of Cores for Data Mapping and Post-Processing: Indicates the number of cores used by the data transfer mapping, interpolation operations and result post-processing should be limited to a user-specified value. The default is to use as many processors as available. If limited, the default is set to two cores.

**Engineering Data**

From **Tools → Options → Engineering Data, Filter Toolbox on Context** enables you to filter Toolbox content based on your selection in the Properties pane.

**Microsoft Office Excel Options**

From **Tools → Options → Microsoft Office Excel Options** you can specify the following options for the Microsoft Office Excel add-in:

**Named Ranges Filtering Prefix.** If you want to use a prefix to filter which Excel named ranges will be exposed as parameters in a Workbench project, enter that prefix here. All named ranges defined in the Excel file that include that prefix will be displayed as parameters in the project. By default, this setting is blank (no filter).

- If you specify a prefix, the prefix will be used to filter the named ranges for all new design exploration systems. For example, if you set this option to **WB**, the Named Range Key property (in the Setup section of the Properties view of the Microsoft Office Excel Analysis system) will be set to **WB** for all new projects you create.

- If you have specified a different filtering prefix the project level via the Named Range Key property, the project-level setting will not be affected by changes to this option.

**TurboSystem**

From **Tools → Options → TurboSystem**, selecting or clearing Include inlet/outlet domains in Turbo Mesh cells by default causes subsequently created Turbo Mesh cells to have the Meshing → Inlet Domain and Meshing → Outlet Domain properties initially selected or cleared, respectively.

**Meshing**

From **Tools → Options → Meshing** you can specify the following:

**Auto Detect Contact On Attach**  
Controls whether contact detection is computed upon geometry import into Meshing. Default: Enabled.

**Save Mesh Data In Separate File**  
Controls the default setting for the Save Mesh Data In Separate File property for subsequently created Meshing components. The property setting controls whether mesh data is stored in a separate .acmo file for the current system.
Saving the mesh data in a separate file reduces the overall file space required and reduces the possibility of disc corruption in very large database files on Linux systems.

**Design Points** During a design point update, periodically restart the Meshing application - Directs the Meshing application to automatically restart after the specified number of design points when running in batch mode. Default: Enabled and set to restart after each (one) design point.

Each restart resets the Meshing; application and slightly lengthens the processing time, but can improve overall system performance (memory and CPU) when the meshing of each design point is long. In such cases, specify a low number (minimum is one) of design points before restarts.

In cases where the meshing step for each design point is short, reduce processing time by increasing the number of design points before restarts or prevent restarts completely by disabling this preference.

**Geometry Import**

From Tools → Options → Geometry Import → Geometry Import you can specify the following:

**Preferred Geometry Editor**

- DesignModeler
- SpaceClaim Direct Modeler (default)

---

**Note**

The SpaceClaim Direct Modeler option is not available when the Use SpaceClaim Direct Modeler as an External CAD option is checked.

---

**CAD Licensing**

- **Hold:** Instructs ANSYS Workbench to keep the license after the import or refresh operation has completed. The option is useful when executing design studies.

  If the Hold option was previously set and subsequently changed to **Release**, the license will be released immediately after clicking OK on the Options dialog box. A plug-in license that is held will always be released when exiting the ANSYS Workbench session.

- **Release** (default): Instructs ANSYS Workbench to free the license for someone else's use after the import or refresh operation has completed.

---

**Note**

The **CAD Licensing** option is not supported for geometry import into SpaceClaim Direct Modeler. In such cases, SpaceClaim Direct Modeler always releases its CAD licenses after importing.

---

**SpaceClaim Preferences**

- **Use SpaceClaim Direct Modeler as an External CAD** Controls interactions between the Workbench and SpaceClaim Direct Modeler. When unchecked (default), SpaceClaim is fully integrated into the Project
Schematic as a geometry editor. When checked, SpaceClaim is controlled as an External CAD system, with no direct integration into the Project Schematic.

**Note**

- Switching this preference from within an active project could result in project schematic inconsistencies and undesired behavior. It is advised that this preference be set during project creation and remain unchanged by all users interacting with the project.

- If the preference must be changed, the Geometry systems that reference SpaceClaim geometry should be Reset and reconfigured to properly release any previously stored parameters and file references.

- **Use Workbench Project Units for Length and Angle** When it is launched from Workbench, SpaceClaim Direct Modeler adopts the units of the Workbench project.

- **Use Workbench Language Settings** When it is launched from the Workbench Project Schematic, SpaceClaim Direct Modeler adopts the language used by Workbench.

**Design Point Specific**

- **Geometry editor behavior during update:** Controls the visibility of the geometry editor during a design point update.
  - **Default:** The update will be run in batch mode. If the geometry editor was open prior to the update, it will be reopened at the completion of the update.
  - **Run interactively:** Forces the geometry editor to be run interactively for the entire update. If the geometry editor was open prior to the update, it will be reopened at the completion of the update.
  - **Run in batch mode:** Forces the geometry editor to be run in batch mode for the entire update. The geometry editor will be left closed at the completion of the update.

- **Keep the geometry editor running for optimized design point updates:** Directs the geometry editor to stay open (in batch or interactively based on the “Geometry editor behavior during update”) and use the same session during a design point update. Allows for quicker processing time as the geometry editor is not restarted after each design point.

- **Keep the geometry editor running for optimized design point updates > Periodically restart the geometry editor:** Directs the geometry editor to automatically restart after the specified number of design points (Specified in “Number of design points to update before restarting the geometry editor”).

- **Keep the geometry editor running for optimized design point updates > Periodically restart the geometry editor > Number of design points to update before restarting the geometry editor:** Default is zero, which executes the same as if this preference were disabled. Each restart resets the geometry editor and slightly lengthens processing time, but can improve overall system performance (memory and CPU) when the geometry update of each design point is long. In such cases, specify a low number (1 or more) of design points before each restart. In cases where the geometry update for each design point is short, reduce processing time by increasing the number of design points before each restart, or prevent restarts completely by disabling this preference.
Basic Options

For detailed descriptions of the basic geometry import options, see the Basic Geometry Options table at Geometry Preferences in the CAD Integration section of the ANSYS Help.

Advanced Options

- **Analysis Type**  Specifies the analysis type. You can choose either 3D or 2D.

For detailed descriptions of the advanced geometry import options, see the Advanced Geometry Options table at Geometry Preferences in the CAD Integration section of the ANSYS Help.

Using Software Licensing in ANSYS Workbench

ANSYS Workbench offers two licensing methods at Release 18.2:

- Share a single license between applications (default) (shared mode)
- Use a separate license for each application (separate mode)

Use the Licensing Preferences dialog box (Start > All Programs > ANSYS 18.2 > ANSYS Client Licensing > User License Preferences 18.2) to specify which method to use and which licenses to use. You must specify the licensing method before starting an ANSYS Workbench session. If you access the Licensing Preferences dialog box from the ANSYS Workbench Tools menu, you will not be able to choose a licensing preference from there.

Single License Sharing  ANSYS Workbench allows you to work across multiple applications and workspaces in ANSYS Workbench while consuming only one of a single type of license per user per session. Using shared licensing, the active application holds the license, preventing other applications that are sharing that license from using it during that time. The application or operation requiring use of the license is called a concurrency event. For example, meshing and solving would each be a concurrency event.

Single license sharing allows you to progress through your analysis, from specifying engineering data through building or attaching a geometry, meshing, setup, solving, and finally, reviewing your results, all under the same license. The application holding the license must close or issue a PAUSE command, or receive an automatic release request to release the license and allow another application to use it. Licenses cannot be released while an application is actively performing a licensed operation (for example, an application cannot release a license in the middle of a solve operation; the license cannot be released until the solve operation is completed).

Single license sharing applies only to licenses of the same type (e.g., Mechanical). Choosing this option does not affect your ability to use licenses of different types simultaneously (e.g., Mechanical for one task and Fluid Dynamics for another).

Because this method is the default, you do not have to take any action to run this way.

Explanation of License Type and Examples  License type is primarily by license feature. It is possible to use both a Mechanical and an Emag license within a single ANSYS Workbench session. It is also possible to use both a Multiphysics and a Mechanical license within a single ANSYS Workbench session.

The first license checked out within a session will be based on your preferences and what capabilities are being requested. For all applications other than the first (subsequent) one opened (within ANSYS Workbench), ANSYS licensing will first look at what other licenses are opened within this session. These
subsequent license requests will look at sharing first to satisfy their request: do any other licenses being used within this session fulfill the needed capabilities? If yes, share an existing license. If not, preferences are used and a new, different license is checked out.

**Example 1:** You have one license for Multiphysics and one license for Mechanical, with Multiphysics listed first in your preferences. The first application starts and only needs capabilities in Mechanical. Since Multiphysics contains Mechanical capabilities and is first in your preferences, Multiphysics will be checked out. The second application starts and needs Multiphysics; since Multiphysics is already checked out, the second application will share it with the first. Only the Multiphysics license is consumed in this session.

**Example 2:** You have one license for Multiphysics and one license for Mechanical, with Mechanical listed first in your preferences. The first application starts and only needs capabilities provided in Mechanical, so Mechanical is checked out. The second application starts and needs capabilities provided on Multiphysics; since (the already in use) Mechanical cannot satisfy its requirements, it checks out Multiphysics. Both a Multiphysics and a Mechanical license are consumed in this session.

**Restrictions of Single License Sharing** You cannot run two concurrency events simultaneously (for example, you cannot mesh one model and solve another simultaneously) with one license.

If you are using a license for one application, other applications may still not be able to share that license if those applications require capabilities not supported by the license. For example, you cannot share a Mechanical license with a Fluent application.

**Single License Sharing in ANSYS Workbench Applications** ANSYS Workbench applications handle single license sharing differently:

**The Mechanical Application:**
You can launch the Mechanical application and move between its components (such as Meshing, Setup, and Solve). The active component will control the license while completing its operations and will release the license as soon as the operation is completed. For example, when you mesh, the Meshing component will control the license during the meshing operation and then immediately release the license when the operation is completed. The other components will remain in a read-only mode while Meshing uses the license, allowing you to view the data in other components but not operate on it.

---

**Note**
Applications in read-only mode because of shared licensing do not refresh their license status automatically. Once the shared license is released by the editor that had consumed it, you must trigger Mechanical to query the license status. The most straightforward way to do this is click outside the Mechanical application window and then click back in the window to cause the license availability to be rechecked.

**The Mechanical APDL Application:**
This application consumes a license as soon as you launch it, and retains that license until it is finished. If you launch the Mechanical APDL application interactively, the license is retained until you either close the application or issue a PAUSE command at the Mechanical APDL command line. PAUSE allows you to temporarily release the license for another application to use. No other operation other than SAVE or /EXIT is permitted while PAUSED. When the second application has finished and releases the license, issue an UNPAUSE command from the Mechanical APDL command line to resume its use of the license.
CFX, Fluent, Autodyn, Polyflow:
These applications consume a license when launched and retain the license until they receive a request from another application to release it. For example, if you open CFX-Pre, CFX-Pre will obtain and control the license. It will retain the license until you close the application or until another application (such as the CFX solver) requests it.

Autodyn and Polyflow also provide a manual PAUSE feature that allows you to interrupt Autodyn or Polyflow and release the license, temporarily, for another application to use.

Separate Licenses    By using the separate-licenses method, ANSYS Workbench requires a separate license for each application. By using this method, you can move freely between the many applications that you might require during an analysis in ANSYS Workbench, provided that you have sufficient licenses. You can leave each application running and easily move between them at any point during the analysis, even if one of the applications is actively using the license (such as during a solve process). The disadvantage to this method is that you could potentially consume many licenses.

To activate the separate licenses method, choose Use a separate license for each application in the Licensing Preferences dialog box (Start > All Programs > ANSYS 18.2 > ANSYS Client Licensing > User License Preferences 18.2). You must specify the licensing method before starting an ANSYS Workbench session.

Examples of Using Separate Licenses    You have two Mechanical licenses. When you open and mesh or solve a model in the Mechanical application, you consume one Mechanical license. If you link that Mechanical analysis to a Mechanical APDL system, you would consume a second Mechanical license when you launch the Mechanical APDL application, if you have not closed out of the Mechanical application. Neither of these licenses would then be available for other users until you closed out of one or both of the applications.

Explicit Product Licensing

Licenses that can be used to start the Mechanical application products are called primary configured tasks. Licenses that cannot start a product but add functionality are called add-on licenses. Most licenses are either one or the other. A primary configured task license will only be pulled during the launch of the application and cannot be added on-demand if the application is already open. For example, the Multi-Body Dynamics analysis is only supported as an add-on license, so another, primary configured task license will be needed to start the Mechanical application for a Transient Structural (Rigid dynamics) analysis. An add-on license will be used whenever the need arises, even if the Mechanical application is opened. However, the ANSYS Explicit STR products like AUTODYN-2D, AUTODYN-3D, and ANSYS Explicit STR are of a dual nature and are supported both as primary configured tasks and as add-ons. The dual nature of explicit products enables the analysis of the mixed implicit and explicit system using a single Mechanical editor.

Configuring External Solvers for Use with ANSYS Workbench

This section describes how to set up your environment to use the Samcef and ABAQUS solvers within ANSYS Workbench.

Configuring Samcef
Configuring ABAQUS

Configuring Samcef

After installing the Samcef program, you must set the following environment variables for compatibility with ANSYS Workbench:
**SAM TECH LICENSE FILE**

The path to your license server or license file. See the Samcef documentation for more information.

**SAM_EXE**

The path to the Samcef executable folder. In a standard installation, this is the `Exec` folder in the base directory of the Samcef install. For instance, if Samcef is installed at `C:\Samcef`, the path to the executable folder would be `C:\Samcef\Exec`.

**SAM_WORK**

The path to a temporary folder for a local run of Samcef. See the Samcef documentation for more information.

---

**The Samcef Result Storage Configuration File**

The exact results stored by the Samcef solver can be controlled using an XML configuration file. This file uses Samcef SAI codes to define which results to write to the results file. Results are classified by result type and category. The configuration file is located at `ANSYS_INSTALL_DIR\v182\aisol\WBAddins\SamcefAddin\SamcefArchiveSettings.xml`.

The configuration file is read when Mechanical is launched. If changes are made to the file while Mechanical is running, Mechanical must be restarted to reflect the changes.

The XML root element in this file is `<SamcefArchiveSettings>`. The child nodes of this root element represent analysis types. The only valid child node is `<Analysis>`, and this child node has the following attribute:

**name (type string)**

The analysis type:
- `default`
- `modal`
- `non_linear`
- `harmonic`
- `thermal`

The `<Analysis>` node can have a child node of `<Output>`, which has the following attribute:

**type (type string)**

The option type, used to order SAI codes in the solver input file:
- `nodal`
- `elemental`

The `<Output>` node has child nodes of `<Codes>` which have the following attributes:

**value (type string)**

List of Samcef SAI codes separated by spaces. Usually a list of integers, positive or negative.

**category (type string)**

Optional, used for options enable or disabled by the user:
- `stress`
- `strain`
- `thermal_flux`
- `contact`
When a solve is executed and the solver input file is created, Mechanical finds the correct `<Analysis>` node in the configuration file to determine the SAI codes to write to the input file. This check is performed by finding the analysis type and whether the analysis is linear or nonlinear. The following table describes the mapping:

<table>
<thead>
<tr>
<th>Workbench Analysis Type</th>
<th>Option</th>
<th><code>&lt;Analysis&gt;</code> Node Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Static Structural (Samcef)</td>
<td>Linear</td>
<td>default</td>
</tr>
<tr>
<td></td>
<td>Nonlinear</td>
<td>non_linear</td>
</tr>
<tr>
<td>Transient Structural (Samcef)</td>
<td>Linear</td>
<td>default</td>
</tr>
<tr>
<td></td>
<td>Nonlinear</td>
<td>non_linear</td>
</tr>
<tr>
<td>Modal (Samcef)</td>
<td>Linear</td>
<td>modal</td>
</tr>
<tr>
<td></td>
<td>Nonlinear</td>
<td>non_linear</td>
</tr>
<tr>
<td>Harmonic Response (Samcef)</td>
<td>-</td>
<td>harmonic</td>
</tr>
<tr>
<td>Eigenvalue Buckling (Samcef)</td>
<td>-</td>
<td>No SAI code written</td>
</tr>
<tr>
<td>Steady-State Thermal (Samcef)</td>
<td>-</td>
<td>thermal</td>
</tr>
<tr>
<td>Transient Thermal (Samcef)</td>
<td>-</td>
<td>thermal</td>
</tr>
</tbody>
</table>

The Samcef Postprocessing Configuration File

In order to postprocess all results from the Samcef solver in the Workbench interface, an XML file is used to map the results between Samcef and Workbench. The XML file defines all of the Workbench result codes with associated data, and lists the corresponding Samcef codes. The configuration file is located at `ANSYS_INSTALL_DIR\v182\aisol\WBAAddins\SamcefAddin\SamcefResult-Codes.xml`.

The configuration file is read when Mechanical starts postprocessing Samcef data. If changes are made to the file while Mechanical is running, Mechanical must be restarted to reflect the changes.

The following is an example result as expressed in the XML configuration:

```xml
<Result result_name="U" result_id="101" data_type="nodal" out_unit="length" style="vector" num_comp="5" comp_labels="XYZLABELS" description="Deformations(XYZs)"/>
   <Codes>
      <Code name="Code 163" />
   </Codes>
</Result>
```

The listing provides the following information:

- The Workbench code "U" identified by Mechanical by the ID 101 is a nodal result and is interpreted as a length.
- The result is represented in the vector style, has 5 components and is part of the XYZLABELS group.
- The result corresponds to Samcef result code, "Code 163".

The XML `Result` object can have the following attributes:

**result_name (type string)**

The Workbench name of the result. Standard Mechanical names are reserved.
result_id (type integer)
The Workbench ID of the result. Standard Mechanical IDs are reserved; you should start numbering solver-specific results at 100000. You should not choose a number larger than 1000000 because those numbers are internally reserved.

data_type (type string enumerate)
The result type:
- nodal
- elem_nodal
- elemental

out_unit (type string enumerate)
The unit type of the result. If this value is defined_per_component, the subtag <UnitsPerComponent> must be defined.

The <UnitsPerComponent> node contains individual <Component> nodes with the attributes name and out_unit. The name attribute corresponds to the component name, and the out_unit attribute has the same requirements as this attribute.

```xml
<UnitsPerComponent>
  <Component name="XXX" out_unit="XXX" />
  <Component out_unit="XXX" />
</UnitsPerComponent>
```

- no_units
- acceleration
- angle
- angular_velocity
- area
- capacitance
- charge
- charge_density
- conductivity
- current
- current_density
- density
- displacement
- electric_conductivity
- electric_field
- electric_flux_density
- electric_resistivity
- energy
- film_coeff
- force
- force_intensity
- frequency
- heat_flux
- heat_generation
- heat_rate
- inductance
- inverse_stress
- length
- magnetic_field_intensity
• magnetic_flux
• magnetic_flux_density
• mass
• moment
• moment_inertia
• permeability
• permittivity
• poisson
• power
• pressure
• relative_perm permeability
• relative_permittivity
• section_modulus
• specific_heat
• specific_weight
• shear_strain
• stiffness
• strain
• stress
• strength
• thermal_expansion
• temperature
• time
• velocity
• voltage
• volume
• gasket_stiffness
• moment_inertia_mass
• psd_acceleration
• psd_acceleration_grav
• psd_displacement
• psd_velocity
• rotational_damping
• rotational_stiffness
• translational_damping
• angular_acceleration
• seedbeck_coefficient
• decay_constant
• fracture_energy
• shock_velocity
• energy_density_mass
• electric_conductance_per_unit_area
• psd_stress
• psd_strain
• psd_force
• psd_moment
• psd_pressure
• force_per_angular_unit
• impulse
• impulse_per_angular_unit
• temperature_difference
• material_impedance
- rs_acceleration
- rs_acceleration_grav
- rs_displacement
- rs_velocity
- warping_factor
- thermal_conductance
- inverse_length
- inverse_angle
- thermal_capacitance
- normalized_value
- mass_flow_rate
- unitless
- stress_intensity_factor
- sqrt_length
- energy_per_volume
- thermal_gradient

**style (type string enumerate)**
The style of the value:
- scalar
- vector
- tensor
- tensor_strain
- euler_angles
- coordinate
- shear_moment_diagram

**num_comp (type integer)**
Number of components, between 1 and the length of **comp_labels**.

**comp_labels (type string enumerate)**
The component labels:
- XYZLABELS
- STRESSLABELS
- CONTACTLABELS
- BEAMLABELS
- GASKETLABELS
- NLLABELS
- MISCLABELS
- SENGLABELS
- SPRINGLABELS
- BEAM188LABELS
- RADIOSITYLABELS
- EULERLABELS
- BEAMRXLABELS
- THERMALMASSLABELS
- SHELLMBPLABELS
- SLASHPNUMLABELS
- CINNLABELS
- PRIN_S_LABELS
- PDMG_LABELS
- PFC_LABELS
description (type string)
Free text.

Once the <Result> node is defined, the <Codes> node with the individual <Code> child nodes are defined. The <Codes> node can have the following attributes:

hasShell (type string)
If present and value = true, the layer attribute should be defined.

layer (type integer)
Only necessary if hasShell is set to true.
- 1 - bottom
- 2 - middle
- 3 - top

---

**Note**

It is possible to have a <Codes> node without any child <Code> nodes. It can be used to define a result with layers but no associated codes for those layers, for example TEMP_UP-SHELL.

The <Code> child nodes can have the following attributes:

name (type string)
Value of the Samcef solver code, generally of the form "Code XXX" or "Sdb XXX".

module (type string)
Optional, if set, defines the code only for a specific Samcef module. Possible values are:
- ba - Bacon
- me - mechano
- as - asef
- st - stabi
- dy - dynam
- mt - mechano/thermal
- re - repdyn

**Limitations**

- If the XML of the configuration file is missing or not well-formed, no results are available.
- If a result has invalid syntax (missing XML components, invalid attributes), it is not available.
- Mechanical must be restarted if any changes are made to the result configuration file during operation.

**Configuring ABAQUS**

ABAQUS versions 6.11 and 6.14 are supported.
After installing ABAQUS, you must configure the `ANSYS_INSTALL_DIR\v182\aisol\WBAddins\AbaqusAddin\config.xml` file in order to postprocess results. Edit the `config.xml` file with a text editor, and specify the version of ABAQUS you have installed:

- `<AbaqusVersion version="6.11-2">`
- `<AbaqusVersion version="6.14-3">`

If more than one version of ABAQUS is installed on your machine, the paths to the version configured for use with ANSYS Workbench must appear first in your `PATH` environment variable.

Assuming ABAQUS is installed at `C:\SIMULIA\Abaqus`, for ABAQUS 6.11-2, the `PATH` environment variable must contain:

- `C:\SIMULIA\Abaqus\Commands`
- `C:\SIMULIA\Abaqus\6.11-2\exec\lbr`
- `C:\SIMULIA\Abaqus\6.11-2\External`
- `C:\SIMULIA\Abaqus\External\Backbone`

Assuming ABAQUS is installed at `C:\SIMULIA\Abaqus`, for ABAQUS 6.14-3, the `PATH` environment variable must contain:

- `C:\SIMULIA\Abaqus\Commands`
- `C:\SIMULIA\Abaqus\6.14-3\code\bin`
- `C:\SIMULIA\Abaqus\6.14-3\tools\SMApy\python2.7\Lib`

The default configuration is for ABAQUS 6.11-2. If the ABAQUS version installed does not match the version specified in the `config.xml` file, Mechanical returns an error when trying to postprocess the ODB result file.

**The ABAQUS Result Storage Configuration File**

The exact results stored by the ABAQUS solver can be controlled using an XML configuration file. This file uses ABAQUS Program Controlled codes to define which results to write to the results file. Results are classified by result type and category. The configuration file is located at `ANSYS_INSTALL_DIR\v182\aisol\WBAddins\AbaqusAddin\AbaqusArchiveSettings.xml`.

The configuration file is read when Mechanical is launched. If changes are made to the file while Mechanical is running, Mechanical must be restarted to reflect the changes.

The XML root element in this file is `<AbaqusArchiveSettings version="1">`. The child nodes of this root element represent analysis types. The only valid child node is `<Analysis>`, and this child node has the following attribute:

**name (type string)**
The analysis type:
- `struct`
- `eigen`
- `thermal`
The `<Analysis>` node can have a child node of `<Output>`, which has the following attribute:

**type (type string)**
- The option type, used to order codes in the solver input file:
  - nodal
  - elemental
  - contact
  - energy
  - radiation

The `<Output>` node has child nodes of `<Codes>` which have the following attributes:

**value (type string)**
- List of ABAQUS codes separated by spaces. Usually a list of integers, positive or negative.

**position (type string)**
- For elemental results, if a result exists with a matching position, it is used. Otherwise results without position are used.

**category (type string)**
- Optional, used for options enable or disabled by the user.
  - stress
  - strain
  - thermal
  - contact

When a solve is executed and the solver input file is created, Mechanical finds the correct `<Analysis>` node in the configuration file to determine the SAI codes to write to the input file. This check is performed by finding the analysis type and whether the analysis is linear or nonlinear. The following table describes the mapping:

<table>
<thead>
<tr>
<th>Workbench Analysis Type</th>
<th><code>&lt;Analysis&gt;</code> Node Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Static Structural (ABAQUS)</td>
<td>struct</td>
</tr>
<tr>
<td>Transient Structural (ABAQUS)</td>
<td>struct</td>
</tr>
<tr>
<td>Modal (ABAQUS)</td>
<td>eigen</td>
</tr>
<tr>
<td>Steady-State Thermal (ABAQUS)</td>
<td>thermal</td>
</tr>
<tr>
<td>Transient Thermal (ABAQUS)</td>
<td>thermal</td>
</tr>
</tbody>
</table>

**The ABAQUS Postprocessing Configuration File**

In order to postprocess all results from the ABAQUS solver in the Workbench interface, an XML file is used to map the results between ABAQUS and Workbench. The XML file defines all of the Workbench result codes with associated data, and lists the corresponding Samcef codes. The configuration file is located at `ANSYS_INSTALL_DIR\v182\aisol\WBAdds\AbaqusAddin\VkiAbaqusResult-Codes.xml`.

The configuration file is read when Mechanical starts postprocessing ABAQUS data. If changes are made to the file while Mechanical is running, Mechanical must be restarted to reflect the changes.

The following is an example result as expressed in the XML configuration:

```xml
<Result result_name="U" result_id="101" data_type="nodal" out_unit="length" style="vector"
```
The listing provides the following information:

- The Workbench code "U" identified by Mechanical by the ID 101 is a nodal result and is interpreted as a length.

- The result is represented in the vector style, has 5 components and is part of the XYZLABELS group.

- The result corresponds to vki result "D", which comes from ABAQUS code "U".

The XML Result object can have the following attributes:

**result_name (type string)**
The Workbench name of the result. Standard Mechanical names are reserved.

**result_id (type integer)**
The Workbench ID of the result. Standard Mechanical IDs are reserved; you should start numbering solver-specific results at 100000. You should not choose a number larger than 1000000 because those numbers are internally reserved.

**data_type (type string enumerate)**
The result type:
- nodal
- elem_nodal
- elemental

**out_unit (type string enumerate)**
The unit type of the result:
- no_units
- acceleration
- angle
- angular_velocity
- area
- capacitance
- charge
- charge_density
- conductivity
- current
- current_density
- density
- displacement
- electric_conductivity
- electric_field
- electric_flux_density
- electric_resistivity
- energy
- film_coeff
- force
- force_intensity
• frequency
• heat_flux
• heat_generation
• heat_rate
• inductance
• inverse_stress
• length
• magnetic_field_intensity
• magnetic_flux
• magnetic_flux_density
• mass
• moment
• moment_inertia
• permeability
• permittivity
• poisson
• power
• pressure
• relative_permeability
• relative_permittivity
• section_modulus
• specific_heat
• specific_weight
• shear_strain
• stiffness
• strain
• stress
• strength
• thermal_expansion
• temperature
• time
• velocity
• voltage
• volume
• gasket_stiffness
• moment_inertia_mass
• psd_acceleration
• psd_acceleration_grav
• psd_displacement
• psd_velocity
• rotational_damping
• rotational_stiffness
• translational_damping
• angular_acceleration
• seedbeek_coefficient
• decay_constant
• fracture_energy
• shock_velocity
• energy_density_mass
• electric_conductance_per_unit_area
• psd_stress
• psd_strain
- psd_force
- psd_moment
- psd_pressure
- force_per_angular_unit
- impulse
- impulse_per_angular_unit
- temperature_difference
- material_impedance
- rs_acceleration
- rs_acceleration_grav
- rs_displacement
- rs_velocity
- warping_factor
- thermal_conductance
- inverse_length
- inverse_angle
- thermal_capacitance
- normalized_value
- mass_flow_rate
- unitless
- stress_intensity_factor
- sqrt_length
- energy_per_volume
- thermal_gradient

**style (type string enumerate)**
The style of the value:
- scalar
- vector
- tensor
- tensor_strain
- euler_angles
- coordinate
- shear_moment_diagram

**num_comp (type integer)**
Number of components, between 1 and the length of `comp_labels`.

**comp_labels (type string enumerate)**
The component labels:
- XYZLABELS
- STRESSLABELS
- CONTACTLABELS
- BEAMLABELS
- GASKETLABELS
- NLLABELS
- MISCLABELS
- SENGLABELS
- SPRINGLABELS
- BEAM188LABELS
- RADIOSITYLABELS
- EULERLABELS
is_membrane (type boolean)
If this attribute is present and marked true, the result is only added if the model has a membrane.

is_six_dof (type boolean)
Optional, applies for only "R" and "M" type Workbench results.

description (type string)
Free text.

The <Solver> node references the solver used by the attribute name. All child <Code> nodes are the codes associated to the Workbench result for this solver. A code is an alphanumerical string referred by attribute name. It is possible to define several codes for the same solver.

The <vki> node is another way to match the solver result. This node has the following attributes:

vki_root_name (type string)
The vki root name as described in the documentation/API.

vki_aux_name (type string)
Only required if vki_root_name is set to UNKNOWN. Matches the vki result in case of unknown vki type.

---

**Note**

If solver-specific data and vki data are fulfilled for a specific result, Mechanical will first try to match the vki code. If it is not found, it will try to match the solver-specific code. For example, when reading a result file, the vki dataset E_ELAST is found, with solver-specific data EE. Mechanical looks for a Workbench result having vki root name E_ELAST. If not found, it looks for a Workbench result having Abaqus code EE.

---

**Limitations**

- If the XML of the configuration file is missing or not well-formed, no results are available.
- If a result has invalid syntax (missing XML components, invalid attributes), it is not available.
- Mechanical must be restarted if any changes are made to the result configuration file during operation.

The following results don’t appear in the XML file, as they have behavior which is not compatible:

- SERR - not associated to VKI or ABAQUS, is available if S and SVOLU are also available.
Customizing Workbench with ANSYS ACT

With ANSYS ACT, you can create extensions to customize supported ANSYS products, including ANSYS Workbench.

ACT provides three levels of Workbench customization:

- **Feature Creation**
  
  Feature creation is the direct, API-driven customization of an ANSYS product. In addition to leveraging the functionality already available in Workbench, ACT enables you to add functionality and operations of your own. Examples of feature creation include the creation of custom loads and geometries, the addition of custom preprocessing or postprocessing features, and the integration of third-party solvers, sampling methods, and optimization algorithms.

  For more information, see Common Capabilities and ACT-Based Properties in the ANSYS ACT Developer's Guide.

- **Simulation Workflow Integration**
  
  Simulation workflow integration is the incorporation of external knowledge such as apps, processes, and scripts into the ANSYS ecosystem. Using ACT, you can customize simulation workflows in the Workbench Project tab.

  For example, you can create custom task groups (systems) and custom tasks (components) for insertion in the Project Schematic, constructing consistent and cohesive simulation workflows that allow your business-specific elements to coexist and interface with pre-built ANSYS solutions.

  For components that support updates via Remote Solve Manager (RSM), you can use ACT to configure job submission options for remote and background updates.

  For more information, see Simulation Workflow Integration and Custom ACT Workflows in Workbench Examples in the ANSYS ACT Developer's Guide.

- **Process Compression**
  
  Process compression is the encapsulation and automation of existing processes available in an ANSYS product. The result is a wizard that provides guidance within the product workflow, walking the end user step-by-step through a simulation. You can create "single" wizards to run in the Workbench Project tab or "mixed" wizards to be run across several ANSYS products.

  Wizards allow you to leverage both the existing functionality of Workbench and the scripting capabilities of the Workbench framework API. With a wizard, you can manipulate existing features and simulation components, organizing them as needed to produce a custom automated process. You can also customize the user interface of a wizard as a whole and define layouts for individual interface components.

  For more information, see Simulation Wizards and Wizard Examples in the ANSYS ACT Developer's Guide.
Working in the ANSYS Workbench Project Tab

In the Project tab, you will take systems from the Toolbox and add them to the Project Schematic. Systems are added from left-to-right, and from top-to-bottom. All data transfer occurs from left (also called upstream) to right (also called downstream); you cannot transfer data from right to left. Therefore, when placing or moving systems, it is important that you place receiving systems to the right of sending systems. All processing of data (such as updates) also occurs in the same direction, from left-to-right and top-to-bottom. Again, be aware of this order when placing or moving systems.

Most analysis systems are defined by three primary attributes: physics type, analysis type, and solver type. ANSYS Workbench uses these attributes to determine valid data transfer and system replacement possibilities. For more information on the types of systems, see ANSYS Workbench Systems (p. 179).

Related Topics:
- Adding Systems to the Project Schematic
- Naming and Renaming Systems
- Working through a System
- Creating and Linking to a Second System
- Duplicating Systems
- Moving, Deleting, and Replacing Systems

Adding Systems to the Project Schematic

The first step in building an analysis is to take one or more systems from the Toolbox and add them to the Project Schematic. ANSYS Workbench offers the following methods of adding new systems:

- Double-click the system in the Toolbox
- Drag the system from the Toolbox and drop it into the Project Schematic
- Right-click the Project Schematic and select the system from the context menu
Adding a System by Double-Clicking

The simplest way to add a new system to the Project Schematic is to double-click the desired system in the Toolbox. The system is placed in a new row in the Project Schematic, below any existing systems.

Adding a System using Drag-and-Drop

You can add a system to the Project Schematic by dragging it from the Toolbox and dropping it in the desired location. This method provides a preview of possible target locations, allowing you to choose the best location for that system. The green boxes in the following animation indicate possible drop targets.

If you move the mouse over one of the drop targets, the box will change to red and text will indicate the result of dropping at that location.

In cases where the new system can be linked to one or more existing systems, drop targets are also shown on the eligible cells of the existing system(s).

The following animation demonstrates adding systems via the double-click and drag-and-drop methods. In this example, several cells of the Structural Static system are also possible drop targets of the Modal system. For more information, see Creating and Linking to a Second System (p. 56).

The following Show-Me Animation is presented as an animated GIF in the online help. If you are reading the PDF version of the help and want to see the animated GIF, access this section in the online help. The interface shown may differ slightly from that in your installed product.

Note

When you attempt to add an invalid system (for example, if the mesh type is not compatible with the system you are attempting to add), the drop target preview will be visible, but the
system will not be added when you release the mouse. Details are written to the Messages View (p. 311).

Adding a System using the Context Menu

You can add a system to the Project Schematic by right-clicking the white space in the Project Schematic. The context menu includes a list of New ... Systems options, enabling you to select the system category and a specific system within that category (the system options reflect your Toolbox configuration). For example, to introduce a new Static Structural system, right-click the Project Schematic white space and select New Analysis Systems → Static Structural, as shown below.

To add a new system with a link to an existing system, right-click the appropriate cell of the existing system. Select Transfer Data From New to create a new system upstream of the selected cell. Select Transfer Data To New to create a system downstream from the selected cell. The following animation demonstrates adding a system using the Transfer Data context menu options.

The following Show-Me Animation is presented as an animated GIF in the online help. If you are reading the PDF version of the help and want to see the animated GIF, access this section in the online help. The interface shown may differ slightly from that in your installed product.
For more information, see Creating and Linking to a Second System (p. 56).

**Naming and Renaming Systems**

In general, it is good practice to give each system a descriptive name that is meaningful for you and that indicates the details of the system. ANSYS Workbench enables you to specify a name for each system, either initially when the system is added to your project, or at any time afterward.

**Naming Systems**

When a new system is added to the **Project Schematic**, the default name of the system will be in focus (highlighted), as shown below.

When the name is in focus, it is editable and you can enter a new name for the system. To accept the default name for the system (the default name is usually the same as the system type), click **Enter** or select any other action in the user interface. In the example shown below, we have typed the name “My Structural Analysis.”
After you click **Enter** (either after entering a new name or accepting the default name), the focus moves to the system cell requiring attention first (see *Understanding Cell States* (p. 315)). In the example above, this cell is the **Geometry** cell. By applying focus in this manner, ANSYS Workbench draws your attention to the cell where you will most likely begin working with your system (see *Working through a System* (p. 51)).

**Renaming Systems**

To rename an existing system, you can double-click the system name. Alternatively, you can right-click the system header (Row 1) and select **Rename** from the context menu. Type the new name and click **Enter**.

The example below shows the system being renamed to “My Structural Analysis.”

**Working through a System**

ANSYS Workbench provides you with a straightforward workflow for creating and working through a system. First, you select a system from the **Toolbox** and add it to the **Project Schematic** (see *Adding Systems to the Project Schematic* (p. 47)). Then you work through the cells in the system, generally from top-to-bottom, until you have completed all the required steps for your analysis.

In most cases, data flows from top-to-bottom through the system, as well. For example, in a Mechanical system, the geometry must be defined before you can define the model; the **Model** cell uses the geometry defined in the **Geometry** cell as its input.
Because the workflows for different types of analyses differ to some degree, we have included two typical examples of working with analysis systems: one for a mechanical analysis (see Basic Mechanical Analysis Workflow (p. 53)) and one for a fluid flow analysis (see Basic Fluid Flow Analysis Workflow (p. 54)).

**Defining your Simulation Geometry**

All analysis systems and several component systems begin with a geometry-definition step. You can define the geometry differently depending on the type of simulation you are running. In most cases, you will use the Geometry cell. With the Geometry cell, you can:

- Create a geometry in DesignModeler or SpaceClaim.
- Import an existing geometry:
  - From neutral formats such as IGES, STEP, Parasolid, and ACIS.
  - From CAD files.
  - From a CAD session running on the same machine.

For Fluid Flow simulations, you can also start with an imported mesh or case file; see Basic Fluid Flow Analysis, Starting from an Imported Mesh (p. 55) for details.

**Specifying Geometry via the Context Menu**

1. Right-click the Geometry cell.
2. Choose New DesignModeler Geometry or New SpaceClaim Geometry to launch those respective programs and create a new model, or choose Import Geometry and browse to an existing CAD model.

Alternatively, you can also launch ANSYS Workbench directly from some CAD systems. When doing so, ANSYS Workbench starts with a Geometry system in place and the CAD file already attached.

After you have attached or imported your geometry, the state (p. 315) appears as Up to Date, and the icon indicates the type of file imported. Geometry types include:

- ACIS (.sat)
- ANSYS Neutral File (.anf)
- Autodesk Inventor (.ipt, .iam)
- BladeGen (.bgd)
- CATIA v4 (.model, .dlv)
- CATIA v5 (.CATPart, .CATProduct)
- Creo Elements/Direct Modeling (.pkg, .bdl, .ses, .sda, .sdp, .sdac, .sdpc)
If you do not need to make any additional changes to your geometry, you can continue working through the analysis as described in the next sections.

If your geometry must be modified before continuing with your analysis, you can edit the geometry in DesignModeler or SpaceClaim. After modifying the geometry, the icon in the Geometry cell will change to the icon of the application you used to make those modifications. For a file imported and then modified in DesignModeler, you can open the file in DesignModeler, and the DesignModeler model tree will indicate the original source of the geometry.

After the geometry is defined, you can share it with other systems. See Data Sharing and Data Transfer for more information on sharing geometry systems.

For detailed CAD-related information specific to the ANSYS DesignModeler application and ANSYS Workbench, see CAD Integration.

**Basic Mechanical Analysis Workflow**

After introducing a new Mechanical analysis system to the Project Schematic and assigning an appropriate name, the focus is typically directed to the Geometry cell, because this is usually the first cell in the system that requires user input. You could edit or define material models via the Engineering Data cell, but this example assumes that the default materials will suffice.
You typically work through the system from top to bottom. Use the context menus for each cell to view and select operations that can be performed for that cell.

1. Import or create a geometry:
   - To import an existing geometry, right-click the Geomty cell and select Import Geometry.
   - To create a new geometry, select New DesignModeler Geometry or New SpaceClaim Geometry as appropriate.

2. To define all loads and boundary conditions, right-click the Setup cell and select Edit. Mechanical opens. Set up your analysis using that application's tools and features.

3. Right-click the Solution cell and choose Update. The results appear automatically.

For more information on setting up and running specific Mechanical analyses, see Analysis Systems (p. 179).

### Basic Fluid Flow Analysis Workflow

After introducing a new Fluid Flow analysis system to the project schematic and assigning it an appropriate name, the focus is typically directed to the Geometry cell, because this is usually the first cell in the system that requires user input. An example of both a CFX and a Fluent fluid flow system is shown below.

You typically work through the system from top to bottom. Use the context menus for each cell to view and select operations that can be performed for that cell. For fluid flow systems, the process is somewhat flexible; you can start from geometry, from an existing mesh, or from an existing case file; each is described in the following sections.
Basic Fluid Flow Analysis, Starting from Geometry

1. Right-click the Geometry cell and select New DesignModeler Geometry or New SpaceClaim Geometry to launch those respective programs and create a new model, or choose Import Geometry and browse to an existing CAD model.

For details, see Defining your Simulation Geometry (p. 52).

2. After your geometry is defined and the Geometry cell shows the green check mark indicating that the cell is up to date, you can proceed to the Mesh cell. Double-click the Mesh cell or right-click and select Edit to launch the Meshing application. Note that if you want to generate a default mesh, you could also right-click the Mesh cell and select Update to generate the mesh in the background without launching the meshing application. When this step has successfully completed, the Mesh cell shows a green check mark indicating an up-to-date state.

3. Double-click the Setup cell or right-click and select Edit to load the physics pre-processor. If you are working a Fluid Flow (Polyflow) system, the editor will be the Fluent application. If you are working with a Fluid Flow (ANSYS CFX) system, the editor will be CFX-Pre. When you have successfully defined your physics, the Setup cell shows a green check mark indicating an up-to-date state.

4. Double-click the Solution cell or right-click and select Edit to open the associated Solution cell editor. If you are working a Fluid Flow (Polyflow) system, the editor will be the Fluent application. If you are working with a Fluid Flow (ANSYS CFX) system, the associated editor will be the CFX-Solver Manager. You can also right-click and select Update to run the solution in the background. When the solution is complete, the Solution cell shows a green check mark indicating an up-to-date state.

5. You can now post-process the resulting solution. Double-click the Results cell or right-click and select Edit to open the resulting solution in ANSYS CFD-Post.

Once the process has been completed, all cells in the system should show a green check mark indicating an up-to-date state.

Basic Fluid Flow Analysis, Starting from an Imported Mesh

It is also possible to bypass the Geometry cell, and begin the simulation process by importing a mesh.

1. Right-click the Mesh cell and select Import Mesh File. In the Open dialog, browse to find your mesh file and select Open. The process for CFX and Fluent differs only in the types of files that are supported (as shown by the options shown in the Files of Type drop-down list). After selecting Open, the Mesh cell changes to Imported Mesh, and shows a green check mark to indicate an up-to-date state. The Geometry cell (which must be unused for the Import Mesh File option to be shown in the Mesh cell context menu) is deleted from the system (examples shown below for both a CFX and a Fluent-based Fluid Flow system).
2. Double-click the **Setup** cell or right-click and select **Edit** to load the physics pre-processor. From this point, follow the procedure described in [Basic Fluid Flow Analysis, Starting from Geometry](#) (p. 55).

**Basic Fluid Flow Analysis, Starting from an Imported Case File: Fluid Flow (ANSYS CFX) System**

You can bypass the **Geometry** cell and the **Mesh** cell and begin the simulation process by importing a case file. The process differs slightly for CFX and Fluent-based systems; each is described below.

1. Right-click the **Setup** cell and select **Import Case** → **Browse**. In the **Open** dialog, browse to find your case file and select **Open**.

2. If the **Geometry** and **Mesh** cells are unused (empty), then the unused cells are automatically deleted. Note that if either cell has an incoming or outgoing connection, then it is considered used, and will not be deleted.

3. Because CFX supports multiple meshes imported into a single setup cell, if either of the **Geometry** or **Mesh** cells contains data, neither cell will be deleted. As a result, both the Mesh generated in the **Mesh** cell and the mesh imported from the case file will be combined in CFX-Pre.

4. Once the import is complete, you can double-click the **Setup** cell or right-click and select **Edit** to start CFX-Pre. From this point, follow the procedure described in [Basic Fluid Flow Analysis, Starting from Geometry](#) (p. 55).

**Basic Fluid Flow Analysis, Starting from an Imported Case File: Fluid Flow (Polyflow) System**

1. Right-click the **Setup** cell and select **Import Polyflow Case**. Choose either from the list of recently used case files or choose **Browse**....

2. A warning dialog informs you that completing this action will result in the deletion of the **Geometry** and **Mesh** cells and any associated data. Click **OK**.

3. After selecting the desired case file, the **Geometry** and **Mesh** cells will be deleted from the system. Any existing connections to the **Geometry** and **Mesh** cells will also be deleted. From this point, follow the procedure described in [Basic Fluid Flow Analysis, Starting from Geometry](#) (p. 55).

**Creating and Linking to a Second System**

After you have created the first system in the **Project Schematic**, you can create additional systems. A new system can be either an independent system or a connected system that has data in common with other systems. See:

- [Creating Independent Systems](#)
- [Creating Connected Systems](#)

**Creating Independent Systems**

**Independent systems** are systems on the **Project Schematic** that are not connected to other systems via data links. Multiple independent systems can be used to keep the analyses for related but separate components within the same project (for example, two parts of the same vehicle). You may also want to create independent systems if you are analyzing the same model but using different solvers to compare the results, or are using different editors on independent yet related data (for example, you are using Mechanical APDL on an independent input file, and using Mechanical on a geometry file that has related origins to the input file of the Mechanical APDL system).
You can create a new independent system using either of the following methods:

• Double-click the desired system in the Toolbox. The new system is created on the Project Schematic below an existing system and will not be linked to any existing system.

• Use a drag-and-drop operation. When you drag the system from the Toolbox and move it over the Project Schematic, you will see all a preview of all possible drop targets. Drop the template on a target that displays the message "Create standalone system".

For an animated example, see Adding a System using Drag-and-Drop (p. 48).

Creating Connected Systems

Connected systems are systems on the Project Schematic that are connected together via data links so data can be shared and/or transferred between the two systems. You can use connected systems for sequential physics coupling (for example, thermal-stress) or for sequential simulation steps, such as a pre-stress modal (stress analysis followed by modal), mode-superposition (modal followed by harmonic), and so on. You can either create connections between existing systems or create a new system that is connected to an existing system.

Note

When using a drag-and-drop operation to create connections and multiple drop targets are available, each target results in a different set of connections.

Connecting Two Existing Systems

To connect two existing systems, use a drag-and-drop operation to share one or more component cells (for example, a Geometry cell and/or an Engineering Data cell) from one system with eligible cells in another system. To preview possible drop targets, drag a cell from the source system and hold it over cells in the target system. Drop the system on the target best suited to your engineering goals. In this case, the data is shared and the two systems are then independent of each other.

Creating a New Connected System

When you create a new system that is connected to an existing system, ANSYS Workbench generates shares and/or data transfers between the systems to achieve a compound analysis. In this case, the data is shared and the two systems are then interdependent.

The new system can be created either upstream (that is, the new system provides inputs to the existing system) or downstream (the new system receives inputs from the new system) of the existing system. The system receiving input is also called the dependent system. To create a new connected system, you can use either a drag-and-drop operation or ANSYS Workbench’s Transfer Data context-menu options.

Use Drag-and-Drop

You can use drag-and-drop functionality to create a new dependent system. Drag a system from the Toolbox, move it over cells in the existing system to preview available drop targets, and drop the system on the desired target. The new system is created downstream on the Project Schematic.

The following animation demonstrates the various drop targets and their results. For example, selecting the Geometry cell as the drop target will result in a second system that will share the Engineering Data and Geometry data. Selecting the Model cell as the drop target will result in a second
system that will share the Engineering Data, Geometry and Model data. The preview for each drop target will indicate how the new system will be connected to the existing one.

If you select the Solution cell as the drop target, the preview will show the text “Share A2:A4 Transfer A6,” meaning that the data for cells A2, A3, and A4 (Engineering Data, Geometry, and Model in the following animation) would be shared, and data from cell A6 (in this case, Solution) would be transferred as input to the new system. It is important to review each potential drop target carefully to ensure that you select the target that best suits your needs. Note that in addition to the red, linked drop targets, you can also preview the green independent drop targets.

The following Show-Me animation is presented as an animated GIF in the online help. If you are reading the PDF version of the help and want to see the animated GIF, access this section in the online help. The interface shown may differ slightly from that in your installed product.

Use Transfer Data Context-menu Options
The Transfer Data options available in the context menu allow you to select a cell in an existing system and create a new system either upstream or downstream of that system.

- To create a new system upstream of the existing system (so the existing system is dependent), right-click the target cell in the existing system and select Transfer Data from New. Select your new system from a list of all possible analysis types that can provide data to the existing cell.

- To create a new system downstream of the existing system (so the new system is dependent), right-click the target cell in the existing system and select Transfer Data to New. Select your new system from a list of all possible analysis types that can accept data from the existing cell.

When using either of the Transfer Data options, all possible cells will be shared, up to the position of the selected cell. The following animation demonstrates using the Transfer Data to New option to add an upstream Eigenvalue Buckling system to an existing Static Structural system.
Duplicating Systems

To duplicate an existing system, right-click it and select **Duplicate** from the context menu. The result of the operation will depend on the cell from which the Duplicate operation is initiated.

To create a duplicate system in which all cells can be edited independently of the original system, right-click the system header and select **Duplicate**, as shown in the image below.

---

**Note**

When a Mechanical system containing a **Results** cell is duplicated, the results will NOT be copied to the new system.

---

The following Show-Me Animations are presented as animated GIFs in the online help. If you are reading the PDF version of the help and want to see the animated GIF, access this section in the online help. The interface shown may differ slightly from that in your installed product.
If the Duplicate operation is initiated from one of the cells in the system, all cells above the one selected for duplication will be shared. The cell selected for duplication can be edited independently. For example:

- If you select **Duplicate** from the **Geometry** cell, the **Engineering Data** cell is shared, allowing you to edit the **Geometry** cell in the duplicate system to investigate a geometric alternative. Data from the **Model** cell and below is copied from the original system and can be modified independently.
• If you select **Duplicate** from the **Model** cell, the **Engineering Data** and **Geometry** cells are shared, allowing you to edit the **Model** cell in the duplicate system to investigate an alternative modeling approach. All data in the **Setup** cell and below is copied from the original system and can be modified independently.

• If you select **Duplicate** from the **Setup** cell, the **Engineering Data**, **Geometry** and **Model** cells are shared, allowing you to edit the **Setup** cell in the duplicate system to investigate alternate loads and constraints. All data in the cells below **Setup** is copied from the original system and can be modified independently.

To duplicate multiple, connected systems, (the equivalent of duplicating at the Model level with multiple environments in previous releases of the Mechanical application), you must use the **Export** capability in the Mechanical application to save a `.mechdat`, then use ANSYS Workbench's **Importing Legacy Databases** (p. 107) capability to import the `.mechdat` into your project to create the duplicated set of systems.

---

**Note**

When a Mechanical system containing a **Results** cell is duplicated, the results will **NOT** be copied to the new system.

---

### Moving, Deleting, and Replacing Systems

#### Moving a System

You can move an existing system to another position on the **Project Schematic**. To move a system, click the header cell and drag the system to the new location. The preview will indicate possible target locations for the system.

#### Deleting a System

To delete a system from the **Project Schematic**, right-click the system header cell and select **Delete**.

#### Replacing a System

To replace an existing system with different type of system, right-click the system header cell and select **Replace With**, and select the type of system that will replace the existing system. The context menu contains a list of all system types that are available to replace the existing system.

---

**Note**

The units setting specified in an existing system is **not** maintained in the replacement system. In the replacement system, you must specify the units setting you want to use.
Working in ANSYS Workbench

This section describes working in ANSYS Workbench after you have populated your Project Schematic with systems.

The following topics are covered:
- Working with ANSYS Remote Solve Manager
- Overview of Job Submission in ANSYS Workbench
- Submitting Project Updates to Remote Solve Manager (RSM) or an EKM Portal
- Submitting Solutions
- Monitoring and Controlling RSM Jobs in Workbench
- Using Journals and Scripts
- Project File Management
- Working with the Chart View
- Working with Project Reports
- Using Help
- Troubleshooting ANSYS Workbench

**Working with ANSYS Remote Solve Manager**

ANSYS Remote Solve Manager (RSM) provides the central framework for job submission to an established cluster. This enables you to access powerful compute resources when needed.

To enable job submission to a cluster, an administrator must create cluster configurations in RSM. Cluster configurations enable RSM to integrate with a third-party job scheduler such as Microsoft HPC or LSF, if one is being used. Alternatively RSM can be configured to submit jobs to an ANSYS RSM Cluster (ARC). An ARC operates in the same way that a commercial cluster does, running ANSYS applications in local or distributed mode, but uses its own scheduling capability rather than that of a third-party job scheduler.

For more information about cluster configurations, see RSM Configuration in the RSM User's Guide.

When you submit updates and solutions to RSM using the Submit to Remote Solve Manager option, you can choose the RSM Queue to use for the job. The RSM queue is associated with a cluster configuration that is defined in RSM. The cluster configuration specifies how your machine will communicate with the cluster, and identifies cluster queues. Jobs are handled by a scheduling system on the cluster submit host. Jobs can be run locally in the background on your local machine, sent to a remote machine, or distributed across multiple machines.

Jobs submitted directly to RSM can be monitored using the Workbench Job Monitor (see Monitoring and Controlling RSM Jobs in Workbench (p. 93)).

This section assumes that RSM has been set up according to the instructions in the Remote Solve Manager User's Guide (see RSM Installation and Startup and RSM Configuration).
Specifying Credentials for RSM Job Submission

RSM needs to acquire and cache your credentials to be able to submit jobs to a cluster on your behalf. RSM’s direct integration with Workbench and built-in caching capability automates this process to a great extent.

When you submit a job to RSM from Workbench for the first time, and your credentials have not yet been cached for the RSM queue in RSM, or the cached password does not validate because your OS password has changed or expired, you will be prompted to specify credentials for that queue:

If the credentials validate, the job will be submitted to the cluster. If the credentials do not validate, the job will be aborted.

Overview of Job Submission in ANSYS Workbench

ANSYS Workbench offers two remote solve options:

- **Submit to Remote Solve Manager** submits a solution or update directly to RSM. Such jobs can be monitored directly in Workbench.

  On the RSM side, configuration includes creating cluster configurations, which result in the creation of RSM queues that appear as choices in the Workbench interface when the **Submit to Remote Solve Manager** option is selected.

  For information about installing and configuring RSM, see RSM Installation and Startup and RSM Configuration in the Remote Solve Manager User’s Guide.

  On the Workbench side, you will be prompted to enter your Remote Solve Manager credentials (p. 64) when submitting a job for the first time.

- **Submit to Portal** submits a solution or update to RSM indirectly via an EKM Portal. You can monitor a Portal job locally in Workbench, or remotely using the EKM web application.
An administrator must install and configure RSM as described above, and may also need to perform additional tasks on the EKM side to enable Portal job submission. Refer to Integrating EKM with Remote Solve Manager (RSM) in the EKM Administration Guide.

On the Workbench side, you will need to create and open a connection to an EKM Portal (p. 66) to be able to submit a job to it.

For details about Portal job submission, see the following:
- Submitting Jobs to an EKM Portal
- Defining EKM Portal Connection Settings in Workbench

## Submitting Jobs to an EKM Portal

ANSYS Engineering Knowledge Manager (EKM) provides access to remote computing resources within an organization or on the ANSYS Enterprise Cloud. You can use EKM to manage simulation data, and submit, monitor and manage simulation jobs from any location. For general information about EKM, see the EKM User’s Guide.

You can use the Submit to Portal option in Workbench to submit updates and solutions to an EKM Portal. EKM integrates with Remote Solve Manager (RSM), which is configured to integrate with an established cluster. The cluster scheduling system determines how jobs are queued and distributed to compute resources for execution.

When you select the Submit to Portal option you must choose a Portal Connection (see Defining EKM Portal Connection Settings in Workbench (p. 66)).

Jobs submitted to an EKM Portal can be monitored using the Workbench Job Monitor (see Monitoring and Controlling RSM Jobs in Workbench (p. 93)), or using the EKM web application on any device (see Monitoring and Controlling Jobs in the EKM User’s Guide).

This section assumes that RSM has been set up according to the instructions in the EKM Administration Guide (see Integrating EKM with Remote Solve Manager (RSM)), and that an EKM server has been started and configured. For more information, see the EKM Installation Guide and EKM Administration Guide.

---

### Note

Job submission from a Linux Workbench client to a Windows EKM Portal is not supported.

---

### Troubleshooting Failed Portal Job Submission

Submitting jobs to an EKM Portal from a network share may fail if the cluster contains Windows compute nodes.

Initially, you may see the following error message displayed in red in the Workbench Job Monitor:

Job was not run on the cluster. Check the cluster logs and check if the cluster is configured properly.

If you see this error, enable debug messages in the Job Monitor to reveal more details about the failed job. Look for an error similar to the following:

```plaintext
259 5/18/2016 3:10:52 PM '\jsmithPC\John-Share\EKM\WB\InitVal_pending\UDP-2'
260 5/18/2016 3:10:52 PM CMD.EXE was started with the above path as the current directory.
261 5/18/2016 3:10:52 PM UNC paths are not supported. Defaulting to Windows directory.
```
To resolve this issue, an IT administrator must modify the registry on Windows compute nodes to enable the execution of commands via UNC paths. See Troubleshooting RSM-Related Issues in the RSM User's Guide for details.

**Defining EKM Portal Connection Settings in Workbench**

You must create a connection to an EKM Portal in Workbench before you can submit an update or solution to it. You may have already created a connection to EKM if you have used the Save to Repository (p. 162) or Open from Repository (p. 165) actions.

Otherwise, follow the instructions in Creating a Connection to an EKM Portal (p. 157).

In order to submit an update or solution to an EKM Portal, the connection must be currently open. See Opening a Connection (p. 160) for details.

Once you have created and opened a connection, it will appear in the Portal Connection drop-down list when the Submit to Portal option is selected in the Project Schematic properties. Note that options for creating and managing connections are also available in the Portal Connection cell.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Property</td>
<td>Value</td>
</tr>
<tr>
<td>2</td>
<td>Notes</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Notes</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Solution Process</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Update Option</td>
<td>Submit to Portal</td>
</tr>
<tr>
<td>6</td>
<td>Project Update</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Portal Connection</td>
<td>Default @ ekmsserver2</td>
</tr>
<tr>
<td>8</td>
<td>Queue</td>
<td>Default @ ekmsserver1&lt;br&gt;Default @ ekmsserver2</td>
</tr>
<tr>
<td>9</td>
<td>Pre-RSM Foreground Update</td>
<td>New Connection...</td>
</tr>
<tr>
<td>10</td>
<td>Component Execution Mode</td>
<td>Manage Connections...&lt;br&gt;Refresh Connections...</td>
</tr>
</tbody>
</table>

In the Portal Connection drop-down, you have the following options:

- ![New Connection](image) (New Connection) launches the Create a Connection wizard (see Creating a Connection to an EKM Portal (p. 157)).

- ![Manage Connections](image) (Manage Connections) launches the Manage Connections dialog box, where you can create, open, close and delete connections (see Working with Existing EKM Connections (p. 159)).

- ![Refresh Connections](image) (Refresh Connections) refreshes the connection list so that it displays the most up-to-date connection information.
Submitting Project Updates to Remote Solve Manager (RSM) or an EKM Portal

You can submit a project to the Remote Solve Manager (RSM) or an EKM Portal for remote update of the project. To do so, you must first configure the project properties and then use the Update Project option to submit the update.

**Note**

If you are sending solve jobs to a remote cluster, note that the license preferences set for your local machine (the RSM Client) may not be the same as the license preferences set for the remote cluster. In this case, the cluster license preferences will be used for all jobs.

1. Access project properties by right-clicking in the white space of the Project Schematic and selecting Properties. Alternatively, you can select the View → Properties menu option when the Project Schematic is open.

2. Under the Solution Process category, set the Update Option property to either Submit to Remote Solve Manager or Submit to Portal.

**Note**

For projects containing a System Coupling system, only the Submit to Remote Solve Manager option is available. For remote update details specific to System Coupling, see Submitting System Coupling Jobs to RSM (p. 69).

3. Additional properties are displayed. Use these properties to specify your remote submission settings.

   - (Submit to Remote Solve Manager) **RSM Queue**: Select the queue to be used for the remote solution. Any queues currently defined for RSM will appear in the drop-down list. If you have added a queue and it does not appear on the list, click the "refresh" icon.
Every RSM queue is associated with a particular **Cluster Configuration** that is defined in RSM. The cluster configuration enables job submission to a **Cluster Queue** via the cluster submit host.

- **Portal Connection**: Select the EKM Portal to which you want to submit the project. If no connections are listed, you may need to create a connection (p. 157) or open an existing connection (p. 160).  
  
**Queue**: Select from the queues already defined in the EKM Portal.

- **Job Name**: The name that will be reported in the RSM job log. The default name for a Workbench job is Workbench, or whatever is set for the **Default Job Name** in your Workbench Options. The default name for a Mechanical job submitted from the Mechanical application is Mechanical. The job name provides a traceable piece of data that administrators can use to track job submissions to a cluster (for billing purposes, for example).

  Job name overrides must adhere to the following conventions:

  - Can only use alphanumeric characters and ~ # % ^ , & * ' ( ) - _ + = / < >
  - Cannot exceed 15 characters
  - The first character must be one of the alphanumeric characters (a-z, A-Z, 0-9)

- **Pre-RSM Foreground Update**:
  
  - Select Geometry to update your geometry locally before submitting project updates to RSM. You would want to do this if the execution node does not have a license to perform geometry updates.
  
  - Select None to submit project updates to RSM without first updating the geometry locally.

- **Component Execution Mode**: Specify serial or parallel solver execution mode. The parallel option is available only if the selected solver supports parallel execution mode. This option may not be available with all systems. When performing a design point update via RSM with component update in the foreground, the **Parameter Set** properties will override the parallel-process settings in individual components. For details on updating design points, see [Updating Design Points via ANSYS Remote Solve Manager or an EKM Portal](p. 144).

The **Project Update** properties specified here are shared with the **Parameter Set** as **Design Point Update Process** properties. Changes to the values of these properties here will be reflected in the **Parameter Set** properties, and vice versa.

---

**Note**

- For details on remote project updates for projects containing a System Coupling system, see [Submitting System Coupling Jobs to RSM](p. 69).

- In most cases, the Update Project button or menu item updates all systems and cells in a project. When a project update is submitted to RSM as described, however, only those systems above the **Parameter Set** bar are sent to RSM for remote update. If needed, DesignXplorer systems can be further updated once the remote project update is completed.
Submitting System Coupling Jobs to RSM

You can send a system coupling simulation to Remote Solve Manager (RSM) for remote update. In order for a system coupling simulation to be executed remotely, you must submit the Workbench project to RSM for a project update. To do so:

1. Set your project’s **Solution Process** and **Project Update** properties as described in Submitting Project Updates to Remote Solve Manager (RSM) or an EKM Portal (p. 67).

2. Click the **Update Project** button in the Workbench toolbar.

   All of the systems on the Project Schematic, including the System Coupling system, will be updated through RSM.

---

**Note**

For the System Coupling **Solution** cell, the **Update Option** property can only be set to **Run in Foreground**. As such, if you attempt to update the System Coupling system from its **Solution** cell, then the project update will not be sent to RSM regardless of the project’s **Update Option** setting.

The following sections provide information that is specific to remote project updates for System Coupling simulations:

- Distribution of Computing Resources Across System Coupling Participants
- Restricting Solve Processes for System Coupling Project Updates
- Monitoring System Coupling Solution Information
- Restarting an Interrupted Remote Project Update

### Distribution of Computing Resources Across System Coupling Participants

In a System Coupling project, the individual components (such as Fluent, Mechanical, or CFX) share resources. By default, when a project containing a System Coupling system is submitted to RSM, available computing resources are distributed equally across all coupling participants according the number of compute nodes available and processes requested. Component-level parallel settings (such as the **Execution Mode** and **Number of Processes** properties) are disregarded during the project update.

**Example 1:**

If a coupled simulation requests 6 processes to be executed on a cluster that has 6 nodes with 1 processor per node, then participant solvers will start 6 processes, with one on each compute node. The participant solvers alternate their processing, so that only one participant is actively using computing resources at a time.

<table>
<thead>
<tr>
<th>Node</th>
<th>Solver Processes for Participant 1</th>
<th>Solver Processes for Participant 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>
Example 2:
If a coupled simulation requests 10 processes to be executed on a cluster that has 4 nodes with 8 processors per node, then each participant solver will start 10 processes.

<table>
<thead>
<tr>
<th>Node</th>
<th>Solver Processes for Participant 1</th>
<th>Solver Processes for Participant 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>8</td>
<td>8</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Restricting Solve Processes for System Coupling Project Updates

For a project configured for parallel processing, you can limit the number of solve processes that a coupling participant can use when the project is submitted to RSM. To do so, set the participant’s Restriction for Project/Design Point Update via RSM Solution cell properties as described in Updating Design Points via ANSYS Remote Solve Manager or an EKM Portal (p. 144).

The solve process limitations are applied only to that component, and resources are otherwise allocated equally across participants. Resource allocation for the restricted participant is as follows:

- If the component’s Specify Number of Processes Restriction is enabled:
  - and Number of Processes Used Not To Exceed is less than or equal to the number of processes requested by the project, then the component will be limited to the component-specified number of processes.
  - and Number of Processes Used Not To Exceed is set to a value greater than the number of processes requested by the project, then the component will be limited to the project-specified number of processes.

- If the component’s Serial Execution Only is enabled, then the component is limited to a single process.

Monitoring System Coupling Solution Information

As the remote project update progresses, a single System Coupling Service Log file (scLog.scl) is generated for the coupling project and displayed in the Solution Information view of the System Coupling workspace. It is updated intermittently so you can use it to monitor the project update.

Note

When a project has multiple design points being updated simultaneously (i.e. the Job Submission Parameter Set property is set to One Job for Each Design Point), you cannot switch between the log files for the different design points. During and after completion of the updates, System Coupling will display the log file for the design point with the highest ID. To display the log file for the Current design point, you must save and reopen the project.

For more information, see the following sections in the System Coupling User’s Guide:

- Solution Information
- System Coupling Service Log File (scLog.scl, scLog##_#.scl)
- Understanding the System Coupling Log File
Restarting an Interrupted Remote Project Update

If you have interrupted a remote update of a System Coupling project, the Solution cells in your project will be given a status of **Interrupted, Up to Date**. To restart the update:

1. Click the **Update Project** button in the Workbench toolbar.

2. In dialog that is displayed, click one of the following buttons:
   - **Use Partially Updated**: Accepts the partially updated solution as **Up to Date** and uses it to update the project.
   - **Update All**: Restarts the interrupted run, updating all solutions to completion before updating the project.

Submitting Solutions

You can use the **Solution Process** properties of a system's Solution cell to control where you run the solution. You can choose from the update options listed here; the defaults for these options are determined by the settings specified in the **Solution Process** preferences under **Tools → Options**.

---

**Note**

If solve jobs will be submitted to a remote cluster, note that the license preferences set for your local machine (the RSM Client) may not be the same as the license preferences set for the cluster. In this case, the cluster license preferences will be used for all jobs.

---

**Run in Foreground** - Solutions are run within the current ANSYS Workbench session. This option is appropriate for quick-running solutions that fit within the resources of your workstation. This option is also the most robust as it is not possible to make changes that impact the current solution. When a solution is executing in the foreground, you cannot change or save the project, but you can interrupt or stop the solution.

---

**Note**

For Polyflow and CFX component or analysis systems, you can switch an update in progress on the local machine to background mode by right-clicking the **Solution** cell and selecting **Switch Active Solution to Background**.

---

**Run in Background** - Runs the solution in the background on the local machine. This option is appropriate for solutions that fit within the resources of your workstation but will take longer to execute. When a solution runs in the background, the cell enters the **Pending** (p. 316) state and you can interact with the project to exit ANSYS Workbench or work with other parts of the project. If you make changes to the project that are upstream of the updating cell, then the cell will not be in an up-to-date state when the solution completes.

---

**Note**

If you choose the **Run in Background** option for multiple solution components or for one solution component with multiple design points, your project and design point updates will run multiple instances of the solver at the same time. If you are using the **Share single license between applications when possible** option in the license preferences, only one
of the solver runs will succeed. The others will fail because they cannot access the single license. There are two workarounds for this problem:

- Change the license preference to be **Use a separate license for each application**. This preference will allocate one license for each running solver.

- Instead of using the **Run in Background** option, use the **Submit to Remote Solve Manager** option and select the **Local** RSM queue. This is provided that a basic ANSYS RSM Cluster (ARC) has been configured to restrict the number of cores that can be used for a job. For more information, see **Configuring an ANSYS RSM Cluster (ARC)** and **Setting the Maximum Number of Cores to be Used on an Execution Node** in the *RSM User's Guide*.

---

**Note**

For Mechanical APDL, the **Download Distributed Files** property is not available and will not appear in the **General Property** table during foreground and background updates.

---

- **Use application default**- (Mechanical application only). Uses the solver settings specified in the Mechanical application.

- **Submit to Remote Solve Manager**- Runs the solution in the background by submitting the solution to Remote Solve Manager (RSM). This option is used primarily for long-running solutions that do not fit within your workstation's resources. Through submission to RSM, the solution can be executed on remote computing resources. RSM can also submit jobs to the local machine to allow the queuing of solutions on your workstation. When a solution is submitted to RSM, the **Solution** cell enters the Pending state, similar to the **Run in Background** option.

---

**Important**

When design points are configured to be updated via RSM, the **Solution** cell cannot also be updated via RSM. If you have configured design points to be updated via RSM or an EKM Portal, change the **Solution** cell update settings by setting the **Update Option Solution Process** property to **Run in Foreground**. For further information about tutorials and documentation on the ANSYS Customer Portal, go to [http://support.ansys.com/docinfo](http://support.ansys.com/docinfo). Note that the update of both the **Solution** cell and design points via an EKM Portal is not supported. If both are submitted to the Portal, the **Solution** cell update will automatically switch to **Run in Foreground** when the design points are being updated through the Portal.

---

- **Submit to Portal**- Submits the solution to an EKM Portal for execution on remote computing resources. This option is used primarily for long-running solutions that do not fit within your workstation's resources, and enables you to monitor the solution remotely using the EKM web application on any computer or mobile device. EKM integrates with Remote Solve Manager (RSM), which is configured to integrate with a cluster. A
scheduling system on the cluster submit host determines how jobs are queued and distributed to compute resources for execution.

**Note**

The **Submit to Portal** option is available for CFX, Fluent, Polyflow, Mechanical APDL, and Mechanical component updates. For Mechanical component updates, the **Submit to Portal** option is available only if the Mechanical APDL solver is selected.

---

**To use the Submit to Remote Solve Manager option, configure RSM using the instructions in the Remote Solve Manager User’s Guide.** For details see RSM Installation and Startup and RSM Configuration. For tutorials featuring step-by-step instructions on configuring RSM for direct job submission from Workbench, go to the *Tutorials & Training Materials* page of the ANSYS Customer Portal. For further information about tutorials and documentation on the ANSYS Customer Portal, go to http://support.ansys.com/docinfo.

**To use the Submit to Portal option, configure RSM using the instructions in the EKM Administration Guide.** For details see Integrating EKM with Remote Solve Manager (RSM). You must also create a connection (p. 157) to an EKM Portal in Workbench. For information about the installation, configuration or features of EKM, see the Engineering Knowledge Manager documentation.

If you choose **Submit to Remote Solve Manager**, you also have the following options, which are populated from or must use the settings from your existing RSM configuration:
- **Solve Process Setting** -- (Mechanical application only) - This setting is the solving configuration that you have defined in Mechanical.

- **RSM Queue** - This is a queue defined in RSM that maps to a specific cluster configuration and cluster queue. Any RSM queues currently defined in RSM will appear in this drop-down list. The cluster configuration and cluster queue that are associated with the selected RSM queue are displayed under **RSM Queue Details**.

If a queue has been recently added in RSM and you do not see it in the list, use the **Refresh Queues** action at the bottom of the **RSM Queue** drop-down to update the queue list.

- **Job Name**: The name that will be reported in the RSM job log. The default name for a Workbench job is *Workbench*, or whatever is set for the **Default Job Name** in your Workbench Options. The default name for a Mechanical job submitted from the Mechanical application is *Mechanical*. The job name provides a traceable piece of data that administrators can use to track job submissions to a cluster (for billing purposes, for example).

  Job name overwrites must adhere to the following conventions:

  - Can only use alphanumeric characters and `~ # % ^ , & * ' ( ) - _ + = / < >`
  - Cannot exceed 15 characters

---

**Properties of Schematic AS: Solution**

<table>
<thead>
<tr>
<th>A</th>
<th>Property</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>General</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Component ID</td>
<td>Solution</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Directory Name</td>
<td>CFX</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Keep Latest Solution Data Only</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Cache Solution Data</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Initialization Option</td>
<td>Update from current solution data if possible</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Execution Control Conflict Option</td>
<td>Warn</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Notes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Notes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Used Licenses</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Last Update Used Licenses</td>
<td>ANSYS Multiphysics</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Multi-configuration Post Processor File Load Options</td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Load Option</td>
<td>Last Results Only</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Solution Process</td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>RSM Queue</td>
<td>Local</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Job Name</td>
<td>Workbench</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>RSM Queue Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Cluster Configuration</td>
<td>localhost</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Cluster Queue</td>
<td>local</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Download Progress Information</td>
<td>Always Download</td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Progress Download Interval</td>
<td>120</td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Execution Mode</td>
<td>Parallel</td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>Number of Processes</td>
<td>2</td>
<td></td>
</tr>
</tbody>
</table>

---
The first character must be one of the alphanumer ic characters (a-z, A-Z, 0-9)

- **Download Progress Information**: Specifies that the solver monitor should periodically query RSM or the EKM Portal for output files in order to display progress (where applicable). Queries begin when you initiate an action to display the solution progress (such as choosing the Display Monitors option in CFX). This option, available for Fluent and CFX systems, is enabled by default.

  - CFX systems have the following options:
    - **Always Download Progress Information** causes queries to RSM or the EKM Portal to begin immediately. This option is enabled by default.
    - **Download Progress Information on Demand** causes queries to RSM or the EKM Portal to begin when you initiate an action to display the solution progress (such as choosing the Display Monitors option in CFX).

  - Polyflow and ANSYS Icepak systems have the following check box:
    - **Download Progress Information** specifies that the solver monitor should periodically query RSM or the EKM Portal for output files in order to display progress (where applicable). Queries begin when you initiate an action to display the solution progress. This option is enabled by default.

- **Progress Download Interval**: Specifies the periodic time interval with which the solver should query RSM or the EKM Portal for output files in order to display progress. Default is 30 seconds. Setting this value to zero (0) results in continuous queries; that is, as soon as files are downloaded from the execution node, ANSYS Workbench will immediately query again. This option is available for Fluent and CFX systems.

- **Execution Mode**: Specifies serial or parallel solver execution mode. The parallel option is available only if the selected solver supports parallel execution mode. This option may not be available with all systems. When performing a design point update via RSM or the EKM Portal with component update in the foreground, the Parameter Set properties will override the parallel-process settings in individual components. For details on updating design points, see Updating Design Points via ANSYS Remote Solve Manager or an EKM Portal (p. 144).

- **Number of Processes**: If parallel execution mode is selected, specifies the number of processes to use for the solution (must be a number greater than or equal to 2).

If you choose **Submit to Portal** as your **Update Option**, you will need to specify the following:

- **Portal Connection**: Select the EKM Portal to which you want to submit the project. If no connections are listed, you may need to create a connection (p. 157) or open an existing connection (p. 160).

- **Queue**: You can select from the batch job submission queues that are currently defined in the EKM Portal.

If a project is unsaved and any cells in your project are configured to use RSM or run in the background, you must save the project or change the solution process settings of those cells to run in the foreground before you can update.

**Note**

The naming scheme for jobs sent to RSM is as follows:

- For Mechanical jobs:
The following sections describe how to use the Solution Process settings to submit a job to RSM for each of the solvers (where applicable).

**Submitting Mechanical Jobs to RSM or an EKM Portal**

See the following sections for more information:
- Submitting Mechanical Application Jobs to RSM or an EKM Portal
- Submitting Mechanical APDL Jobs to RSM or an EKM Portal
- Submitting Mechanical APDL Jobs to a Cluster via RSM or an EKM Portal

**Note**

If submitting Mechanical jobs to an EKM Portal, you should save your credentials when setting up a Portal connection. If a Portal connection closes for any reason during a Mechanical job run, Mechanical will try to re-open the connection. However, if your credentials are not cached, Mechanical will not prompt you for them, and the connection will not be opened.

**Submitting Mechanical Application Jobs to RSM or an EKM Portal**

1. Configure your remote solution settings via Remote Solve Manager. If submitting jobs directly to Remote Solve Manager, see RSM Installation and Startup and RSM Configuration in the RSM User’s Guide. If submitting jobs to Remote Solve Manager via an EKM Portal, see Integrating EKM with Remote Solve Manager (RSM) in the EKM Administration Guide.

2. From the Project Schematic, double-click the Solution cell in your Mechanical system to launch the Mechanical application.

3. In the Mechanical application, choose Tools from the Main Menu → Solve Process Settings. Follow the instructions in Using Solve Process Settings to configure your solution settings. The settings established here will be visible in the Solution Process properties in ANSYS Workbench.

4. In ANSYS Workbench, select the Solution Process settings that you want to use for this solution and update the Solution cell (via a cell, system, project, or design point update).
Alternatively, you can choose the desired solution configuration from the Mechanical application by selecting **Solve** from the main menu and choosing from the configurations listed in the drop-down list.

**Note**

- You can Interrupt or Abort an update by right-clicking the **Solution** cell. These options are available during foreground, background, Portal and RSM updates.

- The Workbench **Options** enable you to control the Mechanical application's license handling. As described in **Mechanical (p. 27)**, you can configure the license to always be released during batch run or to be released when you perform an **Update All Design Points** run. A third option is **On Demand**, which makes a **Release License** option available on the **Solution** cell's context menu when the cell is in the pending state during a batch run.

---

**Opening Mechanical without a License (Read-Only Mode)**

You can open Mechanical without consuming a license by right-clicking on any of the Model, Section Data, Setup, Solution, or Results cells in a Mechanical system and choosing **Edit in Read-only Mode**. Two common applications for using Mechanical in read-only mode are:

- Retrieving data during an RSM run in order to monitor its progress.
- Reviewing results of an already solved project.

This option is not available when the cell state is refresh required or worse.

**Workbench RSM/Portal Integration with the Mechanical Application**

The properties associated with a Mechanical system's **Solution** cell include a **Solution Process** section. This section enables you to specify the **Solve Process Setting** for the Mechanical application to use when an Update operation is initiated from Workbench. You can select only an existing Solve Process Setting, but new Solve Process Settings can be added (and existing Solve Process Settings can be modified) by selecting **Tools → Solve Process Settings** in the Mechanical application.

**Note**

Any solve initiated in the Mechanical application will ignore the Solution component properties selected in Workbench, and will continue to work as they have in previous versions.

**Example 1: Default Update with "My Computer" Set as the Default Solve Process Setting**

In this case, the default Solve Process Setting in the Mechanical application is "My Computer".

In Workbench, the **Solution Process** property **Update Option** is set to **Use application default**, which causes Mechanical to use its default Solve Process Setting.
Results:

<table>
<thead>
<tr>
<th>Solve Initiated From</th>
<th>Solve Process Setting Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workbench</td>
<td>My Computer</td>
</tr>
<tr>
<td>Mechanical</td>
<td>My Computer</td>
</tr>
</tbody>
</table>

**Example 2: Default Update with "My Computer, Background" Set as the Default Solve Process Setting**

In this case, the default Solve Process Setting in the Mechanical application is "My Computer, Background".
In Workbench, the **Solution Process** property **Update Option** is set to **Use application default**, which causes Mechanical to use its default Solve Process Setting.

**Results:**

<table>
<thead>
<tr>
<th>Solve Initiated From</th>
<th>Solve Process Setting Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workbench</td>
<td>My Computer, Background</td>
</tr>
<tr>
<td>Mechanical</td>
<td>My Computer, Background</td>
</tr>
</tbody>
</table>

**Example 3: RSM Update Using "My Computer, Background", with "My Computer" Set as the Default Solve Process Setting**

In this case, the default Solve Process Setting in the Mechanical application is "My Computer".
In Workbench, the **Solution Process** property **Update Option** is set to **Submit to Remote Solve Manager**. The Solve Process Setting selected in Workbench is **My Computer, Background**.

**Results:**

<table>
<thead>
<tr>
<th>Solve Initiated From</th>
<th>Solve Process Setting Used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workbench</td>
<td>My Computer, Background</td>
</tr>
<tr>
<td>Mechanical</td>
<td>My Computer</td>
</tr>
</tbody>
</table>

**Submitting Mechanical APDL Jobs to RSM or an EKM Portal**

You can use RSM or an EKM Portal as a serial or parallel solution for Mechanical APDL jobs. In the **Solution Processes** pane:

1. Configure your remote solution settings via Remote Solve Manager. If submitting jobs directly to Remote Solve Manager, see [RSM Installation and Startup](#) and [RSM Configuration](#) in the *RSM User's Guide*. If submitting jobs to Remote Solve Manager via an EKM Portal, see [Integrating EKM with Remote Solve Manager (RSM)](#) in the *EKM Administration Guide*.

2. In ANSYS Workbench:
   a. Set the **Update Option** to **Submit to Remote Solve Manager** or **Submit to Portal**.
   b. Set the **RSM Queue** or **Queue**, as appropriate.
   c. Set the **Execution Mode** to **Parallel**.
   d. Set the **Number of Processes**. For a serial solution, choose 1; for a parallel solution, specify the number of partitions desired\(^1\).

3. Update the project.
When the Mechanical APDL job is submitted to RSM, some options in the **Properties** view (Processors, Distributed, MPI Type, Machine List, and Custom Executable Path) become read-only and their values are ignored.

---

**Note**

If **Download Distributed Files** is checked, all files involved in a distributed solve will be downloaded.

---

**Note**

Mechanical APDL has the following limitations when used with Remote Solve Manager:

- Reconnect will not work after moving a project to another machine.
- Only one copy of a saved project that is in the pending state can reconnect successfully.
- You must manually save a project after a reconnect.
- Reference files must be in the same directory as the ANSYS input file.
- Restarts of solves to a cluster are not supported from Workbench.

---

**Submitting Mechanical APDL Jobs to a Cluster via RSM or an EKM Portal**

If you have a Microsoft HPC, PBS, LSF, UGE or TORQUE queue available, you can use that as a parallel solution option. In the Solution Processes pane:

1. Set the **Update Option** to **Submit to Remote Solve Manager** or **Submit to Portal**.
2. Set the **RSM Queue** or **Queue**, as appropriate.
3. Set the **Execution Mode** to **Parallel**.
4. Set the **Number of Processes** to the number of partitions desired. The cluster job scheduler automatically controls where the partitions are solved.

Refer to the following sections in the *Remote Solver Manager User’s Guide* for details on defining cluster configurations in RSM, and configuring a cluster:

- RSM Configuration
- RSM Integration with a Cluster

---

**Note**

- For a Microsoft HPC cluster, PSSH is not supported on Microsoft Windows for this operation.

---

1You should have at least 100,000 elements or nodes per partition to compensate for the overhead associated with the partition.
• PBS, LSF, UGE and TORQUE clusters on Windows are not supported.

---

**Submitting Fluids Jobs to RSM or an EKM Portal**

See the following sections for more information:
- Submitting CFX Jobs to RSM or an EKM Portal
- Submitting CFX Jobs to a Cluster via RSM or an EKM Portal
- Submitting Polyflow Jobs to RSM or an EKM Portal
- Submitting Fluent Jobs to RSM or an EKM Portal
- Submitting Fluent Jobs to a Cluster via RSM or an EKM Portal
- Submitting Icepak Jobs to RSM
- Exiting a Project During an RSM Solution Cell Update

**Submitting CFX Jobs to RSM or an EKM Portal**

1. Configure your remote solution settings via Remote Solve Manager. If submitting jobs directly to Remote Solve Manager, see **RSM Installation and Startup** and **RSM Configuration** in the *RSM User’s Guide*. If submitting jobs to Remote Solve Manager via an EKM Portal, see **Integrating EKM with Remote Solve Manager (RSM)** in the *EKM Administration Guide*.

2. In ANSYS Workbench, right-click the **Solution** cell and select **Properties**. Select the Solution Process settings that you want to use for this solution and update the project.

**Note**

• If you set **Execution Mode** to **Parallel**:
  
  - You can specify the number of processes that you want to use to create the results file. You should specify a number that is less than or equal to the number of cores available in the cluster, and you should ensure that each process contains at least 100,000 nodes or elements.
  
  - UGE and PBS clusters must be configured to use the SSH communication protocol; RSH is not supported. If you are using the **Submit to Remote Solve Manager** option, see **Configuring RSM to Use SSH for Job Submission to a Remote Linux Cluster** in the *Remote Solve Manager User’s Guide*.

• You can Interrupt or Abort an update by right-clicking the **Solution** cell. These options are available during foreground, background and RSM updates.

ANSYS CFX has the following limitations when used with Remote Solve Manager or an EKM Portal:

• RIF (Flamelet) cases are not supported.

• Reconnect will not work after moving a project to another machine.

• Only one copy of a saved project that is in the pending state can reconnect successfully.

• You must manually save a project after a reconnect.
• You cannot edit a run that is in progress.

• You cannot perform a remote backup.

• For runs that are submitted to a remote machine:
  – Serial and Local Parallel runs are always supported.
  – Other local parallel modes must be supported on the job host.
  – Distributed parallel is supported only for multi-node clusters.

• The default update interval for Display Monitors is 120 seconds. Use the Download Progress Information and Progress Download Interval options under Tools → Options → Solution Process to enable/disable polling or to change the polling interval. The settings established here will also be visible in the Solution Process properties pane in ANSYS Workbench.

  **Note**

  This monitoring of solution updates submitted to RSM or an EKM Portal has the following limitations:

  – When you use the Solution cell's properties field to set the frequency at which you poll the data, this represents a maximum frequency. In cases of network congestion or where large files are involved, the observed monitor update frequency will be less.

  – Solution monitor data is transferred via the CFX Solver-Manager, which has a limited capacity to handle monitor data transfer requests. In situations where multiple users are using the same CFX Solver-Manager to monitor runs, or where multiple runs are being monitored by a single user, the update frequency of monitor data may decrease or become sporadic.

  – When monitoring RSM updates, CFX Solver-Manager will not report run completion. The Out File window will show the completed run information; however, CFX Solver-Manager's workspace will still display "Running". Note that in these cases, Workbench will accurately report update completion.

### Submitting CFX Jobs with Design Points to RSM or an EKM Portal

When performing a Design Point update with a CFX system via RSM, the Component Execution Mode and Max. Number of Processes Per Job settings on the Parameter Set Properties view control the parallel-processing settings that the CFX Solver uses. For details, see Updating Design Points via ANSYS Remote Solve Manager or an EKM Portal (p. 144).

### Submitting CFX Jobs to a Cluster via RSM or an EKM Portal

If you have a Microsoft HPC, PBS, LSF, UGE or TORQUE queue available, you can use that as a parallel solution option. In the Solution Processes pane:

1. Set the Update Option to Submit to Remote Solve Manager or Submit to Portal.

2. Set the RSM Queue or Queue, as appropriate.

3. Set the Execution Mode to Parallel.
4. Set the **Number of Processes** to the number of partitions desired. The cluster job scheduler automatically controls where the partitions are solved.

Refer to the following sections in the *Remote Solver Manager User's Guide* for details on defining cluster configurations in RSM, and configuring a cluster:

- RSM Configuration
- RSM Integration with a Cluster

**Note**

- For a Microsoft HPC cluster, PSSH is not supported on Microsoft Windows for this operation.
- PBS, LSF, UGE and TORQUE clusters on Windows are not supported.

---

**Submitting Polyflow Jobs to RSM or an EKM Portal**

1. Configure your remote solution settings via Remote Solve Manager. If submitting jobs directly to Remote Solve Manager, see RSM Installation and Startup and RSM Configuration in the *RSM User's Guide*. If submitting jobs to Remote Solve Manager via an EKM Portal, see Integrating EKM with Remote Solve Manager (RSM) in the *EKM Administration Guide*.

2. In ANSYS Workbench, right-click the **Solution** cell and select **Properties**. Select the Solution Process settings that you want to use for this solution and update the project.

**Note**

- You can Abort an update by right-clicking the **Solution** cell. This option is available during foreground, background, Portal and RSM updates.
- Polyflow has the following limitations when used with Remote Solve Manager:
  - Reconnect will not work after moving a project to another machine.
  - Only one copy of a saved project that is in the pending state can reconnect successfully.
  - You must manually save a project after a reconnect.
  - The RSM Interrupt option performs an abort operation, not an interrupt.
  - Parallel design point submissions to batch queue clusters will only run on the master node and with the number of cores allocated by the batch queue scheduler.

---

**Submitting Fluent Jobs to RSM or an EKM Portal**

You can use this feature to queue multiple jobs to run on the local machine, such as overnight or during other low-usage times, and you can submit a job to remote machines.

1. Configure your remote solution settings via Remote Solve Manager. If submitting jobs directly to Remote Solve Manager, see RSM Installation and Startup and RSM Configuration in the *RSM User's Guide*. If submit-
Submitting jobs to Remote Solve Manager via an EKM Portal, see Integrating EKM with Remote Solve Manager (RSM) in the EKM Administration Guide.

2. In ANSYS Workbench, right-click the Solution cell and select Properties. Select the Solution Process settings that you want to use for this solution and update the project.

An update of the Solution cell submits the job to RSM or an EKM Portal, moves into Pending mode for the duration of the solution, and then automatically reconnects at the end of the run.

---

**Tip**

If you set Execution Mode to Parallel, you can specify the number of processes that you want to use to create the results file. You should specify a number that is less than or equal to the number of cores available in the cluster, and you should ensure that each process contains at least 100,000 nodes or elements.

---

**Note**

- You can Interrupt or Abort an update by right-clicking the Solution cell. These options are available during background, Portal and RSM updates.

- Fluent has the following limitations when used with Remote Solve Manager:
  - Only one copy of a saved project that is in the pending state can reconnect successfully.
  - System Coupling is not supported.
  - UDFs are supported but you must have a supported compiler on Windows 64-bit machines. Supported compilers for Windows are Microsoft Visual Studio 2008 Standard and Microsoft Visual Studio 2010 Professional.
  - On Linux, UDFs are supported. You can always send UDFs between Linux machines and make use of the auto-compile feature; if the machines have compatible compilers, you can send precompiled UDFs.

For additional information about compiling Fluent UDFs, see Compiling UDFs in the Fluent Customization Manual.

**Solution Properties: Use Setup Launcher Settings**

The Properties view of the Fluent Solution cell has a toggle that controls whether the solution uses settings from the Setup Launcher. When Use Setup Launcher Settings is checked, the Launcher Settings are copied from Setup component to Solution component. This copying also happens any time you change the Launcher settings in setup. When Use Setup Launcher Settings is cleared, the Solution cell’s Launcher settings are available:

**General**

**Precision**

  Default: Single Precision
Applicable to RSM or EKM Portal: Yes

Show Launcher at Startup
  Default: Enabled

Applicable to RSM or EKM Portal: No

Display Mesh After Reading
  Default: Enabled

Applicable to RSM or EKM Portal: Yes

Embed Graphics Window
  Default: Enabled

Applicable to RSM or EKM Portal: Yes

Use Workbench Color Scheme
  Default: Enabled

Applicable to RSM or EKM Portal: Yes

Set up Compilation Environment for UDF
  Default: Enabled

Applicable to RSM or EKM Portal: No

Use Job Scheduler
  Default: Disabled

Applicable to RSM or EKM Portal: No

Run Parallel Version
  Default: The initial default execution mode (Serial / Parallel) is based on the Run Settings. The initial 'Number of Processors' in RSM is based on the Number of Processors option in the run settings: if it is > 1, that value will be used, otherwise 2 will be used. If Run Parallel Version is not enabled, then Serial mode is forced.

Applicable to RSM or EKM Portal: Yes

UDF Compilation Script Path
  Default: $(FLUENT_ROOT)\$(ARCH)\udf.bat

Applicable to RSM or EKM Portal: No

Use Remote Linux Nodes
  Default: Enabled

Applicable to RSM or EKM Portal: No

Remote

Remote Polyflow Root Path
  Default: none

Applicable to RSM or EKM Portal: No
**Use Specified Remote Working Directory**
Default: Enabled

Applicable to RSM or EKM Portal: No

**Remote Working Directory**
Default: none

Applicable to RSM or EKM Portal: No

**Remote Spawn Command**
Default: `RSH`

Applicable to RSM or EKM Portal: No

**Use Remote Cluster Head Node**
Default: Enabled

Applicable to RSM or EKM Portal: No

**Remote Host Name**
Default: none

Applicable to RSM or EKM Portal: No

**Parallel Run Settings**

**Number of Processors**
Default: 1

Applicable to RSM or EKM Portal: No

**Interconnect**
default

Applicable to RSM or EKM Portal: No*

---

**Note**

* You can enable **Interconnect** to be available for Polyflow RSM runs by enabling **Tools** → **Options** → **Solution Process** → **Show Advanced Solver Options**. This setting requires you to ensure that the remote Compute Servers can accept the Interconnect that you specify—there is no automatic checking for such compatibility.

To learn what values are available, see Starting Parallel ANSYS Fluent on a Windows System Using Command Line Options in the Fluent User's Guide.

**MPI Type**
default
Applicable to RSM or EKM Portal: No*

**Note**

* You can enable **MPI Type** to be available for Polyflow RSM runs by enabling **Tools → Options → Solution Process → Show Advanced Solver Options**. This setting requires you to ensure that the remote Compute Servers can accept the MPI Type that you specify—there is no automatic checking for such compatibility.

To learn what values are available, see **Starting Parallel ANSYS Fluent on a Windows System Using Command Line Options in the Fluent User’s Guide**.

**Use Shared Memory**

Default: Disabled

Applicable to RSM or EKM Portal: No

**Machine Specification**

Default: (file containing the machine list)

Applicable to RSM or EKM Portal: No

**Machine Filename**

Default: none

Applicable to RSM or EKM Portal: No

The **Solution cell’s Solution Process** setting is always displayed; when **Use Setup Launcher Settings** is checked, the option is read-only:

**Solution Process**

**Update Option**

You can choose to **Run in Foreground**, **Run in Background**, **Submit to Portal**, or **Submit to Remote Solve Manager**. When **Submit to Remote Solve Manager** or **Submit to Portal** is chosen, options that are not applicable to RSM/Portal are hidden. Also, fluentlauncher.txt will not contain options that conflict with RSM.

**Submitting Fluent Jobs to a Cluster via RSM or an EKM Portal**

If you have a Microsoft HPC, PBS, LSF, UGE or TORQUE queue available, you can use that as a parallel solution option. In the Solution Processes pane:

1. Set the **Update Option** to **Submit to Remote Solve Manager** or **Submit to Portal**.
2. Set the **RSM Queue** or **Queue**, as appropriate.
3. Set the **Execution Mode** to **Parallel**.
4. Set the **Number of Processes** to the number of partitions desired\(^2\). The cluster job scheduler automatically controls where the partitions are solved.

---

\(^2\)You should have at least 100,000 elements or nodes per partition to compensate for the overhead associated with the partition.
Refer to the following sections in the *Remote Solver Manager User’s Guide* for details on defining cluster configurations in RSM, and configuring a cluster:

- RSM Configuration
- RSM Integration with a Cluster

---

**Note**

- For a Microsoft HPC cluster, PSSH is not supported on Microsoft Windows for this operation.
- PBS, LSF, UGE and TORQUE clusters on Windows are not supported.

---

**Submitting Icepak Jobs to RSM**

You can use this feature to queue multiple jobs to run on the local machine, such as overnight or during other low-usage times, and you can submit a job to remote machines.


2. In ANSYS Workbench, right-click the Solution cell and select Properties. Select the Solution Process settings that you want to use for this solution.

   ![Solution Properties](image)

   An update of the Solution cell submits the job to RSM, moves into Pending mode for the duration of the solution, and then automatically reconnects at the end of the run.

---

**Tip**

If you set Execution Mode to Parallel, you can specify the number of processes that you want to use to create the results file. You should specify a number that is less than
or equal to the number of cores available in the cluster, and you should ensure that each process contains at least 100,000 nodes or elements.

3. Under **Solution Process**:
   
   - If solving in serial, enable **Serial** for **Execution Mode**.
   - If solving in parallel, select **Parallel** for **Execution Mode** and enter the number of processes in the text field below, across from **Number of Processes**.

![Properties of Schematic A3: Solution](image_url)
RSM updates Icepak with Convergence plot data at the Progress Download Interval specified in Workbench. Set the Progress Download Interval as needed prior to starting the solution.

Update the project. An update of the Solution cell submits the job to RSM, moves into Pending mode for the duration of the solution, and then automatically reconnects at the end of the run. To re-run a solution with the same model, run another solution in the same project, or run a restart solution, right-click the Setup cell in Workbench and select Enable Update.

Note

- You can Interrupt or Abort an update by right-clicking the solution in the Workbench Job Monitor. These options are available during background and RSM updates. To display the Job Monitor, select Jobs → Open Job Monitor.

- Icepak has the following limitations when used with Remote Solve Manager:
  - You cannot submit jobs containing parametric trials to RSM.
  - Convergence data is not plotted in Icepak on the local computer. The .res and .uns_out files are written at the frequency specified in RSM settings. You must open them in Icepak to view them.
Exiting a Project During an RSM Solution Cell Update

You can exit a project while a Solution cell update via RSM is in progress (that is, one or more RSM jobs are running in the background and the Progress view displays a project Status of Waiting for background task).

Note

You cannot exit Workbench while job files are being uploaded. You can abort the job during the upload, however, by using the Stop button in the Progress bar.

In order for RSM jobs to continue to run after you exit the project, the project must be saved at least once after the Solution cell update job was initiated.

If you attempt to exit a project while a Solution cell update job is still running, the following scenarios will cause a dialog to display, allowing you to specify whether you want to save the project before exiting:

• You have never saved the project at any time after the same Solution cell update job was initiated.

• You have saved the project at least once after the same Solution cell update was initiated, but results have been retrieved since your last Save.

In either of these cases, if you do not save the project before exiting:

• All results retrieved since the last Save operation will be lost. You must save the project before exiting if you want to keep any of results retrieved since the last save of the background Solution cell update.

• If the project has never been saved after the Solution cell update job was initiated, all RSM jobs will be aborted and will show a Status of Cancelled and the Cancelled icon (.Cancelled) in the RSM List view; the asterisk on the icon indicates that the job has also been released. When you reopen the project, it will be in the state of your last manual save.

• If the project has been saved at least once after the Solution cell update job was initiated, RSM jobs that are queued and running will continue to run after you exit. When you reopen the project, you can resume the update of the pending jobs to reconnect and download the results.

If you do save the project before exiting:

• Retrieved results will be saved to the project.

• RSM jobs that are queued and running will continue to run after you exit.

• Jobs for which the results have been saved will show a Status of Finished and the Finished icon (Finished) in the RSM List view; the asterisk on the icon indicates that the job has also been released.

• Jobs for which results have not yet been saved are not released upon exit. When you reopen the project, you can resume update of the pending jobs to reconnect and download the results.
Monitoring and Controlling RSM Jobs in Workbench

If you have chosen to submit project updates, design point updates, or component updates using the Submit to Remote Solve Manager or Submit to Portal option, you can monitor their progress by displaying the Job Monitor in Workbench.

To display the Job Monitor, select Jobs → Open Job Monitor, or click on the status bar.

The Job Monitor provides a live view of what is happening in RSM with regard to the current Workbench project.

To view jobs that have been submitted to RSM, select RSM from the Jobs Submitted To drop-down.

To view jobs that have been submitted to an EKM Portal, select the corresponding portal connection name from the Jobs Submitted To drop-down.

To view jobs that have been submitted to an EKM Portal, select the corresponding portal connection name from the Jobs Submitted To drop-down.
The **Job Monitor** displays the following information for each job:

- Job name
- Status (Running, Finished, Failed, and so on)
- Submission date/time
- Owner
- RSM queue (RSM jobs)
- Cluster configuration (RSM jobs)
- Cluster queue

Clicking on a job displays a detailed job log in the lower pane of the **Job Monitor**.

You can perform the following actions in the **Job Monitor**:
• To hide design point updates in the job list, disable the **Include Design Point Jobs** check box.

• To view a job report for a specific job, select the job in the **Jobs** pane. The report is displayed in the **Details** pane.

• To save a job report to a file, click 📜 in the **Details** pane, then accept or specify the save location, filename, and content to include:

![Save Job Report dialog](image)

**Note**

For jobs submitted to an EKM Portal, the save action is disabled while the job is in the **Input Pending** state.

You can use the context-sensitive menus in the **Jobs** pane and **Details** pane to perform a variety of actions. For example, you can customize the job list display, and perform actions on a job such as **Abort** or **Interrupt**.

### Using the Taskbar Icon

When you launch the **Job Monitor**, a job monitor icon is also displayed on your Windows taskbar. If you subsequently minimize the **Job Monitor** window, you can quickly restore it by clicking the taskbar icon.

![Taskbar Icon](image)

### Viewing the Status of Jobs

The status of each job is indicated in the **Status** column in the **Jobs** pane, and by a unique icon at the beginning of the job entry. For jobs that have completed, the **Status** column and icon indicate the final status of the job. The addition of an arrow symbol to the final status icon indicates that the job has been released.

<table>
<thead>
<tr>
<th>Status</th>
<th>Description</th>
<th>Icon</th>
<th>Released Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input Pending</td>
<td>Job is being uploaded to the cluster.</td>
<td>🏡</td>
<td></td>
</tr>
<tr>
<td>Queued</td>
<td>The job has been placed in the cluster queue, and is waiting to run.</td>
<td>🕒</td>
<td></td>
</tr>
<tr>
<td>Status</td>
<td>Description</td>
<td></td>
<td></td>
</tr>
<tr>
<td>-------------</td>
<td>----------------------------------------------------------------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Running</td>
<td>Job is running.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cancelled</td>
<td>Job has been terminated via the <strong>Abort</strong> option.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Also applies to jobs that have been aborted because you exited a project without first</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>performing one of the following actions:</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Saving the project since the update was initiated</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Saving results retrieved since your last save</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Finished</td>
<td>Job has completed successfully.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Also applies to jobs that have been terminated via the <strong>Interrupt</strong> option or for which you</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>have saved results prior to exiting the project.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Failed</td>
<td>Job has failed.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Also may be applied to jobs that cannot be cancelled due to fatal errors.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Controlling the Display of the Job List

You can sort the job list by job name, status, owner, and so on by clicking on the appropriate column header in the **Jobs** pane. Clicking on the same column header again reverses the sort order.

If you right-click any column header, a context menu is displayed which contains the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select All</td>
<td>Selects all jobs in the list.</td>
</tr>
<tr>
<td>(CTRL+A)</td>
<td></td>
</tr>
<tr>
<td>Scroll to Top</td>
<td>Returns you to the beginning of the job list.</td>
</tr>
<tr>
<td>Scroll to Bottom</td>
<td>Takes you to the end of the job list.</td>
</tr>
<tr>
<td>View Line Numbers</td>
<td>Toggles the display of numbers at the beginning of each entry in the job list.</td>
</tr>
</tbody>
</table>

### Performing Job Actions

If you right-click a job in the **Jobs** pane, a context-sensitive menu is displayed that contains the options described below.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Abort</strong></td>
<td>Immediately terminates a running job. Enabled only if a running job</td>
</tr>
<tr>
<td></td>
<td>is selected.</td>
</tr>
<tr>
<td></td>
<td>Jobs terminated via this option will have a <strong>Status</strong> of <strong>Canceled</strong> in the</td>
</tr>
<tr>
<td></td>
<td><strong>Jobs</strong> pane.</td>
</tr>
<tr>
<td><strong>Interrupt</strong></td>
<td>Terminates a running job. Enabled only if a running job is selected.</td>
</tr>
<tr>
<td></td>
<td>Jobs terminated via this option will have a <strong>Status</strong> of <strong>Finished</strong> in the</td>
</tr>
<tr>
<td></td>
<td><strong>Jobs</strong> pane.</td>
</tr>
</tbody>
</table>
### Remove

Deletes the selected job or jobs from the **Jobs** pane. Enabled only if a completed job is selected.

Cannot be used on a running job.

---

**Note**

- For Mechanical solution component updates submitted to an EKM Portal, the Job Monitor’s **Abort** and **Interrupt** actions are disabled when the job is in the **Input Pending** state. You can, however, abort or interrupt such an update through the **Progress** view in Workbench, or directly from the Mechanical application.

### Controlling the Display of Job Details

When you select a job in the **Jobs** pane, a corresponding job log is displayed in the **Details** pane. The log automatically scrolls to the bottom to keep the most recent messages in view.

If you right-click in the job log view, a context-sensitive menu is displayed which contains the following options:

<table>
<thead>
<tr>
<th><strong>Copy</strong></th>
<th>Copy selected text in the <strong>Details</strong> pane. Alternatively, you can use the Ctrl+C key combination.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select All</strong></td>
<td>Select all of the text in the <strong>Details</strong> pane. Alternatively, you can use the Ctrl+A key combination.</td>
</tr>
</tbody>
</table>
| **Save Job Report...** | Save the job log to a file. The Job Report will include job details and the contents of the job log shown in the **Details** pane. When generating the report, you can specify the following report preferences:  
  - **Include Debug Messages**: whether debugging messages are included in the Job Report  
  - **Include Log Time Stamp**: whether a log time stamp is included in the Job Report  
  - **Include Line Numbering**: whether line numbering will be displayed on the Job Report  
  Click the **Browse** button to select the directory to which the report will be saved, type in the report filename (`RSMJob.html` by default), select the report format (HTML or text format), and click **Save**. Note that for jobs submitted to an EKM Portal, the **Save Job Report** action is disabled while the job is in the **Input Pending** state. |
| **View Line Numbers** | Toggle the display of line numbers at the beginning of each line in the job log. |
| **View Time Stamps** | Toggle the display of time stamps at the beginning of each line in the job log. |
**Using Journals and Scripts**

ANSYS Workbench offers the ability to record the actions you perform via the GUI, which we refer to as *journaling*. Journals are recorded as Python-based scripts. You can modify these scripts or create new ones, which we refer to as *scripting*. Together, these capabilities allow you to quickly and easily replay analyses you've already run via recorded journals, as well as to extend functionality, automate repetitive analyses, and run analyses in batch mode.

For detailed instructions on using journaling and scripting, as well as a complete list of all available data containers, namedpaced commands, and data types, see the *ANSYS AIM and Workbench Scripting Guide*.

**Related Topics:**
- Journaling
- Scripting

**Journaling**

A journal is a record of all operations that have modified data during your session. Based on your Preferences setting, a journal of your full session will automatically be saved to the location you specify (see Setting Journaling Preferences (p. 98)). You can also choose to record part of a session to a journal file, capturing a specific set of actions. Playing back the journal will recreate the recorded actions exactly. Journaling and scripting tools (including recording and playback) are available through the **File** → **Scripting** menu and can be performed by anyone using ANSYS Workbench.

- Use journaled sessions to restore work after a crash.

- Journals are platform independent and portable, subject to file location consistency between accounts (see File Path Handling in ANSYS Workbench for details on file path handling within journals and scripts). They can be used with any ANSYS installation (release 12.1 or higher).

**Setting Journaling Preferences**

You can set journaling preferences such as the default directory where journals will be written and how long to keep a journal file.

1. In ANSYS Workbench, select **Tools** → **Options** → **Journals and Logs**.

2. Select **Record Journal Files** to have ANSYS Workbench automatically write journal files.

3. Specify the default location where journal files will be written. This is the location that the browser will open in automatically when you choose to begin recording a journal. You will still be able to browse to a different location before saving a particular journal.

4. Specify the number of days to keep a journal file.
5. Specify how long (in seconds) to pause between each command when running a journal file.

6. Click **OK** to save your settings.

---

**Recording and Playing a Journal**

Follow the steps described below to record a journal and then to playback a journal interactively. To use the command window, see Using the Command Window (p. 99).

**Recording a Journal**

1. Launch ANSYS Workbench.

2. Select **File → Scripting → Record Journal**.

3. Specify the name and location of the journal file and click **Save**.

4. Use the GUI to work through your analysis as you normally would.

5. Select **File → Scripting → Stop Recording Journal**.

6. A message appears informing you that you will stop recording. Click **OK**.

---

**Note**

Not all actions are journaled—only actions that change project data. Some examples of actions that are not journaled include:

- Interface-only actions, such as:
  - Interrupting a Solve operation
  - Running in Compact mode
  - Launching help (including quick help and the **Sidebar Help** view)
  - Running the View Solver Output option from VistaTF’s **Solution** cell.

- Actions taken in some data-integrated applications; see Scripting and Data-Integrated Applications.

---

**Playing Back a Recorded Journal**

1. Select **File → Scripting → Run Script File**.

2. Select the journal file to be played back and click **Open**.

3. The previously recorded actions will occur.

---

**Using the Command Window**

The command window allows you to invoke commands, access data entity properties, and invoke data entity and data container methods interactively, one at a time.

1. Select **File → Scripting → Open Command Window**.

2. Enter the commands you want to run, one at a time.
3. As you enter each command, the appropriate action will occur in ANSYS Workbench.

**The Console Window**   The console window is the same as the command window but is present when running in batch mode to provide a way of working directly with commands outside of the user interface.

**Scripting**

A script is a set of instructions to be issued to ANSYS Workbench. The script can be a modified journal, or it can be a completely new set of instructions that you write directly.

The creation of scripts requires a general understanding of programming constructs and paradigms. ANSYS Workbench uses an object-based approach, similar to object-oriented programming.

For detailed information on using Scripting, see Using Scripting in ANSYS Workbench in the ANSYS AIM and Workbench Scripting Guide.

**Project File Management**

ANSYS Workbench’s file management system stores several different files under a single project, using directory trees to organize files relevant to each system and the applications used in the system.

When the project file (<filename>.wbpj) is created, ANSYS Workbench creates a project folder named <filename>_files where <filename> is a name you provide. All files relevant to the project are saved within this folder.

The primary subdirectories within the project folder are dp0, dpall, and user_files.

We strongly recommend that you use caution when directly modifying any of the content in any of the ANSYS Workbench project directories or subdirectories other than user_files. You should work through the ANSYS Workbench GUI to manage your project as much as possible. ANSYS Workbench may not recognize or be aware of any changes that you make directly in the file system (such as adding or removing a file).

---

**Important**

If you are resuming a project in Mechanical on the Linux platform, there is a restriction that the path to the project, as well as the project name, include ASCII characters only, otherwise, the project will not open.

---

**Project Directories**

The project directory structure includes the follow directories:

dp0 Subdirectory
user_files Subdirectory
dpn Subdirectories and Working with Design Points

---

**Important**

If you are resuming a project in Mechanical on the Linux platform, there is a restriction that the path to the project, as well as the project name, include ASCII characters only, otherwise, the project will not open.
**dp0 Subdirectory**

ANSYS Workbench designates the active project as design point 0 and creates a dp0 subdirectory that always corresponds to the active project files. For more information on dp0 and design points, see the section **dpn Subdirectories and Working with Design Points** (p. 102).

Within the design point folder are system folders for each system in the project. Within each system folder are folders for each application used in the system (for example, the Mechanical application, Fluent, and so on). These folders contain application-specific files and folders, such as input files, model directories, engineering data, and resources. System folders for each system type are named as follows.

<table>
<thead>
<tr>
<th>System Type</th>
<th>Folder name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autodyn</td>
<td>ATD</td>
</tr>
<tr>
<td>BladeGen</td>
<td>BG</td>
</tr>
<tr>
<td>Design Exploration</td>
<td>DX</td>
</tr>
<tr>
<td>Engineering Data</td>
<td>ENGD</td>
</tr>
<tr>
<td>FE Modeler</td>
<td>FEM</td>
</tr>
<tr>
<td>Fluid Flow (Fluent)</td>
<td>FFF (analysis system), FLU (component system)</td>
</tr>
<tr>
<td>Fluid Flow (Polyflow)</td>
<td>PFL (Polyflow), PFL-BM (Blow Molding), PFL-EX (Extrusion)</td>
</tr>
<tr>
<td>Fluid Flow (CFX)</td>
<td>CFX</td>
</tr>
<tr>
<td>Geometry</td>
<td>Geom</td>
</tr>
<tr>
<td>Mesh</td>
<td>SYS (top level) / MECH (subdirectory)</td>
</tr>
<tr>
<td>Mechanical</td>
<td>SYS (top level) / MECH (subdirectory)</td>
</tr>
<tr>
<td>Mechanical APDL</td>
<td>APDL</td>
</tr>
<tr>
<td>TurboGrid</td>
<td>TS</td>
</tr>
<tr>
<td>Vista TF</td>
<td>VTF</td>
</tr>
<tr>
<td>Icepak</td>
<td>IPK</td>
</tr>
</tbody>
</table>

* The Mechanical application and Mesh system folders under the dp folder(s) are labeled SYS. Both the Mechanical application and Mesh files are written to MECH subdirectories, because both are generated by Mechanical-based applications.

In addition to the system folders, the dpn folders also contain a global folder. This folder contains subdirectories for all systems in the project. These subdirectories may be shared by more than one system in the project and contain all database files, as well as any files that are associated directly with the database files. For example, the Mechanical application will write figures and images and contact tool data to the appropriate system subdirectory under the global folder.

**user_files Subdirectory**

Also under the project folder is a user_files directory. This folder contains any files (such as input files, referenced files, etc.) that you supply to a project or any output (images, charts, movie clips, etc.) generated by ANSYS Workbench that you want to have associated with the project. In most cases, you are responsible for placing required files into this directory. In other cases, such as the export of design point update data from a design exploration system to a CSV log file, data is written directly to a file created in this directory. For details, see Exporting Design Point Parameter Values to a CSV File (p. 142).
Along with other project files, all of the files contained in the user_files directory appear in the Files view in ANSYS Workbench. Thus, any files that you have placed into this directory can be accessed easily from the ANSYS Workbench user interface via the Open Containing Folder option of the right-click context menu.

ANSYS Workbench also protects this directory and ensures that it is managed and archived appropriately with the rest of the project; therefore, you can safely store additional files (such as PowerPoint or Excel files, or other files from separate applications that are associated with this project) here without the risk of losing data. If you save files in any other directory in the project structure and then exit without saving, ANSYS Workbench will delete any files saved there since the last ANSYS Workbench save.

**dpn Subdirectories and Working with Design Points**

ANSYS Workbench allows you to create multiple design points and generate comparison studies (What-If studies) of input and output parameters. To analyze your simulation across several design points, you must first generate input parameters for the current project (and, if appropriate, specify output parameters to be created). Once you have created parameters, you will see a Parameters cell added to the relevant system(s) and a Parameter Set bar added to the project. At this point, the current project is designated as Design Point 0, or dp0.

Use the Parameters (p. 123) tab to vary input parameters and create multiple design points, which can be updated separately or sequentially. Before running a design point update, you should decide whether you want to retain the files generated during the design point update for further analysis. ANSYS Workbench saves the data for the current design point, any retained design points, and the values of the output parameters computed for each design point. If you want a different design point to be the current design point, you can:

- Right-click the design point and select **Copy inputs to Current** to copy the design point's input values to the Current design point.

- If the design point has the Retain column selected, right-click it and select **Set as Current** to make it the Current design point.

While a design point update is running, ANSYS Workbench creates temporary design point folders. If the Retain check box has been selected for a design point, its data is saved to a dpn subdirectory (where dpn indicates the number of the design point) that will be a sibling to the dp0 subdirectory. For more information on retaining design point data, see Retaining Design Point Data.

If you want to examine a design point in a different project, right-click it and select **Export Selected Design Points**. The design point's data is saved to a new project, named <filename>_dpn (where dpn indicates the number of the exported design point), with a project file named <filename>_dpn.wbpj. Working files are saved to a <filename>_dpn_files directory that is a sibling to the original <filename>_files project folder. For more information on exporting design point data, see Exporting Design Points to New Projects.

For more information, see Working with Parameters and Design Points (p. 123).

**Example Project**

A finished project that includes a Fluid Flow (Polyflow) system (FFF), a Mechanical application system (MECH), and parameters (DesignXplorer) might look like this:
The corresponding directory structure would look like this:

```
Myworkbenchproject_files
dp0
  FFF
  DM
  Fluent
  MECH
  Post
  global
  MECH
  FFF
  SYS
  SYS
  ENGD
  MECH
dpall
  global
  DX
```

**Working with Files and Projects**

See the following sections for more information on:
- Importing Files
- Archiving Projects
- Project Recovery
- Project Locking

**Importing Files**

When working in ANSYS Workbench, you may need to import files, such as input files, existing mesh files, geometries, etc.

When you edit an imported file, ANSYS Workbench saves a copy of the file to the project directory, rather than overwriting the original file. This process ensures that your original files are never compromised.
Most files from previous releases can be imported using **File → Import**. The import operation will create systems, cells, and links to represent the previous release project. For more information on importing legacy databases, see Importing Legacy Databases (p. 107).

**Archiving Projects**

If you want to send a project to a colleague or to ANSYS Technical Support, or need to package all of the files for archiving or other purposes, choose **File → Archive**. In the **Save Archive** dialog box, navigate to the directory where you want to save the file and select the archive type: Workbench Project Archive (.wbpz) or a Zip (.zip/.tar.gz) file. You will also need to specify which optional items you want to archive, such as result/solution items, imported files, and items in the **user_files** directory.

The Workbench **Options** dialog box allows you to specify the compression level for .wbpz archives. For more information, see Project Management (p. 17).

When you import an external file, Workbench archives it by adding it to the **user_files** directory. However, if the external file refers to other files (for example, as when a CAD assembly is linked to the CAD parts), the system is not able to place all of the necessary referenced files in the **user_files** directory. In order to make the referenced files part of the archive, you must copy them manually into the **user_files** directory.

To restore an archived file, select **File → Restore Archive**. You are prompted for a project path to which the archive will be extracted, and then that project is opened.

---

**Note**

If your project contains Imported Boundary Conditions in the Mechanical application, you should choose to include result/solution items so that the necessary upstream files are archived. Failure to archive these files will prevent you from importing data or accessing features that involve reading upstream data, when the project is restored.

---

**Windows Only** On Windows systems, you can also double-click the .wbpz file to open the archive. If you double-click the .wbpz to open a file and then make changes to the project, when you save the project, you are prompted to either overwrite the archive, create a copy of the archive, or cancel the save operation. If you choose to create a copy of the archive, you are prompted for a name and location for the copy. The new copy will also have a .wbpz extension. After the save operation, you are returned to ANSYS Workbench, working in the new (copy) archive. The original archive remains unchanged. Use **File → Save As** to restore the project to a .wbpj file.

You cannot update retained design points when working in an archived project. If you choose to update a design point with the retained option on, you are prompted to first use **File → Save As** to save the project as a .wbpj file.

**Project Recovery**

ANSYS Workbench creates backup files of projects that are currently active and in progress. In the event of a crash, ANSYS Workbench can use these backup files to restore your project to the last saved event. As with any computer program, it's important that you save your work frequently to minimize data loss in the event of a crash. Do not move or otherwise alter the backup directory.

If a project save operation fails (for example, an application is busy and cannot execute the save), you will be given the following options:
• Revert to the last saved project.

• Make a copy of the last saved project before continuing with the partially saved project. The project will be copied into a new location that you specify.

• Exit Workbench and decide later. Use this option if you want to handle the save failure manually. As a result, the backup directory will NOT be cleared so that you can manually recover files from that directory later.

• Continue with the partially saved project, discarding the last saved project (not recommended). This option results in the backup directory being cleared. Use this option with caution, as it could result in corrupt project files.

**Note**

This save-failure behavior applies only to a Save operation and NOT to a Save As (or first save) operation.

---

**Project Locking**

ANSYS Workbench implements a project locking mechanism in order to help prevent the project from being loaded into more than one session at a time. A project is locked by creating a .lock file in the project files directory. The project is unlocked by deleting the .lock file.

An improperly unlocked project can occur in situations such as program crash where the .lock file is not deleted, or if the project files directory is duplicated and the .lock file is copied with it. If ANSYS Workbench finds a project is locked, you will be asked how to proceed.

If the file is locked because of an abnormal termination, such as a program crash, you can safely select Unlock and continue. If the file is locked because the project is already open in another ANSYS Workbench session, you should select Cancel. Opening the same project in multiple sessions can result in corrupted project files.

**Notes About Project File Management**

We strongly recommend that you use caution when directly modifying any of the content in any of the ANSYS Workbench project directories or subdirectories other than user_files. You should work through the ANSYS Workbench GUI to manage your project as much as possible. ANSYS Workbench may not recognize or be aware of any changes that you make directly in the file system (such as adding or removing a file).

If you have deleted any project files through the file system and not through the ANSYS Workbench GUI, you may see a warning message when you attempt to open the project. The error message will list the missing file(s). The corrective action depends on the type of files that are missing:

• For files that are programmatically integrated with ANSYS Workbench (such as database files, geometry files, engineering data files, application-generated files, and so on), use **View → Files** to open the Files pane, where you can use the context menu to repair a file or permanently remove it from the project's file list if it is no longer needed. Repairing these types of files should be done judiciously; it is possible to use files or file types that are not similar to the original. Missing or erroneous files can cause unintended consequences for project stability and usability.
• For files that are not programmatically integrated with ANSYS Workbench (such as user-supplied input files, dp$n files, and so on), you can replace them using your file system and then open the project again. These files may not be necessary for the project; in this situation, you can safely ignore the warning message.

The project system may delete, back up, or restore files when:

• Deleting, duplicating, or replacing systems in the schematic
• Opening an application for a cell
• Closing a project without saving
• Archiving a project
• Switching to the next design point during the execution of the Update All Design Points operation

While the project system is performing one of these operations, you cannot have project files open in other applications (such as a text editor) or have the directories open in Windows Explorer. Doing so may cause these file management operations to fail.

You cannot move a project or any of its associated files to another machine while a background run is in progress. File information for the background run is, by necessity, machine-specific. You cannot package or modify the background run while it is in progress.

You will also have errors if you move a project that has references to files outside of the project directory to a different machine or location. By opening the project from a different machine or location, those file references will no longer resolve unless the file is still available under the same absolute path.

Copied images exist in only one location on disk that is referenced and do not exist as physical copies. If you delete an image that has been copied, all pointers to the copies of that image will contain broken links.

If your project name contains characters that are not native to your local operating system the project may fail to save, and if it fails, may corrupt the data.

**ANSYS Workbench Files**

To view all files associated with a project, choose View → Files from the menu bar. You will be able to see the name and type of file, the ID of the cell the file is associated with, the size of the file, the location of the file, and other information. Files added to the project will appear here. Files deleted from the project will be shown in red and will be marked with a “Deleted” icon. See Files View (p. 307) for more information on using the Files view. Database files associated with the various ANSYS Workbench applications are listed below.

**Database Files**  ANSYS Workbench applications create the following types of database files:

• ANSYS Workbench project database file = .wbpj

• Mechanical APDL = .db

• Fluent = .cas,.dat,.msh

• CFX = .cfx,.def,.res,.mdef and .mres

• DesignModeler = .agdb
Workbench Journal and Log Files  ANSYS Workbench writes journal and log files for each ANSYS Workbench session. For more information on journal and log files, see Journals and Logs (p. 19).

Design Point Log Files  During a design point update, the parameter values of each successfully updated design point are written to a CSV log file in the user_files directory. For more information, see Exporting Design Point Parameter Values to a CSV File.

Importing Legacy Databases

ANSYS Workbench offers several methods to import databases from earlier releases:

1. **Context Menu Import:** The file can be imported via a cell's context menu. To import a file using this method, you first create the appropriate system and cell, and then import the file into the cell via the context menu.

2. **File → Import:** The file can be imported via the File → Import menu. The proper systems and cells are created and populated with the data from the imported file. However, you must launch the associated application or editor to use the imported file. You can also drag-and-drop one or multiple files from Windows Explorer onto the Project Schematic. These files will be treated as if they were imported via File → Import.

3. **Project Import:** The file can be imported as part of an earlier release's project import. The file must be listed as part of the earlier release's project file's contents. When the project file is selected via the File → Import menu, all necessary systems, cells, and links will be established and populated with data from the various files that made up the earlier release's project.

In each of these cases, you must launch the associated application to use the imported file, which is typically the same application that was used to edit the file in the earlier release. The imported files are not undergoing any transformation in this release of ANSYS Workbench; rather, access to the files is being coordinated through the Project Schematic interface.

Not all products/databases use all of these methods.

DesignXplorer Release 11 (.dxdb) file import is not supported; however, basic parameter import is supported.
The following table shows which applications can use the three methods described above.

**Table 1: Import Methods**

<table>
<thead>
<tr>
<th>Application</th>
<th>Context Menu Import (#1)</th>
<th>File&gt;Import (#2)</th>
<th>Project Import (#3)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ANSYS Workbench, Release 11 or 10 (.wbdb)</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Mechanical (.dsdb)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>FE Modeler (.fedb)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Engineering Data (.eddb)</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Engineering Data (.xml,.engd)</td>
<td></td>
<td></td>
<td>(except convections and load histories)</td>
</tr>
<tr>
<td>AWA (.aqdb)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Autodyn (.ad)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Mechanical APDL (.inp,.dat,.cdb,.mac,.anf)</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>DesignModeler (.agdb)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Meshing (.cmdb)</td>
<td></td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>Fluent (.msh,.cas,.dat)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>CFX (.cfx,.def,.res)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>BladeGen (.bdg)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

*a. .cmdb files from Release 10 that contain CFX-Mesh data are not supported. To import these files, import them first into Release 11, save as a Release 11 file, and then import into Release 18.2.*

**Additional Mechanical Application Import Details**

- Legacy .dsdb files that contain multiple models are split into multiple files.
- .dsdb files become .mechdb files internally.
- Separate systems are created to correspond to each of the Release 11 environments. Environments that use the same geometry and model are represented with a link between the Geometry and Model cells of the systems. Physics environments are typically represented as a link between a Solution cell of the originating system and the Setup cell of the receiving system. For example, a thermal condition is represented by a connection between the Solution cell of a thermal system and the Setup cell of a structural system.
- Information that is transferred from the Release 11 system to the current system includes:
  - Model name
  - Model state
  - Physics type
  - Internal IDs for model, mesh, environment, and answer set
- Engineering Data file path
- Material property suppression path
- Solver files directory path
- Solver type
- Geometry preferences
- Parameters

- Legacy .dsdb files that do not contain an environment are imported as Mechanical Model (p. 281) systems.

**Additional FE Modeler Import Details**

- FE Modeler systems will be imported as standalone systems. You can manually create any necessary links between systems, but you will not have the data that FE Modeler may have created (such as geometry).

- If FE Modeler was associated with a Release 11.0 applet, and the .dsdb being imported does not contain any environments, a link is established between the Model cell of the Mechanical Model system and the Model cell of the FE Modeler system. Likewise, if FE Modeler was associated with a Release 11.0 Meshing applet, a link is also established.

- FE Modeler allows you to import a number of mesh files through the Model cell context menu.

**Additional Aqwa Import Details**

- A legacy Aqwa database is imported as a standalone Hydrodynamic Diffraction system

- If the legacy database contains multiple analyses, these will be converted into multiple Hydrodynamic Diffraction systems

- Geometry associated with the legacy database will be associated with the Geometry cell of the Hydrodynamic Diffraction system and will be editable

**Additional Autodyn Import Details**

No links are created when Autodyn files are imported from Release 11.0.

**Additional CFX Import Details**

If CFX files are present in the .wbdb project, they will appear in the Files view, but no system or links associated with these files are created. You can choose to Import to Schematic from the Files view, which will create a CFX system and import the selected file.

You can import CFX-Solver .bak files or full .trn files into the Project Schematic so that you can post-process results for debugging when a run fails. You may find it useful to use full .trn files as a backup mechanism because all timesteps are retained, instead of just the most recent ones, and it is easier to post-process multiple timesteps.

**Additional DesignModeler Import Details**

- DesignModeler files (.agdb) can be imported through context menu import.
• .agdb and .modeldv files can be imported via File → Import.

• Links with other cells are automatically generated when .agdb files that are present in the Release 11.0 .wbdb project are imported into the appropriate system (Mechanical Model or other appropriate system).

• Parameters contained in the .agdb file will not be immediately published to the Project Schematic interface. They will be published when the DesignModeler application is opened.

• CAD files that were imported into the .agdb will not immediately be registered in the Files view of the Project Schematic. Registration of these files will occur when the DesignModeler application is opened.

**Additional Meshing Import Details**

• Links with other cells are automatically generated when .cmdb files that are present in the Release 11.0 .wbdb project are imported into the appropriate system (Mechanical model or other appropriate system).

• CFX-Mesh files (.gtm, .cfx) can be imported via context menu import from the Mesh cell of a Mesh system.

**Working with the Chart View**

The Chart view is available for Workbench applications. Applications can display data using a number of different basic chart types. Each chart type has editable display properties.

The following chart topics are discussed:

  Chart Types
  Setting Chart Properties
  Chart Zoom, Pan, and Rotate
  Using the Triad
  Saving a Chart

**Chart Types**

Although the content of a chart will be tailored to the application that is displaying the chart, there are a standard set of charts that you might see in Workbench. These include:

**XY Plot**
  Lines, points, steps, bars, splines, scatter, or shaded regions can be plotted.

**XYZ Plot**
  Lines, points, bars, lines, splines, scatter, or surfaces can be plotted.

**Pie Chart**
  Displays variables as proportionally sized segments of a circle. If a variable to be displayed has no value, that variable displays as a ring around the circle.
**Spider Chart**
Similar type of display as the pie chart, in multiple dimensions. Good for displaying between 3 and 10 variables. Can usually be displayed as a Parallel Coordinate plot also.

**Parallel Coordinate Plot**
Provides a graph to display variables (design points, etc.) using parallel Y axes to represent all of the inputs and outputs. Selecting an axis allows you to filter the variables shown by dragging the arrows at the ends of the axis (variables with points outside of the axis range will be eliminated from the chart). Can usually be displayed as a Spider chart also.

**Correlation Matrix**
Enables you to visualize how closely the various input and output parameters are coupled. The strength of correlation is indicated by color in the matrix.

**Setting Chart Properties**
Each chart has properties that can be set for the chart data, and properties that can be set for the chart display. The chart data properties should be discussed in the help for the individual applications that are displaying the chart. This section will talk about the chart display properties, which should be common to charts displayed by any Workbench application. The various chart properties will be shown in the **Properties** view in the tab.

---

**Note**
Only the properties that are applicable for the current chart type will be displayed when you edit any particular chart component (an axis, for example). Therefore, although a property may be listed in this document under **Axis Properties**, that property might only appear for one or two chart types, or the property may only appear for continuous or discrete axes.

**Axis Properties**
To set axis properties, right-click on or outside of an axis and select **Edit Properties**. The axis properties that are available depend on whether the chart axis is discrete or continuous. Some of the settings include:

- **Title** – name for that axis (often defaults to variable name)
- **Title Background Color** – background color used for axis name
- **Show/Hide Grid** – if checked, show a grid for this chart axis
• Automatic Range – if checked, use automatic scaling for the axis, otherwise use the Range Minimum and Range Maximum, if they fall within the data bounds

• Range Minimum – set minimum range of axis

• Range Maximum – set maximum range of axis

• Is Logarithmic – if checked, set axis scaling to be logarithmic if (linear if unchecked)

• Is Usability – if checked, display a line/bar plot of the cross section data in a perpendicular direction to the axis direction

Legend Properties
Legend properties can be set by right-clicking the legend (border or background) and selecting Edit Properties, or can be set as part of the general chart properties. Be sure not to click one of the legend variables as the properties for that variable will be displayed, rather than the legend properties. The legend properties include:

• Visible – if checked, displays the legend for the chart

• Style – displays the legend entries either horizontally or vertically, and allows the legend to be expanded in the same direction, if it provides any benefit (defaults to vertical)

• Foreground Color – sets the color of the legend border

• Background Color – sets the color of the legend background

The legend defaults to no background color or foreground color (border). When you hover the cursor over the legend, you should see its borders. You set the background and foreground colors using a color wheel. You can select a new color and apply it, and you can also click More>> and change the Alpha channel to 0 for transparent or 255 for opaque.

Note
If there are too many entries in the legend, the legend will not display, even if Visible is checked.

Variable Properties
Variable display properties can be set by either right-clicking the variable plot on the chart and selecting Edit Properties, or by right-clicking the variable name in the legend and selecting Edit Properties. The Properties view shows the display properties available for that variable. The properties, when available, may include the following fields.

• Label - name for that variable plot

• Display As - selects the type of plot used for the variable

• Automatic Range - set automatic determination of variable range on or off

• Range Minimum - set minimum range of variable values displayed

• Range Maximum - set maximum range of variable values displayed

• Allow Filtering - allow filtering on parallel coordinate plot
**Style Display Properties**

When plot rendering is controlled per variable, the **Style** display properties will appear when you edit the variable properties. When plot line rendering is controlled generally rather than per variable (as for spider charts, for example), the **Style** display properties will appear when you edit the chart properties.

- **Smoothed Edges** – renders lines/surfaces with anti-aliasing set on, such that the line/surface appears to be smooth
- **Line Style** – choose type of line used for plot
- **Symbol Style** – choose type of symbol displayed in plot
- **Fill Style** – choose the fill style for the objects in the plot that use it
- **Line Colors** – sets the color sequence for multiple lines displayed on the chart
- **Fill Colors** – sets the color sequence for sequential symbols or gradient used for plot display
- **Number of Color bands** – when set to 0, the gradient will be a smooth graduation between values, rather than banded, where a single color is shown for a range of values
- **Relative Bar Width** – sets the width of a bar as a proportion of available space [0 - 1], determined by the maximum size bar that can be displayed without overlapping any adjacent bars of the same variable (if other variables appear between bars of this variable, making the bar wider may overlap those intervening variables)
- **Relative Bar Offset** – sets the start position of a bar, proportional to the minimum point where the bar could be placed to the maximum point where the bar could be placed [0 - 1], with the maximum size based on the same criteria as Relative Bar Width
- **Show Linear Interpolation of Lines** – causes the ends of a line plot to extend to the edge of the chart, when the plot is not against a discrete axis
- **Symbol Outline Colors** – sets the color used to outline displayed symbols
- **Symbol Size** – sets the size of displayed symbols in pixels [1 - 16]
- **Line Width** – sets the width of lines (including lines outlining bars), in pixels [1 - 10]

**Note**

In most cases, properties are not shown if they are not applicable to the item selected. However, Show Linear Interpolation of Lines is displayed whether the axis is discrete or continuous, but it only applies in cases of continuous axes. The option will have no effect if you set it when the plot is displayed on a discrete axis.

**Chart Properties**

Most charts have a few general properties that appear under a **Chart** entry in the **Properties** view when you click the background of a chart and select **Edit Properties**. When plot line rendering is controlled generally rather than per variable (as for spider charts, for example), the **Style** display properties will also appear when you edit the chart properties. Chart properties may include:

- **Title** – chart title that appears in the **Chart** view title bar
• Chart Type – allows some charts to be displayed as another chart type
• Display Percentages – turns on percentage values on pie charts

**Chart Zoom, Pan, and Rotate**

You can manipulate the display of a 3D chart using the zoom, pan, and rotate features.

• Zoom by using the mouse wheel or **Shift** + middle mouse button
• Box zoom by using the right mouse button
• Pan by using the **Ctrl** + middle mouse button
• Rotate by using the left or middle mouse buttons

Pan and rotate by holding down the appropriate key sequence and moving the mouse.

There are several ways that you can enlarge or shrink portions of the chart in order to view more or less detail. To zoom the entire chart, click the chart and use the scroll wheel or **Shift** + middle mouse button to magnify or shrink the chart. The chart expands or shrinks as you roll the wheel (or move the mouse) toward you or away from you, remaining centered in the view pane. The chart can be panned or rotated when it is magnified.

To magnify a particular area of a chart, right-click and drag a box top to bottom over the area you want to view. The contents of the box you draw will be magnified to fill the chart view, so the smaller the box you draw, the closer the magnification on a particular area.

If you right-click and draw a box bottom to top over the chart, the chart will shrink to roughly correspond to the size of the box that you have drawn, so a very small box will give you a tiny chart.

**Using the Triad**

On three dimensional charts, the **triad** appears in the lower left corner of the chart view, showing the orientation of the three axes for the current view of the chart. The x axis is red, the y axis is green, and the z axis is blue. There is a light blue ball in the triad that indicates the orientation ISO z axis up position of the chart. If you click this ball, it sets your chart view to be ISO z axis up, fit to window.

If you move your cursor around the triad, you will see a yellow arrow appear that shows the direction that corresponds to the position of your cursor (+x, -x, +y, -y, +z, -z). If you click the arrow, it changes your chart view so that the chart axis indicated by the arrow is facing out.

There are several shortcut keys that can be used when you are viewing a 3D chart:

• **f** – fits the chart to the window
• **x** – displays the x+ view, fit to window
• **y** – displays the y+ view, fit to window
• **z** – displays the z+ view, fit to window
• **i** – displays the chart in the ISO z axis up position, fit to window
Saving a Chart

You can save the chart that you are viewing as a graphic:

1. Right-click the background of the chart and select **Save Image As**.

2. In the dialog box that appears there is a small image of the chart; select the **Size** (resolution) to be used when saving the chart. Click the ellipsis button and navigate to the folder where you want to save the file.

3. Enter a filename; you can select either `.png` or `.bmp` as the graphic file type.

4. Click **Save** to select that file path as your save location.

5. Click **OK** to save the file to the location that you selected, with the resolution you selected.

Working with Project Reports

ANSYS Workbench project reports enable you to generate a visual "snapshot" of your project. The contents and organization of the report reflect the layout of the **Project Schematic**, with sections for global project information, analysis system information, system cell information, and where applicable, content provided by applications in the project.

---

**Note**

At this time, DesignXplorer, CFD-Post, and ANSYS AIM are the only applications that provide the project report with detailed report content. Content for other applications is limited to the data visible at the project level (for example, in the **Properties** view for the associated cell in the **Project Schematic**).

This section addresses the following topics:

- Configuring Project Reports (p. 115)
- Generating Project Reports (p. 116)
- Report Content for Projects with Design Points (p. 116)
- Editing Project Reports (p. 116)

Configuring Project Reports

**Setting Project Report Options**

You can specify report settings in the Workbench **Options** dialog.

1. In Workbench, select **Tools → Options**.

2. In the **Options** dialog, expand the **Project Reporting** option in the navigation tree.

3. Select the **After exporting report, automatically open in default browser** check box to launch your default browser and load the report immediately upon generation. If you do not select this option, you will need to navigate to the report file and open it manually.

Including CFD-Post Data in the Project Report
To include CFD-Post data in your project report:

1. On the **Project Schematic**, right-click the **Results** cell for an ANSYS CFD analysis system or Results system and select **Properties**.

2. In the **Properties** view, select the **Publish Report** check box.

3. Repeat for each **Results** cell to be included in the project report.

**Note**

- Only 2D content such as graphs and figures are supported in the project report. If interactive 3D content exists, it will be displayed in 2D format.

- The format/style of CFD-Post reports produced from Workbench are consistent with general Workbench-produced reports; reports from standalone CFD-Post use the standard CFD-Post format.

---

**Generating Project Reports**

The content and status of the project determine the content of the report. The project report reflects the current state of the project at the time the report is generated.

To generate a project report, select **File → Export Report**.

**Report Content for Projects with Design Points**

If the project includes parameters and report content has been provided by an application in the project during a design point update, then the design points table will contain links to sub-reports for each design point. Detailed report content for each design point can be accessed via a hyperlink in the **Report** column of the design points table in the project report. Clicking the link opens a sub-report that contains the application-specific content for that design point (if available).

**Editing Project Reports**

Once you have generated a project report, you can edit its contents as needed.

1. Open the report file with an HTML-adapted editor (such as Microsoft Word) by right-clicking the file and selecting **Open with**.

2. Edit the report contents and formatting as needed.

3. Save the file in the desired file formats to a location outside Workbench.

**Viewing the Report Image**

If you have a solved project that has design points, if a project report has been generated, you can preview design point images from the report in the **Parameter Set** tab. To see report images:

1. In the **Project Schematic**, right-click the **Results** cell and select **Properties**.

2. In the **Properties** view, enable **Update Options → Publish Report**.
3. In the toolbar, click **Update All Design Points**.

4. When the project has updated, click the **Parameter Set** bar.

5. In the **Properties** view, **Design Point Report** → **Report Image** lists the PNG files that are available for design points. These image files are located in this directory:

\[\text{project_location}\]dp[\text{current_design_point}]\system_type\Post\Report\Report.

6. Double-click the Parameter Set bar.

7. In the design points table, click a thumbnail in the **Report Image** column to open the image file.

To clear the images, in the **Properties** view, set **Report Image** to **None**.

---

**Note**

The image in the **Report Image** column is the default image for a CFX or Fluent report (Generic Report Figure 1). To have a different image:

1. Set up CFD-Post to display the image you want in the report.

2. Click the Figure icon in the toolbar.

3. In the **Outline** view, disable Generic Report Figure 1 and enable Figure 1.

4. In Workbench, click **Update All Design Points**.

---

**Using Help**

ANSYS Workbench offers three levels of help:

- **Quick Help** (p. 117)
- **Sidebar Help** (p. 118)
- **Online Help** (p. 118)

**Quick Help**  Quick help is available for most cells in a system. Click the blue arrow in the bottom right corner of the cell to see a brief help panel on that cell. Quick help is generally state-sensitive; as the state of a cell changes, the content of the quick help panel will update to match. From quick help, you can also access related help topics in the online help system.
Sidebar Help  Context-sensitive help is available at any time by pressing F1. The Sidebar Help view displays on the right side of the screen. The content of this help panel is determined by the portion of the interface that has focus (that is, where the mouse was last clicked). If no particular area has focus, you will see an overview topic. If the Project Schematic has focus but no systems are defined, you will see a Getting Started topic. If the Project Schematic has focus and one or more systems have been defined, you will see links to those specific system types, as well as links to general topics. You can also access the Sidebar Help view by choosing Help → Show Sidebar Help from the menu bar.

Online Help  Online help is available from the ANSYS Workbench Help menu, or from any of the links in the quick help or the Sidebar Help view. Online help provides a comprehensive discussion of all ANSYS Workbench features and capabilities, and includes a full search capability.
Troubleshooting ANSYS Workbench

This section lists problems and error messages that you may encounter while running ANSYS Workbench. After each situation description or error message is the action required to correct the problem.

**Problem Situations**

**Startup or Graphics Problems**

**Limitations**

**Error Messages**

This section does not include troubleshooting for data-integrated applications. For troubleshooting information for data-integrated applications, see the help for the specific application.

For additional troubleshooting information on native applications, see the following:

- DesignXplorer Troubleshooting
- DesignModeler Frequently Asked Questions

You can find additional FAQs on the *Product Documentation* section of the *ANSYS Customer Portal* at [https://support.ansys.com](https://support.ansys.com).

**Problem Situations**

During setup, if you encounter any errors containing the text "0x8000FFFF", you will need to install the required installation prerequisites. Run the installation launcher (*setup.exe*) and choose **Install Required Prerequisites**.

**CAD System Plug-In Menus Do Not Appear for NX or Creo Parametric**

ANSYS Workbench on Windows platforms appends its information to an existing customization file for NX and/or Creo Parametric. If no customization file exists, ANSYS Workbench creates a file. For NX, ANSYS Workbench looks for the `custom_dirs.dat` file in the directory specified via the `UGI_CUSTOM_DIRECTORY_FILE` environment variable. For Creo Parametric, ANSYS Workbench looks for the `config.pro` file in the `%HOMEDRIVE%%HOMEPATH%` directory. In addition, during setup of the Creo Parametric Geometry In-
terface, ANSYS Workbench will also append its information to the config.pro file located in the Creo Parametric installation path, under the text directory (for example, Proewildfire2\text\config.pro).

If ANSYS Workbench encounters a read-only file, it will not be able to write the necessary information to the file. In this case, you will need to revise the permissions on the file and manually add the appropriate ANSYS Workbench-specific information in order for the ANSYS menu to appear in NX or Creo Parametric.

Script Errors When Running ANSYS Workbench If you encounter script errors such as "Error: Unable to create object microsoft.XMLDOM," you may need to install the latest version of Microsoft's MSXML. Visit Microsoft's web site at http://www.microsoft.com/downloads/details.aspx?FamilyID=993c0bcf-3bcf-4009-be21-27e85e1857b1&DisplayLang=en for more information on downloading and installing MSXML.

Charts Do Not Appear If you do not see the appropriate charts created after a design point run or other updates (such as response surface updates), reset the tab by going to View → Reset Workspace.

Applications Do Not Start After Crash On Linux, if ANSYS Workbench applications will not launch after an abnormal exit such as a crash, run the following utility:

$INSTALL/v182/aisol/wbcleanup

Wobbly Desktop Effect Causes Crashes The Wobbly desktop effect on Linux may cause ANSYS Workbench or its applications to crash. This effect is on by default on some Linux platforms. Make sure the effect is turned off.

System Freezes After Certain GUI Operations There are known issues involving UI operations if you are using the KDE 3.5 desktop environment on Linux systems when running ANSYS Workbench products. If using KDE 3.5 and you open a drop-down list in the Details View, you must select an entry from the list before performing any other UI operation or the product may hang. As an alternative, use the GNOME desktop environment.

KDE Support Limitations KDE is not supported on SuSE Linux Enterprise Server & Desktop 12.

Startup or Graphics Problems

To minimize graphics problems, always verify that you are running the latest graphics drivers provided by your computer's hardware manufacturer. If you are not, you may see the following message:

***An error occurred while setting up the graphics window. Please ensure that you have the latest drivers from your graphics card manufacturer. If the error persists, you may need to decrease the graphics acceleration. For more information, please see the Troubleshooting section in the ANSYS Workbench help.

Linux If you are running ANSYS Workbench on Linux and experience problems at startup or with the user interface or graphics displaying correctly, and you are running in accelerated graphics mode, you may need to relaunch ANSYS Workbench using the -oglmesa flag to activate software rendering:

runwb2 -oglmesa

If ANSYS Workbench detects that graphics problems are causing crashes, it will automatically switch to software rendering. ANSYS Workbench also will use software rendering mode by default when running on a remote display, or on a local display if the hardware does not appear to be accelerated.

To revert to accelerated graphics mode, launch ANSYS Workbench using the -oglhw flag:

runwb2 -oglhw
If you are running under Exceed3D, try the following settings if you are having graphics problems:

• Turn off the graphics (hardware) acceleration option in Exceed3D options.

• If graphics acceleration is on, turn on the GLX 1.3 option.

Any version of Exceed that does not have the GLX 1.3 option is unlikely to function correctly with graphics acceleration.

Windows    If you experience graphics issues on Windows systems, you can find the details of your graphics card and the driver that is currently installed by running Start> Run and typing the following into the Open field:

dxdiag

Select the Display tab and review your graphics card information. You can then contact the vendor or visit the vendor's website for details of the latest graphics drivers available for your specific graphics card.

You may also have to adjust the hardware acceleration. To adjust the hardware acceleration, go to the Control Panel and choose Display> Settings> Advanced> Troubleshoot or your operating system's equivalent. The hardware acceleration slider should then be visible. You can also choose Display> Settings> Troubleshoot and use the troubleshooting tool to guide you to the Hardware Acceleration panel. Try turning hardware acceleration off by dragging the slider to None. Try the software again; if the graphics problems are resolved, then gradually increase Hardware Acceleration as far as you can before the software fails again.

Limitations

• Selecting a preference in the Details view while another property is being edited may result in a system failure or freeze on Linux 64-bit operating systems when using KDE (K Desktop Environment) 3.5.

• KDE is not supported on SuSE Linux Enterprise Server & Desktop 12.

• On SUSE Enterprise 12, when using any kernel greater than 3.12.36-38.1, Workbench or RSM may be unstable. This is due to a change that is known to cause instability in the mono runtime being introduced to the kernel. Although this has been fixed in the kernel source, this change has not been applied to the SUSE 12 kernels at the time of this writing (kernel version 3.12.51-52.31.1). For best results, use kernel revision 3.12.36-38.1 or lower. If this is impractical, it is possible to work around this problem by adjusting the mono nursery size by setting the MONO_GC_PARAMS environment variable, choosing a power of 2. An example would be:

  csh:
  setenv MONO_GC_PARAMS nursery-size=32m

  sh/bash:
  export MONO_GC_PARAMS=nursery-size=32m

Error Messages

***Unable to connect to Solver Manager.

Another application might be using the Solver Manager port (10002 by default). Try changing the port number by editing the Ansys.SolverManager.exe.config file located in the installation directory at \AISOL\Bin\<platform>. 
If you are getting the "Unable to connect to Solver Manager" error message or are having difficulty launching other applications/editors, it is also possible that the Windows hosts file has been corrupted. Make sure that localhost is specified in the Windows <os drive>:\Windows\system32\drivers\etc\hosts file.

***FATAL

***Parallel capability is not valid for this product

If you see this message in the Mechanical APDL output window when attempting to run Mechanical APDL with an ANSYS LS-DYNA license (commercial or academic) from ANSYS Workbench, set the number of processors for Mechanical APDL to 1 (Tools> Options> Mechanical APDL). You will then be able to run Mechanical APDL and solve an ANSYS LS-DYNA analysis.

Warning at File: myxml, line 1, col 40, Encoding (utf-16, from XMLDecl or manually set) contradicts the auto-sensed encoding, ignoring it.

The message above will sometimes be displayed in the RSM log; you can ignore it.

System.IO.IOException: Too many open files

Many Linux distributions set a default maximum for the number of files a process can have open and this can be exceeded when solving some cases. You will need to increase the maximum number of open files allowed by editing limits.conf, which on most Linux distributions is found in /etc/security/limits.conf.

For example, adding the lines

```
# ANSYS file handle limits modification
*    soft    nofile  2048
*    hard    nofile  2048
```

to limits.conf will set the maximum number of open files to 2048 (the default on most Linux distributions is 1024). Increase the maximum number of open files allowed by powers of 2, trying 2048, 4096, 8192.

Further information can be found in the manual page for limits.conf, which can be accessed via the command `man limits.conf` on any Linux machine with the `man` command installed.

You can check the current limit by using the command `ulimit -a` in a bash shell session or `limit` in a tcsh shell session. In the output, the maximum number of open files will be shown under open files or descriptors, respectively.
Working with Parameters and Design Points

In ANSYS applications you can define key simulation properties to be parameters. You can then manipulate the parameters at the project level in Workbench to investigate design alternatives. A set of parameter values representing one design alternative is called a design point. You can create a set of design points in tabular form and run them automatically to perform a what-if study.

For the most part, you work with parameters and design points in the Parameters tab and the Parameter Set tab. However, you can also use parameters and design points in ANSYS DesignXplorer for automated design exploration studies. DesignXplorer supports the insertion of the following systems from the Workbook Toolbox into the Project Schematic: Direct Optimization, Parameters Correlation, Response Surface, Response Surface Optimization, and Six Sigma Analysis.

Note

Workbench can manage and store as many as 1000 design points with good responsiveness. However, UI responsiveness is reduced with increasing numbers of design points. For larger parametric studies, specific strategies can be adopted to retain the required interactivity. You should contact technical support for guidance appropriate to your specific situation. Improvements in UI efficiency for very large parametric studies are under active development and will be available in the near future.

This chapter discusses:
- Parameters
- Working with Parameters in the Parameters Tab
- Working with Design Points

Parameters

A parameter is a numerical or other measurable factor that helps to defines a particular system. A parameter is linked to a data model property within an application. You can have input and output parameters. Parameter values can be numeric or non-numeric (string or Boolean). Non-numeric parameters are ignored for charting purposes. An input parameter can be modified at the project level and drives a change within the data model. The value of an output parameter is set by the application, based on the current results or state.

Input parameters are parameters that define the geometry or inputs to the analysis for the system under investigation. Input parameters have predefined values or ranges that may be changed. These include CAD parameters, analysis parameters, and DesignModeler parameters. CAD and DesignModeler input parameters include length and radius. Analysis input parameters include pressure, material properties, and sheet thickness.

Output parameters are parameters that result from the geometry or are the response outputs from the analysis. These include volume, mass, frequency, stress, velocities, pressures, forces, and heat flux.

Custom Parameters are input or output parameters you have created by defining an expression. For more information, see Custom Parameters (p. 124).
All parameters have a quantity, preferably with a quantity name. The quantity name is used to define preferred and available units for the quantity. If the value does not have a quantity name defined, Workbench displays the value without units.

You can add parameters to or delete them from the current project. However, this may set the existing design points and Design Exploration systems to an out-of-date state and can result in several hours of recalculation time, depending on the project. Be aware that deleting a parameter referenced in the expression of another parameter invalidates the driven data model, resulting in an error.

**Custom Parameters**

At the project level, you can create custom parameters that are not directly associated with a data model property. They can be custom input or custom output parameters that are defined by a constant value, such as 12.5 [cm] or sin(pi/2). Or, they can be derived parameters, defined by an expression of other parameters, such as P2+3*P3.

To create a derived parameter, you enter the expression statement in either the Expression field in the Properties view or in the Value field in the Outline view. Both constant values and derived parameters can be added in the Outline view. While constant values can be edited in the Outline view, once derived parameters are added, they become read-only in the Outline view. To edit them, you must use the Properties view.

If the expression defining a custom parameter results in a quantity, Workbench infers its quantity name from the value produced by the expression evaluation. Consequently, if the expression is a sum of multiple terms, every term must be using the same quantity name. For example, if the resulting quantity is 3.4 [m²], the new custom parameter must have its Quantity Name property set to Area. In some cases, more than one quantity name may be valid for the expression. In these cases, the Quantity Name property is not set, but you can select from a list for Quantity Name property in the Properties view for the parameter. Once the value quantity name is determined from the unit of the value, it can be subsequently changed only by changing the Quantity Name property for the parameter. For example, you cannot change the expression from Area to Volume without changing the Quantity Name property.
The expression defined for a custom Boolean parameter can be the Python values **True** or **False**, or it can be a Python logical expression such as \( P_1 > P_2 \) or \( P_1 == 10 \) and \( P_2 == 10 \). For a parameterized Boolean parameter, you can select **True/False** from the drop-down in the **Value** column.

The expression defined for a custom string parameter must be quoted with single or double quotes; that is, ‘string value’ or “string value”.

**Chaining Output Parameters to Input Parameters**

You can chain an output parameter to an input parameter to allow an input to be driven directly from the current value of an output, provided that the chaining does not create a circular dependency. To chain parameters, change the input parameter definition to an expression involving other parameters. To create a derived variable, first insert an expression and then edit the **Expression** field in the **Outline** view.

**Expressions, Quantities, and Units**

The ANSYS Workbench expression parser supports standard math functions and operators, as well as units for quantities. Dimensional quantities are defined in units that are a combination of one or more separate units.

---

**Note**

- Negative dimension values can invert the direction vector of SpaceClaim operations with which they are associated. This change is applied to the current and subsequent design point updates. As a result, when a Workbench input parameter is used as a driving dimension for a SpaceClaim geometry, negative dimension values can result in unexpected geometric changes.

- When dimensional geometry parameters are imported into Workbench from SpaceClaim or a bi-directional CAD interface, design point updates may fail when dependencies exist between the parameters or when the parametric update in the CAD-system or SpaceClaim cannot be realized with the parameter values specified in Workbench.

---

ANSYS Workbench expression and mathematical function evaluation is based on the Python 2.6 programming language ([www.python.org](http://www.python.org)) and inherits some behavior as described here. All Python numeric and function capabilities can be used. For example, Python provides support for hexadecimal (base 16) numbers. Appending a zero and an x to the front of a number tells Python to treat the number as a hexadecimal numeric literal.

When entering expressions, you must use the list and decimal separators defined in your locale settings. For example, if a comma is defined as a decimal separator and a semicolon defined as a list separator, use these when you type in an expression.

Do not start expression definitions with an `=` operator. Given existing parameters \( P_1, P_2, \) and \( P_3 \) to define a derived parameter \( P_4 \) such that \( P_4 = P_1 \cdot P_2 \cdot P_3 \), type the expression \( P_1 \cdot P_2 \cdot P_3 \) in the **Value** field.
Expressions that involve quantities must be dimensionally consistent. The + and − operators require that the two operands have compatible units. For example, you cannot add an *Area* parameter to a *Length* parameter. Both units must be *Length* or both units must be *Area*. The * and / operators do not have this limitation. They allow one operand to be a quantity with a unit and the other operand to be a dimensionless factor. Or, they allow both operands to be quantities with units where the result is a different quantity type. For example, *Length/Time* results in a quantity with a *Velocity* unit.

Expressions support the following intrinsic functions, which support both standard numeric values and quantities as arguments. For functions preceded by an asterisk (*), be sure to read the information that follows this list.

- `abs(arg)`
- `cosh(arg)`
- `log10(arg)`
- `sin(arg)`
- `acos(arg)`
- `exp(arg)`
- `max(arg list)`
- `sinh(arg)`
- `asin(arg)`
- `fabs(arg)`
- `min(arg list)`
- `sqrt(arg)`
- `atan(arg)`
- `floor(arg)`
- `nint(arg)`
- `tan(arg)`

---

When you click away from the field, the expression is solved.
The arguments for trigonometric functions are evaluated as follows:

- If the argument is a real number or integer, the argument is evaluated as radians.
- If the argument is a quantity (which has a value and units), the argument must be of type `Angle`. The evaluation is based on the supplied units ([deg] or [rad]).

You can include units, assuming that the unit makes sense in context of the expression. For example, \( P2 + 3 \text{[mm]} \times P3 \) is valid if mm is a valid unit expression for \( P2 \) and \( P3 \). For example, mm is a valid unit expression if \( P2 \) is torque and \( P3 \) is force, or if \( P2 \) is area and \( P3 \) is length.

The project unit system is used to evaluate the expressions. For temperatures, absolute temperature values are used in expression evaluation. All quantity values in an expression are converted to the project unit system.

The general units syntax in ANSYS Workbench is defined as \texttt{multiplier|unit|^power}, where:

- \texttt{multiplier} is a multiplying quantity or its abbreviation, such as mega (M) or pico (p)
- \texttt{unit} is the unit string or abbreviation, such as gram (g), pound (lb), foot (ft), or meter (m)
- \texttt{power} is the power to which the unit is raised

For examples of multipliers and commonly used units, see Table 3: Unit Multipliers (p. 129) and Table 4: Example Quantities and Units (p. 129).

When typing units in an expression, you must enclose the units in square braces [ . . . ]. You generally do not see the braces when selecting units from a list of commonly used units. In general, units declarations must obey the following rules:

- A units string consists of one or more units quantities, each with an optional multiplier and optional power. Each separate units quantity is separated by one or more spaces.
- Abbreviations for multipliers and unit names are typically used, but full names are also supported.
- Powers are denoted by the \texttt{^} (caret) symbol. A power of 1 is assumed if no power is given. A negative power is typically used for unit division. For example, \texttt{[kg m^-3]} corresponds to kilograms per cubic meter.
- If you enter units that are inconsistent with the physical quantity being described, then an expression error occurs.
- Units do not have to be given in terms of the fundamental units, which are mass, length, time, temperature, angle, and solid angle. For instance, Pa (Pascals) and J (Joules) are both acceptable as parts of unit strings.
• Units strings are case sensitive. For example, \textit{Kg} and \textit{KG} are invalid units strings; \textit{kg} is correct.

\textbf{Caution}

When the specified project unit system uses the relative temperature units (C or F), the evaluation of expressions involving temperature, temperature differences, or temperature variances is a special case.

For the unit conversion of a specific temperature value, \(1 \text{ degC} = 274.15 \text{ K}\). However, the unit conversion for a temperature interval (delta T) is \(1 \text{ degC} = 1 \text{ K}\). The expression evaluator takes any temperature value and treats it as a specific temperature (not a temperature interval) by converting it to the absolute unit of the project unit system (either K or R). If the intent is to perform the evaluation in terms of temperature intervals, you need to start with temperatures in absolute units.

Similarly, any expressions to be evaluated in terms of temperatures or temperature differences are converted to absolute units for calculation. In an expression with a temperature unit raised to a power other than 1 or a unit involving both temperatures and other units (for example a temperature gradient [C/m]), the temperature is assumed to be a temperature difference.

\begin{table}[h]
\begin{tabular}{|c|c|}
\hline
\textbf{Scenario} & \textbf{Example} \\
\hline
Temperature unit conversion & \(10[^{\circ}\text{C}] \times 2 = 566.3[^{\circ}\text{K}] = 293.15[^{\circ}\text{C}]\) \\
\hline
Temperatures appearing as part of a mixed unit are converted as temperature intervals & \(10[^{\circ}\text{C/m}] \times 50 \,[\text{m}] = 500[^{\circ}\text{K}]\) \\
\hline
Temperatures raised to a power other than 1 are converted as temperature intervals & \(10[^{\circ}\text{C}^3] \times 10[^{\circ}\text{C}] = 2831.5[^{\circ}\text{K}^4]\) \\
\hline
\end{tabular}
\end{table}

Once the value quantity name (such as \textit{Area}) is determined from the unit of the value, it can only be subsequently changed by changing the \textbf{Quantity Name} property for the parameter. You cannot change the expression (for example, from area to volume) without changing the \textbf{Quantity Name} property. Automatic unit conversion is only done when the quantity name is known. If you want to express a temperature difference, start with temperature in absolute units.

\textbf{Note}

"Sound Pressure Level" and "A Weighted Sound Pressure Level" are dimensionless quantities with units dB and dBA, respectively.

• Math operations between these two units or either of these and a numerical value will result in a value with no unit. For example, \(10 \text{ dB} \times 10 = 100\). (no unit)
Math operations between either of these units and a dimensional unit will result in a value with the dimensional unit. For example, 10 dB x 10 m = 100 m.

Table 3: Unit Multipliers

<table>
<thead>
<tr>
<th>Multiplier Name</th>
<th>Multiplier Value</th>
<th>Multiplier Abbreviation</th>
</tr>
</thead>
<tbody>
<tr>
<td>exa</td>
<td>$10^{18}$</td>
<td>E</td>
</tr>
<tr>
<td>peta</td>
<td>$10^{15}$</td>
<td>P</td>
</tr>
<tr>
<td>tera</td>
<td>$10^{12}$</td>
<td>T</td>
</tr>
<tr>
<td>giga</td>
<td>$10^9$</td>
<td>G</td>
</tr>
<tr>
<td>mega</td>
<td>$10^6$</td>
<td>M</td>
</tr>
<tr>
<td>kilo</td>
<td>$10^3$</td>
<td>k</td>
</tr>
<tr>
<td>hecto</td>
<td>$10^2$</td>
<td>h</td>
</tr>
<tr>
<td>deca</td>
<td>$10^1$</td>
<td>da</td>
</tr>
<tr>
<td>deci</td>
<td>$10^{-1}$</td>
<td>d</td>
</tr>
<tr>
<td>centi</td>
<td>$10^{-2}$</td>
<td>c</td>
</tr>
<tr>
<td>milli</td>
<td>$10^{-3}$</td>
<td>m</td>
</tr>
<tr>
<td>micro</td>
<td>$10^{-6}$</td>
<td>u</td>
</tr>
<tr>
<td>nano</td>
<td>$10^{-9}$</td>
<td>n</td>
</tr>
<tr>
<td>pico</td>
<td>$10^{-12}$</td>
<td>p</td>
</tr>
<tr>
<td>femto</td>
<td>$10^{-15}$</td>
<td>f</td>
</tr>
<tr>
<td>atto</td>
<td>$10^{-18}$</td>
<td>a</td>
</tr>
</tbody>
</table>

Table 4: Example Quantities and Units

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Dimensionality</th>
<th>Example Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acceleration</td>
<td>Length Time^-2</td>
<td>m s^-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ft s^-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>in s^-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>um ms^-2</td>
</tr>
<tr>
<td>Current</td>
<td>Current</td>
<td>A</td>
</tr>
<tr>
<td></td>
<td></td>
<td>mA</td>
</tr>
<tr>
<td></td>
<td></td>
<td>pA</td>
</tr>
<tr>
<td>Density</td>
<td>Mass Length^-3</td>
<td>kg m^-3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>g cm^-3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>lb ft^-3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>slug in^-3</td>
</tr>
<tr>
<td></td>
<td></td>
<td>slinch in^-3</td>
</tr>
<tr>
<td>Electric Charge</td>
<td>Current Time</td>
<td>A s</td>
</tr>
<tr>
<td></td>
<td></td>
<td>coulomb</td>
</tr>
<tr>
<td></td>
<td></td>
<td>pA s</td>
</tr>
<tr>
<td>Energy</td>
<td>Mass Length^2 Time^-2</td>
<td>J</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BTU</td>
</tr>
<tr>
<td>Quantity</td>
<td>Dimensionality</td>
<td>Example Units</td>
</tr>
<tr>
<td>----------------</td>
<td>-------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>erg</td>
</tr>
<tr>
<td></td>
<td></td>
<td>lbf ft</td>
</tr>
<tr>
<td></td>
<td></td>
<td>slug in^2 s^-2</td>
</tr>
<tr>
<td>Force</td>
<td>Mass Length Time^-2</td>
<td>dyne</td>
</tr>
<tr>
<td></td>
<td></td>
<td>N</td>
</tr>
<tr>
<td></td>
<td></td>
<td>pdl</td>
</tr>
<tr>
<td></td>
<td></td>
<td>lbf</td>
</tr>
<tr>
<td></td>
<td></td>
<td>slug in s^-2</td>
</tr>
<tr>
<td>Length</td>
<td>Length</td>
<td>m</td>
</tr>
<tr>
<td></td>
<td></td>
<td>cm</td>
</tr>
<tr>
<td></td>
<td></td>
<td>foot</td>
</tr>
<tr>
<td></td>
<td></td>
<td>in</td>
</tr>
<tr>
<td></td>
<td></td>
<td>mm</td>
</tr>
<tr>
<td></td>
<td></td>
<td>micron</td>
</tr>
<tr>
<td></td>
<td></td>
<td>ft</td>
</tr>
<tr>
<td></td>
<td></td>
<td>um</td>
</tr>
<tr>
<td></td>
<td></td>
<td>um</td>
</tr>
<tr>
<td>Pressure</td>
<td>Mass Length^2 Time^-2</td>
<td>Pa</td>
</tr>
<tr>
<td></td>
<td></td>
<td>MPa</td>
</tr>
<tr>
<td></td>
<td></td>
<td>N m^-2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>bar</td>
</tr>
<tr>
<td></td>
<td></td>
<td>torr</td>
</tr>
<tr>
<td></td>
<td></td>
<td>mm Hg</td>
</tr>
<tr>
<td></td>
<td></td>
<td>psi</td>
</tr>
<tr>
<td></td>
<td></td>
<td>psf</td>
</tr>
<tr>
<td></td>
<td></td>
<td>atm</td>
</tr>
<tr>
<td></td>
<td></td>
<td>dyne cm^-2</td>
</tr>
<tr>
<td>Power</td>
<td>Mass Length^2 Time^-3</td>
<td>W</td>
</tr>
<tr>
<td></td>
<td></td>
<td>BTU s^-1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>HP</td>
</tr>
<tr>
<td></td>
<td></td>
<td>erg s^-1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>lbf ft s^-1</td>
</tr>
<tr>
<td>Temperature</td>
<td>Temperature</td>
<td>K</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C</td>
</tr>
<tr>
<td></td>
<td></td>
<td>R</td>
</tr>
<tr>
<td></td>
<td></td>
<td>F</td>
</tr>
<tr>
<td>Temperature Difference</td>
<td>Temperature</td>
<td>K</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C</td>
</tr>
<tr>
<td></td>
<td></td>
<td>R</td>
</tr>
<tr>
<td></td>
<td></td>
<td>F</td>
</tr>
<tr>
<td>Temperature Variance</td>
<td>Temperature^2</td>
<td>K^2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C^2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>R^2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>F^2</td>
</tr>
</tbody>
</table>
Working with Parameters in the Parameters Tab

The process of working with parameters begins when you define a parameter in an application, such as your CAD system, Mechanical, or Fluent. For information on defining parameters, refer to the documentation for each application in which you are working.

ANSYS Workbench recognizes parameters defined in the individual applications and exposes them in the Parameter Set bar, which can be shared by multiple systems. The Parameter Set bar is the visual representation of the project’s full parameter set. Double-clicking it opens the Parameter Set tab, which displays all parameters defined for all systems in your project. Each parameter is identified by its system of origin.

Additionally, each system with parameters has a Parameters cell, which you can double-click to open the corresponding Parameters tab. The Parameters tab for a given system displays all of the parameters defined for this system.

Each of these tabs has an Outline view and a Properties view for viewing and working with your parameters.
Outline View

The Outline view lists the parameters, grouping them into Input Parameters and Output Parameters. Input parameters affect the definition of the data model. Output parameters are analysis results that are quantities of interest for the design.

**Note**

In a Parameters tab, the title in the header for the Outline view displays the ID of the corresponding Parameters cell to indicate the source of the parameters. In the Parameter Set tab, the title is Outline of All Parameters.

For each parameter, the Outline view shows an ID, name, current value, and unit system. You can edit most of these properties. The exceptions are the parameter IDs and the units for parameters with quantity values. When you select a parameter, its properties are shown in the Properties view.

You can also add new parameters in the Outline view. For parameters created in this way, you can assign a value but not an expression. To add an expression (p. 125), you must select the newly created parameter and add the expression and quantity name in the Properties view.

**Note**

Opening a file from a previous release can result in an unlinked parameter. An unlinked parameter is one that was associated with a property that existed in a previous release but no longer exists in the current release. Unlinked parameters are labeled as such in the Value column in the Outline view. To delete an unlinked parameter, right-click and select Delete Selected Unlinked Parameters.
Properties View

The Properties view displays information for the object selected in the Outline view. The objects available for selection include parameters, expressions, and charts.

From the Properties view, you can:

- Enter or change the value of input parameters
- Specify properties for a parameter created in the Outline view
- Delete existing user-defined parameters
- Change parameter names
- Edit parameter descriptions
- Enter or edit parameter expressions
- Link an input parameter to an output parameter by editing its expression

When working with expressions, once the value quantity name (such as Area) is determined from the unit of the value, you can only modify it by changing the Quantity Name property. For example, you cannot change the value quantity name for an expression from Area to Volume without first changing the Quantity Name property.
After making any changes to parameter definitions, you perform an **Update** operation to run the needed updates and return the values of the output parameters. Note that an **Update** operation can be lengthy, depending on the analysis details.

For more information, see Parameters (p. 123).

**Working with Design Points**

Each design point is a single set of parameter values representing one design alternative. Basically, you can think of a design point as a snapshot of your design given a set of input parameter values, where output parameter values are calculated by an update of the project. Design points allow you to perform what-if studies and can be created in the Parameter Set bar or generated with ANSYS DesignXplorer.

You manage design points in the **Table** view for the Parameter Set tab or a Parameter tab. The **Table** view displays the design points.

<table>
<thead>
<tr>
<th>Table of Design Points</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>A</strong></td>
</tr>
<tr>
<td>-------</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

From the **Table** view, you can see existing design points and perform the following operations:

- Add new design points
- Duplicate existing design points
- Enter or change the input parameter values for design points
- Delete existing design points (except for the design point designated as **Current**)
- Specify the design point update order
- Update design points, either locally or via ANSYS Remote Solve Manager
- Retain design point data within the project for design points other than the current, which by default has retained data
- Preview the image from the project report, assuming that the project has design points, is solved, and a saved project report (p. 115) exists
- Set a design point with retained data as the current design point
• Export selected design points to separate projects

• Export a CSV file of the design points table

If you add a new design point, change its input parameter values, and update the project, you calculate output parameter values for this new design point. You can then perform what-if studies to compare this design to other designs.

**Adding Design Points**

To add new design points, either:

• Duplicate an existing design point. Right-click a design point in the table and select **Duplicate**. When you duplicate a design point, all parameters, parameter values, design point states, and design point export (p. 139) settings are copied. You can then modify any of these values as required.

• Create a new design point. Enter a parametric value in a cell in the bottom table row, as shown in the following animation.

The following Show-Me Animation is presented as an animated GIF in the online help. If you are reading the PDF version of the help and want to see the animated GIF, access this section in the online help. The interface shown may differ slightly from that in your installed product.

![Design Point Animation](image)

The design point that you interact with via the **Project Schematic** is always the current design point. Initially, the current design point is DP 0. However, you can set any design point that has retained results to be the current design point. You cannot rename or delete the current design point.

Non-parametric changes made to a project with up-to-date design points may cause all existing design points to go out of date, if the change is related to the parametric study being performed. Any change not relevant to the parametric study, such as adding a standalone system or making a change downstream of the study, should not cause design points to go out-of-date. For changes that invalidate the design points table, you must update the project, which can require significant time and computing resources. You should always save your project after updating all design points and before further modifying the project.
In most cases, a design point update applies only to cells affected by parameter changes and cells downstream. Cells without associated parameters or cells whose associated parameters did not change are not updated.

**Note**

The exception is External Connection and CFD-Post systems. For these, you can specify that some cells must always be updated with a design point update, even when parameter values are not affected. To do so, in the cell's Properties view, select *Always Include in Design Point Update*.

To update all project cells regardless of whether the parameters associated with the cells have changed, you must select **Update Project**. Cell states will reflect this behavior.

**Related Topics:**
- Updating Design Points
- Retaining Design Point Data and Exporting Design Points
- Performing and Retaining Partial (Geometry-Only) Updates
- Updating Design Points via ANSYS Remote Solve Manager or an EKM Portal
- Reserving Licenses for a Design Point Update
- Design Point Update Data
- Design Point States

**Updating Design Points**

Output parameter values for a design point are calculated when you update the design point. You can update only the current design point, a set of selected design points, or all design points. Updating design points updates solution data only where output parameters have been defined.

You have several options for updating design points. The settings specified by the *Design Point Initiation* property apply. For more information, see *Specifying the Initiation Conditions for a Design Point Update* (p. 138).

If the update of a design point is interrupted, the partially updated icon (と思って) may appear beside the values of the output parameters for the interrupted component. The next time that this design point is selected for update, a dialog box opens. To continue, you must click one of the following buttons:

- **Use Partially Updated**: Accepts output parameters that are only partially updated as up-to-date, using the existing results to update design points.

- **Update All**: Restarts the interrupted update, recalculating results for all output parameters that are partially updated and then updating all design points. The dialog box notes that this can be a lengthy process.

To abandon the update, you would click the **Cancel** button.

**Update Only the Current Design Point**

To update only the current design point, click **Update Project** on the toolbar or select it from the context menu for the **Project Schematic**.
**Update Selected Design Points**

To update a set of selected design points:

1. In the design points table for the Parameters tab, hold the Ctrl key and left-click each design point to update.

2. Release the Ctrl key and then right-click one of the selected design points.

3. Select **Update Selected Design Points** from the context menu.

If you are updating multiple design points and the update for one of the design points fails, the **Update Failed, Update Required** ✖ icon shows for the failed design point, but the next design point update begins immediately. In this case, the **Messages** view opens, showing the error message for the one or more design points that failed. When the update process is complete, a failure summary dialog box opens, where you should review the error messages for details on which design points failed to update.

**Update All Design Points**

To update all design points, click **Update All Design Points** on the toolbar or select this option from the context menu for the **Project Schematic**.

**Design Point Update Settings**

When you update multiple design points, you can choose the order in which design points update. You can also choose the initial conditions with which they update.

- You may want to specify the order for design point updates to improve efficiency. For instance, if several design points use the same geometry parameter values, it is more efficient to process them together so as to update the geometry only once.

- By default, when each design point is updated, the design point is initialized with the data of the design point designated as current. Retained design points with valid retained data are exceptions because they do not require initialization data. In some cases, it may be more efficient to update each design point starting from the data of the previously updated design point, rather than restarting from current design point each time.

**Changing the Design Point Update Order**

By default, design points are updated in the order in which they appear in the design points table. The **Update Order** column shows the order number for each design point. To view the column, right-click...
in the table and select **Show Update Order**. To change the order in which design points are updated, use any of the following methods:

- Right-click in the table and select **Optimize Update Order**. An optimal update order is determined by an analysis of parameter dependencies in the project and a scan of parameter values across all design points. The **Update Order** value for each design point is updated automatically.

---

**Note**

The primary goal of **Optimize Update Order** is to reduce the number of geometry and mesh system updates. In general, the optimized order is driven by the order of the update tasks, which means that the components are updated depending on their order in the system, their data dependencies, their parameter dependencies, and the state of the parameters. This works best in a horizontal schematic with geometry as the first separate system. In a single vertically-integrated system project, the parameters defined in the upper components are considered the most important. In some cases, because of the order of parameter creation or the presence of engineering data parameters, you may find that the first columns are not geometry parameters. In this case, it is recommended that you use the **Optimize Update Order** option to sort by geometry parameters.

---

- Edit the values in the **Update Order** column.

- Sort the table by one or several columns and then right-click in the table and select **Set Update Order by Row**. The **Update Order** value for each design point is regenerated to match the sorting of the table.

### Specifying the Initiation Conditions for a Design Point Update

When a design point is updated, the solver is initialized with data:

- Design points with valid retained data use that as their initialization data

- Other design points either:
  - Initialize with the data of the design point designated as current (**From Current**)
  - Initialize starting from the data of the previously updated design point (**From Previous Updated**).

To set how design points are to be updated, right-click the **Parameter Set** bar, select **Properties**, and set the **Design Point Initiation** property.

You might want to use the **From Previous Updated** option when:

- Sequential design points share the same geometry. For example, if DP2 has the same geometry as DP1, but both of these differ from DP0, changing the default behavior would save the computational cost of updating both the geometry and the mesh for DP2.

- You have modified the design point update order via the **Update Order** column, either by editing the values manually or by generating them with the **Set Update Order by Row** option.

- The design point update order has been optimized, either by the **Optimize Update Order** option or by a DesignXplorer optimization.
The following Show-Me Animation is presented as an animated GIF in the online help. If you are reading the PDF version of the help and want to see the animated GIF, access this section in the online help. The interface shown may differ slightly from that in your installed product.

<table>
<thead>
<tr>
<th>Table of Design Points</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
</tr>
<tr>
<td>1</td>
</tr>
<tr>
<td>2</td>
</tr>
<tr>
<td>3</td>
</tr>
<tr>
<td>5</td>
</tr>
<tr>
<td>6</td>
</tr>
<tr>
<td>7</td>
</tr>
<tr>
<td>8</td>
</tr>
<tr>
<td>9</td>
</tr>
<tr>
<td>10</td>
</tr>
<tr>
<td>11</td>
</tr>
<tr>
<td>12</td>
</tr>
</tbody>
</table>

Note

- For External Connection and CFD-Post systems, it is possible to specify that a cell is always to be updated with a design point update operation, even when the update will not affect parameter values. To do so, in the cell’s properties, select the **Always Include in Design Point Update** check box.

- In AIM, Results tasks that are not associated with output parameters are not updated and will have a state of Update Required when the design point update is complete. To ensure that all Results tasks are updated with a design point update, you can set the **Retained Design Point** property for the Parameter Set bar to **Update Full Project**.

Retaining Design Point Data and Exporting Design Points

By default, ANSYS Workbench does not retain design points after they are solved. It saves the calculated data only for the current design point (p. 134). For other design points, only the parameter values are saved. If you want to work with a design point other than current design point, you can:

- Retain design point data (p. 140) and set a different design point as current (p. 141) within the project
- Export design points to new projects (p. 141)

Additionally, you can export design point parameter values to a CSV file (p. 142), which you can then use in other programs for further processing.
Retaining Design Point Data

In some cases, you might want to switch back and forth between multiple designs within the same project. ANSYS Workbench enables you to select one or more design points and retain their calculated data within the project. Data is always retained for the current design point (p. 134).

To retain design point data:

1. In the design points table, select the Retained check box for each of the desired design points.
2. Generate retained design point data by updating the design points.
3. Once design point data has been retained:
   - You can verify that the data has been retained and see the availability and state of the retained data. For more information, see Reviewing the Retained Data Column (p. 140).
   - You can view multiple designs by setting different design points as current. For more information, see Setting a Different Design Point as Current (p. 141).

Reviewing the Retained Data Column

You can verify that data has been retained by viewing the icon in the Retained Data column for each design point. This icon indicates the availability, validity, and state of the retained data for the design point.

Different kinds of changes to the project have different impacts on retained data. Changes to the parameter values for the design point cause the retained data to become out-of-date but still valid. Non-parametric changes cause the retained data for non-active design points to become invalid.

---

Note

During a local design point update, only the design point being updated is active. When no update is in progress, only the current design point is active.

The state of the design point and the validity of its retained data do not necessarily match. It is possible for a design point to be up-to-date while its retained data is invalid or vice versa.

When used in the Retained Data column, icons have slightly different meanings than they do elsewhere in Workbench. The following table describes the meaning of each icon within the context of retained design point data.

<table>
<thead>
<tr>
<th>Icon</th>
<th>State/Validity</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✅</td>
<td>Valid and up-to-date</td>
<td>The design point has valid retained data that is up-to-date. The retained data is available to be exported.</td>
</tr>
<tr>
<td>🟢</td>
<td>Valid but out-of-date</td>
<td>The design point has valid retained data, but the retained data is out-of-date because of a change to the design point's parameter values. The retained data is available to be exported.</td>
</tr>
<tr>
<td>⚡</td>
<td>Invalid or non-existing</td>
<td>The design point either does not have retained data or previously retained data has been invalidated by a non-parametric change. The retained data is not available to be exported.</td>
</tr>
</tbody>
</table>
Each state is illustrated in the image below, as follows:

- **DP0 (Current)** has retained data that is valid and up-to-date. The current design point always has valid retained data and the **Retain** check box is disabled.
- **DP1** has valid retained data that is current and up-to-date.
- **DP2** either does not have retained data or has retained data that is invalid.
- **DP3** has retained data that is valid but out-of-date.

### Setting a Different Design Point as Current

Once multiple design points have retained data, you can switch back and forth between these multiple designs within the project. To view the design associated with a given design point, you set it as the current design point. Only design points with retained data can be set to current, and only one design point can be set to current at a time.

**To set a design point as the current design point:**

1. In the design points table, right-click a design point that has retained data (p. 140).
2. From the context menu, select **Set as Current**.

The design point becomes the current design point for the project. In the **Name** column, (Current) displays after the name of the current design point. Setting a design point as current does not automatically update it.

**Note**

In a project that includes a Microsoft Office Excel system and uses retained design points, switching to a different up-to-date design point via the **Set as Current** menu option automatically updates the Excel system, which can be time-consuming if the spreadsheet contains macros or extensive calculations.

### Exporting Design Points to New Projects

To work with the calculated data for a design point other than the current design point (p. 134), you can export the design point to a separate project. A new project is created for each design point that is exported.

When you export a design point, if the design point has already been exported, the existing exported files are overwritten.
To export design points:

1. In the design points table, select the desired design points.
2. Right-click the points.
3. Select **Export Selected Design Points**.

The projects resulting from the export are fully independent projects named `projectname_dpn.wbpj`. They are located as siblings in the same directory as the main project. The content of the new project depends on the state of the design point's retained data at the time of the export:

- If valid retained data is available for an exported design point, the retained data is used to create the new project. This retained data can be either up-to-date or out-of-date.

- If no valid retained data is available for an exported design point, the project exported is an out-of-date project based on the current design point with the parameter values for this design point applied. No valid retained data exists if the design point is either not selected to retain data or is selected but retained data is not yet generated or has become invalid. You are asked to confirm before the export of such a design point is performed. When you open the exported project, it is out-of-date and requires an update to solve for the exported design point.

After an export, you must save the parent project before you can export design points again.

If a design point fails to export, the files for this design point remain in the `project_files\dpn` directory until you delete them manually or attempt to update the design point again.

---

**Note**

Be aware that DesignXplorer data is not a part of design points and is not exported. DesignXplorer is a consumer of design points but does not define design points. Consequently, it is not involved when a design point is updated, or by extension, exported.

---

### Exporting Design Point Parameter Values to a CSV File

From the design points table, you can export the design point parameter values to a CSV (Comma-Separated Values) file, which you can then use with other software tools for further processing. This file is created in an "extended" file format. In addition to supporting standard CSV formatting, it supports several Workbench-specific formatting conventions.

To export design point parameter values to a CSV file:

1. In the design points table, right-click a cell.
2. Select **Export Table Data as CSV**.

A file similar to the following is generated:

```plaintext
# 10/1/2012 10:38:01 AM
# The parameters defined in the project are:
# P1 - WB_B [mm], P2 - WB_D [mm], P3 - WB_L [mm], P4 - WB_P [N], P5 - WB_E [MPa],
# P10 - WB_SIG [MPa], P8 - WB_DIS [mm], P9 - WB_BUCK [N]
#
# The following header line defines the name of the columns by reference to the parameters.
Name, P1, P2, P3, P4, P5, P10, P8, P9
DP 0, 2, 5, 100, 1000, 20000, 12000, 80, 1028.91145833333
```
The values are always exported in units as defined in ANSYS Workbench.

**Explanation of the Workbench CSV File Format**

- Values are separated by commas.
- The optional header line indicates the name of each column.
- Each line is an independent record made of fields separated by commas.
- The format is not dependent on the locale, which means that the real number 12 and 345 one-thousandths is always written as 12.345, regardless of the regional settings of the computer.
- If a line starts with a "#" character, it is considered a comment line rather than a header or data line and is ignored.
- The header line is mandatory. It is the line where each parameter is identified by its ID (P1, P2, ..., Pn) to describe each column. The IDs of the parameters in header line match the IDs of the parameters in the project.
- The first column is used to indicate a name for each row.
- A file can contain several blocks of data, with the beginning of each block being determined by a new header line.

**Performing and Retaining Partial (Geometry-Only) Updates**

If you want to check your geometry for parametric failures, Workbench enables you to perform a geometry-only design point update. When the partial results have been calculated, you can save them to the project to be used in subsequent design point updates. You might do this if you want to generate the geometry updates on one machine and then move the project to a machine that cannot update geometry.

To perform a geometry-only update:

1. Set **Update Option** to **Run in Foreground**.
2. Set **Partial Update** to **Geometry**.
3. To retain the results from the partial update, set **Retain Partial Update** to **Geometry**.

**Note**

If you set **Retain Partial Update** to **Geometry**, the geometry results are saved whether you perform a partial update or a full update.

Partial update data can exist from either a partial or full design point update. To remove existing partial update data, set **Retain Partial Update** to **None**. The partial retained data is deleted from the project the next time that design points are updated.
Updating Design Points via ANSYS Remote Solve Manager or an EKM Portal

If an administrator has defined cluster configurations in ANSYS Remote Solve Manager (RSM) such that RSM queues are available in Workbench, you can submit design point updates to RSM. Cluster configurations enable RSM to integrate with established compute clusters, providing you with access to powerful compute resources when needed. For information on setting up RSM, see RSM Configuration in the RSM User’s Guide.

Similarly, if you have access to an EKM Portal, and have created and opened a connection to it, you can submit the design point update to the EKM Portal for execution. EKM then dispatches the task to RSM, which sends it to the cluster submit host for scheduling. For information on submitting design point updates to RSM via an EKM Portal, refer to Integrating EKM with Remote Solve Manager (RSM) in the EKM Administration Guide.

**Important**

- If you are sending design point update jobs to a remote computing cluster, note that the license preferences set for your local machine (the RSM Client) may not be the same as the license preferences set for the remote cluster. In this case, the cluster license preferences will be used for all jobs. For more information, see Establishing User Licensing Preferences.

- When design points are configured to be updated via RSM or an EKM Portal, the Solution cell cannot also be updated via RSM. In order to update design points via RSM, change the Solution cell update settings by setting the Update Option property to Run in Foreground. For further information about tutorials and documentation on the ANSYS Customer Portal, go to http://support.ansys.com/docinfo. Note that the update of both the Solution cell and design points via an EKM Portal is not supported. If both are submitted to the EKM Portal, the Solution cell update will automatically switch to Run in Foreground when the design points are being updated through the EKM Portal.

To update design points via RSM or an EKM Portal:

1. Right-click the Parameter Set bar and select Properties to view the Design Point Update Process settings. If the Properties view is already visible, click the Parameter Set bar to refresh the Properties view with the design point settings.

2. In the Properties view, specify the Design Point Update Process settings. These settings are initially populated based on your selections in Tools → Options → Solution Process. For more information, see Solution Process (p. 21). You can choose different settings here if the default settings are not appropriate. For design points to be updated via RSM, set Update Option to Submit to Remote Solve Manager and then specify an available RSM Queue. For design points to be submitted via an EKM Portal, set Update Option to Submit to Portal and then select a Portal Connection and Queue. If no connections are listed, you may need to create a connection (p. 157) or open an existing connection (p. 160).

3. For the Job Submission property, select one of the following options:
   - **One Job for All Design Points**: All design points are submitted as a single job to RSM.
   - **One Job for Each Design Point**: Each design point is submitted as a separate job to RSM (simultaneous parallel updates).
• **Specify Number of Jobs:** Design points are divided into groups and submitted in multiple jobs, up to the specified maximum number of jobs. You can look at the RSM List view to determine which design points are assigned to each job. If you select this option, the **Number of Jobs** property is enabled, allowing you to specify the maximum number of jobs that can be created.

**Note**

The maximum number of jobs that can actually be run on the cluster is determined by the cluster’s resource management system.

4. For the **License Checkout** property, select one of the following options:

- **On-demand:** Licenses are checked out on demand. If licenses are unavailable, the update will not proceed.

- **Reserved:** Enables you to reserve licenses to ensure that you have sufficient licenses available for the duration of your design point study. When you select this option, a **Select Licenses** option becomes available, enabling you to select the licenses to reserve.

For more information, see Reserving Licenses for a Design Point Update (p. 151).

5. For the **Component Execution Mode** property, select one of the following options:

- **Serial:** All components participating in the update are to run in serial mode.

- **Parallel:** All components participating in the update that support this setting are to run in parallel mode.

If you select **Parallel:**

- The **Number of Processes** property allows you to specify the number of processes to be used in the solver for each job in the update. For jobs being sent to a cluster, the value entered for this property also determines how many cores are allocated on the cluster for each job. Note that resource allocation is determined by the cluster’s resource management system.

- RSM considers each design point update job as a single job, although the component will use more resources.

Submitting a design point update to RSM is supported by the **Solution** (or **Analysis**) component update for the Mechanical APDL, Mechanical, Fluent, CFX and Polyflow solvers. These settings override any parallel or serial settings defined at the component level. When updating a component, system, or project, the **Parameter Set** properties for a design point update are ignored. The product specific settings that are overridden for a design point update via RSM are listed below.

- For CFX:

  The following properties for the CFX-Solver Manager or CFX-Pre **Solution** cell are ignored for a design point update via RSM:

  - All settings under the **Parallel Environment** tab.

    **Run mode**
    All host information and partition weighting

- For Fluent:
The following properties for the Fluent Solution cell are ignored for a design point update via RSM:

- Use Job Scheduler
- Run Parallel Version
  
  (Visible under Parallel Run Settings when RPV=True)
  Number of Processes
  Use Shared Memory
  Machine Specification (visible when USM=false)
  Machine List (visible when USM=false)

Notable exceptions in the parallel run settings group are the following properties whose effects remain enabled if set in all situations.

  Interconnect
  MPI Type

• For Mechanical:

  The following properties in the Advanced section of a Mechanical Solve Process Setting are ignored for a design point update via RSM:

  - Distributed Solution (if possible)
  - Max number of utilized cores

• For Mechanical APDL:

  The following properties for the Mechanical APDL Analysis cell are ignored for a design point update via RSM:

  - Processors
  - Distributed
  - MPI Type
  - Machine list

• For Polyflow:

  The following properties in the Polyflow Options accessed via Solution cell preferences are ignored for a design point update via RSM:

  - Number of Processes

---

**Note**

The Component Execution Mode and Number of Processes settings are applied to all components participating in the update but can be overridden by component-level settings. This is described in an upcoming step.
6. For the **Retained Design Point** property, select one of the following options:

   - **Update parameters** (default): Only parameters are updated for retained design points. If a component is not needed to get the value of an output parameter, it is not updated.

   - **Update full project**: Full project is updated for retained design points. Use this setting if you want to generate reports, or other content, from components that do not produce output parameters.

7. Design point updates to RSM include component override settings for individual systems using the **Solution** or (**Analysis**) component for Mechanical APDL, Mechanical, Fluent, CFX and Polyflow systems. These settings override the **Component Execution Mode** and **Number of Processes** defined for the **Parameter Set** bar.

Before updating a component:

   a. Right-click the **Solution** or (**Analysis**) component to expose the properties information.

   b. Under **Restriction for Design Point Update Via RSM**:

      - If solving in serial, enable **Serial Execution Only**.

      - If solving in parallel, enable **Specify Number of Processes Restriction** and enter the number of processes in the text field across from **Number of Processes Used Not to Exceed**.

        **Note**

        These settings override the serial or parallel settings for only this specific system.

        - For Mechanical APDL and Mechanical, if solving in parallel, enable **Specify Number of Processes Restriction**, enter the number of processes in the text field across from **Number of Processes Used Not to Exceed** and enable **Shared Memory Parallel**.

          **Note**

          **Shared Memory Parallel** allows jobs to strictly run in parallel on the master node. It does not run jobs in distributed parallel.

8. To update your geometry locally prior to submitting design point updates to RSM, set **Pre-RSM Foreground Update** to **Geometry**.

   If you are using reserved licensing feature to send design point updates to RSM, you can specify whether or not your pre-RSM geometry update is to use reserved licenses. For more information, see **Performing a Pre-RSM Geometry Update** (p. 148).

9. Save the project. If you are working in an archived project, you must save the project to a permanent location.

10. Initiate the update of the desired design points. For more information, see **Updating Design Points** (p. 136). The project is archived, submitted to a cluster via RSM. The remote data is retrieved periodically as the design point updates complete. Should a design point update fail, an error is reported to the **Messages** view.
When updating design points via RSM, each output parameter that was out-of-date when the design point update was initiated is shown in a pending state ( ) in the design points table. ANSYS Workbench periodically queries RSM and refreshes any design point updates that have completed since the previous query. Design point updates that have not yet completed continue to be shown in a pending state.

Design points that have been updated via RSM need to be reintegrated into the project as the updates complete. To ensure the integrity of the data, ANSYS Workbench restricts or disables several GUI operations during pending RSM design point updates:

- Open editors may automatically close.
- Drag and drop from the **Toolbox** is disabled.
- Most context menu, toolbar, and menu selections are disabled.
- Accessing the **Properties** view via a context menu is allowed, but properties cannot be modified.
- Input parameters cannot be modified.
- All **File** menu options except **Exit** and **Save** are disabled.

**Note**

If you have updated design points remotely via a queuing system for RSM, information on the reserved licenses is available to the job scripts in the ANSYS_RESERVED_LICENSE_INFO environment variable.

**Related Topics:**
- Performing a Pre-RSM Geometry Update
- Aborting or Interrupting an RSM Design Point Update
- Exiting a Project during an RSM Design Point Update
- Suspending and Resuming Collection of RSM Design Point Results
- Product-Specific Limitations

**Performing a Pre-RSM Geometry Update**

You can update your geometry locally before submitting design point updates to RSM. You would want to do this when:

- Design points are to be updated simultaneously via RSM. The geometry update infrastructure does not support simultaneous design point updates in the same source geometry.
- The compute cluster cannot perform geometry updates.

To perform the local geometry update before design point submission:

1. Configure whether to use reserved licensing.

   If you are using reserved licensing to send design point updates to RSM, you can specify whether or not a pre-RSM geometry update is to use a reserved license. By default, a DesignModeler license is checked out of the reserved license pool for the pre-RSM geometry update. To specify that a reserved license is not needed, in the **Parameter Set** properties, clear the check box for reserving licenses for the pre-RSM update. A DesignModeler license is checked out in the standard manner,
rather than from the reserved license pool. The license is released once the geometry update is completed. For more information, see Reserving Licenses for a Design Point Update (p. 151).

2. Set **Pre-RSM Foreground Update** to **Geometry**.

---

**Note**

If the project includes a Geometry component and you have set **Default Job Submission** to either **One Job per Design Point** or **Specify Number of Jobs** (with **Number of Jobs** set to a value greater than 1), ANSYS Workbench ignores the setting for **Pre-RSM Foreground Update**. The geometry is updated locally in the foreground before your design points jobs are sent to RSM.

---

**Aborting or Interrupting an RSM Design Point Update**

You can abort or interrupt an RSM update that is in progress. In the **Progress** view, while the **Status** column displays the message *Waiting for background task*, click the stop button (●) in the **Progress** column. You are prompted to either abort or interrupt the update. You can also choose cancel to close the dialog box.

- To stop the RSM job and return no data to the project, click **Abort**.
- To interrupt the RSM job and return any available data to the project, click **Interrupt**.

---

**Exiting a Project during an RSM Design Point Update**

You can exit a project while an RSM design point update is in progress. During the update, while the one or more RSM jobs are running in the background, the **Progress** view displays a project **Status** of *Waiting for background task*.

---

**Note**

- If you have submitted the **Update All Design Points** operation via RSM and are unable to exit the project because Workbench remains busy, see Suspending and Resuming Collection of RSM Design Point Results (p. 150).

- You cannot exit Workbench while job files are being uploaded. However, you can abort the job during the upload by clicking the stop button (●) in the **Progress** bar.

---

For RSM jobs to continue to run after you exit the project, the project must be saved at least once after the design point update job was initiated.

If you attempt to exit a project while a design point update job is still running, the following scenarios cause a dialog box to open, allowing you to specify whether you want to save the project before exiting:

- You have never saved the project at any time after the same design point update job was initiated.
- You have saved the project at least once after the same design point update was initiated, but design point results have been retrieved since your last save.
In either of these cases, if you do not save the project before exiting:

- All design point results retrieved since the last Save operation are lost. However, if the project has been saved at least once since the update job was initiated, the results can be retrieved again when the project is reopened.

- If the project has never been saved after the update job was initiated, all RSM jobs are aborted and show a Status of Cancelled. The cancelled icon (☐) displays in the RSM List view. The asterisk on the icon indicates that the job has also been released. When you reopen the project, it is in the state of your last manual save.

If you do save the project before exiting:

- Retrieved design point results are saved to the project.

- RSM jobs that are queued and running continue to run after you exit.

- Jobs for which the results have been saved show a Status of Finished. The finished icon (✔) displays in the RSM List view. The asterisk on the icon indicates that the job has also been released.

- Jobs for which results have not yet been saved are not released upon exit. When you reopen the project, you can resume update of the pending jobs to reconnect and download the results.

**Suspending and Resuming Collection of RSM Design Point Results**

When the Update All Design Points operation has been submitted via RSM, Workbench may stay too busy collecting intermediate and final results to allow you to exit the session. To pause the data collection so you can exit the Workbench session, select Tools → Suspend Collection of RSM Results.

When you exit the project, results are saved according to the criteria described in Exiting a Project during an RSM Design Point Update (p. 149).

**Note**

The Suspend Collection of RSM Results option is also available during a project update via RSM. However, because only the current design point is being updated and RSM collects results only at the end of the update process, this option has no impact on the project update.

To resume the collection of design point data, select Tools → Resume Collecting RSM Results. The project reopens in the same state it was in when it closed. Once all the design points have been updated, all of the suspended results are collected and then updated to the project at the same time.

It is not necessary to use the Resume Collecting RSM Results option. The collection and update happen automatically when all jobs have been completed.

**Product-Specific Limitations**

Some products have additional limitations when submitting design points updates via RSM:

**Ansoft**

Projects that include Ansoft systems return updated parameter values but do not return the detailed solution for the current design point.
Mechanical
Design point updates via RSM can fail for a class of problems (typically involving a Structural system linked to a Modal or other type of Mechanical system) that meet the following criteria:

- A non-parameterized upstream Mechanical system provides solution data to a parameterized downstream Mechanical system and both systems share the same geometry/model.
- Updates are performed via a pre-RSM local update.

The parameters for some of the design points are not computed and are marked as errors in the design points table.

Workarounds:
- Select the **Enable Legacy Solve** check box (Tools → Options → Mechanical).
- In the **Parameter Set** properties, set **Pre-RSM Foreground Update** to None and **Job Submission** to One Job for All Design Points.

Rigid Body Dynamics and Explicit Dynamics
Rigid Body Dynamics and Explicit solvers always use RSM for update of the **Solution**, so it is not possible to update design points via RSM until special steps have been taken to enable update of a **Solution** via RSM within design point update via RSM. For assistance with enabling this functionality and configuring your system to support, go to the Support page of the ANSYS Customer Portal and submit an online support request. For further information about tutorials and documentation on the ANSYS Customer Portal, go to [http://support.ansys.com/docinfo](http://support.ansys.com/docinfo).

Third-Party CAD Systems
Projects that include geometry parameters that rely on third-party CAD systems do not update the geometry unless the CAD system is accessible on the execution node.

Reserving Licenses for a Design Point Update
To ensure that you have sufficient licenses available for the duration of your design point study, you can reserve the licenses that are needed for design point updates.

To reserve licenses for a design point update:

1. Set up your design point study as you normally would.
2. Right-click the **Parameter Set** bar and select **Properties**.
3. In the **Properties** view:
   a. Select **License Checkout > Reserved**.
   b. Select **Reserved License Set > Select Licenses**.
   c. In the **Select Licenses** dialog box, click each license under the **Available Licenses** tab that you want to reserve and click **Add**. You can select multiple licenses at one time by holding down the **CTRL** key as you click each license. The licenses you have selected appear in the **Reserved Licenses** panel. You can choose to filter the licenses shown by license type (Solver, PrepPost, Geometry, and so on).

When using an ANSYS HPC Parametric Pack license with either ANSYS HPC or ANSYS HPC Pack licenses, the number of licenses shown in the **Concurrent Licenses** column indicates the total...
number of HPC task available for the simultaneous design point update. For example, an HPC Parametric pack license used with eight HPC licenses shows 32 HPC tasks available because a single HPC Parametric Pack license enables four simultaneous design points, each of which can use up to eight HPC tasks. See Using HPC Parametric Pack Licenses (p. 154).

d. You may be able to see what licenses were used for this study in previous updates by clicking the **Used Licenses** tab. See Tracking Licenses (p. 153). You can add licenses to the reserve from this list as well.

e. To reserve more than one license of a given type, click the license in the **Reserved Licenses** panel and either click **Add** multiple times or type in the number of licenses in **Change Number Selected** at the bottom of the panel.

f. When you have selected all of the licenses you need to reserve, click **OK**. The selected licenses are not checked out at this time. License checkout occurs only when you begin the update.

4. If you are in an environment in which there may be contention for licences, you may want Workbench to check for reserved license availability as soon as possible, so that you know licences are available before you load data and attempt to update. To do this, clear **Run-time Checkout of Reserved Licenses**.

To instead check out reserved licenses at the start of the first job launched as part of a design point update, select **Run-time Checkout of Reserved Licenses**.

If the reserved license checkout fails for any reason, an error is reported in the RSM log.

5. Update your design points, either directly, or as a result of updating Design Exploration systems and components. The selected licenses are now checked out and held for the duration of the update.

---

**Note**

- If you have updated design points remotely via a queuing system for RSM, information on the reserved licenses is available to the job scripts in the ANSYS_RESERVED_LICENSE_INFO environment variable.

- You can specify whether a pre-RSM foreground update uses reserved licenses. For more information, see Performing a Pre-RSM Geometry Update (p. 148).

---

**Restrictions**

- You see only those licenses that are available on license server machines that are in your license server path specification. You cannot see or reserve licenses from other license servers.

- All machines used in your design point study must use the same license server.

- If the license server that you are using is part of a triad and the triad's master server goes down, subsequent license checkouts behave as standard checkouts, rather than checking out licenses from the reserve pool.

- You do not need to reserve licenses for DesignXploror components because DesignXploror does not check licenses out of the reserve pool.

- If design points are being updated on remote resources using ANSYS Remote Solve Manager (RSM), the execution nodes must be accessing the same license server as the source project.
• Do not use the **ANSWAIT** environment variable when reserving licenses.

• Reserved licensing can be disabled by your corporate license administrator. You are warned when you try to use this feature if it has been disabled.

**Special Cases**

You might need to reserve a Geometry license even when the **Geometry** cell is not parameterized and is up-to-date, if either of the following situations is true:

• If the project contains CAD geometry or any other geometry that is not managed by the **Geometry** cell but rather by a downstream Model or Mesh cell, and the geometry is parameterized via the Model or Mesh cell.

• If an **Engineering Data** cell is parameterized and shares a model or mesh downstream with an unparameterized **Geometry** cell.

If you are using reserved Mechanical APDL licenses with RSM on Linux machines and you have the **ANSYS182_PRODUCT** environment variable set in a global login startup script that is used by all users on a machine, you may see update failures caused by license checkout errors. You should remove the **ANSYS182_PRODUCT** environment variable from any global login startup scripts. Note that if the **ANSYS182_PRODUCT** environment variable is set in a user’s local startup script, or is set manually at runtime or via the launcher, the reserved licenses run correctly.

**Related Topics:**
- Tracking Licenses
- Returning Reserved Licenses
- Using HPC Parametric Pack Licenses

**Tracking Licenses**

ANSYS Workbench tracks licenses that are used during an update. You can see what licenses were used for any cell by viewing that cell’s properties. The property **Last Update Used Licenses** shows which licenses were used. You may find it useful to run the update of at least one design point as you normally would and then review the licenses that were used so that you know which licenses need to be reserved for a future study. License usage is tracked only for an Update operation in a component to which reserved licensing functionality is applied. It is not tracked if a cell becomes up-to-date as the result of an Edit operation.

**Note**

License usage is not tracked for DesignXplorer components. DesignXplorer uses reserved licenses indirectly by initiating design point updates.

License tracking may not return the information in some cases, such as if a cell was open for viewing or editing at the time of the update. In this case, **Not Applicable** is shown for **Last Update Used Li-**
censes, even though a license is used. To ensure that tracking captures information for all components, close all cells before updating.

**Note**

License tracking can be turned off by your corporate license administrator. If you run a study and do not see which licenses were used, see your license administrator.

**Returning Reserved Licenses**

If you are running a design point study and are using reserved licenses, you may need to free licenses if one or more design point runs hang or do not complete successfully. For example, you might delete a project that contains pending updates using reserved licenses. This situation should rarely occur. Typically, licenses are released if a design point fails. To free a reserved license, select **Tools > Release Reserved Licenses**. Select the projects for which you want to release licenses and click **Release Selected**.

This utility removes any free or hung licenses in the reserve. If any of the reserved licenses are still in use, those running jobs continue to completion or until they attempt to check out further licenses. The design point study fails if it attempts to update further design points because the reserves have been removed.

**Using HPC Parametric Pack Licenses**

ANSYS, Inc. offers additional license options called **HPC Parametric Packs** for ANSYS Workbench jobs requiring multiple design point updates. HPC Parametric Packs enable you to simultaneously update multiple design points of a single design study while using only a single license of each required base license. HPC Parametric Pack licenses can be used for design point updates initiated from DesignXplorer. To use HPC Parametric Pack licenses, you must use the ANSYS Workbench reserved licensing feature.

HPC Parametric Packs enable a specific number of simultaneous design points, as follows:

- 1 HPC Parametric Pack: 4 simultaneous design points
- 2 HPC Parametric Packs: 8 simultaneous design points
- 3 HPC Parametric Packs: 16 simultaneous design points
- 4 HPC Parametric Packs: 32 simultaneous design points
- 5 HPC Parametric Packs: 64 simultaneous design points

You can use a maximum of five HPC Parametric Pack licenses per design study.

If you reserve more than one license of an individual licensed product, the HPC Parametric Pack license multiplies only one of the licenses (allowing four simultaneous design points when used with 1 HPC Parametric Pack). If you have multiple licenses specified in the **Reserved Licenses** panel when you add an HPC Parametric Pack license, the number of licenses is decremented to one.

HPC Parametric Packs also work in conjunction with ANSYS HPC and ANSYS HPC Pack licenses. Use the HPC licenses to enable multiple parallel processes to be used for each design point.

For example, if you specify that you want to run the ANSYS Mechanical solver for the design point study using eight parallel processes for each design point, you must reserve the necessary HPC licenses to enable eight parallel processes (one HPC Pack or six processes of ANSYS HPC). The HPC Parametric Pack...
license allows all design points to run using eight-way parallel processing. If \( n \) design points are updated simultaneously, this scenario uses \( n \times 8 \) cores, while consuming only one HPC Pack or six processes of ANSYS HPC, as well as the license that enables the Mechanical solver.

If a design point update involves more than one solver, the parallel licenses that you reserve are available for use with both solvers running sequentially. For example, if you define a design point study that uses both an ANSYS Mechanical and an ANSYS Fluent license, and you specify that you want to use 8 parallel processes for Mechanical and 32 processes for Fluent, you must reserve sufficient HPC licenses to enable 32 parallel processes (2 HPC Packs or 32 processes of ANSYS HPC). The HPC Parametric Pack license then allows all design points to run using up to 32–way parallel with both solvers involved in the design point study. If you update \( n \) points simultaneously, this scenario uses \( n \times 8 \) cores for ANSYS Mechanical and \( n \times 32 \) cores for ANSYS Fluent, while consuming only 2 HPC Packs (or 32 ANSYS HPC processes).

---

**Note**

- If you have updated design points remotely via a queuing system for RSM, information on the reserved licenses is available to the job scripts in the ANSYS_RESERVED_LICENSE_INFO environment variable.

- You can specify whether a pre-RSM foreground update uses reserved licenses. For more information, see Performing a Pre-RSM Geometry Update (p. 148).


### Design Point Update Data

When design points are updated, DesignXplorer provides the following methods of retaining parameter data for solved design points:

- It saves design point data to the design point cache. DesignXplorer reuses data from the cache when you preview or update a Design Exploration system. For more information, see Cache of Design Point Results in the DesignXplorer User’s Guide.

- It exports design point data into design point log files. You can import the log file back into DesignXplorer as needed. For more information, see Design Point Log Files in the DesignXplorer User’s Guide.

- It allows you to export all design point values to an ASCII file. This functionality is available for DesignXplorer charts or tables containing design point data, including the design points table. You can then use the parameter values in the file with other programs for further processing or import into DesignXplorer.

---

**Note**

Both the design point log files and the ASCII file are formatted in the "Extended CSV File Format." For details, see Exporting Design Point Parameter Values to a CSV File (p. 142).

### Design Point States

On the Parameters Set tab and any Parameters tab, the Outline and Table views display icons on output parameters to indicate their states.
• An output parameter that is up-to-date displays no icon. Only the value of the output parameter is shown.

• An output parameter that is out-of-date displays the **Update Required** icon (🚀). Either the output parameter has not been solved or requires an update because local data has changed.

• An output parameter that has failed to update displays the **Update Failed, Update Required** icon (❌).

• An output parameter that has partially updated values because of an interruption to either a project update or a design point update displays the **Partially Updated** icon (◉).

During cell, system, project, and both local and remote design point updates, the **Outline** and **Table** views update the states of the output parameters.

Changes elsewhere in the project could cause the state of some, but not all, output parameters to go out-of-date and require update. In those cases, only those output parameters affected by the changes are shown as requiring an update. Output parameters that are not affected by the changes remain up-to-date.

Changes to derived parameters or associated expressions are recalculated immediately rather than requiring an update. If you add or change derived parameters, other parameters are not affected by this change and so do not require an update.

Design points that are being updated via RSM display the **Pending** icon (利) in the design points table while the remote design point update is in progress. When each updated design point is retrieved, associated output parameters reflect the results of the update.
Working with ANSYS Workbench and EKM

The ANSYS Engineering Knowledge Manager (EKM) is a simulation process and data management (SPDM) software system that enables you to work with simulation data in an EKM repository. Within ANSYS Workbench, you can establish a connection (p. 157) to an EKM Portal so that you can transfer projects to and from EKM repositories, and submit updates and solutions to remote computing resources.

You can use EKM to:

• Archive completed projects or store works-in-progress in a central repository
• Share your projects and collaborate on those of others
• Retrieve your own projects or those shared by other users
• Change the permissions of projects or place them under version control
• Search projects based on names, dates, simulation type, or other criteria
• Create reports
• Remotely execute design point runs and design exploration studies

For a complete description of EKM capabilities, refer to the ANSYS EKM User’s Guide.

For information about submitting updates and solutions to an EKM Portal, see the Working in ANSYS Workbench (p. 63) chapter.

This chapter covers the following topics:

Creating a Connection to an EKM Portal
Launching EKM with a Web Browser
Working with Existing EKM Connections
Working with ANSYS Workbench Projects Saved in an EKM Repository
Importing Repository Files
Troubleshooting EKM Connections from ANSYS Workbench

Creating a Connection to an EKM Portal

To be able to save a Workbench project to an EKM repository (directly from Workbench), retrieve a project from an EKM repository, or submit jobs to an EKM Portal for remote execution, you must create a connection between your local ANSYS Workbench installation and an EKM Portal.

A connection contains information about the server hosting EKM, the workspace to which you want to connect, and the credentials you use to sign in to EKM.

To create a connection to EKM in Workbench:

1. Select File → Manage Connections, then click Create Connection in the Manage Connections dialog box.
You can also create a connection through the **Project Schematic** properties when submitting a project update (p. 67), solution (p. 71), or design point update (p. 144) to an EKM Portal. When you select **Submit to Portal** as your **Update Option**, an option to create a connection is available in the **Portal Connection** drop-down list:

2. In the **Create a Connection** dialog box, specify a **Name** for the connection. This will be used to identify the connection in the **Portal Connection** drop-down list. Then, enter the **URL** address of the EKM Portal sign-in page, followed by your EKM **Username** and **Password**. Enabling **Save Credentials** will provide instant access to the EKM Portal every time that you access it. Otherwise, you will be prompted to enter your credentials each time.

3. Click **OK**. Your credentials are verified, and the connection is opened.

4. An EKM server may have multiple workspaces. When setting up a connection, the default workspace is automatically selected. If you would like to select a different workspace for your connection, or simply check which workspace is currently selected, select **File > Manage Connections**.
In the **Manage Connections** dialog box, select the desired workspace from the **Workspace** dropdown:

![Manage Connections Dialog Box](image)

Note that the **Workspace** drop box will list only those workspaces that you are permitted to access.

---

**Note**

- In order to create a connection to a Release 18 EKM Portal, the version of Workbench must be 17.1 or later.

- Creating multiple connections to the same EKM workspace using different connection names is not supported. If you create two connections that specify the same URL address and user credentials, the first connection will be automatically removed from the list of connections.

---

**Launching EKM with a Web Browser**

To simplify access to advanced EKM functionality, you can select **File → Launch EKM Web Client...** from ANSYS Workbench to open the EKM web client in your default browser. If you have more than one connection defined, you will first be prompted to select a connection to open. From here, you can access any EKM functionality as described in the **ANSYS EKM User’s Guide**.

**Working with Existing EKM Connections**

It is possible to create multiple connections to an EKM Portal using the method described in **Creating a Connection to an EKM Portal (p. 157)**.

You can open, close and delete connections by selecting **File → Manage Connections** and using the context-sensitive menu in the **Manage Connections** dialog box.
Opening a Connection

When you create a connection to an EKM Portal, it will open automatically upon creation. When a connection is open, it will show a **Status** of **Open** in the connections list. Only one connection can be open at one time, so if another connection was previously opened, it will be closed.

If you subsequently close an opened connection, or it is closed by EKM or Workbench, you will need to open it again to be able to use it.

To open a connection in the **Manage Connections** dialog box, right-click the connection and select **Open Connection**.

If you submit a project update or design point update to an EKM Portal, and then close Workbench, the connection will be closed at that time. To resume the update you can re-open Workbench. When you do so, Workbench will attempt to re-open the connection.

- If you selected **Save Credentials** when creating the connection, the connection will open automatically every time that you attempt to use it.

- If you did not select **Save Credentials** when creating the connection, the **Open Connection** dialog box will display. Enter your credentials and specify whether they should be saved for future use. If you do not choose to save credentials, you will be prompted to enter them every time that you attempt to use the connection.

If you do not enter the correct credentials, or cannot open the connection for any reason, an error message will be displayed in the dialog box. To view the details of the error, click **Show Details**.
Closing a Connection

To close an open connection in the Manage Connections dialog box, right-click the open connection and select Close Connection.

Deleting a Connection

To delete a connection in the Manage Connections dialog box, right-click the connection and select Delete Connection.

The connection name is removed from the connections list. The connection must be recreated in order to use it again.

Working with ANSYS Workbench Projects Saved in an EKM Repository

When working with an EKM repository, you must understand the relationship between your local working version of the project and the copy stored in the repository. Even if a project has been stored to or opened from a repository, ANSYS Workbench always operates directly on the local working copy of the project.

ANSYS Workbench is aware of the relationship between the local project and the repository copy, and will help you manage your project and maintain consistency. When closing a changed local copy of a project you can update the repository copy. If you open a local project, and the copy in the repository is more recent, you have the option of downloading and updating to the repository version. This situation can happen if, for example, you are collaborating with another user on a project that is stored centrally in the repository, and that user has made recent changes to the project. Access control settings enable you to restrict project permissions or apply project versioning, helping to minimize the potential for conflicts or duplicate work.

When you save an ANSYS Workbench project to an EKM repository, EKM always stores it as a Workbench Project Archive (p. 104) (*.wbpz file) so that you can act on a single object in EKM, rather than on a set of objects. Conversely, when you open a project from the repository, ANSYS Workbench downloads the archive and extracts the project and project files to the local directory you specify.

The following sections discuss how to work with projects saved to an EKM repository. Each section assumes that you already have an open repository connection.
Saving Projects and Files to an EKM Repository

You can save your ANSYS Workbench project or any files on your local system to an EKM repository for archive storage, or to share with other users.

To save a project or local files to an EKM repository:

1. If you want to save the current project to the repository, save the project locally first.

2. Select File → Save to Repository.

3. If you have not created a connection to an EKM Portal, the Create a Connection dialog box appears. Refer to Creating a Connection to an EKM Portal (p. 157).

   If connections exist but none are currently open, the Manage Connections dialog box appears. Right-click the connection that you want to open and select Open Connection.

When you open a connection and click OK in the Manage Connections dialog box, the Save to Repository dialog box appears:

4. Specify what you would like to save to the repository:
   - To save the current Workbench project to the repository, click Current Project.
   - To save specific files that are on your local system, click Local Files or Folder.

5. In the Save to Repository dialog box, select the repository location to which you want to save. To go up a level in the repository, click . You can navigate to a specific folder by drilling down in the tree.
The **My Data** folder is your own private folder that others cannot access. The **Shared Data** folder, on the other hand, is accessible to multiple users. To be able to save to **Shared Data**, your **Access Level** must be set to **Shared** in your EKM profile. Contact your EKM administrator for more information.

6. If you are saving the current project to the repository, the project’s file name in the repository will be the same as the project’s local file name.

   If you are saving local files to the repository, click **Browse** next to the **File(s)** field, then select the file(s) on your local system that you would like to save to the repository.

7. Optionally enter a **Description** of the project or selected file(s). This description will appear in EKM.

8. If you are saving the current project to the repository, you can click **Show Options** to specify access and control options.

   Select one of the following options from the **Access control** drop-down:

   - **Use Default Permission**: Uses the default permissions for your account.
   - **Get Exclusive Control**: Gives you exclusive control of the project, preventing other users from editing it.
• **Place under Version Control**: Places the project under version control, allowing the file to be edited by only one user at a time. When you select this option, you can check out the project by selecting the **Check out** check box on the **Version Control** dialog box. Files under version control are identified by their version numbers in Workbench.

  For more information on this option, see **Version Control and Access Management** in the **EKM User's Guide**.

If you want to receive an email alert when any of the following events occur, enable the appropriate check boxes in the **Alert on** section:

- **Modified**
- **Downloaded**
- **Checked In/Checked Out**
- **Lifecycle State Changed**

9. Click **Save**.

10. In the **File Options** dialog box, specify which optional items you would like to include in the save.

![](image)

If you are saving the current project, the project files will be uploaded to the EKM repository and archived in a `.wbpz` file. Once the upload portion of the operation has started, you can continue with further analysis tasks or work with other projects. You will not be allowed to exit ANSYS Workbench until the upload has completed.

When you upload a file to the EKM repository, you will regain control of the ANSYS Workbench interface as soon as the upload completes; EKM will extract the metadata asynchronously. If the metadata extraction fails, you will not see any indication in ANSYS Workbench. However, the project object in EKM (viewed via the EKM web client) will indicate that metadata is missing.

Once the project has been successfully uploaded to the repository, you can perform additional EKM-based operations on it through the EKM web client if desired.

**Note**

If you try to save a project in the **Shared Data** folder, and you do not have permission to write to **Shared Data**, you will see a message similar to the following:
In this case you can save your project to your private My Data folder instead. Or, if you want to be able to save to Shared Data, contact your EKM administrator to request a change to your Access Level.

**Opening a Project from an EKM Repository**

When you open a project from an EKM repository, ANSYS Workbench downloads the project and project files to the local directory that you specify.

**Note**

- You cannot open a project from an EKM repository if it is currently checked out by someone else. Attempting to do so will result in the error message 'current user does not have modify permission'.

- You cannot use the Open from Repository action to open a branched repository project, or a Workbench project archive (.wbpz) file that has been renamed or copied in EKM. In these cases you will need to sign in to EKM, download the project, and then use the standard Open action in Workbench to open the downloaded project.

To open a project from an EKM repository:

1. From ANSYS Workbench, select **File → Open from Repository**.
2. If you have not created a connection to an EKM Portal, the Create a Connection dialog box appears. Refer to Creating a Connection to an EKM Portal (p. 157).

   If connections exist but none are currently open, the Manage Connections dialog box appears. Right-click the connection that you want to open and select Open Connection.

   When you open a connection and click OK in the Manage Connections dialog box, the Open Project from Repository dialog box appears:
3. Browse to the repository location that contains the project and select it. You can also search the repository (p. 166) if needed.

4. Change the location in which the local copy of the project is to be placed, if necessary.

5. Click **Open** to download the project from the repository.

6. If the project is under version control, check the project out when prompted.

   **Note**

   If the project is under version control, you must have the project checked out in order to send changes to the repository or modify the repository version of the project. You cannot check out a project that is already checked out by another user.

7. Extract the project to the specified location and open it in ANSYS Workbench.

   **Searching the Repository**

   The **Open Project from Repository** dialog box contains powerful search features to assist you in finding projects anywhere in the repository. To perform a basic search, enter text in the **Search Repository**
field and press **Enter**. The quick search will search the repository and show search results whose name, description, or additional metadata contains the specified text.

To perform an advanced search or execute a saved search, click and select **Advanced Search** or **Saved Searches**. When performing an **Advanced Search**, you can search on text or additional properties such as date, owner, or simulation types contained in the project.

![Advanced Search dialog box](image)

Use the **Saved Searches** option to perform predefined public or private searches that have been saved in the EKM repository. For additional information on saved searches, see Managing Queries and Search Results in the *Engineering Knowledge Manager*.

**Sending Project Changes to the EKM Repository**

When working with a project that has been saved to or opened from an EKM repository, ANSYS Workbench generally enables you to update the repository with the current project version.

To update the repository with the changes made in a local project:

1. Save the project.
2. Select **File → Send Changes to Repository**. You can use this option at any time to save your changes to the repository.
3. In the **File Options** dialog box, specify which optional changes to include in the send.
When sending changes to the EKM repository for a project under version control, you can either keep the project checked out, check the project back in, or check the project in and then check it back out.

If you check the project in, you have the option of adding comments. The project version will be updated upon check in. If you do not check the project in, you can check it in at a later time by selecting File → Manage Repository Project → Check In.

Note

- You cannot send changes to the repository if the project is checked out to or locked by another user, or if you do not have write permissions on the project. Attempting to do so will result in the error message 'current user does not have modify permission'.

- The Send Changes to Repository action is disabled on the menu if you have closed the repository connection with which the project is associated. For information on opening connections, see Working with Existing EKM Connections (p. 159).
• If the repository connection with which the project is associated is currently open, and you submit a job to an EKM Portal using a different connection, the original connection will be closed. In this scenario, the **Send Changes to Repository** action will still be available on the menu, but attempting to send changes to the repository will fail, because the appropriate connection is not open. For information on opening connections, see *Working with Existing EKM Connections* (p. 159).

---

**Getting Project Changes from the EKM Repository**

When you open an ANSYS Workbench project that has been previously opened from or saved to an EKM repository, ANSYS Workbench checks to determine if a more recent copy of the project exists in the repository. If a more recent copy exists, you are prompted and given the option to update your local copy with the version of the project in the repository. If the project is under version control and is not already checked out (either by another user or by yourself), you are given the option of checking the project out.

To update a project with the changes from the EKM repository:

1. Open an ANSYS Workbench project that has a more recent copy in the repository.
2. The **Check Repository for the Project** dialog box asks if you want to check the repository for changes to the project.
   - If you do not want to be prompted to check for project updates in the future, select the **Save my choice and don’t ask this question again** check box. Your preference will be saved to the Workbench **Tools → Options → Repository** preferences and will be used the next time you open a repository project. If you do not select this check box, ANSYS Workbench will check for project updates according to the preference set in the **Options** dialog box. For details on configuring how Workbench checks for project updates, see *Repository* (p. 25).
   - Click **Yes** to check the repository for changes.

3. If there are changes to the repository version of the project, the **Get Changes from Repository** dialog box will ask if you want to download the changes to your local project.
   - Select **Check out the project** if you want to prevent others from modifying the repository copy while you are working on the project locally.
• Select **Create backup of local project** if you want to save a copy of the project before downloading the changes. (Note that the backup project will not be under repository control.)

• Click **OK**.

![Get Changes from Repository](image)

For a project that is already open, you can also manually retrieve changes from the EKM repository at any time: To do so:

1. In ANSYS Workbench, select **File → Manage Repository Project → Refresh Control Status**. This synchronizes the status of your local project with the status of the repository version.

2. Select **File → Get Changes from Repository** in ANSYS Workbench.

3. If there are changes to the repository version of the project, the **Get Changes from Repository** dialog box displays and lets you know that getting changes will overwrite your local copy.

4. By default, the **Create backup of local project** check box is selected. If you leave it selected, a backup copy called `<projectname>_backup.wbpj` will be created in the same local directory as the original project.
Note

The **Get Changes from Repository** action is disabled on the menu if you have closed the repository connection with which the project is associated. For information on opening connections, see **Working with Existing EKM Connections** (p. 159).

Note

- The **Get Changes from Repository** action is disabled on the menu if you have closed the repository connection with which the project is associated. For information on opening connections, see **Working with Existing EKM Connections** (p. 159).

- If the repository connection with which the project is associated is currently open, and you submit a job to an EKM Portal using a different connection, the original connection will be closed. In this scenario, the **Get Changes from Repository** action will still be available on the menu, but attempting to get changes from the repository will fail, because the appropriate connection is not open. For information on opening connections, see **Working with Existing EKM Connections** (p. 159).

Managing EKM Repository Project Changes

When you have a project opened from the repository, the **File** → **Manage Repository Project** menu includes the following options. Note that certain options may be disabled according the project status and your permissions.

- **Refresh Control Status**: Synchronize local project status with repository project status. Other **Manage Repository Project** menu options will then become enabled or remain disabled according to the project status and your permissions.

- **Access Control Status**: View the current control status of the project. Selecting this option performs a refresh of the menu so that it shows the current status of the project in terms of exclusive control, version control, and checkout availability. Note that if the project is under the exclusive control of a user, the status message will report that the project is ‘locked’ by that user.

- **Alert Setting**: Specify alert settings for the project. Selecting this option launches the **Alert Settings** dialog box, which enables you to specify that you will be notified by email when the project is modified, downloaded, checked in/checked out, or when its lifecycle state is changed.
• **Get Exclusive Control**: Selecting this option allows you to gain exclusive control of the project.

• **Release Exclusive Control**: Available only when you have exclusive control of the project. Selecting this option releases the exclusive control.

• **Add to Version Control/Remove from Version Control**: When adding the project to version control, you have the option of checking out the project (which is necessary to send changes to the repository).

• **Check In**: Available for projects under version control that you chose to keep checked out after sending changes using **Send Changes to Repository**. When you check a project in, you have the option of adding comments, and immediately checking the project out again. The project version number will be updated upon check-in. Note that this option is only available for sent changes.

• **Check Out**: Enables you to modify a project that is under version control while preventing others from modifying it. When you subsequently send changes to the repository, you will have the option of checking the project back in, or keeping it checked out.

• **Undo Checkout**: Available for projects that you have checked out, this option checks a project back in without checking in changes that you have made to the project. The project and its version number will remain unchanged in the repository.

To gain or release control over a project via the **File** → **Manage Repository Project** menu:

1. Load the project into ANSYS Workbench from the repository.

2. Select **File** → **Manage Repository Project** → **Refresh Control Status** to synchronize your local project settings with the project settings in the repository version of the project. Selecting this option refreshes the Workbench view of the repository, which may change the status of the exclusive control, version control, and check out settings, depending on whether there are other users accessing the repository and working with the project files.
3. Select **File → Manage Repository Project → Access Control Status** to view the full status of the file in the **Access Control Status** dialog box.

4. Select **File → Manage Repository Project → <action>**, where `<action>` is one of the control status-related options available to you. For example, you can:

   - Select **Add to Version Control** to add the project to version control. If a project is already under version control, you can select **Remove from Version Control** to remove it.

   - Select **Get Exclusive Control** to gain exclusive control of the project. If the project is already under exclusive control, you can select **Remove from Exclusive Control** to allow others to access the project.

If the desired option is not available, you can view the repository to see which user has made the project file unavailable to you.

---

**Note**

- When you make the desired change to the repository, you need to manually refresh your view of the repository to confirm the change of state.

- If you have sent project changes to the repository, the actions on the **Manage Repository Project** menu will not be refreshed until metadata extraction from the project has completed in the EKM repository. For larger projects this may take some time.
Using a Cache Server for EKM File Transfers

A cache server is a local EKM server that can be used to improve file transfer times by allowing files to be accessed on a Local Area Network (LAN), while the repository itself is accessed via a Wide Area Network (WAN). When a cache server is in place, file transfers between Workbench and the EKM repository use the cache server as an intermediary. (For more information, see Using a Cache System for WAN Transfers in the ANSYS EKM User’s Guide.)

For example, for repository operations involving file uploads from Workbench (that is, Save to Repository), the files are first uploaded from Workbench to the cache server, and then transferred from the cache server to the EKM repository. For repository operations involving file downloads to Workbench (that is, Open from Repository), the sequence is reversed: the files are transferred from the EKM repository to the cache server, and then downloaded from the cache server to Workbench.

You can check the status of a file transfer via the cache server by selecting File → Transfer to Repository Status. The Cache Transfer Status dialog box will display, showing a progress bar and a message to indicate whether the transfer status is Active, Failed, or Completed. Once you have clicked the OK button to exit the dialog box, the Transfer to Repository Status option becomes disabled until another file transfer is performed.

Note that no repository actions (except Transfer to Repository Status) are available while a project is being transferred to the cache server. Once the project has been cached, you can open other projects from the repository, but you cannot perform any actions on the project being transferred until it reaches the EKM server.

Importing Repository Files

On the Workbench Project Schematic, certain system cells allow you to browse the EKM repository for files, which you can then import into a Workbench project. The Browse from Repository menu option may be available for any cell that already has the local Browse option.

---

**Note**

- To import files, you must have an open repository connection. Only one connection can be open at a time. For more information on opening a connection, see Creating a Connection to an EKM Portal (p. 157).
- If multiple repository files are to be imported into a project, you should import them from the same repository connection.

---

Importing the Repository File to a Project

In the example below we’ll use the Geometry cell of a standalone Geometry system to import a data file into the project.

1. In the Project Schematic, right-click the Geometry cell and select Import Geometry → Browse from Repository.
2. In the **Open from Repository** dialog box, select the desired file and click **Open**.

**Verifying the Repository File Import**

You can verify that the file was successfully imported to your project by checking the project **Files** view. The repository file can be distinguished from local files by the EKM icon and the repository path in the **Location** column.

Although the **Files** view shows only the repository location, a copy of the imported file is saved and stored locally so you can continue working on the project without having a connection to the repository.

**Checking for Newer Versions of Imported Files**

ANSYS Workbench allows you to check for newer versions of a file imported from the repository. The checks can be done either automatically (when the project is opened via the **File → Open** menu item) or manually (at any time via the **File → Get Changes from Repository** menu item).

You can also check for newer file versions manually at any time, as follows:

1. Select the **File → Get Changes from Repository** menu item.

2. The **Check Repository for Imported Files** dialog box opens. Click **Yes** to check for newer file versions.
3. If you do not want to be prompted to check for updates to imported files, select the **Save my choice and don't ask this question again** check box. Your preference will be saved to the Workbench **Tools → Options → Repository** preferences and will be used the next time you open a project contains files imported from a repository. For details on configuring how Workbench checks for updates to imported files, see **Repository (p. 25)**.

4. The **Refresh Files Imported from Repository** dialog box opens, showing a list of imported files with changes in the repository. To download the newer version of a file, select the **Download** check box for that file and click **OK**.

5. When the new file version is downloaded to the project, the state of an up-to-date cell changes to **Refresh Required**.

![Refresh Files Imported from Repository](image)

**Note**

While it is possible to download newer versions of imported files from the repository, you cannot send local changes to the files back to the repository. To change a file in the repository, open the EKM web client and overwrite the existing file with a newer version.

---

**Troubleshooting EKM Connections from ANSYS Workbench**

If you encounter problems connecting to or using an EKM portal, review the following hints and tips. For additional help, also refer to **EKM Troubleshooting**.

To be able to connect to an EKM portal, the EKM server must be running on the target machine.

**Cannot connect to an EKM portal from ANSYS Workbench**

If you encounter problems with connecting to an EKM portal from within ANSYS Workbench, try opening a connection manually to the portal using a web browser:

1. Open a web browser.

2. In the address bar, enter the full address of the EKM server. Assuming the server is running on the default port of 8080, the full address will be:

   ```
   http://<server_name>:8080/ekm
   ```
3. If successful, the EKM web client for that server is launched and you are prompted for your sign-in credentials.

See Launching the EKM Web Client in the *Engineering Knowledge Manager* for more information.

**Cannot connect to an EKM portal using a web browser**

If you cannot connect to EKM with a browser, ensure the pop-up blocker is disabled or allows pop-ups from the EKM server.

**Cannot disconnect from an EKM portal**

If you are connected to EKM via Workbench, and Workbench crashes or does not exit cleanly, you will not be disconnected from the EKM portal. This means that if you try to connect to EKM again, you will get an error. To resolve this issue, an EKM administrator must forcibly log you out of EKM. See Forcing the Sign-out of a User in the *EKM Administration Guide* for details.
ANSYS Workbench Systems

The systems available in the Project tab Toolbox are divided into the following categories:

- **Analysis Systems (p. 179)** -- Complete systems with all the necessary component cells already defined and ready to be populated. For example, a Static Structural analysis system includes all the cells needed for the analysis, Engineering Data through Results.

- **Component Systems (p. 199)** -- Component building blocks which represent only a subset of a complete analysis. For example, you can use a Geometry component system to define your geometry and then connect the component system to several downstream systems, so component system can then be connected to several downstream systems, so that the downstream systems share the same geometry source. The Component Systems category also includes applications that open outside of ANSYS Workbench (rather than as a tab), allowing you to use Workbench to manage your analysis data and files. This can be useful for products such as Mechanical APDL, which uses numerous files during an analysis.

- **Custom Systems (p. 300)** -- Predefined templates for custom coupled systems, composed of multiple analysis systems with predefined data connections. You can also create templates for your own custom system templates, which will then be stored and displayed as part of this category.

- **Design Exploration (p. 302)** -- DesignXplorer systems that can be added beneath the Parameter Set bar, allowing you to perform various design exploration studies.

- **External Connection Systems (p. 303)** -- enables you to integrate custom, lightweight, external applications and processes into the ANSYS Workbench Project Schematic workflow. Features exposed by the External Connection also allow you to perform automation and customization activities.

With the External Connection, you can integrate custom, lightweight, external applications; define User Interface (UI) elements, such as buttons in the Workbench Toolbar or entries in custom menus, and create the scripts that enable them; and create new systems to facilitate interaction with the Workbench Project Schematic.

**Analysis Systems**

One way to start an analysis in ANSYS Workbench is to select an analysis system from the Toolbox. When you select one of these analysis types, the corresponding system will appear in the Project Schematic, with all the necessary components of that type of analysis. Some analysis types offer different solvers, noted in parentheses. The features available can differ from one solver to another.

Available analysis systems include:
- Design Assessment
- Eigenvalue Buckling
- Electric
- Explicit Dynamics
- Fluid Flow (CFX)
- Fluid Flow (Fluent)
- Fluid Flow (Polyflow)
- Harmonic Acoustics
Harmonic Response
Hydrodynamic Diffraction
Hydrodynamic Response
IC Engine
Magnetostatic
Modal Acoustics
Modal
Random Vibration
Response Spectrum
Rigid Dynamics
Static Structural
Steady-State Thermal
Thermal-Electric
Topology Optimization
Throughflow and Throughflow (BladeGen)
Transient Structural
Transient Thermal
Turbomachinery Fluid Flow

When you either double-click or drag an analysis system onto the **Project Schematic** it appears in the **Project Schematic** as a system. Components for that analysis type's system are listed as individual cells. For example, a typical structural analysis might have the following components/cells:

- Engineering Data (p. 313)
- Geometry (p. 313)
- Model/Mesh (p. 314)
- Setup (p. 314)
- Solution (p. 314)
- Results (p. 315)

Right-click each cell to see a menu of actions that are available for that cell. Selecting an action may launch a separate application, if appropriate. When you've completed the necessary actions in that application, you can solve in the application or return to the **Project Schematic** to Update the project and continue. Updating a project allows other systems or other cells within the same system to acquire the newest information.

ANSYS Workbench provides templates for some of the commonly used coupled analyses, such as one-way FSI analyses, pre-stress modal, thermal stress, random vibration, and response spectrum. Select these templates from the Custom Systems (p. 300) area of the Toolbox.

You can also import databases from previous releases. See Importing Legacy Databases (p. 107) for instructions and restrictions on importing legacy databases.

**Design Assessment**

The Design Assessment analysis system provides the capability of performing a solution combination for a Static Structural, Modal, Harmonic Response, Random Vibration, Response Spectrum, Explicit Dynamics, or Transient Structural analysis, and then performing post processing through a customizable script using additional geometry-associated data and extraction of custom results.

You will configure your **Design Assessment Analysis** in the Mechanical application, which uses the appropriate solver to compute the solution.

1. Add analysis system to the **Project Schematic** and attach the geometry.
2. Add a Design Assessment analysis template by dragging the template from the Toolbox onto the last structural template in the **Project Schematic**, sharing the **Engineering Data**, **Geometry**, and **Model** cells.

3. The assessment type will then need to be set. This can be done in two ways, explained below.

4. Specify the Mechanical settings by right-clicking on the **Model** cell and choosing **Edit**.

5. In the Mechanical application window, complete your analysis using the application's tools and features.

6. Start the solution by selecting **Solve** from the Mechanical application or **Update** from the **Solution** cell in the **Project Schematic**.

### Available Assessment Types

There are three supplied assessment types.

- FATJACK
- BEAMST
- Solution Combination Only

You can also choose to define your own type by creating an attribute file for use with the system.

---

**Note**

- The default assessment type is Solution Combination Only.
- FATJACK and BEAMST options are available only if ASAS is installed.

---

For more information on creating the attribute file see The Design Assessment XML Definition File in the **ANSYS Mechanical User's Guide**.

### How to Set the Assessment Type

Use one of the two methods described below to set the assessment type for the system.

- **Setup Cell Right Mouse Button Menu**

  Right-click the **Setup** cell of the system and select **Assessment Type** from the menu. Here you can select either one of the pre-defined types or import a user-defined XML file.

  If you select to import a user-defined type, you are presented the option to import the file by either browsing to it or by selecting one that has been browsed to previously from the list (if available).

  To check which assessment type has been selected, there is a check box next to the pre-defined types on the menu that will display a check mark when they have been selected. If no check mark is visible, a user-defined type has been selected.

- **Setup Cell Properties Panel**

  Select **View** then **Properties** from the main menu. This will display the **Properties** view in the workspace.
Now click the **Setup** cell of the design assessment system and the **Properties** view will be updated to show the available options for the cell.

From here you can change the assessment type from the drop-down list in the **Design Assessment Settings** section. You can choose between the pre-defined types or to use a user-defined type. If you select the user-defined option, you will be presented with an "open file" dialog box so you can choose the XML file you want to use. The name of this file will be displayed in the **Properties** view.

**Eigenvalue Buckling**

Eigenvalue Buckling analysis predicts the theoretical buckling strength of an ideal elastic structure. This method corresponds to the textbook approach of elastic buckling analysis: for instance, an eigenvalue buckling analysis of a column will match the classical Euler solution. However, imperfections and non-linearities prevent most real-world structures from achieving their theoretical elastic buckling strength. Thus, Eigenvalue Buckling analysis often yields quick but non-conservative results.

You will configure your Eigenvalue Buckling analysis in the Mechanical application, which uses the ANSYS or the Samcef solver to compute the solution.

An Eigenvalue Buckling analysis must follow a prestressed static structural analysis. Follow the instructions in **Static Structural** (p. 194) to build a prestressed Static Structural system, and then follow the instructions below to build and link an Eigenvalue Buckling system.

1. From the Static Structural system, right-click the **Solution** cell and select Transfer Data to New → Eigenvalue Buckling.

2. A new Eigenvalue Buckling system is created, with the **Engineering Data, Geometry, Model**, and **Setup** cells linked from the static structural system.

3. Right-click the **Setup** cell in the Eigenvalue Buckling system and select **Edit**, or double-click the **Setup** cell to open the Mechanical application. In the Mechanical application window, set your Eigenvalue Buckling controls using the Mechanical application's tools and features. See **Eigenvalue Buckling Analysis** in the Mechanical application help for more information on conducting an Eigenvalue Buckling analysis in the Mechanical application.

4. On the Toolbar, click **Update Project**.

**Electric**

An electric analysis supports Steady-State Electric Conduction. Primarily, this analysis type is used to determine the electric potential in a conducting body created by the external application of voltage or current loads. From the solution, other results items are computed such as conduction currents, electric field, and joule heating.

You will configure your electric analysis in the Mechanical application, which uses the ANSYS solver to compute the solution.

1. Add an electric analysis template by dragging the template from the **Toolbox** into the **Project Schematic** or by double-clicking the template in the **Toolbox**.

2. Load the geometry by right-clicking on the **Geometry** cell and choosing **Import Geometry**.

3. Right-click the **Setup** cell and select **Edit**, or double-click the **Setup** cell. This step will launch the Mechanical application.
4. In the Mechanical application window, complete your electric analysis using the Mechanical application's tools and features. See Electric Analysis in the Mechanical application help for more information on conducting an electric analysis in the Mechanical application.

**Explicit Dynamics**

1. Add an explicit dynamics analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry.

3. View the geometry by right-clicking the Model cell and choosing Edit, or by double-clicking the Model cell. Alternatively, you can right-click the Setup cell and select Edit. This step will launch the Mechanical application.

4. In the Mechanical application window, complete your explicit dynamics analysis using the Mechanical application's tools and features. See Explicit Dynamics Analysis in the Mechanical application help for more information on conducting an explicit dynamics analysis in the Mechanical application.

**Fluid Flow (CFX)**

ANSYS CFX enables you to perform fluid-flow analysis of incompressible and compressible fluid flow and heat transfer in complex geometries. You import the geometry and meshes, specify the materials, boundary conditions, and solution parameters, solve the calculations, view the results, then create reports using built-in tools.

To use ANSYS CFX as an analysis system in ANSYS Workbench:

1. Add a Fluid Flow (ANSYS CFX) analysis system by dragging the system from the Toolbox into the Project Schematic or by double-clicking the system in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry. Alternatively, you can create the geometry in DesignModeler by right-clicking on the Geometry cell and choosing New Geometry.

3. Create a mesh by right-clicking on the Mesh cell and choosing Edit.

4. Specify the ANSYS CFX physics definitions in CFX-Pre by right-clicking on the Setup cell and choosing Edit. Alternatively, you can import a previously saved case file by right-clicking the Setup cell and choosing Import Case → Browse.

5. Right-click the Solution cell and choose Update to start the solver. Alternatively, right-click the Solution cell and select Edit, set the solver execution controls in CFX-Solver Manager, and start the solver.

   You can also import an existing CFX-Solver Results file by right-clicking on the Solution cell and choosing Import Solution → Browse.

6. Analyze the results of the calculations in CFD-Post by right-clicking the Results cell and choosing Edit.

For detailed information on working with ANSYS CFX, see ANSYS CFX in ANSYS Workbench in the CFX Introduction.
The Fluid Flow (ANSYS CFX) analysis system is also used as part of the FSI: Fluid Flow (ANSYS CFX) > Static Structural (p. 301) custom system.

Note

If you import a CFX-Solver Input File into a CFX Setup cell and:

- The reload file format is not a CFX-Solver Input File (for example, a DEF file)
- The Reload Options were not defined or did not contain a replacetype option

...you may need to modify the definition of the Mesh Reload Options as follows.

Example 1: Modifying the Mesh Reload Options

If a definition file contains a mesh from a GTM file and is imported into a Setup cell, the original mesh type is automatically changed to "CFX-SolverInput file". If the remeshing process is not explicitly told to import the GTM file as a GTM file, the remeshing process assumes that the mesh is also a "CFX-Solver Input file", rather than a GTM file.

This fails when the remeshing process runs. This is a limitation and must be modified by hand. To do this, add a line similar to the following to the DEF file:

```
Mesh Reload Options = "replacetype=GTM,notransform=false"
```

See Remeshing Tab in the CFX-Pre User's Guide for details.

Resuming a Failed Run

If your CFX run fails and a backup file is available, you can resume a run from the latest standard or essential backup, or equivalent transient results file. This capability is especially useful for cases with very long runtimes to avoid restarting from initial conditions or, if the solver failed due to an error, reviewing backed up results to diagnose and correct the issue. To take advantage of this capability, follow these steps when starting your run:

1. Import a case file or begin with an existing CFX setup definition.
2. Open Setup and define backups:
   1. From the menu bar, choose Insert > Solver > Output Control and select the Backup tab. For more information on output controls and the Backup tab in CFX-Pre, see Output Control.
   2. Define your backup settings. Note that only Essential or Standard backup files provide sufficient data for a clean restart. Additional backup files using the Smallest or Selected Variables option can be included, but will not be available for restarting a solution.
   3. Close CFX-Pre.
3. In the Workbench Project Schematic, update the system to start the solution.
4. If the solver fails to write a results file, right-click the Solution cell and choose Resume Solution from Backup to resume the solution, or Copy Backup to New Solution if you wish to review the results in CFD-Post or keep the backup to use as initial conditions.
1. If you choose **Resume Solution from Backup**, the update will continue from the last completed backup.

2. If you choose **Copy Backup to New Solution**, a new CFX system with only **Solution** and a new **Results** cell will be created in the project schematic. You can review the results from this system to determine the status of the solution at the last completed backup point. From there, you can choose to resume the original interrupted run or you can choose to revise your original case as necessary.

---

**Note**

Note that the solution is restarted directly from the backup file and will include any modifications made through the Command Editor. Also, if the setup is modified, **Resume Solution from Backup** will no longer be available. If you wish to modify the setup and restart from a backup, first copy the backup to a new solution using **Copy Backup to New Solution** and link this backup solution to your solution cell to use it as an initial guess.

---

**Fluid Flow (Fluent)**

Fluent allows for fluid flow analysis of incompressible and compressible fluid flow and heat transfer in complex geometries. You specify the computational models, materials, boundary conditions, and solution parameters in Fluent, where the cases are solved.

You can use a Fluent fluid flow analysis system to apply a computational mesh to a geometry within Workbench, then use Fluent to define pertinent mathematical models (for example, low-speed, high-speed, laminar, turbulent, and so on), select materials, define boundary conditions, and specify solution controls that best represent the problem to be solved. Fluent solves the mathematical equations, and the results of the simulation can be displayed in Fluent or in CFD-Post for further analysis (for example, contours, vectors, and so on).

To use ANSYS Fluent as an analysis system in ANSYS Workbench:

1. Add a fluid flow analysis template by dragging the template from the **Toolbox** into the **Project Schematic** or by double-clicking the template in the **Toolbox**.

2. Load the geometry by right-clicking on the **Geometry** cell and choosing **Import Geometry**. Alternatively, you can create the geometry in DesignModeler by right-clicking on the **Geometry** cell and choosing **New Geometry**.

3. Create a mesh by right-clicking on the **Mesh** cell and choosing **Edit**.

4. Specify the Fluent settings by right-clicking on the **Setup** cell and choosing **Edit**. Alternatively, you can import a previously saved Fluent case file or Fluent case and data files by right-clicking on the **Setup** cell and selecting **Import Fluent Case** or **Import Fluent Case And Data**, respectively.

5. Analyze the results of the calculations in CFD-Post by right-clicking on the **Results** cell and choosing **Edit**.

For detailed information on working with Fluent, see the Fluent User’s Guide as well as the other online documentation available under the Help menu within Fluent. In addition, see the Fluent in Workbench User’s Guide.
Fluid Flow (Polyflow)

Polyflow allows for the analysis of fluid flows with free surfaces, complex rheology (including non-Newtonian behavior with viscoelasticity), heat transfer, and chemical reactions. The usage of Polyflow involves: specifying the computation models inside Polydata, which is the module for problem setup; and running the calculations using the Polyflow solver. Polyflow also comes with several useful utilities, which can be accessed via the right-click menu on the Setup and Solution cells. For example, Polymat can be used to calculate material properties, including viscoelastic parameters based on experimental data. For more details, see the product documentation.

There are three Polyflow fluid flow analysis systems available in Workbench:

- The Fluid Flow (Polyflow) system provides the full simulation capabilities of Polyflow.
- The Fluid Flow - Blow Molding (Polyflow) system provides only the application-specific capabilities of Polyflow that are suited to blow-molding simulations.
- The Fluid Flow - Extrusion (Polyflow) system provides only the application-specific capabilities of Polyflow that are suited to extrusion simulations.

Use a Polyflow, Blow Molding (Polyflow), or Extrusion (Polyflow) fluid flow analysis system to apply a computational mesh to a geometry within Workbench, then use Polydata to define pertinent mathematical models (for example, Generalized Newtonian, Viscoelastic, and so on), select materials, define boundary conditions, and specify solution controls that best represent the problem to be solved. Polyflow solves the mathematical equations, and the results of the simulation can be displayed in CFD-Post for further analysis (for example, contours, vectors, and so on).

1. Add a Polyflow, Blow Molding (Polyflow), or Extrusion (Polyflow) fluid flow analysis system by dragging the system from the Toolbox into the Project Schematic or by double-clicking the system in the Toolbox.

2. Load the geometry by right-clicking the Geometry cell and clicking Import Geometry in the context menu that opens. Alternatively, you can create the geometry in DesignModeler by right-clicking the Geometry cell and clicking New Geometry in the context menu that opens.

3. Create a mesh by right-clicking the Mesh cell and clicking Edit in the context menu that opens. Alternatively, you can import a previously saved mesh by right-clicking the Setup cell and clicking Import Mesh in the context menu that opens. You can merge, scale, translate, and rotate the mesh by right-clicking the Setup cell and clicking Polyfuse in the context menu that opens.

4. You can define your preferences for Polydata by right-clicking the Setup cell and clicking Preferences and Polydata in the context menu that opens.

5. Specify the simulation setup by right-clicking the Setup cell and clicking Edit in the context menu that opens. Alternatively, you can import a previously saved Polyflow data file by right-clicking the Setup cell and clicking Import Polyflow Dat... in the context menu that opens. You have the option of specifying material data by right-clicking the Setup cell and clicking Polymat in the context menu that opens.

6. You can define your preferences for Polyflow by right-clicking the Solution cell and clicking Preferences and Polyflow in the context menu that opens.

7. Run the Polyflow calculation by right-clicking the Solution cell and clicking Update in the context menu that opens. You can check the status of the solver during or after the calculation by right-clicking the Solution cell and clicking Polydiag in the context menu that opens. You can open the listing file to see...
what Polyflow has done during or after the calculation by right-clicking the **Solution** cell and clicking **Listing Viewer** in the context menu that opens.

8. Analyze the results of the calculations in CFD-Post by right-clicking the **Results** cell and clicking **Edit** in the context menu that opens. You can generate plots of the solution data by right-clicking the **Solution** cell and clicking **Polycurve** in the context menu that opens. You can statistically postprocess the results of the solution data by right-clicking the **Solution** cell and clicking **Polystat** in the context menu that opens.

For detailed information on working with Polyflow, see the online help in Polyflow, as well as the separate ANSYS Polyflow User’s Guide. In addition, see the separate ANSYS Polyflow section in the ANSYS Workbench User’s Guide.

**Harmonic Acoustics**

You use **Harmonic Acoustics** analyses to determine the steady-state response of a structure and the surrounding fluid medium to loads and excitations that vary sinusoidally (harmonically) with time.

You configure the environmental conditions of a **Harmonic Acoustics** analysis in the Mechanical application. This analysis type uses the Mechanical APDL solver to compute the solution.

1. Add a **Harmonic Acoustics** analysis template by dragging the template from the **Toolbox** into the **Project Schematic** or by double-clicking the template in the **Toolbox**.

   Once the analysis type is selected, the following prompt displays.

   ![Multiphysics System Created](image)

   This prompt, that you can deactivate from future display, alerts you to the fact that you can automatically create a **Physics Region** (object) in the downstream Mechanical system by making a selection in the properties of the **Setup** cell. The **Acoustics** property, as illustrated below, is a read-only property that is always active.
2. Load your geometry by right-clicking on the Geometry cell and choosing Import Geometry.

3. Import the model into Mechanical by right-clicking the Setup cell and selecting Edit. Alternatively, you can double-click the Setup cell. This step launches the Mechanical application.

4. In the Mechanical application window, complete your analysis using the Mechanical application’s tools and features. See the Harmonic Acoustics section of the ANSYS Mechanical User’s Guide for the steps to conduct a Harmonic Acoustics analysis.

**Harmonic Response**

In a structural system, any sustained cyclic load produces a sustained cyclic (harmonic) response. Harmonic analysis results are used to determine the steady-state response of a linear structure to loads that vary sinusoidally (harmonically) with time, therefore enabling you to verify whether or not your designs will successfully overcome resonance, fatigue, and other harmful effects of forced vibrations. This analysis technique calculates only the steady-state, forced vibrations of a structure, typically at a number of discrete points within a range of frequencies. The transient vibrations, which occur at the beginning of the excitation, are not accounted for in a harmonic response analysis.

You will configure your harmonic response analysis in the Mechanical application, which uses the ANSYS solver to compute the solution.

1. Add a harmonic response analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry.

3. View the geometry by right-clicking on the Model cell and choosing Edit, or double-clicking the Model cell. Alternatively, you can right-click the Setup cell and select Edit. This launches the Mechanical application.

4. In the Mechanical application window, complete your harmonic response analysis using the Mechanical application’s tools and features. A mode-superposition harmonic analysis will automatically run the modal portion of the solution and cannot transfer data from a separate modal system in the Project Schematic. See Harmonic Response Analysis in the Mechanical application help for more information on conducting a harmonic response analysis in the Mechanical application.
**Hydrodynamic Diffraction**

Aqwa allows for the calculation of Wave Forces and Structure Motions in regular or irregular waves. You specify the geometry in DesignModeler, and Aqwa specific solution parameters within the Aqwa application where the calculations are solved.

Use an Aqwa Hydrodynamic Diffraction analysis system to apply a computational mesh to a geometry within the Aqwa application and produce a solution.

1. Add a Hydrodynamic Diffraction analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the **Geometry** cell and choosing **Import Geometry**. Alternatively, you can create the geometry in DesignModeler by right-clicking on the **Geometry** cell and choosing **New Geometry**.

3. Specify the Aqwa settings by right-clicking on the **Setup** cell and choosing **Edit**.

4. In the Aqwa application window, complete your Aqwa analysis using the application's tools and features.

5. Start the solution by selecting **Solve** from the Aqwa application or **Update** from the **Solution** cell in the Project Schematic.

Optionally, you can connect an Aqwa Hydrodynamic Diffraction solution cell to a Static Structural Setup cell and transfer the data to the Static Structural system.

You also have the option of importing a previously saved Aqwa .aqdb file by selecting **File → Import** from the Workbench toolbar, choosing files of Type **AQWAWB Database (*.aqdb)**, and navigating to the database file. See Importing Legacy Databases (p. 107) for additional information.

For detailed information on working with Aqwa in ANSYS Workbench, see Introduction available in the ANSYS online help. In addition, see the separate Aqwa documentation that can be accessed from **Start > All Programs > ANSYS 18.2 > Help > AQWA > AQWA Reference 18.2**.

**Hydrodynamic Response**

Aqwa allows for the calculation of Wave Forces and Structure Motions in regular or irregular waves. You specify the geometry in DesignModeler, and Aqwa specific solution parameters within the Aqwa application where the calculations are solved.

Use an Aqwa Hydrodynamic Response analysis system to apply ocean environment forces (wind, wave, current) to a structure.

1. Add a Hydrodynamic Diffraction analysis template to the Project Schematic and attach a geometry to it.

2. Add a Hydrodynamic Response analysis template by dragging the template from the Toolbox into the Hydrodynamic Diffraction system in the Project Schematic or by double-clicking the template in the Toolbox, sharing the **Geometry, Model**, and **Solution** cells from the Hydrodynamic Diffraction system.

3. Specify the Aqwa settings by right-clicking on the **Setup** cell and choosing **Edit**.

4. In the Aqwa application window, complete your Aqwa analysis using the application's tools and features.

5. Start the solution by selecting **Solve** from the Aqwa application or **Update** from the **Solution** cell in the Project Schematic.
You also have the option of importing a previously saved Aqwa .aqdb file by selecting **File → Import** from the Workbench toolbar, choosing Files of Type **AQWAWB Database (*.aqdb)**, and navigating to the database file. See Importing Legacy Databases (p. 107) for addition information.

For detailed information on working with Aqwa in ANSYS Workbench, see Introduction available in the ANSYS online help. In addition, see the separate Aqwa documentation that can be accessed from **Start > All Programs > ANSYS 18.2 >Help > AQWA> AQWA Reference 18.2.**

**IC Engine**

IC Engine (Internal Combustion Engines in Workbench) is a customized application to setup and solve the flow inside an IC engine. IC Engine system is used for quantification of flow rate, swirl and tumble, and other flow parameters inside the engine during the engine cycle with moving geometry. IC Engine system uses ANSYS Fluent solver for fluid flow analysis.

1. Add an IC Engine analysis system by dragging the system from the Toolbox into the Project Schematic or by double-clicking the system in the Toolbox.
2. Select type of simulation and specify engine parameters in the ICE cell **Properties** and update the cell.
3. Double-click the **Geometry** cell to open the DesignModeler. Load the geometry and click **Input Manager** to enter the geometry inputs required and generate the features. Then decompose the geometry by clicking **Decompose**.
4. Open the Meshing application by double-clicking, or selecting **Edit** from the context menu of the **Mesh** cell of IC Engine System. Once the geometry is loaded into the meshing application, click **IC Setup Mesh** and set the meshing parameters followed by **IC Generate Mesh** to create the mesh. Update the **Mesh** cell in the IC Engine System.
5. Open the ANSYS Fluent application by double-clicking or editing the **Setup** cell and enter the number of time steps in Fluent settings and run the case.
6. Analyze the results of the calculations in CFD-Post by double-clicking the **Results** cell.

For detailed information on working with IC Engine, see Internal Combustion Engines in Workbench.

**Magnetostatic**

Magnetic fields may exist as a result of a current or a permanent magnet. In ANSYS Workbench, you can perform 3D static magnetic field analysis. You can model various physical regions including iron, air, permanent magnets, and conductors.

You will configure your magnetostatic analysis in the Mechanical application, which uses the ANSYS solver to compute the solution.

1. Add a magnetostatic analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.
2. Load the geometry by right-clicking the **Geometry** cell and choosing **Import Geometry**.
3. View the geometry by right-clicking the **Model** cell and choosing **Edit**, or double-clicking the Model cell. Alternatively, you can right-click the **Setup** cell and select **Edit**. This launches the Mechanical application.
4. In the Mechanical application window, complete your magnetostatic analysis using the Mechanical application's tools and features. See Magnetostatic Analysis in the Mechanical application help for more information on conducting a magnetostatic analysis in the Mechanical application.

**Modal Acoustics**

A Modal Acoustics analysis models a structure and the surrounding the fluid medium to determine frequencies and standing wave patterns within a structure.

You configure the environmental conditions of a Modal Acoustics analysis in the Mechanical application. This analysis type uses the Mechanical APDL solver to compute the solution.

1. Add a Modal Acoustics analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

   Once the analysis type is selected, the following prompt displays.

   ![Prompt](image)

   This prompt, that you can deactivate from future display, alerts you to the fact that you can automatically create a Physics Region (object) in the downstream Mechanical system by making a selection in the properties of the Setup cell. The Acoustics property, as illustrated below, is a read-only property that is always active.

   ![Diagram](image)

2. Load your geometry by right-clicking on the Geometry cell and choosing Import Geometry.
3. Import the model into Mechanical by right-clicking the **Setup** cell and selecting **Edit**. Alternatively, you can double-click the **Setup** cell. This step launches the Mechanical application.

4. In the Mechanical application window, complete your analysis using the Mechanical application’s tools and features. See the **Modal Acoustics** section of the *ANSYS Mechanical User’s Guide* for the steps to conduct a **Modal Acoustics** analysis.

### Modal

A modal analysis determines the vibration characteristics (natural frequencies and corresponding mode shapes) of a structure or a machine component. It can serve as a starting point for other types of analyses by detecting unconstrained bodies in a contact analysis or by indicating the necessary time-step size for a transient analysis, for example. In addition, the modal-analysis results may be used in a downstream dynamic simulation employing mode-superposition methods, such as a harmonic response analysis, a random vibration analysis, or a spectrum analysis. The natural frequencies and mode shapes are important parameters in the design of a structure for dynamic loading conditions.

You will configure your modal analysis in the Mechanical application, which uses either the ANSYS, ABAQUS, or Samcef solver, depending on which system you selected, to compute the solution.

1. Add a modal analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the **Geometry** cell and choosing **Import Geometry**.

3. View the geometry by right-clicking on the **Model** cell and choosing **Edit**, or double-clicking the **Model** cell. Alternatively, you can right-click the **Setup** cell and select **Edit**. This step will launch the Mechanical application.

4. In the Mechanical application window, complete your modal analysis using the Mechanical application’s tools and features. See **Modal Analysis** in the Mechanical application help for more information on conducting a modal analysis in the Mechanical application.

### Random Vibration

The loads on a structural system may not always be known or quantifiable with certainty. Sensitive electronic equipment mounted in an automobile, for example, may experience slightly-different conditions each day, due to changes in engine vibration or pavement roughness, even if the same road is traveled. A random vibration analysis enables you to determine the response of structures to vibration loads that are random in nature. Since the input loads are described using statistical quantities, the outputs are said to be nondeterministic, meaning that the results can be known only within a certain probability.

You will configure your random vibration analysis in the Mechanical application, which uses the ANSYS solver to compute the solution.

A random vibration analysis must follow a modal analysis that extracts the natural frequencies and mode shape. See the instructions in **Modal** (p. 192) to build a Modal analysis system. Then follow the instructions below. Alternatively, you can select (double-click) Random Vibration from Custom Systems in the Toolbox. This option creates a random vibration system template that includes both the modal analysis and random vibration analysis system templates with the links pre-defined.

1. From the modal analysis system, right-click the **Solution** cell and select **Transfer Data to New>Random Vibration**.
2. Workbench creates a new Random Vibration system. The Engineering Data, Geometry, and Model cells are linked and the Modal Solution cell is linked to the Random Vibration Setup cell.

3. Right click the Setup cell in the Random Vibration system and select Edit, or double-click the Setup cell to open the Mechanical application. In the Mechanical application window, set your Random Vibration controls using the Mechanical application's tools and features. See Random Vibration Analysis in the Mechanical application help for more information on conducting a random vibration analysis in the Mechanical application.

4. On the Toolbar, click Update Project.

**Response Spectrum**

A response spectrum analysis has similarities to a random vibration analysis. However, unlike a random vibration analysis, responses from a response spectrum analysis are deterministic maxima. For a given excitation, the maximum response is calculated based upon the input response spectrum and the method used to combine the modal responses. The combination methods available are: the Square Root of the Sum of the Squares (SRSS), the Complete Quadratic Combination (CQC) and the Rosenblueth's Double Sum Combination (ROSE).

You will configure your response spectrum analysis in the Mechanical application, which uses the ANSYS solver to compute the solution.

A response spectrum analysis must follow a modal analysis. See the instructions in Modal (p. 192) to build a Modal analysis system. Then follow the instructions below. Alternatively, you can select (double-click) Response Spectrum from Custom Systems in the Toolbox. This option creates a response spectrum system template that includes both the modal analysis and response spectrum analysis system templates with the links pre-defined.

1. From the modal analysis system, right-click the Solution cell and select Transfer Data to New → Response Spectrum.

2. Workbench creates a new Response Spectrum system. The Engineering Data, Geometry, and Model cells are linked and the Modal Solution cell is linked to the Response Spectrum Setup cell.

3. Right-click the Setup cell in the Response Spectrum system and select Edit, or double-click the Setup cell to open the Mechanical application. In the Mechanical application window, set your Response Spectrum controls using the Mechanical application's tools and features. See Response Spectrum Analysis in the Mechanical application help for more information on conducting a response spectrum analysis in the Mechanical application.

4. On the Toolbar, click Update Project.

**Rigid Dynamics**

You can perform a rigid dynamic analysis that specifically uses the ANSYS Rigid Dynamics solver. This type of analysis is used to determine the dynamic response of an assembly of rigid bodies linked by joints and springs. You can use this type of analysis to study the kinematics of a robot arm or a crankshaft system for example.

You will configure your rigid dynamics analysis in the Mechanical application, which uses the ANSYS Rigid Dynamics solver to compute the solution.
1. Add a Rigid Dynamics analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry.

3. View the geometry by right-clicking on the Model cell and choosing Edit, or double-clicking the Model cell. Alternatively, you can right-click the Setup cell and select Edit. This step will launch the Mechanical application.

4. In the Mechanical application window, complete your transient structural analysis using the Mechanical application's tools and features. See Rigid Dynamics Analysis in the Mechanical application help for more information on conducting a Rigid Dynamics analysis in the Mechanical application.

**Static Structural**

A static structural analysis determines the displacements, stresses, strains, and forces in structures or components caused by loads that do not induce significant inertia and damping effects. Steady loading and response conditions are assumed; that is, the loads and the structure's response are assumed to vary slowly with respect to time.

You will configure your static structural analysis in the Mechanical application, which uses the ANSYS, ABAQUS, or Samcef solver, depending on which system you selected, to compute the solution.

1. Add a static structural analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry.

3. View the geometry by right-clicking on the Model cell and choosing Edit, or double-clicking the Model cell. Alternatively, you can right-click the Setup cell and select Edit. This step will launch the Mechanical application.

4. In the Mechanical application window, complete your static structural analysis using the Mechanical application's tools and features. See Static Structural Analysis in the Mechanical application help for more information on conducting a structural analysis in the Mechanical application.

**Steady-State Thermal**

You can use a steady-state thermal analysis to determine temperatures, thermal gradients, heat flow rates, and heat fluxes in an object that are caused by thermal loads that do not vary over time. A steady-state thermal analysis calculates the effects of steady thermal loads on a system or component. Engineers often perform a steady-state analysis before performing a transient thermal analysis, to help establish initial conditions. A steady-state analysis also can be the last step of a transient thermal analysis, performed after all transient effects have diminished.

---

**Important**

By default, the application does not write thermal gradient results to the result file. To have these results written to the results file, use a Command object and insert the command OUTRES,ERASE.

You will configure your steady-state thermal analysis in the Mechanical application, which uses the ANSYS, ABAQUS, or Samcef solver to compute the solution.
1. Add a steady-state thermal analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry.

3. View the geometry by right-clicking on the Model cell and choosing Edit, or double-clicking the Model cell. Alternatively, you can right-click the Setup cell and select Edit. This step will launch the Mechanical application.

4. In the Mechanical application window, complete your steady-state thermal analysis using the Mechanical application's tools and features. See Steady-State Thermal Analysis in the Mechanical application help for more information on conducting a steady-state thermal analysis in the Mechanical application. See the Thermal Analysis Guide for more information on thermal analyses using the Mechanical APDL application.

**Thermal-Electric**

A Steady-State Thermal-Electric Conduction analysis allows for a simultaneous solution of thermal and electric fields. This coupled-field capability models joule heating for resistive materials as well as Seebeck, Peltier, and Thomson effects for thermoelectricity.

You will configure your thermal-electric analysis in the Mechanical application, which uses the ANSYS solver to compute the solution.

1. Add a thermal-electric analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry.

3. View the geometry by right-clicking on the Model cell and choosing Edit, or double-clicking the Model cell. Alternatively, you can right-click the Setup cell and select Edit. This step will launch the Mechanical application.

4. In the Mechanical application window, complete your thermal-electric analysis using the Mechanical application's tools and features. See Thermal-Electric Analysis in the Mechanical application help for more information on conducting a thermal-electric analysis in the Mechanical application.

**Topology Optimization**

Using a Topology Optimization analysis, you compute an optimal structural design of your geometry for a selected region of your model with specified design objectives and constraints. The topology optimization is a physics driven optimization tool that is based on a set of loads and boundary conditions provided by a preceding Static Structural analysis or a Modal analysis or combination of static and modal analyses.

If necessary, you configure the environmental conditions of a Topology Optimization analysis in the Mechanical application. Use the following steps to create the analysis and import your model into Mechanical.

**Single Upstream System:**

1. Add a Static Structural or Modal analysis by dragging the corresponding system from the Toolbox into the Project Schematic or by double-clicking the system in the Toolbox.
2. Perform the appropriate steps to setup the Static Structural or Modal analysis by importing the Geometry, creating a mesh, adding the appropriate loads and boundary conditions, solving the problem, and adding the appropriate results to review.

3. From the Static/Modal analysis system, right-click the **Solution** cell and select **Transfer Data to New > Topology Optimization**.

   Or...

   Drag and drop a **Topology Optimization** system onto the **Solution** cell of the Static Structural or Modal system.

   Or...

   Drag and drop a **Topology Optimization** system onto **Model** cell of the Static Structural or Modal system.

4. If necessary, link the **Solution** cell of the Static Structural or Modal analysis to the **Setup** cell of the **Topology Optimization** system.

   The new **Topology Optimization** system shares the **Engineering Data**, **Geometry**, and **Model** cells with the same cells of the preceding Static Structural/Modal system and the **Solution** cell of Static Structural/Modal system links to the **Setup** cell of the **Topology Optimization** system.

   ![Project Schematic](image)

   **Note**

   Once you link the analyses, automatic property specifications will be made in Mechanical to define the relationship between the systems.

5. Import the model into Mechanical by right-clicking the **Setup** cell and selecting **Edit** or by double-clicking the **Setup** cell to launch Mechanical.

6. In the Mechanical application window, complete your analysis using the Mechanical application's tools and features. See the **Topology Optimization** section of the Mechanical Help for the steps to conduct a **Topology Optimization** analysis.
Multiple and/or Combined Upstream Systems

1. Add a Static Structural or Modal analysis by dragging the corresponding system from the Toolbox into the Project Schematic or by double-clicking the system in the Toolbox.

2. Perform the appropriate steps to setup the Static Structural or Modal analysis by importing the Geometry, creating a mesh, adding the appropriate loads and boundary conditions, solving the problem, and adding the appropriate results to review.

3. From the Static/Modal analysis system, right-click the Solution cell and select Transfer Data to New > Topology Optimization.

   Or...

   Drag and drop a Topology Optimization system onto the Solution cell of the Static Structural or Modal system.

   Or...

   Drag and drop a Topology Optimization system onto Model cell of the Static Structural or Modal system.

4. If necessary, link the Solution cell of the Static Structural or Modal analysis to the Setup cell of the Topology Optimization system.

   The new Topology Optimization system shares the Engineering Data, Geometry, and Model cells with the same cells of the preceding Static Structural/Modal system and the Solution cell of Static Structural/Modal system links to the Setup cell of the Topology Optimization system.

---

Note

Once you link the analyses, automatic property specifications will be made in Mechanical to define the relationship between the systems.

---

5. Drag and drop a new Static Structural or Modal analysis onto the Model cell of the existing Static Structural or Modal analysis.
6. Link the Solution cell of the newly added Static Structural or Modal analysis to the Setup cell of the existing Topology Optimization analysis. All analyses link as illustrated below.

7. Import the model into Mechanical by right-clicking the Setup cell and selecting Edit or by double-clicking the Setup cell.

8. In Mechanical, complete your analysis using the application's tools and features. See the Topology Optimization section of the ANSYS Mechanical User's Guide for the steps to conduct a Topology Optimization analysis.

**Throughflow and Throughflow (BladeGen)**

The Throughflow analysis system contains cells for conducting a study with Vista TF starting with the geometry and ending with a report. Essentially, Throughflow is a Vista TF system with an added Geometry cell, whereas Throughflow (BladeGen) is a Vista TF system with an added Blade Design cell. For details on the Vista TF system, see Vista TF (p. 300).

**Transient Structural**

You can perform a transient structural analysis (also called time-history analysis) that specifically uses the ANSYS Mechanical solver. This type of analysis is used to determine the dynamic response of a structure under the action of any general time-dependent loads. You can use it to determine the time-varying displacements, strains, stresses, and forces in a structure as it responds to any transient loads. The time scale of the loading is such that the inertia or damping effects are considered to be important. If the inertia and damping effects are not important, you might be able to use a static analysis instead.

You will configure your Transient Structural analysis in the Mechanical application, which uses the ANSYS, ABAQUS, or Cemcef solver to compute the solution.

1. Add a Transient Structural analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the Geometry cell and choosing Import Geometry.
3. View the geometry by right-clicking on the **Model** cell and choosing **Edit**, or double-clicking the **Model** cell. Alternatively, you can right-click the **Setup** cell and select **Edit**. This step will launch the Mechanical application.

4. In the Mechanical application window, complete your transient structural analysis using the Mechanical application's tools and features. See **Transient Structural Analysis** in the Mechanical application help for more information on conducting a transient structural analysis in the Mechanical application.

**Transient Thermal**

Transient thermal analyses determine temperatures and other thermal quantities that vary over time. The variation of temperature distribution over time is of interest in many applications such as with cooling of electronic packages or a quenching analysis for heat treatment. Also of interest are the temperature distribution results in thermal stresses that can cause failure. In such cases the temperatures from a transient thermal analysis are used as inputs to a static structural analysis for thermal stress evaluations. Many heat transfer applications (such as heat treatment problems, electronic package design, nozzles, engine blocks, pressure vessels, and so on) involve transient thermal analyses.

You will configure your transient thermal analysis in the Mechanical application, which uses the ANSYS, ABAQUS, or Samcef solver to compute the solution.

1. Add a transient thermal analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.

2. Load the geometry by right-clicking on the **Geometry** cell and choosing **Import Geometry**.

3. View the geometry by right-clicking on the **Model** cell and choosing **Edit**, or double-clicking the **Model** cell. Alternatively, you can right-click the **Setup** cell and select **Edit**. This launches the Mechanical application.

4. In the Mechanical application window, complete your transient thermal analysis using the Mechanical application's tools and features. See **Transient Thermal Analysis** in the Mechanical application help for more information on conducting a transient thermal analysis in the Mechanical application. See the **Thermal Analysis Guide** for more information on thermal analyses using the Mechanical APDL application; specifically, for more information on time stepping, see the discussion on **general load step options**.

**Turbomachinery Fluid Flow**

The Turbomachinery Fluid Flow analysis system contains cells for conducting a study with ANSYS CFX starting with the mesh and ending with a report. Turbomachinery Fluid Flow is essentially a CFX system with an added **Turbo Mesh** cell. For details on the CFX system, see CFX (p. 203).

**Component Systems**

Component systems enable you to launch and use familiar stand-alone editors to build a project. They usually do not include all components and steps necessary to achieve an analysis system; however, if you are familiar with a particular application, you can use your product knowledge to complete an analysis.

Component systems available with ANSYS Workbench include the following. Systems will be available only if you have installed the product and have an appropriate license.

- **Autodyn**
- **BladeGen**
When you double-click or drag a component system onto the Project Schematic, you will see that type of system.

**Autodyn**

You can use the Autodyn system to launch the standalone Autodyn application. This application supports the full range of Autodyn capabilities including the Explicit Eulerian solvers, meshfree SPH solvers, and explicit solver coupling (FSI).

---

**Note**

The Explicit Dynamics analysis system supports the FE components of the Autodyn solver.

---

**Input Files**: The Autodyn system takes the binary database (.ad) file as input.

**Output Files**: Files that are produced by all Autodyn runs. Primary output files include:

- Results file (.adres) for postprocessing
- Save file (admodel_cycle.adres) for postprocessing and database modification during a run
- History data files (.his,.sum) that record time dependant data at gauge locations and summary data for materials/parts
- Print file (.prt) recording a text summary of the model definition and results
• Log file (.log) listing solution information and warnings or errors encountered

**Working with an Autodyn Analysis**

To add an Autodyn analysis to your project, double-click the Autodyn object or drag-and-drop it from the Component Systems area of the Toolbox into the Project Schematic. An Autodyn system appears in the Project Schematic.

You can connect other systems to an Autodyn system by using the Transfer Data From New context menu options. When transferring data to an Autodyn system from another system, you can transfer data to the Setup cell from two locations:

• **Setup** cell of an analysis system (most commonly an Explicit Dynamics system)

• **Mesh** cell of a Mesh component system

In both cases, you must update the Setup/Mesh cell after connecting to the Autodyn Setup cell. This update operation produces a CAERep.xml file that can subsequently be consumed by the Autodyn Setup cell.

To launch Autodyn interactively, right mouse-click and select Edit Model or New Model.

To launch Autodyn with input and reference files specified, right mouse-click the Setup cell and select Import Model. Then select Edit Model. Autodyn will launch in interactive mode, and the input file(s) specified will be loaded.

**ANSYS Autodyn Context Menu Options**

The Autodyn system contains two cells:

1. **Setup: Setup** cell context menu options include the following.
   - **New Model**: Opens the Autodyn editor where you can set up a new 2D or 3D Autodyn model, solve, or postprocess results.
   - **Edit Model**: Opens the Autodyn editor and loads in the database currently associated with system. You can then further edit the model, solve, or postprocess results.
   - **Import Model**: Imports an existing Autodyn database (.ad file) into the system. This action will replace any existing database associated with the system. If the import detects that there are other files in the source directory for the model that is being imported, you are presented with the option to import all the associated files.
   - **Select User Executable**: Selects the Autodyn executable file (autodyn.exe) you want to associate with the system and use for subsequent preprocessing, solving, and postprocessing. Typically this option is used to select a user-customized executable.
   - **Transfer New Data From**
     - **Mesh**: Inserts a Mesh component system and generates a link between its Mesh cell and the Autodyn system Setup cell. This option enables the transfer of a mesh from the ANSYS Meshing system into the Autodyn system.
     - **Explicit Dynamics**: Inserts an Explicit Dynamics analysis system and generates a link between its Setup cell and the Autodyn system Setup cell. This option enables the transfer of the initial model
defined in the Explicit Dynamics system or the Autodyn system. The initial model includes materials, mesh, connections, coordinate systems, initial conditions, loads, constraints, and analysis settings.

- **Update**: Update is used to transfer the latest upstream data from the Mesh or Explicit Dynamics system into the Autodyn system.

---

**Note**

Any modifications made in Autodyn to a model that originated from an Explicit Dynamics system are likely to be overwritten during the update process. Items defined in the Explicit Dynamics or Mesh system represent the master version of the data.

---

- **Duplicate, Properties, Rename**: Standard actions as described in Cells in Workbench (p. 312).

2. **Analysis**: Analysis cell context menu items include the following.

- **Duplicate**: Duplicates the Autodyn system. All data associated with the system (including results files) will be copied into a new Autodyn system.

- **Update, Clear Generated Data, Rename**: Standard actions as described in Cells in Workbench (p. 312).

---

**BladeGen**

BladeGen is a component of ANSYS BladeModeler. The BladeModeler software is a specialized, easy-to-use tool for the rapid 3D design of rotating machinery components. Incorporating extensive turbomachinery expertise into a user-friendly graphical environment, the software can be used to design axial, mixed-flow and radial blade components in applications such as pumps, compressors, fans, blowers, turbines, expanders, turbochargers, inducers and others.

BladeModeler provides the essential link between blade design and advanced simulation including computational fluid dynamics and stress analyses. BladeModeler contains a rich set of tools and functions for designing a turbomachinery blade from the very beginning, using industry-specific tools, workflow, and language that you expect.

With BladeGen, you can re-design existing blades to achieve new design goals or create completely new blade designs from the very beginning. When either re-designing or evaluating an existing blade design, BladeGen facilitates the import of blade geometry interactively or through files you supply. BladeGen allows sculpted or ruled element blades with linear or compound lean leading or trailing edges. Over/Under-Filing can be applied and leading and trailing edge shapes are easily specified as a full radius, an ellipse ratio, or a simple cutoff.

BladeModeler represents a pivotal link between blade design, advanced analysis and manufacturing. Used in combination with ANSYS analysis software, you can rapidly evaluate the performance of a component. BladeGen model files can be imported into DesignModeler using the BladeEditor feature. BladeEditor provides a seamless path to both structural and fluid analysis, which enables you to efficiently transition from preliminary blade design, to full 3D viscous flow analysis, and finally to your native CAD system.

To run BladeGen, drag the BladeGen component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox, then edit the F cell. For more information on ANSYS BladeGen, see the ANSYS BladeGen help.
To run BladeEditor, drag the Geometry component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox. Edit the **Geometry** cell to invoke DesignModeler. Inside DesignModeler, BladeEditor features will be available depending on your license preferences. To set the license preferences for running BladeEditor, follow the instructions in Configuring the ANSYS BladeModeler License. For more information on ANSYS BladeEditor, see ANSYS BladeEditor help.

**CFX**

ANSYS CFX enables you to perform fluid-flow analysis of incompressible and compressible fluid flow and heat transfer in complex geometries. You import meshes, specify the materials, boundary conditions, and solution parameters, solve the calculations, view the results, then create reports using built-in tools.

To use ANSYS CFX as a component system in ANSYS Workbench:

1. Add a CFX component system by dragging the system from the Component System Toolbox into the Project Schematic or by double-clicking the system in the Toolbox.

2. Read a mesh and specify the ANSYS CFX physics definitions in CFX-Pre by right-clicking on the **Setup** cell and choosing **Edit**. Alternatively, you can import a previously saved case file by right-clicking the **Setup** cell and choosing **Import Case → Browse**.

3. Right-click the **Solution** cell and choose **Update** to start the solver. Alternatively, right-click the **Solution** cell and select **Edit**, set the solver execution controls in CFX-Solver Manager, and start the solver.

   You can also import an existing CFX-Solver Results file by right-clicking on the **Solution** cell and choosing **Import Solution → Browse**.

4. Analyze the results of the calculations in CFD-Post by right-clicking on the **Results** cell and choosing **Edit**.

For detailed information on working with ANSYS CFX, see ANSYS CFX in ANSYS Workbench in the CFX Introduction.

For information on submitting ANSYS CFX jobs to Remote Solve Manager, see Submitting CFX Jobs to RSM or an EKM Portal.

**Engineering Data**

Use the **Engineering Data** cell with the Mechanical application systems or the Engineering Data component system to define or access material models for use in an analysis.

To add an **Engineering Data** component system to the Project Schematic, drag the Engineering Data component system from the Toolbox to the Project Schematic or double-click the system in the Toolbox.

To add or modify material data, double-click the **Engineering Data** cell to display the Engineering Data tab.

For detailed information on working with Engineering Data, see Engineering Data.

**Explicit Dynamics (LS-DYNA Export)**

1. Add an **LS-DYNA** explicit dynamics analysis template by dragging the template from the Toolbox into the Project Schematic or by double-clicking the template in the Toolbox.
2. View the geometry by right-clicking on the Model cell and choosing Edit. Alternatively, you can right-click the Setup cell and select Edit. This step will launch the Mechanical application.

3. In the Mechanical application window, complete your explicit dynamics analysis setup using the Mechanical application's tools and features. See Explicit Dynamics Analysis in the Mechanical application help for more information on exporting to LS-DYNA using an explicit dynamics analysis in the Mechanical application.

If you have a Mechanical APDL system linked to the LS-DYNA system, and you attempt to launch Mechanical APDL using an ANSYS LS-DYNA license (commercial or academic), you may see the following error in the Mechanical APDL output window:

***FATAL

***Parallel capability is not valid for this product

If you see this message, set the number of processors for Mechanical APDL to 1 (Tools> Options> Mechanical APDL). You will then be able to run Mechanical APDL and solve an ANSYS LS-DYNA analysis.

External Data

The External Data system enables you to import data from text files and feed that data into a Mechanical application or a System Coupling component system. You need to specify the data format in order to process the files in the External Data tab. This information can then be transferred to a downstream Mechanical application where the data can be applied as loads in an analysis.

Note

If the project has an External Data system that consumes files stored within the design point path and multiple design points, updating the multiple design points can cause the project to fail or produce inaccurate data. When a different design point is run, the External Data system will not switch to the new design point's filepath for the files it requires, and cannot be made to do so within an update of multiple design points.

Creating and Configuring an External Data System

To create an External Data system:

1. Drag an External Data system from the Component Systems Toolbox onto the Project Schematic.

2. To display the External Data tab, double-click the Setup cell, or right-click and choose Edit from the context menu.

   You can now add the files in the Outline view.

3. To add files:

   a. In the Location column, you may browse to local files using the Browse option or to files stored on an EKM repository using the Browse from Repository option. For more information on Browse from Repository, see Importing Repository Files (p. 174).
When you click **Open**, the selected file names, locations, and identifiers are automatically displayed in the **Data Source** column. You can enter descriptions for the files in the **Description** column.

---

**Note**

Importing files from design point folders within the same project directory (with the exception of the Current design point) is not supported.

---

**Table 5: Data Source View: Definition Section**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Identifier</td>
<td>A string that can be used to identify the file in the downstream Mechanical application.</td>
</tr>
<tr>
<td>Master</td>
<td>Enables you to choose a master file so that the system displays and uses the <strong>Properties</strong> for this file only. The nodal coordinate data for the selected master file will be processed by the Mapping Utility. Any nodal coordinate data contained in non-master files will be skipped. You can select only one file to be the master file. If you multi-select a master file and non-master files, the <strong>Dimension</strong>, <strong>Length Unit</strong> and <strong>Transformation</strong> properties in the <strong>Properties &gt; Definition</strong> view will be hidden. If you duplicate the master file, only one instance will be designated as the master file.</td>
</tr>
<tr>
<td>Description</td>
<td>Text that describes the file to you and to other users.</td>
</tr>
</tbody>
</table>

---

b. Optionally, you can right-click a file (or files) in the **Outline** view and use the context menu to duplicate them.

All files—whether imported or duplicated—can be sorted or filtered.

c. Once the files have been added, use the **Properties** view to input the information required to process the file and apply the data in the Mechanical application.

If you select multiple files in the **Data Source** column, the **Properties** view displays:

- A value when that value is the same for all selected files
- A blank field when values differ between selected files
- A yellow field when a value is required, but not currently specified for at least one of the files.

If you edit any field in the **Properties** view when multiple files are selected, your change is applied to all files.

---

**Note**

Although you can multi-select files in the **Data Source** view, when you click away from that view the highlighting applied to those files disappears. However, the files
remains selected and operations subsequently performed will be applied to all of
the selected files.

### Table 6: Properties of File: Definition Section

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>You can choose to either import data from 2D or 3D models. If the 2D option is selected, you will be able to import data only at the X and Y coordinates. The Z coordinate is not supported for the 2D option.</td>
</tr>
<tr>
<td>Start Import at Line</td>
<td>The line number at which you want the data import to start. Line numbers start at 1.</td>
</tr>
<tr>
<td>Format</td>
<td>Choose either:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Delimited</strong> causes the Delimiter Character field to appear, which enables you to specify the character that delimits data elements in a line. The options are Comma, Semicolon, Space, Tab, or User-Defined. The latter choice enables you to specify any character as the data delimiter.</td>
</tr>
<tr>
<td></td>
<td>• <strong>User-Defined</strong> enables you to specify the format specification for the file. The allowed format specifiers are given below.³</td>
</tr>
<tr>
<td>Length Unit</td>
<td>The unit system in which source point locations are defined.</td>
</tr>
<tr>
<td>Coordinate System Type</td>
<td>Specifies the nature of the source point locations. Options include Cartesian (X, Y, Z) or Cylindrical (R, theta, Z). The default value is Cartesian.</td>
</tr>
<tr>
<td>Average Data at Midside Nodes</td>
<td>If Yes, the data at Midside nodes, if not specified, is calculated as average of data specified at corner nodes.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong></td>
</tr>
<tr>
<td></td>
<td>This property is only available when <strong>Format Type</strong> is <strong>Delimited</strong> or <strong>User Defined</strong> and <strong>cdb</strong> file is chosen as <strong>Master</strong>.</td>
</tr>
<tr>
<td>Material Field Data</td>
<td>In order to map values from an external user-defined file to the nodes or elements of your model, activate (check) this property. Once active, Field Variables become available in the <strong>Data Type</strong> drop-down menus in the <strong>Table of File</strong> pane of the <strong>Setup</strong> tab.</td>
</tr>
</tbody>
</table>

³The format specification used here is drawn from the C format specification.

### Table 7: Properties of File: Analytical Transformation Section

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X/Y/Z Coordinate</td>
<td>Enables you to apply scaling factors or functions to the corresponding column <strong>Data Type</strong> selected in the <strong>Table of File</strong> view. For example, to scale all values for the X Coordinate column by 90%, change the X Coordinate text entry to x*0.9.</td>
</tr>
</tbody>
</table>
When the Coordinate System Type is cylindrical, the X Coordinate will refer to the radius and the Y Coordinate refers to the angle. By default, each X, Y, and Z Coordinate is set to x, y, and z.

For a complete list of supported functions, see Parameters. For an example, see Source Point Analytical Transformations (p. 219).

---

**Note**

When the Dimension type is 2D, the Z Coordinate is not shown.

Rotations, resulting from specified analytical transformations, do not get applied to mapped data (pressure, displacement, force) in a downstream Mechanical system.

---

### Table 8: Properties of File: Rigid Transformation Section

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Origin X/Y/Z and Theta X/Y/Z/X</td>
<td>Enables you to apply a coordinate transformation to the source points. The source locations are transformed by the coordinate system defined by the Origin and Theta entries. For example, applying an X value of .1 meters would modify the x locations of all the source points by adding .1 meters to their values. The option Display Source Points on an imported load object inside Mechanical respects this transformation and can be very helpful in assuring proper alignment between the source and target points. This option is useful if the source points are defined with respect to a coordinate system that is not aligned with the target geometry system.</td>
</tr>
</tbody>
</table>

---

**Note**

Rotation transformations (Theta X/Y/Z/X) specified in the External Data system will be applied to the mapped data (pressure, displacement, force) in a downstream Mechanical system. Prior to release 14.5, rotation transformations were not applied.

---

### Table 9: Allowed Format Specifiers

<table>
<thead>
<tr>
<th>Type</th>
<th>Specifier</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal floating point</td>
<td>F or f</td>
</tr>
<tr>
<td>Scientific notation (exponent) using E/e character</td>
<td>E or e</td>
</tr>
<tr>
<td>Signed decimal integer</td>
<td>D or d</td>
</tr>
</tbody>
</table>
In the example below, the line has one integer followed by four exponential data types.

The corresponding format is

```
113,4e17.9
```

**Where:**

- The first entry is the number of occurrences
- The second entry is the format specifier (from Table 9: Allowed Format Specifiers (p. 207))
- The third entry is the number of characters of data in the definition (including numeric values (0-9), the letter 'e' (for instances of scientific notation), and any white space and + or - signs)
- The fourth entry is the number of digits after the decimal point.

**Tip**

By default, Excel puts a minus sign at the beginning of a negative number but it does not put a plus sign at the beginning of a positive number, which changes the number of characters in the negative version of a number. However, if you select a column in Excel and apply a custom format, you can have a plus sign added to positive numbers. In Excel's Format Cells dialog box, set the Type with an example of the format for a positive number and a negative number, separating the two types with a semicolon. For example:

```
+00.00E+00;−00.00E+00
```
• Z Coordinate
• Element ID
• Node ID
• Temperature

• Heat Generation
• Thickness
• Displacement
• Body Force Density

**Note**

- The **Node ID** field is useful when the nodal locations and values on nodes are specified in different files, as is the case when one of the files is specified as "Master". They are not meant to apply the values directly on the nodes of the target mesh. If a file is set up without specifying the nodal locations (X/Y/Z), all the points from the file default to (0,0,0). Similarly, the **Element ID** field is useful only when used in conjunction with a CDB file.

- **Thickness** uses the **Length Data Unit** and the **Data Identifier** should start with **Thickness**.

**Tip**

You can multi-select rows (from the left-most column in the **Table of File** view), then right-click to set all highlighted Data Type values or Data Unit values (where applicable) at the same time.

Column data is ignored if the **Data Type** is set to Not Used.

When **Coordinate System Type** is set to **Cartesian** in the **Properties** view, the **Data Unit** cell for the X, Y, and Z Coordinates will be read-only in the **Table of File** view. When **Coordinate System Type** is set to **Cylindrical**, the **Data Unit** cell for the Y will have a combo box that can specify its **Data Unit** string (either as **Degrees** or **Radian**).

You can change the data identifier from the default string for allowed data types. The data identifiers are appended to the file identifier, specified in the **Properties** view, so that you can pick the correct source data in the downstream Mechanical application.

A preview of the file is shown in the **Preview** view. The first ten imported lines are shown.

When you multi-select files, the **Preview** view is disabled and the **Table of File** view displays data in columns that you can sort and filter from the down arrow beside each column heading.

5. The **Setup** cell of the **External Data** system can be linked to a **Model** cell or to a **Setup** cell of a Mechanical system (except for Rigid Dynamics Systems).
You can modify any file in the **Outline** view by browsing to a new file using the browse option provided in the **Location** column.

**Note**

If you modify an **External Data** system's data file outside of Workbench, you need to cause Workbench to re-read the data file: right-click the **Setup** cell and select **Re-read Input Files**.

Note that the **Re-read Input Files** operation will cause Workbench to regard the file as having changed whether the file has changed or not, and the status of the **Setup** cell will change appropriately.

You can also delete files that you have selected (or multi-selected) by right-clicking one of the files in the **Outline** view and then choosing **Delete** from the context menu.

To add a downstream Mechanical system, either drag a valid analysis system from the Toolbox and drop it on the appropriate **Setup** cell of the **External Data** system, or right-click the **Setup** cell and choose the **Transfer Data To New** context menu option.

For additional information for using the data in a downstream Mechanical application, refer to **External Data Import**.

### Importing a Trace File into a Mechanical Model Cell

To import a circuit board's trace layout file (ODB++ TGZ, Ansoft ANF, Cadence BRD, MCM, SIP, BOOL + INFO, or Icepak COND + INFO) for use by a Mechanical system's Model cell, add an **External Data** component to your project, then edit its Setup cell. In the Outline view, select the trace file as the data source.

The **External Data** component enables you to perform rigid transformations to the trace file. When any required transformations are complete, drag the **External Data** Setup cell to a Mechanical system's Model cell.

**Note**

- If you import a project from Release 16 that has an External Data system, you will not immediately be able to load in trace files. In order to import a trace file, you must delete the connection between the External Data Setup cell and the downstream Model cell, and then recreate the connection. The new connection will support the transfer of trace files.

- For trace-file imports, the **Table** and **Preview** panes are disabled.

**Prerequisites**

- BRD/MCM/SIP import uses your Cadence installation and accesses local environment variables. These environment variables were automatically set during the Cadence installation. If you access Cadence from your network, not locally, you need to set additional environment variables as described below.

- If your Cadence installation is located in the mapped network location \V:\SPB_16.6, add the following variables:
  
  → set CDSROOT=\V:\SPB_16.6
To import a Mechanical APDL-generated CDB file as a source file using the External Data component, select a file or files from the Location field in the Outline. Once selected, the Format Type property is automatically set to .cdb.

CDB files have certain restrictions:

- The Start Import at Line setting is disabled as the entire file is read as data. Delimiter Type, Delimiter Character, and Format String are also disabled.

- The data is always in the Cartesian global frame-of-reference.

- The Table and Preview panes are disabled, so you cannot specify data types or preview data.

Mechanical APDL CDB files can be added as a master mesh in the External Data system. The file must be generated using ‘blocked’ formatting (see CDWRITE in the Mechanical APDL Command Reference). Files generated in unblocked format are not supported. Only NBLOCK and EBLOCK data will be read from the file. Elements defined in the EBLOCK command should also have a corresponding element type and number (ET command) defined in the CDB file. No load/data transfer information is read.

The following element types are ignored during reading of the file:

- Solid168
- Targe169,170
- Conta171,172,173,174,175,176,177,178
- SURF152,153,154,156

Data transfer information must be defined in separate files, which will also need to be added to the same External Data system. These files must have a column providing node identifiers that match the node IDs defined in the Mechanical APDL CDB file. If the data transfer file contains element nodal values, then both node and element identifier columns need to be defined. Element values are not supported.

**Note**

- An element defined in the CDB file will be ignored by the common mapping utility if any of the below conditions exist. The ignored elements will not be used when data is mapped in the downstream application.

  - One or more of the nodes forming the element are not defined in the NBLOCK command.
The element does not have a corresponding element type and number (ET command) defined in the CDB file.

**Note**

- CDB files must contain only solid elements or shell elements, but not both.
- For nodal data transfers, the number of nodes in the Mechanical APDL CDB file must match the number of data transfer items in all slave files.
- If data is not available at midside nodes, then the **Average Data at Midside Nodes** property can be used to specify the data at midside nodes as an average of data at corner nodes.

---

**Importing an ANSYS External Data File as Input**

To import an .axdt file as a source file, select **Data Sources > Location**. When you specify an ANSYS External Data file, the **Format Type** is automatically set to **ANSYS External Data File**. Also, the **Length Unit** property will not be available because this information is specified in the file. All length unit information in the .axdt file must be the same (all meters, for example).

ANSYS External Data files have the restriction that the **Start Import at Line** setting is disabled as the entire file is read as data. **Delimiter Type**, **Delimiter Character**, and **Format String** are also disabled.

This file format is described in the next section.

**ANSYS External Data File Format**

CFD-Post and the Mechanical application can export data files (.axdt) that can be used by the **External Data** system. Note that the Mechanical application does not export temperature data in units of K. The following is an example of an .axdt file that has been exported from CFD-Post:

```
[Name]
Plane 1

[Data]
X [m] (X coordinate), Y [m ] (Y coordinate), Z [ m ] (Z coordinate),
Wall Heat Transfer Coefficient [W m^-2 K^-1] (Heat Transfer Coefficient),
Wall Adjacent Temperature [K] (Temperature)
-1.77312009e-02, -5.38203605e-02, 6.00000024e-02, 7.12153496e-06, ...
-1.77312009e-02, -5.79627529e-02, 5.99999949e-02, 5.06326614e-06, ...
  .

[Faces]
369, 370, 376, 367
350, 374, 367, 368
```

This file contains three blocks, each with one of the labels: **[Name]**, **[Data]** and **[Faces]**. The **[Name]** block contains the name of the region contained/defined in the file.

The **[Data]** block contains node coordinates and values. The first line following the **[Data]** label is a header that contains a comma separated list of unique labels, units and quantity type for coordinates.
and values at each node. Units are contained in square brackets and quantity types are contained in parentheses. Subsequent lines, one per node, contain a comma separated list of data defined in the header. The [Data] block ends in the line before the [Faces] block label.

The [Faces] block contains definitions for topologically two-dimensional faces (small surfaces), each by 3 (triangle) or 4 (quadrilateral) points. The points must be ordered to trace a path going around the face. For proper rendering, the faces should have consistent point ordering, either clockwise or counterclockwise. Each face is automatically closed by connecting the last point to the first point. Face connectivity data is listed in the [Faces] block and references the points in the [Data] block, where the latter are implicitly numbered, starting with 0.

**Importing Multiple Data Sets**

External Data can be configured to efficiently import multiple data sets (for example, from a transient analysis). It can handle multiple sets through a single file or via multiple files.

This section will guide you through the steps to set up such an analysis:

1. Create the External Data system by double-clicking External Data in the Component Systems toolbox. An External Data system appears in the Project Schematic.

2. Double-click the External Data system’s Setup cell to edit it. The Outline view, Properties view, and Table view appear.

3. Using the Outline view, choose the data files. You can:
   - Perform multiple file add operations in the Outline view.
   - In the Location column, click the browse icon (circled in the figure that follows), multi-select files in the Open File(s) dialog box that appears, and click Open.
If you have a list of fully-qualified paths to the files you want, you can copy the list from a text file or an Excel file and paste it into the Outline view's Data Source field.

To paste from a flat-text editor such as Notepad:

1. List the paths to the files in the editor. Ensure that there are no trailing spaces in the lines.
2. Select all the files and copy them (Ctrl+A, then Ctrl+C)
3. In the Outline view, click the asterisk. The line becomes highlighted, and the text **Click here to add a file** remains visible.
4. Press **Ctrl+V** to add the files.

4. In the **Properties** view, set the properties of the files. If the files are of the same or similar format, you can make use of multi-selection of the files for quick settings of common properties:

   a. Multi-select the desired files in the **Outline** view. You will see:
      
      - A value when that value is the same for all selected files.
      - A blank field when values differ between selected files.
      - A yellow field when a value is required, but is not currently specified for any of the files.
If you edit any field in the Properties view when multiple files are selected, your change is applied to all files.

b. If the X, Y, Z locations of the source points is common between all the files, you can make use of the "Master" Designation. By designating a "Master" file, all other files will use that file's values for the X, Y, Z locations. This leads to faster user interface set up, as well as much faster mapping times as the mapping weight calculations need to be done only once and then are shared for all slave files.

5. Use the Table view (which is populated from the Format String field in the Properties view) to specify the Column data in the file.

Here again you can make use of multi-selection of the files in order to fully populate the Table view. You can span data from all selected files and use various right-mouse button actions to efficiently define the column data.
a. In the **Outline** view, multi-select the desired files.

b. In the **Table** view, sort the table by **Column** to efficiently order the file data. For example, if you have four data fields and the first three specify the X, Y, Z locations, sorting by column will place the remaining data-field entries together at the bottom of the column.

c. Select all the rows for which you want to change data:

   i. Select the first row to be changed by clicking on the *row number* (which is in the table boundary).
   
   ii. Press and hold **Shift** key.
   
   iii. Select the last row to be changed by clicking on the row number.
   
   iv. Right-click anywhere over the selected cells, choose **Set Data Type To**, and set the desired data type. Repeat as required to set the data units via **Set Unit To**.

---

**Tip**

If **Set Data Type To** or **Set Unit To** are not available, ensure that your mouse cursor is over the body of the table, not on the table boundary.
6. Select and copy the cell entries in the **Combined Identifier** Column that correspond to the multiple data sets (using **Ctrl+C** or right-click and select **Copy**). These data-identifier strings will be used to specify which data set will be imported at each load step inside Mechanical.

7. Link the External Data system into the desired Mechanical system/cell.

8. Update the External Data system.

9. Edit (or, if editor is already open, Refresh) the Mechanical system.

10. Set the desired **Number Of Steps** in Mechanical's **Analysis Settings** object. Set the step end times as desired (you can copy and paste).

11. As needed, create the desired **Imported Load/Thickness** in Mechanical.
12. Select the **Imported Object**, then paste the data identifier text into the appropriate cells inside the **Data view** on the imported object.

13. As required, copy and paste the desired step end times on the **Analysis Settings Object** and the **Imported Data Object** (in the **Analysis Time(s)** column).

14. Right-click **Import Load** to invoke the mapping calculations.

15. After mapping has completed, you can review the various mappings by adjusting the **Active Row** entry in the details view. The graphics will render a contour plot of the imported data at the specified row. Additionally, this data can be exported out of Mechanical by right-clicking the tree object and selecting **Export**.

**Source Point Analytical Transformations**

Analytical transformation options can be applied to the source nodal locations. You can enter constant or functional values that will be applied to the x, y, and z (or r, theta, z for cylindrical) values read from the input file from within the External Data User Interface. For a complete list of supported functions, go to **Expressions, Quantities, and Units** (p. 125). The order of operations for conversion of the original node locations into a format the common mapping utility uses must be taken into consideration when setting up analytical transformation functions, rotation, and translation information.

The nodal data, as well as any unit system information, is read into the common mapping utility. If any nodal analytical transformation values or functions are provided, they are applied directly to the nodal coordinates as they are read in from the file. If the data is provided in a cylindrical system, it is converted into Cartesian coordinates. Once the nodes are in Cartesian, all nodal data is converted into MKS, so that the mapping utility stores all data in the same unit system. If any rotational information is provided, this is applied next, followed by any translations.

The following example takes nodal data, written in a cylindrical system, from a ring with an inner radius of 8 mm and an outer radius of 10 mm and allows an analytical transformation value to be applied to the radius of the source data, such that it aligns with a smaller ring with an inner radius of 7.2 mm and an outer radius of 9 mm.

Thermal results on an expanded or stretched ring (inner radius is 8 mm and outer radius is 10 mm)
Sample cylindrical nodal data:

<table>
<thead>
<tr>
<th>Node Number</th>
<th>Radius (mm)</th>
<th>Theta (radians)</th>
<th>Z Location (mm)</th>
<th>Temperature (°C)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>8.914523065</td>
<td>-0.247535105</td>
<td>1.6</td>
<td>99.983</td>
</tr>
<tr>
<td>2</td>
<td>8.914523065</td>
<td>-0.247535105</td>
<td>1.2</td>
<td>99.984</td>
</tr>
<tr>
<td>3</td>
<td>8.914523065</td>
<td>-0.247535105</td>
<td>0.8</td>
<td>99.984</td>
</tr>
<tr>
<td>4</td>
<td>8.914523065</td>
<td>-0.247535105</td>
<td>0.4</td>
<td>99.983</td>
</tr>
<tr>
<td>5</td>
<td>8.917873803</td>
<td>-0.192647608</td>
<td>1.6</td>
<td>99.983</td>
</tr>
<tr>
<td>6</td>
<td>8.917873803</td>
<td>-0.192647608</td>
<td>1.2</td>
<td>99.984</td>
</tr>
<tr>
<td>7</td>
<td>8.917873803</td>
<td>-0.192647608</td>
<td>0.8</td>
<td>99.984</td>
</tr>
<tr>
<td>8</td>
<td>8.917873803</td>
<td>-0.192647608</td>
<td>0.4</td>
<td>99.983</td>
</tr>
<tr>
<td>9</td>
<td>8.927166575</td>
<td>-0.137916029</td>
<td>1.6</td>
<td>99.983</td>
</tr>
</tbody>
</table>

If we simply import the nodal data, you can see how the source nodes are not contained within the target volume.

Imported temperature load with unmodified source points displayed:
Within the External Data System user interface, you can enter analytical transformation values as either constants, or as functions of \( x \), \( y \), or \( z \). For our example, we want to scale the source radius (that is, X Coordinate) by 90%.

Applying a constant analytical transformation scale factor to the radius (that is, X Coordinate) of the cylindrical source nodal locations:
<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Property</td>
<td>Value</td>
<td>Unit</td>
</tr>
<tr>
<td>2</td>
<td><strong>Definition</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Dimension</td>
<td>3D</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Start Import At Line</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Format Type</td>
<td>Delimited</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Delimiter Type</td>
<td>Tab</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Delimiter Character</td>
<td>Tab</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Length Unit</td>
<td>mm</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Coordinate System Type</td>
<td>Cylindrical</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td><strong>Analytical Transformation</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>X Coordinate</td>
<td>x=9.9</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Y Coordinate</td>
<td>Y</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Z Coordinate</td>
<td>Z</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td><strong>Rigid Transformation</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Origin X</td>
<td>0</td>
<td>m</td>
</tr>
<tr>
<td>16</td>
<td>Origin Y</td>
<td>2</td>
<td>mm</td>
</tr>
<tr>
<td>17</td>
<td>Origin Z</td>
<td>0</td>
<td>m</td>
</tr>
<tr>
<td>18</td>
<td>Theta XY</td>
<td>0</td>
<td>radian</td>
</tr>
<tr>
<td>19</td>
<td>Theta YZ</td>
<td>90</td>
<td>degree</td>
</tr>
<tr>
<td>20</td>
<td>Theta ZX</td>
<td>0</td>
<td>radian</td>
</tr>
</tbody>
</table>

Updating the schematic and looking at the imported load we see the analytical transformation value has been applied to the nodal locations and now coincides with the target model.

Imported temperature load with "transformed" source points displayed:
Importing the load generates the following imported load:
Performing System Coupling Simulations Using External Data

You can use Workbench to perform coupled simulations using multiple Analysis or Component Systems. The External Data System may be used as a source of static (that is, unchanging) data for other co-simulation participants such as ANSYS Fluent or ANSYS Mechanical, as described in the System Coupling Guide.

System Coupling’s tutorial Heat Transfer from a Heating Coil is an example of a coupled analysis using External Data. To access tutorials and their input files on the ANSYS Customer Portal, go to http://support.ansys.com/training.

External Data System and System Coupling Configuration

Each External Data system that is connected to the System Coupling system is represented as a coupling participant in the System Coupling setup. The name of this participant will be the name of the External Data system specified in the Workbench Project Schematic. Note that since the External Data system acts as a source of static data, it can only be defined as the source in System Coupling’s Data Transfer definition.

Each input file added to an instance of the External Data system is represented as a coupling region for the associated coupling participant in the System Coupling setup.

Supported Input File Formats

In order to use the External Data system as a coupling participant, the "ANSYS External Data File" file format should be used. For information regarding use of this file format, see Importing an ANSYS External Data File as Input (p. 212).
Supported Data Types

Data Types provided by External Data that are currently consumable by the System Coupling system include Temperature and Heat Rate.

Note that in the XML file transferred from the External Data System to System Coupling, if the units of the coordinates in are not all consistent, an error will be reported.

External Model

The External Model system enables you to import finite element models created outside of Workbench such as models created in Mechanical APDL, Abaqus, or NASTRAN. External Model supports the following file formats for import:

- Mechanical APDL common database (.cdb)
- Abaqus Input (.inp)
- NASTRAN Bulk Data (.bdf, .dat, .nas)
- Fluent Input (.msh, .cas)
- ICEM CFD Input (.uns)

Important

Note the following Workbench support limitations when importing Abaqus Input files:

- Parts and Assemblies are not supported. That is:
  - Only the data from the very first *Instance command is read by External Model. All other data from any additional *Instance command is ignored.
  - The element and node sets, as well as the materials, that are associated with the first *Instance command are processed. Any data that follows the first *End Part or *End Instance commands is ignored.

- Workbench does not support keywords that generate additional items, such as keyword *NGEN. The commands *NSET, *ELSET, and *NODAL THICKNESS are the only commands that support the Generation parameter.

- Only the first load step of the Abaqus file is read by External Model.

Geometry

For these file type, you can import solid, shell, and line body finite element meshes. These meshes can then be imported directly into ANSYS Mechanical. The Geometry is automatically synthesized and made available inside Mechanical.

Refer to the Importing Mesh-Based Geometry section of the Mechanical Help for additional information about how to process and with imported geometry data.
**Finite Element Data**

For Mechanical APDL common database (.cdb), Abaqus Input (.inp), and Nastran Bulk Data (.bdf, .dat, .nas) files, you can import the following finite element data for use within your simulation.

- Constraint Equations and Couplings
- Nodal Orientations
- Contact
- Rigid Remote Connections
- Coordinate Systems
- Point Masses
- Element Orientations
- Shell Thicknesses
- Flexible Remote Connections
- Spring Connectors
- Named Selections

Refer to the Importing Mesh-Based Databases section of the Mechanical Help for additional information about the data types and how to use the data in Mechanical.

**Working with the External Model System**

Select a link below to jump to steps for working with finite element data from External Model:
- Creating and Configuring an External Model System
- Transferring Data to Mechanical
- Transferring Data to Engineering Data

**Creating and Configuring an External Model System**

To create an External Model system:

1. Drag an External Model system from the Component Systems Toolbox onto the Project Schematic.
2. To display the External Model tab, double-click the Setup cell, or right-click and choose Edit from the context menu.

You can now add the files in the Outline view.

3. To add files:
   a. In the Location column, you may browse to local files using the Browse option or to files stored on an EKM repository using the Browse from Repository option. For more information on Browse from Repository, see Importing Repository Files (p. 174).

   When you click Open, the selected file names and locations are automatically displayed in the Data Source column. You can enter descriptions for the files in the Description column. An entry appears in the Identifier column; by default this is File, but you can change the name.

   b. For ABAQUS files (.inp), a row labeled Click here to add support file is added to the schematic that enables you to select and attach additional files to the parent .inp file, such as node and element files. These attached files are included in the same import group as the parent file and Mechanical treats them as a package. There is no limit on the number of .inp files you can add and/or attach.
c. Optionally, you can right-click a file (or files) in the **Outline** view and use the context menu to duplicate them.

All files (whether imported or duplicated) can be sorted or filtered.

d. Once you have opened your files, use the **Properties** window to modify the unit system and/or coordinate system transformation properties. These properties transform the mesh coordinate systems of the sub-assemblies for proper alignment in Mechanical.

e. If you select multiple files in the **Data Source** column, the **Properties** view displays:

- A value when that value is the same for all selected files
- A blank field when values differ between selected files
- A yellow field when a value is required, but not currently specified for at least one of the files.

If you edit any field in the **Properties** view when multiple files are selected, your change is applied to all files.

---

**Caution**

Although you can multi-select files in the **Data Source** view, when you click away from that view the highlighting applied to those files disappears. However, the files remain active and any subsequent operations are applied affect the files.

---

**Table 10: Properties View: Definition Section**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unit System</td>
<td>The unit system in which the file is defined. Source points are interpreted</td>
</tr>
<tr>
<td></td>
<td>in these units.</td>
</tr>
<tr>
<td></td>
<td><strong>Important</strong></td>
</tr>
<tr>
<td></td>
<td>When you import a project from a previous release that contains an <strong>External Model</strong> system, the Length Unit from that project is converted to a compatible Unit System. You must confirm that the Unit System chosen is appropriate; if it is not, choose the correct system from the dropdown list of consistent unit systems.</td>
</tr>
<tr>
<td></td>
<td>The <strong>External Model</strong> system must have a consistent unit system before you can perform an update.</td>
</tr>
<tr>
<td>Process Nodal Components</td>
<td>Enables the <strong>External Model</strong> system to import node-based components defined in the mesh files. The application transfers the data to downstream Mechanical systems as node-based Named Selections. The application renames the node-based Named Selection objects in Mechanical based on the selection made in the <strong>Object Renaming</strong> property.</td>
</tr>
<tr>
<td>Nodal Component Key</td>
<td>This entry field enables you to filter and import only those node-based components that start with a specified name/substring value in the mesh files. For example, you want to import only node-based components that start with the prefix string &quot;nodal_.&quot; Enter that string into this field and the</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Process Element Components</td>
<td>Enables the <strong>External Model</strong> system to import any element-based components defined in the mesh files. The application transfers data to downstream Mechanical systems as elemental-based Named Selections. The application renames the element-based Named Selection objects in Mechanical based on the selection made in the <strong>Object Renaming</strong> property.</td>
</tr>
<tr>
<td>Element Component Key</td>
<td>This entry field enables you to filter and import only those element-based components that start with a specified name/string value in the mesh files. For example, you want to import only element-based components that start with the prefix string &quot;<em>elemental_</em>.&quot; Enter that string into this field and the application filters through all component names and returns only the components that begin with this string value.</td>
</tr>
<tr>
<td>Process Face Components</td>
<td>Enables the <strong>External Model</strong> system to import any face components defined in the mesh files. The application transfers data to downstream Mechanical systems as face-based Named Selections. The application renames the face-based Named Selection objects in Mechanical based on the selection made in the <strong>Object Renaming</strong> property.</td>
</tr>
<tr>
<td>Face Component Key</td>
<td>This entry field enables you to filter and import only those face components that start with a specified name/string value in the mesh files. For example, you want to import only face components that start with the prefix string &quot;<em>face_</em>.&quot; Enter that string into this field and the application filters through all component names and returns only the components that begin with this string value.</td>
</tr>
<tr>
<td>Process Model Data</td>
<td>When this option is selected (default), external mesh files are imported into Mechanical. Deselect this option to exclude external mesh files. This feature does not apply to imported Named Selections, Nodal Orientations, Point Masses, Shell Thicknesses, or Spring Connectors.</td>
</tr>
<tr>
<td>Process Mesh200 Elements</td>
<td>This option supports .cdb files only. When selected, Mesh200 elements present in your mesh file are included with your geometry in Mechanical.</td>
</tr>
<tr>
<td>Node and Element Renumbering Method</td>
<td>When you connect the <strong>Setup</strong> cell of an <strong>External Model</strong> to a Mechanical system, this property controls whether mesh nodes and elements are automatically renumbered to prevent conflicts. The property's options include <strong>Automatic</strong> (default) and <strong>Offset</strong>. The application does not renumber nodes and elements if you specify <strong>Offset</strong>. In this case, and in order to avoid conflicts, use the <strong>Node Offset</strong> and <strong>Element Offset</strong> fields to preprend your node and element IDs with the positive number of your choice.</td>
</tr>
</tbody>
</table>
This property requires that the **Number of Copies** property is set to 0. If you enter a value in the **Number of Copies** property, other than zero, the application requires automatic node and element ID renumbering.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number Of Copies</strong></td>
<td>When set to zero (default), only the source mesh is transformed. If you specify a number of copies greater than zero, these will be in addition to the source mesh. For example, if you import a .cdef file with a single part and set <strong>Number Of Copies</strong> to 2, you will get 3 parts in Mechanical.</td>
</tr>
<tr>
<td><strong>Transform Original</strong></td>
<td>This property is available only when <strong>Number Of Copies</strong> is set to 1 or greater. Select the check box if you want to apply the specified transformation to the source mesh as well as any copies.</td>
</tr>
<tr>
<td><strong>Origin X/Y/Z</strong></td>
<td>These properties allow you to translate the origin of the model along the X, Y, or Z axis. If you specify any copies, the translation will be applied relative to the previous copy (or source mesh in the case of the first copy).</td>
</tr>
<tr>
<td><strong>Theta XY/YZ/ZX</strong></td>
<td>These properties allow you to rotate the model about its origin in the XY, YZ, or ZX plane. If you specify any copies, the rotation will be applied relative to the previous copy (or source mesh in the case of the first copy).</td>
</tr>
</tbody>
</table>

**Note**

These transformations are applied in the following order:

1. Rotation about the Y Axis
2. Rotation about the X Axis
3. Rotation about the Z Axis
4. Translations

f. Update property modifications (**Update Project**) and return to the **Project** tab.

**Note**

- You can modify any file in the **Outline** view by browsing to a new file using the browse option provided in the **Location** column.

- You can also delete files that you have selected (or multi-selected) by right-clicking one of the files in the **Outline** view and then choosing **Delete** from the context menu.

4. The **Setup** cell of the **External Model** system can be linked to the following cells of a Mechanical Model or a Mechanical analysis system:
• Model

• Engineering Data (Windows Platform Only)

---

**Note**

If a file imported into External Model tool is updated and you want systems connected to External Model to use the data, then you must manually re-read the data by right-clicking on the External Model setup cell and selecting Re-read Data Files. Consequently, you must use care when attempting to use parameters and design points with projects that include External Model systems. Specifically, these systems will not automatically re-read imported files or be updated as parameters and design points are updated.

---

**Transferring Data to Mechanical**

The next step is to open your mesh files in Mechanical.

1. To add a downstream Mechanical system:
   
   a. Drag a valid analysis system from the Toolbox onto the project schematic.
   
   b. Establish a link from the External Model [Setup] cell to the Mechanical system [Model] cell to complete the connection which will delete the Geometry cell. Multiple model cells in the Project Schematic can link to one analysis system. See Assembling External Models and Mechanical Models in the ANSYS Mechanical User's Guide for more details.
   
   c. Modify the Mesh Conversion Options associated with the Mechanical Model cell as required. See Importing Mesh-Based Geometry in the ANSYS Mechanical User's Guide for more details.

2. Launch Mechanical.

**Associativity between External Model and Mechanical**

Geometry from External Model (.cdb) files is partially associative. When you have geometry from multiple External Model system assembled, and you refresh upstream model data into the downstream system, any geometry scoping that you have performed on an object in the downstream analysis will be lost for the modified External Model system only. That is, only External Model systems that you change lose scoping. For example, if you have two External Model systems assembled, System 1 and System 2, and you have objects scoped to geometry in the assembled system. If you modify System 1 and then refresh the upstream system, geometry scoping on objects is lost only for System 1. System 2 experiences no scoping losses. A more robust way to maintain scoping is to properly define imported Named Selections or criterion-based Named Selections. These scoping features automatically update when the upstream model updating is complete.

**Re-reading Modified External Mesh Files**

If you change your mesh file, such as making a manual change or as a result of an automated tool, these types of changes are not automatically updated in Workbench. Therefore, you must reread your External Data file (Setup cell option Re-read Data Files) and then also update the system (Setup cell option Update) in order to re-import the changed data.
**Transferring Data to Engineering Data**

As desired, you can incorporate Engineering Data.

1. To add a downstream Engineering Data system:
   a. Drag a valid analysis system from the **Toolbox** or an Engineering Data system onto the project schematic.
   b. Establish a link from the **External Model [Setup]** cell to the Engineering Data system. You can link the **Setup** cell to multiple Engineering Data cells.

2. Launch Engineering Data.

---

**Note**

- Review the supported MAPDL, NASTRAN, and ABAQUS material commands listed in the subsections below.
- The application creates material names in the Engineering Data workspace based on the material identifier in the imported file (.cdb, ABAQUS Input, or NASTRAN Bulk Data). The names include the corresponding (linked) Workbench cell and number as well as the value in the **Identifier** column in the **External Model** setup interface.

---

**MAPDL Material Commands**

The following MAPDL material commands are supported when importing material data into the Engineering Data workspace.

**MPTEMP and MPDATA**

The following temperature-dependent material property labels are supported for these commands:

ALPX, ALPY, ALPZ, C, DENS, EX, EY, EZ, GXY, GYZ, GXZ, KXX, KYY, KZZ, NUXY, NUYZ, NUXZ, PRXY, PRYZ, PRXZ, REFT, MU, MURX, MURY, MURZ, RSVX, RSVY, RSVZ, MGXX

**TB and TBDATA**

Bilinear isotropic hardening (BISO) is the only non-linear material property and label supported.

**NASTRAN Supported Material Specifications**

The following NASTRAN material properties are supported when importing material data into the Engineering Data workspace.

**MAT1**

The Material 1 Card supports the following properties:

- Young’s Modulus
- Shear Modulus
- Poisson's Ratio
- Mass Density
• Thermal Expansion Coefficient
• Reference Temperature

---

**Note**

If one value of the Young’s modulus, shear modulus, or Poisson’s ratio is not specified, it is calculated from the other two.

---

**MAT2**

The Material 2 Card supports the following properties:

• 3 X 3 symmetric material property matrix
• Mass density is supported
• Thermal expansion coefficient vector
• Reference temperature for thermal expansion, if thermal expansion is defined

**MAT3**

No data is supported for the Material 3 Card. Only the material id is maintained.

**MAT4**

The Material 4 Card supports Thermal conductivity and Specific Heat.

**MAT5**

No data is supported for the Material 5 Card. Only the material id is maintained.

**MAT8**

The Material 8 Card supports the following properties:

• Moduli of elasticity
• Poisson’s ratio
• Shear moduli
• Mass density
• Thermal expansion coefficients
• Reference temperature for thermal expansion, if thermal expansion is defined

**MAT9**

The Material 9 Card supports the following properties:

• 6 X 6 symmetric material property matrix
• Mass density is supported

---

**Note**

The stiffness terms must be positive (which requires that all determinants to be positive). Otherwise, the properties will not be imported.

---

**MAT10**

No data is supported for the Material 10 Card. Only the material id is maintained.

**AB AQUS Supported Materials Keywords**

The following ABAQUS Materials Keywords are supported when importing material data into the Engineering Data workspace.

• ***MATERIAL**
  – The NAME parameter is supported.

• ***ELASTIC**
  – Supported for TYPE = ISOTROPIC, ENGINEERING CONSTANTS, and LAMINA.
  – The DEPENDENCIES parameter is NOT supported.
    → Material property definition is NOT processed.
  – For TYPE = ISOTROPIC:
    → Young's Modulus and Poisson's Ratio are supported.
    → If Poisson's Ratio is not specified, 0.3 is the value that is used.
    → Temperature dependency is supported.
  – For TYPE = ENGINEERING CONSTANTS and TYPE = LAMINA:
    → Young's Moduli, Poisson's Ratios, and the Shear Moduli in the principal directions is supported.
    → Temperature dependency is NOT supported - the data for the first temperature is used.

• ***DENSITY**
  – The DEPENDENCIES parameter is NOT supported.
    → Material property definition is NOT processed.
  – Temperature dependency is supported.

• ***EXPANSION**
  – TYPE = ISOTROPIC only
  – The DEPENDENCIES parameter is NOT supported.
Material property definition is NOT processed.

- Temperature dependency is supported.

- **PLASTIC**
  - HARDENING = ISOTROPIC only.
  - Temperature dependency is NOT supported - the data for the first temperature is used.
  - The RATE parameter is not supported.
    - These stress-strain curves will be ignored.
  - Curve must have a positive slope.

- **CONDUCTIVITY**
  - Supported for TYPE = ISOTROPIC and ORTHO.
  - The DEPENDENCIES parameter is NOT supported.
    - Material property definition is NOT processed.
  - For TYPE = ISOTROPIC, temperature dependency is supported.
  - For TYPE = ORTHO, temperature dependency NOT supported. The data for the first temperature is used.

- **SPECIFIC HEAT**
  - The DEPENDENCIES parameter is NOT supported.
    - Material property definition is NOT processed.
  - The temperature dependency is supported.

## Finite Element Modeler

Use the FE Modeler system to import a mesh and create a faceted (or NURBS) geometry to export to an analysis or geometry system. You can also create a parametric study within FE Modeler. Right-click the Model cell and select **Edit** or **Import Mesh** to input an existing mesh file.

You can link many systems to an FE Modeler system by using the **Transfer Data From New** or **Transfer Data To New** context menu options. When transferring data from another system, you can transfer data from:

- **Model** Cell
- **Setup** Cell
- **Mesh** Cell

When transferring data to another system, you can transfer data to:

- **Geometry** Cell
• **Engineering Data Cell**
• **Model Cell**
• **Mesh Cell**

For more information on FE Modeler capabilities in ANSYS Workbench, refer to **FE Modeler System Usage in Workbench**.

**Fluent**

Fluent allows for fluid flow analysis of incompressible and compressible fluid flow and heat transfer in complex geometries. You specify the computational models, materials, boundary conditions, and solution parameters in Fluent, where the calculations are solved.

Use a Fluent component system to model incompressible and compressible fluid flow and heat transfer in complex geometries for your project. Within Fluent, a computational mesh is applied to a geometry, pertinent mathematical models are applied (for example, low-speed, high-speed, laminar, turbulent, and so on), materials are chosen, boundary conditions are defined, and solution controls are specified that best represent the problem to be solved. Fluent solves the mathematical equations, and results of the simulation can be displayed in Fluent for further analysis (for example contours, vectors, and so on).

Drag the Fluent component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox. The Fluent component system has two cells: a **Setup** cell and a **Solution** cell. Double-click the **Setup** cell to open Fluent, where you can import a computational mesh, specify the computational models, materials, boundary conditions, and solution parameters, as well as perform the calculations. Alternatively, you can import a previously saved Fluent case file or Fluent case and data files by right-clicking the **Setup** cell and selecting **Import Fluent Case** or **Import Fluent Case And Data**, respectively.

**Fluent (with Fluent Meshing)**

**Fluent (with Fluent Meshing)**, also known as Fluent Meshing or Fluent in meshing mode, allows for meshing as well as fluid flow analysis of incompressible and compressible fluid flow and heat transfer in complex geometries. You specify the mesh in Fluent in meshing mode, then proceed to set up the computational models, materials, boundary conditions, and solution parameters using Fluent in solution mode, where the calculations are solved.

Use a Fluent Meshing component system to model incompressible and compressible fluid flow and heat transfer in complex geometries for your project. Within Fluent in meshing mode, a computational mesh is imported and manipulated. Switch to Fluent in solution mode where pertinent mathematical models are applied (for example, low-speed, high-speed, laminar, turbulent, and so on), materials are chosen, boundary conditions are defined, and solution controls are specified that best represent the problem to be solved. Fluent solves the mathematical equations, and results of the simulation can be displayed in Fluent for further analysis (for example, contours, vectors, and so on).

Drag the **Fluent (with Fluent Meshing)** component system from the Toolbox to the **Project Schematic**, or double-click the system in the Toolbox. The **Fluent (with Fluent Meshing)** component system has three cells: a **Mesh** cell, a **Setup** cell, and a **Solution** cell. Double-click the **Mesh** cell to open Fluent in meshing mode, where you can import a computational mesh. Double-click the **Setup** cell to open Fluent in solution mode, where you can specify the computational models, materials, boundary conditions, and solution parameters, as well as perform the calculations. Alternatively, you can import a previously saved Fluent case file or Fluent case and data files by right-clicking the **Setup** cell and selecting **Import Fluent Case** or **Import Fluent Case And Data**, respectively.
saved Fluent case file or Fluent case and data files by right-clicking the Setup cell and selecting Import Fluent Case or Import Fluent Case And Data, respectively.

For detailed information on working with Fluent Meshing, see the ANSYS Fluent Meshing User's Guide as well as the other on-line documentation available under the Help menu within Fluent Meshing. In addition, see the Fluent in Workbench User's Guide.

For information on submitting Fluent jobs to Remote Solve Manager, see Submitting Fluent Jobs to RSM or an EKM Portal.

**Geometry**

Use the Geometry system to import a model. Right-mouse click the Geometry cell and select New Geometry or Import Geometry.

If you select New Geometry, the DesignModeler application opens. You can then build a model using the DesignModeler features. When you save the geometry in DesignModeler, the file becomes an .agdb file. If you select Import Geometry, you can browse to an existing geometry file.

You can also choose ANSYS SpaceClaim Direct Modeler via the Tools menu. For more information, see New Geometry in the DesignModeler section of the help.

You can connect other systems to a Geometry system by using the Transfer Data From New or Transfer Data To New context menu options. You can transfer data from the following types of systems:

- BladeGen: Connects the Blade Design cell to the Geometry cell.
- Finite Element Model: Connects the Model cell to the Geometry cell.

You can transfer data to the following types of systems:

- Mechanical APDL: Connects the Geometry cell to the Analysis cell. Transfer connection is via an .anf file.
- TurboGrid: Connects the Geometry cell to the Turbo Mesh cell.
- Vista TF: Connects the Geometry cell to the Setup cell. Transfer connection is via a .geo file.
- ANSYS AIM: Connects the Geometry cell to the Data Import cell.

For more information on the geometry capabilities in ANSYS Workbench, refer to Project Schematic Operations in the DesignModeler User's Guide.

**ANSYS ICEM CFD**

ANSYS ICEM CFD extends ANSYS meshing capabilities with robust and varied geometry import, the ability to efficiently mesh large or complex models with extended meshing controls, advanced interactive blocking tools for structured or unstructured mesh generation, extended mesh diagnostics, advanced interactive mesh editing, and output to a wide variety of solver formats including CFD, FEA, and neutral formats.

ANSYS ICEM CFD can input geometry in almost any format, whether a commercial CAD design package, third-party universal database, scan data, point data, or even combinations of CAD, facets, and mesh. It includes a variety of "patch independent" meshing methods which are able to work with dirty cad and does not require that surfaces be formed into solids or that flow volumes be extracted. It does include
a wide range of interactive geometry, blocking and mesh editing tools that can be used to generate advanced or high quality meshes for any application.

The data-integrated ICEM CFD component system, or "ANSYS ICEM CFD Add-in", enables you to launch ICEM CFD from ANSYS Workbench and use it to build a project, with the option of adding upstream data from Geometry, Mesh, Mechanical Model, or combined Geometry and Mesh system components. You can also use ICEM CFD to provide data to downstream component systems, such as ANSYS Fluent, ANSYS CFX, ANSYS Polyflow, FENSAP-ICE, Mechanical APDL, and FE Modeler.
Elements of the ICEM CFD Component

The ICEM CFD Component system contains the following cells:

ICEM CFD system header
The System Header identifies the component type and provides access to Workbench context menu options. The ICEM CFD system header context menu options include:

- Refresh
- Update
- Duplicate
- Clear Generated Data
- Delete
- Rename
- Properties
- Add/Edit Note

These standard actions are described in the System Header Context Menu Options (p. 332), Duplicating Systems (p. 59) and Moving, Deleting, and Replacing Systems (p. 61) sections.

Model cell
The Model cell is associated with the ICEM CFD application. You can use the Model cell to modify some aspects of the project. You can also double-click the Model cell to open the project in ICEM CFD. The Model cell context menu items include the following:

- Edit: Opens the ICEM CFD application and loads an existing Geometry/ICEM CFD file.
- Duplicate: Copies the entire geometry and mesh data, enabling you to edit the Model cell in the duplicate system to investigate an alternative modeling approach.
• **Transfer Data From New**: Enables the transfer of data from upstream **Geometry, Mesh, Mechanical Model**, or combined **Geometry** and **Mesh** components.

  **Note**
  
  If the **Geometry** cell option **Use Associativity** is **On** (its default setting), Part Reference IDs are stored in a Workbench database and remain persistent in ICEM CFD even if the topology of the geometry is changed.

• **Transfer Data to New**: Enables the transfer of data from an ICEM CFD project to downstream data-integrated system projects, such as:
  
  – Fluent
  – CFX
  – Polyflow
  – FENSAP-ICE
  – Mechanical APDL
  – FE Modeler

• **Update, Refresh, Reset, Rename, Properties**, and **Add/Edit Note**. These standard actions are described in the **System Header Context Menu Options (p. 332)**, **Duplicating Systems (p. 59)** and **Moving, Deleting, and Replacing Systems (p. 61)** sections.

• An additional property is **Create Subset(s) from Named Selection**. If this option is set, then overlapping named selections are transferred to multiple subsets instead of to exclusive parts. This enables the creation of geometry subsets instead of parts, allowing you to determine the part to which the geometry entity (point/curve/surface) should be associated. When this option is disabled each geometry is assigned to only one part, thereby losing association with other Named Selections (which are mapped to parts).

**Parameters cell (optional)**

The **Parameters** cell enables you to see and edit Input and Output parameters for ICEM CFD.

**Note**

Scripts written in ICEM CFD may not be parametric with upstream or downstream projects. Care should be taken to write scripts whose functions do not exceed the capabilities of the upstream or downstream component systems.

**Creating an ICEM CFD Component**

You can create an ICEM CFD component system in Workbench using any of these methods:

• Double-click the ICEM CFD system template in the **Toolbox**.

• Drag-and-drop the ICEM CFD system template onto the **Project Schematic**.

• Right-click a Geometry or Mesh project and select **Transfer Data to New > ICEM CFD**.

---

Release 18.2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.
Choose **File → Import** to import a standalone ICEM CFD project into Workbench. When the **Import** dialog opens, choose **ICEM CFD Project File (*.prj)** and navigate to the project you want to import.

### Updating ICEM CFD Projects

Updating a project in Workbench brings the entire ICEM CFD system up to the most current status, including upstream and downstream data.

Changes that require you to update your ICEM CFD project include changes to upstream data and changes you make in the ICEM CFD editor. When changes are made, the cell in the **Project Schematic** window indicates that an update is required. Note, however, that changes made in the ICEM CFD editor will not cause the system to go out of date until the project, tetin file (geometry), blocking file, and/or Replay file are saved.

The actions taken by Workbench depend on whether the following conditions are met:

- Blocking exists.
- A Replay file exists.
- Blocking parameters are set.
- Other input parameters are set.

The following table describes the actions performed by ICEM CFD according to these conditions:

**Table 12: Updating ICEM CFD Projects**

<table>
<thead>
<tr>
<th>Blocking</th>
<th>Replay File</th>
<th>Blocking Input Parameters</th>
<th>Other Input Parameters</th>
<th>Actions performed by ICEM CFD</th>
</tr>
</thead>
<tbody>
<tr>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>1. Runs tetra default meshing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>2. Saves the unstructured mesh.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>3. Saves the project</td>
</tr>
<tr>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>1. Runs hexa default meshing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>2. Saves the unstructured mesh.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>3. Saves the project</td>
</tr>
<tr>
<td>No</td>
<td>No</td>
<td>No</td>
<td>Yes</td>
<td>1. Sets all input parameters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>2. Runs tetra meshing. Runs prism meshing if any Part PART_NAME: Prism input</td>
</tr>
<tr>
<td>Blocking File</td>
<td>Replay File</td>
<td>Blocking Input Parameters</td>
<td>Other Input Parameters</td>
<td>Actions performed by ICEM CFD</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
<td>---------------------------</td>
<td>------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>No</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>1. Sets all input parameters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>2. Runs the Replay file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>3. Saves the unstructured mesh.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>4. Saves the project.</td>
</tr>
<tr>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>1. Sets all input parameters except blocking parameters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>2. Runs the Replay file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>3. If blocking now exists:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>a. Sets blocking input parameters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>b. Runs hexa meshing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>c. Converts pre-mesh to unstructured.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>d. Saves the unstructured mesh</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>4. Saves the project.</td>
</tr>
<tr>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Yes</td>
<td>1. Sets all input parameters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>2. Sets blocking input parameters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>3. Runs hexa meshing.</td>
</tr>
</tbody>
</table>
### Actions performed by ICEM CFD

<table>
<thead>
<tr>
<th>Blocking</th>
<th>Replay File</th>
<th>Blocking Input Parameters</th>
<th>Other Input Parameters</th>
<th>Actions performed by ICEM CFD</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>1. Sets all the input parameters except blocking.</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>2. Runs the Replay file.</td>
</tr>
<tr>
<td></td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>3. If blocking still exists:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>a. Sets blocking input parameters.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>b. Runs hexa meshing.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>c. Converts pre-mesh to unstructured.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>d. Saves the unstructured mesh.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>4. Saves the project.</td>
</tr>
</tbody>
</table>

ICEM CFD saves the unstructured mesh and project only if the ICEM CFD project is closed and you update from Workbench. If the ICEM CFD project is open, you will need to manually save the unstructured mesh and project.

The order of operations is Meshing input parameters are set before the Replay file is run; Blocking Input parameters are set after a replay file is run, but only if blocking exists after the replay file is run.

If no Replay file exists, the default mesher is determined by the presence or absence of blocking: if no blocking exists in the project, **tetra** is the default. Conversely, if blocking exists in the project, **hexa** is the default mesher.
Updating a Project

To update a project and refresh upstream and downstream data, right-click the Model cell and choose Update.

**Note**

If available, Update will use the ICEM CFD Replay file to update the ICEM CFD project.

*Interface Differences in the Data-Integrated ICEM CFD*

The data-integrated ICEM CFD interface has been modified to provide additional functionality that enhances the integration of ICEM CFD and Workbench.

- **One-click menus** that enable you to control basic project and Replay Recording functions.

**Note**

If you create Workbench Input Parameters and want to step through the script line-by-line or using a line range, you must open the Workbench Replay Control dialog from this menu.

- The Workbench Replay Control dialog enables you to test and edit Replay scripts created within Workbench.

You can ensure that you are working within the data integrated environment by checking the Message window within IIEM CFD. The first line identifies that the application is integrated in the Workbench Framework.

```
ICEM CFD is integrated in Workbench 2.0 Framework.
Checked out ansys\iaenv \product\ANSYS ICEM CFD from server [server name]
Loading project settings file: ICM.pi
Loading geometry file "ICM.tir"
Current Coordinate system is global
Loading domain "ICM.uns" ...
Loading family boco data from ICM.fbc
Current Coordinate system is global
```

**One-Click Menus**

The following one-click menu options are available in the Toolbar when you open ICEM CFD from Workbench:

- **Save Project:** Saves the entire project, including Workbench data.

- **Refresh Project:** Refreshes the upstream data in the ICEM CFD project.

- **Update Project:** Brings the entire ICEM CFD system up to the most current status, including upstream and downstream data.

- **Start Replay Recording:** Begins recording the commands needed to generate a custom meshing process. All of the steps in the mesh development process are recorded, including blocking, mesh size,
edge meshing, boundary condition definition, and final mesh generation. See Replay Scripts in the ANSYS ICEM CFD Help Manual. After you click the Start Replay Recording icon, the icon changes to the Stop Replay Recording icon. You can click this icon to stop recording.

You can also click the arrow to choose Pause Replay Recording, Run Replay File, Delete Replay File, and Replay Control, which opens the Workbench Replay Control dialog.

Start Replay Recording
Pause Replay Recording
Stop Replay Recording
Run Replay Recording
Delete Replay File
Workbench Replay Control

---

**Note**

If you create Workbench Input Parameters and want to step line by line or using a line range through a replay file, you must use the Replay Control item from this menu to start the Workbench Replay Control dialog.

---

**Output Mesh**: You can choose to save the ICEM CFD mesh output to one of several formats including Fluent, CFX, Polyflow, ANSYS Meshing, or FENSAP-ICE projects.

---

**Workbench Replay Control Dialog**

The Replay Control dialog helps you create, test, and edit script files by performing operations in ANSYS ICEM CFD and recording the equivalent Tcl/Tk commands in a Replay file. You can then use the dialog to step through and edit the script.

The Workbench Replay Control dialog works exactly the same as the standalone Replay Control dialog, with two key exceptions:

- The **Workbench Replay Control dialog** supports Workbench Input Parameters and allows you to step through them.
- The dialog automatically loads the current Replay script file (ICM.rpl) instead of opening a file browser.
For more information, see the Replay Scripts section in the ANSYS ICEM CFD Help Manual.

**Setting Parameters**

Using input parameters in Workbench enables you to pass data to ICEM CFD, while output parameters allow you to receive data back from ICEM CFD. The interaction of parameters between applications provides you with greater flexibility and capabilities to run optimization and what-if scenarios. For more information about using parameters in Workbench, see Working with Parameters and Design Points (p. 123).

Parameters may be set globally or individually, with individual parameters taking precedence over global values.

You can perform the following operations involving parameters:

- Setting Input Parameters
- Setting Workbench Mesh Parameters for Parts
- Setting Parameters for Prism Meshing
- Setting Output Parameters
- Setting User Defined Parameters
• Deleting Parameters

**Setting Input Parameters**

Clicking the box to the right of certain **Meshing Input** parameters enables you to select whether the parameter is controlled from within ICEM CFD or from within Workbench. A “P” in the check box indicates that it has been selected as a Workbench Input parameter. If the check box is empty, you can control the input from within ICEM CFD.

You can set the following input parameters in Workbench:

- **Global Mesh Size** (See Global Mesh Size in the ANSYS ICEM CFD Help Manual.)
- **Shell Meshing** (See Shell Meshing Parameters in the ANSYS ICEM CFD Help Manual).
- **Volume Meshing** (See Volume Meshing Parameters in the ANSYS ICEM CFD Help Manual).
- **Prism Meshing** (See Prism Meshing Parameters in the ANSYS ICEM CFD Help Manual).
- **Surface Mesh Setup** (See Surface Mesh Setup in the ANSYS ICEM CFD Help Manual).
- **Curve Mesh Setup** (See Curve Mesh Setup in the ANSYS ICEM CFD Help Manual).
- **Edge Params** (See Edge Params in the ANSYS ICEM CFD Help Manual).
- **Vertex Location** (See Set Location in the ANSYS ICEM CFD Help Manual)

**Tip**

- For **Surface Mesh Setup**, **Curve Mesh Setup**, and **Edge Params**, you can set parameters for all existing surfaces, curves, or edges at once; in addition to setting a parameter for a single surface, curve, or edge.

- Parameterized edges and vertices (location) can be easily located in the graphics display. Use **Edges → Show Parameterized Edges**, under **Blocking** in the **Display Tree** to color all paramet-
erized edges red. Similarly, **Vertices → Show Parameterized Vertices** will color the parameterized vertex number red.

---

**Note**

If you create Workbench Input Parameters and want to step line by line or using a line range through a replay file, you must use the **Workbench Replay Control** item from the **One-Click** menu to start the **Workbench Replay Control** dialog.

---

**Setting Input Parameters**

To set input parameters in Workbench:

1. Within ICEM CFD, choose any of the input parameters listed above.
2. Select the check box next to the parameter.
3. Click the **Yes** button in the message dialog box to confirm the selection. A P in the check box indicates that the parameter has been created for Workbench.

**Note**

You will not be able to edit the parameter within ICEM CFD unless you click the check box again and deselect the parameter.

4. In **Workbench**, double-click the project’s **Parameters** cell.
5. Edit the parameter values in the **Outline of Schematic: Parameters** window.

![Image of the Outline of Schematic: Parameters window]

6. Click the **Project** tab to return to the **Project Schematic** window.

You can now update the project using the new parameter settings.

**Setting the parameters for a single curve, surface, or edge**

1. Within ICEM CFD, open the **Surface Mesh Setup, Curve Mesh Setup, or Edge Params** parameters from the **Tab** menu.
2. Click the **Select** button at the top of the **Parameters** window.

3. Click the **Left Mouse** button to select the curve, surface, or edge for which you want to set parameters.

4. Click the **Middle Mouse** button to complete the selection.

   The surface, curve, or edge you selected are listed in the selection entry.

<table>
<thead>
<tr>
<th>Surface Mesh Setup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Surface(s)</td>
</tr>
</tbody>
</table>

5. Select the check box next to the parameter you want as the input parameter.

6. Click the **Yes** button in the message dialog box to confirm the selection. A **P** in the check box indicates that the parameter for the single surface, curve or edge has been created for Workbench.

### Setting the Parameters for All Existing Curves, Surfaces, or Edges

1. Within ICEM CFD, open the **Surface Mesh Setup**, **Curve Mesh Setup**, or **Edge Params** parameters from the **Tab** menu.

2. Leave the surface, curve or edge selection field empty (do not select any surface, curve or edge).

3. Select the check box next to the parameter you want as the input parameter.

4. Click the **Yes** button in the message dialog box to confirm the selection. A **P** in the check box indicates that the parameter for all existing surfaces, curves or edges has been created for Workbench.

### Setting Workbench Mesh Parameters for Parts

The **Part Mesh Setup** parameters enable you to specify the mesh parameters for different parts of a geometry. See **Part Mesh Setup** in the **ANSYS ICEM CFD Help Manual**.

To create a Workbench mesh parameter for a part:

1. Click the **Mesh** tab.

2. Click the **Part Mesh Setup** icon.

3. In the **Part Mesh Setup** dialog, choose a part and assign non-zero values to one or more of its parameters.

4. Click in the **Parameter** column for the part.

5. A dialog asks you to confirm that you want to create a Workbench parameter for each value you’ve changed.

   **Note**

   If any Workbench parameters are already set for the part, a dialog will ask if you want to delete that Workbench parameter.

   Parameters assigned as Workbench parameters are highlighted in blue.
To delete a parameter, click in the Parameter column. A dialog will ask you to confirm that you want to delete each individual Workbench parameter in the row.

As with ICEM CFD, the Apply inflation parameters to curves and Remove inflation parameters from curves options affect Workbench parameter behavior as well. The current value of Apply inflation parameters to curves is saved to the project file/.aienv_options file, so it is always available in GUI or Batch mode.

Setting Parameters for Prism Meshing

You can add prism meshing parameters using the Part Mesh Setup dialog:

1. Click the Mesh tab.
2. Click the Part Mesh Setup icon.
3. In the Part Mesh Setup dialog, choose a part and check the check box in the Prism column.
4. Click in the Parameter column for the part.
5. A dialog asks you to confirm that you want to create a Workbench parameter for Part PARTNAME: Prism.

Note

If any Workbench parameters are already set for the part, a dialog will ask if you want to delete that Workbench parameter.

Setting Output Parameters

You can set Workbench Output parameters to:

- list unstruct mesh and pre-mesh blocking quality metrics
- list the number of mesh errors and possible problems
- list the number of element and block types created.

You set the output parameters within the ICEM CFD application, then view them in either Workbench or ICEM CFD.
Setting Output Parameters

1. Within ICEM CFD, choose **Settings → Workbench Parameters → Workbench Output Parameters**.

2. Optionally, click the **Output quality metrics** check box to select quality metrics.
   a. Use the **Quality Metrics** drop-down menu to choose the metric you want to set.
   b. Click the radio buttons to select the mesh types to check for the metric.

3. Optionally, click the **Output number of elements** check box.
   a. Check the boxes next to the element types for which you want an output.

4. Optionally, click the **Output Check Mesh** check box.
   a. Check the boxes next to the errors you want to have tallied in the output results. ICEM CFD will perform an analysis as part of the meshing process and list the results in the **Output** window and in the **Workbench Parameters** window.

5. Similarly, check the boxes for **Output Pre-Mesh Quality** and **Output Number of Blocks** to set the Blocking Output Parameters.

For more information about pre-mesh quality, see **Determining the Pre-Mesh Quality** in the ANSYS ICEM CFD User’s Manual.

For more information about Hexa Block types, see **Hexa Block Types** in the ANSYS ICEM CFD User’s Manual.
Deleting Output Parameters

1. Within ICEM CFD, choose **Settings → Workbench Parameters → Workbench Output Parameters**.

2. In the **Workbench Output Parameters** window, check one or more of **Delete all quality metrics output parameters**, **Delete all number of elements output parameters**, **Delete all Pre-Mesh Quality output parameters**, or **Delete all Number of Blocks output parameters** as required.

3. Click **OK**.

Setting User-Defined Parameters

Setting User Defined Parameters gives greater flexibility and control over the meshing operation. For example, parameters that cannot be applied as single input parameters can be individually set with User-Defined Parameters.

---

**Note**

See the *ANSYS ICEM CFD Programmer's Guide* for information about using user-defined parameters with replay scripting.

---

Setting User Defined Input Parameters

1. Within ICEM CFD, choose **Settings → Workbench Parameters → Workbench User Defined Parameters**.

2. In the **Workbench User Defined Input/Output Parameters** window, check the **Create Input Parameter** check box.

3. Enter a value for the **Parameter name**.

4. Enter a value for the **Parameter**. This value must not be empty.

You can edit this value in the **Outline of Schematic: Parameters** window.

---

Release 18.2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.
Setting User Defined Output Parameters

1. Within ICEM CFD, choose Settings → Workbench Parameters → Workbench User Defined Parameters.

2. In the Workbench User Defined Input/Output Parameters window, check the Create Output Parameter check box.

3. Enter a value for the Parameter name.

4. Enter a value for the IC Function.

   The IC Function must start with ic_geo_ or ic_uns_ or ic_hex_ and must return an integer or a float value.

5. Click Apply or OK.

Deleting Parameters

You can use this procedure to delete any input or output parameter, whether user-defined or otherwise.

1. Within ICEM CFD, choose Settings → Workbench Parameters → Workbench User Defined Parameters.

2. In the Workbench User Defined Input/Output Parameters window, check the Delete Input/Output Parameter check box.

3. Use the drop-down menu to choose the name of the parameter you want to delete.

4. Click Apply or OK.

---

Note

See the ANSYS ICEM CFD Programmer's Guide for information about IC functions.
**User-Defined Parameters Example**

This example illustrates how you can use user-defined parameters to test different meshing scenarios for a simple box:

1. In the **Workbench Toolbox**, double-click the **ICEM CFD** component to start the data-integrated ICEM CFD component system.

2. Double-click the **Model** cell to open ICEM CFD.

3. First, create an Input parameter, **ZSIZE**, that you can manipulate from Workbench.
   a. Choose **Settings** → **Workbench Parameters** → **Workbench User Defined Parameters**.
   b. Click **Create Input Parameter**.
   c. Name the Parameter **ZSIZE** and set the **Parameter Value** as 2.
   d. Click **OK** to finish.

4. Now create a box model upon which you will perform a meshing operation. Record the process so the operation can be performed again when you update it from Workbench.
   a. Click the **Start Replay** button.
   b. Click the **Geometry** tab and choose **Create/Modify Surface**.
   c. Choose **Standard Shape** from the **Create/Modify Surface** window.
   d. Choose **Box** and click **Apply**.
   e. Click the **Mesh** tab and choose **Compute Mesh**.
   f. Choose **Volume Mesh** and click **Compute**.
   g. Click **Yes** on the message dialog box to use autosizing for the mesh size.
   h. Click the **Stop Replay Recording** button.
i. Choose **File → Save Project** to save the project.

5. Next, edit the script to use the input parameter.
   a. Choose **Workbench Replay Control** from the **One-Click Replay Recording** menu.
   b. Click the **Edit** button.
   c. **Edit Line 15** (or whichever line is appropriate),
      
      \[
      \text{ic_vid_objectbox8 GEOM 00 \{0 0 0\} 1 1 1, to ic_vid_objectbox8 GEOM 00 \{0 0 0\} 1 1 [ic_wb2_get_parameter user_defined ZSIZE]}
      \]
   d. Choose **File → Save**.
   e. Close the **Edit** window.
   f. Click the **Save** button and save **ICM.rpl**.
   g. Click the **Done** button. Do not close ICEM CFD.
6. Now you can change the Input parameter through Workbench.
   a. In the Workbench **Project Schematic** window, double-click the **Parameters** cell of the ICEM CFD component.
   b. Change the value of **ZSIZE** to 5 and return to the **Project** tab.
   c. Right-click the **Model** cell and choose **Update**.

You can watch the Replay script run using the new parameter in the ICEM CFD interface. Each time you change the **ZSIZE** parameter in Workbench, a new part will be generated and meshed with the new **ZSIZE** parameter value.

**Transferring an ICEM CFD Project to Static Structural**

When you create a project that transfers ICEM CFD data downstream to a Static Structural system, data that is applied to the geometry, such as load data, is not transferred to the structural system. To work around this limitation, you can use a Finite Element Modeler (FE Modeler) system as a bridge between the two systems, then manually set the connections between them.

To transfer an ICEM CFD project to Static Structural:

1. Start with an **ICEM CFD** component.
   a. Choose **File** → **Import** to select an existing **ICEM CFD** project, or;
   b. Drag an **ICEM CFD** component system into the **Project Schematic** window, then click the model to open the ICEM CFD Add-In and create your model.

2. Drag out an **FE Modeler** system and drop it on the **ICEM CFD** system.
   Note that they are connected through the **Model** cell.

3. Drag out a **Static Structural** system as a **Standalone** system.

   **Tip**

   If you drag the **Static Structural** system out and drop it on the **FE Modeler** system, the two cells will link **Model** to **Engineering** data, and model information will not be passed downstream.

4. Drag the **Model** cell from the **FE Modeler** system and drop it on the **Model** cell of the **Static Structural** system.

5. Right-click the **Model** cell of the **ICEM CFD** system and choose **Update**.

6. Right-click the **Model** cell of the **FE Modeler** system and choose **Update**.

The model is now ready to use within Static Structural.
**Icepak**

The Icepak application allows engineers to model electronic designs and perform heat transfer and fluid flow simulations. You can construct your model geometry or import model data from other CAD and CAE packages. Icepak then creates a mesh for your model geometry and passes the mesh and model definition to the solver for computational fluid dynamics simulation. The resulting data can then be postprocessed using Icepak and/or CFD-Post.

ANSYS Workbench has the capability of coupling Ansoft steady-state to Icepak steady-state cases and Ansoft transient to Icepak steady-state cases.

There are two ways to create a project in Icepak. In both cases you will first need to add an Icepak template to the project schematic. You can accomplish this by dragging the template from the Toolbox into the Project Schematic or double-click the template in the Toolbox. You will see the following in the project schematic:

![Project Schematic](image)

**Note**

ANSYS Workbench provides visual indications of a cell's state at any given time with the use of icons on the right side of each cell. The descriptions of these icons are described in *Understanding Cell States* (p. 315).

---

**Note**

A description of context menu options can be found in *Context Menu Options* (p. 326)

---

1. The first option for creating an Icepak project is described below:

   a. Right-click the **Setup** cell and select **Edit** or double-click the **Setup** cell. This launches Icepak.

   b. Create a geometry within the Icepak application. After creating a geometry, the system shows an incomplete cell state.

   ![Incomplete Cell State](image)

   ⚡ indicates the system has not been solved.

   c. In Icepak, set up the problem and complete your analysis using Icepak's tools and features. After solving, the Icepak system will show an up to date cell state as shown below.
2. The second option for creating an Icepak project is described below:

   a. After adding an Icepak template, you can load an existing Icepak model by doing a right-click the **Setup** cell and selecting **Import Icepak Project**. You will find Icepak project files located in the system directory under **IPK**. All Icepak projects saved in ANSYS Workbench will follow this naming convention which is described in Project File Management (p. 100). All other Icepak projects can be saved anywhere. Note, there are no special icons for Icepak projects to differentiate them from other files.

   Note
   
   You can only import one Icepak project per system.

   You can also load an existing Icepak model by doing a right-click the **Setup** cell and selecting **Import Icepak Project From .tzr**. Click **Browse**. A file open dialog box will be displayed in which you can browse the directory structure and select the model to load. The system will show an incomplete cell state.

   ![Incomplete cell state](image)

   indicates the system has not been solved.

   b. In Icepak, set up the problem and complete your analysis using Icepak's tools and features. After solving, the Icepak system will show an up to date cell state as shown below.

   ![Complete cell state](image)

   indicates that all necessary files are loaded and up to date.

   Note
   
   If you load an Icepak project that already has a solution, the **Solution** cell state will show an up to date cell state after the model is loaded.
3. You can also import geometry into Icepak from DesignModeler. See the DesignModeler to Icepak (p. 260) section for details on importing geometry from DesignModeler into Icepak or loading a geometry.

**Workbench Menu Options Overview for Icepak Projects**

Many Icepak options remain the same when running Icepak from the ANSYS Workbench framework. However, there are a few changes that should be noted.

**Save project**
Select Save project to save all changes to your project. The Save button in Workbench works the same way as Save project in Icepak, you can use either one. All Icepak projects saved in ANSYS Workbench will follow the directory structure described in Project File Management (p. 100). See File Menu (p. 320) for a description of Save and Save as options in ANSYS Workbench.

---

**Archive**
Select Archive to generate a single archive file that contains all project files. This archive will include the project file and all files in the project_name_files directory, not just Icepak files. The archive will be saved as a zip file. Icepak users familiar with the Pack option in the standalone Icepak application will find this option works in a similar fashion except that all ANSYS Workbench files are archived. See File Menu (p. 320) for a complete description of the Archive option in ANSYS Workbench.

---

**Note**
Previously imported external files from a restored archive directory are treated as internal files if archived again.

---

**Restore Archive**
Select Restore Archive to restore a previously-generated archive file. After you select the project archive to be restored, you are prompted for the name and location where the restored file(s) are to be located. After the archive is extracted, the project opens in ANSYS Workbench. See File Menu (p. 320) for a complete description of the Restore Archive option in ANSYS Workbench.

---

**Note**
You can also extract the archive manually by using an unzip utility, and then opening the .wbpj file.

---

**Icepak Context Menu Options**

When the Icepak system is active in the schematic, use the right mouse button to initiate the following Setup cell actions:

**Edit**
Launches Icepak. This is the default operation.

**Import Icepak Project From .tza**
Brings up a Browse dialog box to add an input file, then launches Icepak and reads the input files. This is the default action. This option is available only when a project is empty.

**Import Icepak Project**
Brings up a Browse For Folder dialog box to add an input file, then launches Icepak and reads the input files. This is the default action. This option is available only when a project is empty.
**Duplicate**

Creates a duplicate of the Icepak system and any upstream data. If the duplicate operation is performed on a system containing a solution, the solution will not be transferred and the user will need to re-solve. The system cell state will indicate the need to re-solve.

**Transfer Data From New**

Creates a second, dependent (connected) system with the existing system.

**Update**

If data is changed or modified, you can perform an update. You have the option to incorporate the changes in the **Refresh Input Data** view and initiating the solver inside Icepak. See DesignModeler to Icepak (p. 260) for a further description of the update option and how the **Refresh Input Data** panel is used.

---

**Note**

You must open the Icepak editor before doing an update.

---

**Refresh**

If data is changed or modified, you can perform a refresh. You have the option to incorporate the changes in the **Refresh Input Data** panel. See DesignModeler to Icepak (p. 260) for a further description of the refresh option and how the **Refresh Input Data** panel is used.

---

**Note**

You must open the Icepak editor before doing a refresh.

---

**Rename**

Renames the system or cell.

**Properties**

Displays applicable cell properties in the **Properties** window.

**Enable Update**

If data is unchanged, you can click **Enable Update** to change the **Setup** cell icon from a green checkmark to the Update lightning icon. This allows you to run the solution.

**Quick Help**

Displays a quick help panel for the cell. Quick help provides a brief description of how to use the cell in its current state. You can also click the blue triangle in the lower right corner of a cell to view quick help.

The **Solution** cell actions are similar to those of the **Setup** cell; however, there are additional actions and functions. These are described in the list below. Use the right mouse button to initiate the following **Solution** cell actions.

**Set Case File...**

Brings up an **Open** dialog box where you can specify an Icepak solution file to load. This option is used primarily to view multiple solutions for a project. If the user re-solves in Icepak, the solution case file will be overwritten with the latest solution.

**Transfer Data to New**

Creates a downstream system that can accept data from the selected cell. Only those systems that can provide valid data to the selected cell are shown. When you choose a system from the options shown here,
that system will appear to the right of the currently-selected system, with all appropriate connections drawn.

**Update**

If solution data is changed or modified, you can perform an update. You can bring in the latest solution case file into the solution cell for consumption.

**System Names**

You can enter an Icepak system name for your project as described in Naming Your Systems (p. 56). In addition, you can use the Rename option to change the name of a system or cell. In the Icepak application you will find the system coordinate, system name and application name displayed in the top left corner.

![System Names Diagram]

**Icepak Properties**

Select or enable Use Workbench Color Scheme to keep the ANSYS Workbench background graphics colors and display defaults in Icepak. You can enable this option by right-clicking the Setup cell and selecting Properties. Enable the option by clicking the check box under the Value column.

**DesignModeler to Icepak**

CAD models created or edited in DesignModeler can be imported into Icepak. Icepak instructs DesignModeler to export the current DesignModeler geometry into Step file format so it is readable by Icepak. The procedure to transfer Geometry upstream to Icepak is described in this section.

1. Double-click Geometry in the Toolbox under the Component Systems node or drag and drop the Geometry template into the Project Schematic.

 ![Geometry Toolbox]

2. In the Project Schematic, double-click the Geometry cell to launch the DesignModeler application or right-click to display the context menu. Select New Geometry to create a geometry in DesignModeler. You can import any geometry or load an existing DesignModeler geometry by right-clicking the Geometry cell and selecting Import Geometry from the context menu.
indicates that all necessary files are loaded and up to date.

3. The connection to Icepak can be established one of the following ways:

   • Drag and drop an Icepak system on top of the Geometry cell to establish a connection.

   • Double click Icepak in the Toolbox under the Component Systems node to bring the Icepak system into the Project Schematic, click the Geometry cell and drag it to the Icepak Setup cell to establish a connection.

   • From the Icepak cell, perform a right mouse click and select Transfer Data From New in the context menu. You can then select a connection to DesignModeler.

   • From the Geometry cell, perform a right mouse click and select Transfer Data to New in the context menu. You can then select a connection to Icepak.

4. Double-click the Icepak cell to launch the Icepak application. If the geometry is different from the DesignModeler’s native format (.agdb) then you will need to edit the geometry first before exporting into Icepak.

5. A new project will be created in the name of the project cell. DesignModeler geometry will be imported into Icepak as STEP geometry.

6. If the geometry is changed or modified, the Icepak Setup cell will need to be refreshed in order to bring in the new geometry.
After you refresh the data, you will need to decide if you want to replace the entire model in Icepak or update individual geometries that have changed. You are prompted with the following dialog box.

If you select **Update model**, the Icepak model will be updated to match the existing model in DesignModeler which may result in creating objects that are not currently present in the Icepak model, the geometries of modified objects will be updated, and the thermal and material properties of the updated objects will be retained. Objects created separately in Icepak will not be updated. If you select **Replace model**, the entire Icepak model will be replaced with the latest input CAD data from DesignModeler. See the sample session in Chapter 2 of the Icepak documentation for an example on how to use Icepak. Refer to **Understanding Cell States** (p. 315) for a complete list of all cell states.

7. Perform an analysis on the model if you have not yet done so.

8. If the geometry has changed after you have solved, you can perform an update to bring in the new changes.

You can choose to not overwrite the solution via the dialog box shown below, and the update will be cancelled (❌).
Postprocessing of Icepak Results

Icepak provides two methods for examining the results of your simulation: you can postprocess results inside of Icepak or by using CFD-Post.

1. To postprocess results in Icepak, add an Icepak system to the project schematic and perform an analysis on the model. You can then create graphical displays and examine your results in Icepak. For details, see Examining the Results in the Icepak documentation.

2. Use one of the following ways to connect to CFD Post:
   - Drag and drop a Results cell on top of the Icepak Solution cell to establish a connection.
   - Double click Results in the Toolbox under the Component Systems node to bring the Results system into the Project schematic, click the Icepak Solution cell and drag it to the Results cell to establish a connection.
   - From the Results cell, right-click and select Transfer Data From New in the context menu. You can then select a connection to Icepak.
   - From the Icepak cell, perform a right mouse click and select Transfer Data To New in the context menu. You can then select a connection to Results.

3. Icepak results can be postprocessed in CFD Post by double-clicking the Results cell. If you have more than one solution or your solution has changed, you need to update the Results cell. If solution data is not transferred, then Results cannot be launched. See CFD-Post help for more details.
Thermal Results From Icepak to Mechanical

Icepak results can be transferred to the following analysis types within ANSYS Workbench: Static Structural, Steady-State Thermal, Transient Structural, or Transient Thermal. To add an analysis type, follow the procedure below:

1. Add an Icepak system to the project schematic and perform an analysis on the model inside Icepak.

2. Use one of the following ways to connect to Mechanical.
   - Drag and drop an Analysis cell on top of the Icepak Solution cell to establish a connection.
   - Double click an analysis type in the Toolbox under the Analysis Systems node to bring the analysis into the Project schematic, click the Icepak Solution cell and drag it to the analysis Setup cell to establish a connection.
   - From the analysis Setup cell, perform a right mouse click and select Transfer Data From New in the context menu. You can then select a connection to Icepak.
   - From the Icepak cell, perform a right mouse click and select Transfer Data To New in the context menu. You can then select a connection to an analysis system.

3. Load geometry to satisfy the system.
4. Double-click the **Setup** cell to launch Mechanical.

5. While in Mechanical insert the appropriate loads based on the type of analysis. See *Icepak to Mechanical Data Transfer* for a detailed description of how to import an external load.

**Design Explorer - Icepak Coupling in Workbench**

The exploration of a given design can be performed by using optimization algorithms in ANSYS DesignXplorer. Parameters exposed from Icepak provide a method for solving an optimization and/or parameterization problem. To publish Icepak variables, follow the procedure below:

1. In Icepak, define input and output parameters. See *Overview of Parameterization* for a description on how to define parameters.

   **Note**

   The **Design variables** tab of the **Parameters and optimization** panel displays all the parameters names that are currently defined, along with their associated values.

2. In the **Setup** tab of the **Parameters and optimization** panel, select **Single trial (current values)** for **Trial type** if not already selected.

3. Click the **Publish to WB** button at the bottom of the **Parameters and optimization** panel to display the **Publish to WB** panel.
Figure 1: The Parameters and optimization Panel

- In the **Publish to WB** panel, select the input and output variables to publish to Workbench.

**Note**

Variables can be selected independently. In the case of multiple variables, click the green check mark to toggle all variables on and off.
Figure 2: The Publish to WB Panel

- Click **Accept** to publish variables to Workbench, click **Done** to publish variables and close the panel, or click **Cancel** to withdraw the request. ANSYS Workbench recognizes the parameters defined and exposes them in a parameter set bar that can be shared by multiple systems. Double-click the parameter bar or right-mouse click and select **Edit** from the context menu to access the **Parameters** tab. For information on defining parameters, refer to Working with Parameters and Design Points (p. 123).

Figure 3: Icepak System with Parameters

---

**Note**

A design point is a set of input parameter values and corresponding output parameter values associated with an individual parameterized project definition. Design points can be created within the **Parameters** tab and allow you to perform what-if studies. For information on design points, refer to Design Points (p. 134).
4. To create a new design point, enter the input parameter values that you want to use for that design point in the Table of Design Points in the row with an asterisk (*) in the first column. You can create several design points. Once you have finished specifying design points, you can right-click the row for one design point and select the Update Selected Design Point option from the context menu to compute the output parameters for that design point. Alternatively, you can select Update All Design Points from the Toolbar to update all of your design points in sequence.

**Important**

Only the data from the design point in the row labeled Current is saved with the project. If you want to post-process the results from a different design point in either ANSYS Icepak or ANSYS CFD-Post, click the box in the Exported column for that design point before you update that design point. Otherwise, the data for that design point is automatically deleted after the output parameters for that design point are updated. If you choose to export a design point, the data associated with that design point is exported to a new project. The new project is located in the same directory as the original project. The name of the project is the same as the name of the original project, except that it is appended with _dpn, where n is the row number that corresponds to the design point in the original project’s Table of Design Points.

**Important**

Note that you cannot create, edit, delete, or rename parameters in Icepak if any iterations (or time-steps) have been performed. If you want to create, edit, delete, or rename parameters in Icepak for a case with an existing solution, you must first initialize the solution.

5. Optimization of an Icepak system can be performed in ANSYS DesignXplorer. ANSYS DesignXplorer provides various optimization methods with parameters as its fundamental components. These parameters can come from any supported analysis system, such as Icepak, DesignModeler, and various CAD systems. Responses can be studied, quantified and graphed. For information on how to set up an ANSYS DesignXplorer analysis, see the DesignXplorer User's Guide.

**Ansoft - Icepak Coupling in Workbench**

Icepak can be coupled with Ansoft applications within Workbench in order to perform a one-way or two-way electromagnetic-thermal interaction problem. Coupling between Ansoft and Icepak applications within Workbench can be used for simulating fluid flow around or inside electromechanical (EM) devices when the temperature of the device is influenced by electromagnetic losses.

The coupling involves solving an electromagnetic problem in the Ansoft application, and mapping the resulting volumetric heat loss and/or surface loss information into Icepak. Volumetric loss is mapped onto the solid cell zones as a heat source (load) at the cell centroids that is then added to the energy
equation. Surface loss is applied to the adjacent cells of the solid zones at the surface that contribute to the source terms of these cells.

**Note**

Surface loss is highly concentrated near the surface of the solid zone, so you should have a fine layer of good quality hexahedral or prism mesh elements located where surface loss occurs.

You can analyze the results of volumetric or surface losses using the heat flow postprocessing variable under **Summary report**.

**Note**

When surface losses are enabled, the double precision solver is recommended.

**One-way Coupling between Ansoft and Icepak Within Workbench**

The workflow for an Icepak-HFSS/Maxwell/Q3D Extractor analysis is as follows:

- The Ansoft to Icepak connection can happen one of the following ways:
  1. Drag and drop a HFSS/Maxwell/Q3D Extractor system onto the **Project Schematic**. Import/create the geometry in the Ansoft application. Setup the problem and solve to obtain a solution for transfer into an Icepak system. Connect the HFSS/Maxwell/Q3D Extractor **Solution** cell to the Icepak **Setup** cell.

  **Figure 4: Maxwell Transfer to Icepak**

  ![Project Schematic](image)

  2. From the Icepak cell, you can perform a right mouse click and select **Transfer Data From New** in the context menu. You can then select a connection to HFSS/Maxwell/Q3D Extractor or from the geometry cell, perform a right-click and select **Transfer Data to New** in the context menu to connect to Icepak.
Double-click the Icepak cell to launch the Icepak application. A new project will be created in the name of the project cell. If a DesignModeler system is used the geometry will be imported into Icepak automatically. Otherwise, the geometry must be created in Icepak using Icepak primitive objects.

**Note**

The geometry can be exported from the HFSS/Maxwell/Q3D Extractor cell to a Geometry cell and imported to the Icepak cell using DesignModeler Electronics.

In Icepak, go to the File menu and select EM Mapping and Volumetric heat losses or Surface heat losses.

The Volumetric heat losses panel contains the following inputs:

- A list of solid objects onto which the loss information can be mapped. For these objects, Icepak requests the heat source (loss) terms from the Ansoft application. Click the Objects button to toggle your current object selections. Right-click Objects and select All or None to select all or none of the objects.

- Solution ID contains available solution sets. Since the HFSS/Maxwell/Q3D Extractor application may have multiple solutions, Icepak will request the generated heat source data for the selected solution.

- Frequency (steady-state only) contains available frequencies. Icepak will request that the HFSS/Maxwell/Q3D Extractor application provide the heat source data for the selected frequency.

- Start time(s) and End time(s) (transient only) contains the available time steps. Icepak will request that the HFSS/Maxwell/Q3D Extractor application provide an averaged heat loss for the selected time steps.

**Note**

The Start time(s) and End time(s) specified are applied to both volumetric and surface heat losses.

- Temperature feedback option is used in two-way coupling problems. This option is explained below.
Figure 6: Volumetric heat losses - Steady-state
Click **Accept** to close the panel.

- In Icepak, click **Start solution** to solve the project. During solving, HFSS/Maxwell/Q3D Extractor will be launched in the background and the volumetric losses calculated and mapped onto the selected Icepak solid objects. This loss mapping from HFSS to Icepak is conservative. This is especially important for accurate temperature calculation.

**Two-Way Coupling Between Ansoft and Icepak Within Workbench**

Two-way coupling enables thermal feedback to be provided between the systems so that you can exchange temperature data from Icepak to Ansoft applications within Workbench. To enable two-way coupling between Icepak and Ansoft, you should perform the following steps:

1. Open the Maxwell (or HFSS/Q3D Extractor) project and define temperature–dependent material properties (enabling the Thermal Modifier field in the View/Edit Material dialog box and editing the material's thermal property definition). This makes sure that the Ansoft and Icepak applications generate the temperature–dependent data.
2. Select **Enable Feedback** in the **Temperature of Objects** dialog box. The **Temperature of Objects** dialog box is displayed when selecting **Set Object Temperature** in the Maxwell 3D/HFSS/Q3D Extractor menu.
Note

In Maxwell/HFSS/Q3D Extractor, you can have different losses (Ohmic loss, Core loss, Hysteresis loss) depending on the type of simulation. Maxwell/HFSS/Q3D Extractor can also compute the "total loss" which is the sum of all the losses when appropriate. All the different losses mentioned above including the "total loss" are a function of space and they are also a function of time in the Maxwell/HFSS/Q3D Extractor transient solver. When doing the coupling simulation, the "total loss" is mapped to Icepak for the temperature calculation. For transient simulations, the total loss is time averaged between two times that you specify before it is mapped to Icepak.

3. From the Icepak cell, you can perform a right mouse click and select Transfer Data From New in the context menu. You can then select a connection to HFSS/Maxwell/Q3D Extractor or from the geometry cell, perform a right-click and select Transfer Data to New in the context menu to connect to Icepak.

Figure 8: A Coupled HFSS-Icepak System
Double-click the Icepak cell to launch the Icepak application. A new project will be created in the name of the project cell. If a DesignModeler system is used the geometry will be imported into Icepak automatically. Otherwise, the geometry must be created in Icepak using Icepak primitive objects.

**Note**

The geometry can be exported from the HFSS/Maxwell/Q3D Extractor cell to a **Geometry** cell and imported to the Icepak cell using DesignModeler Electronics.

4. In Icepak, go to the **File** menu and select **EM Mapping** and **Volumetric heat losses**.

The **Volumetric heat losses** panel contains the following inputs:

- A list of solid objects onto which the loss information can be mapped. For these objects, Icepak requests the heat source (loss) terms from the Ansoft application.
- **Solution ID** contains available solution sets. Since the HFSS/Maxwell/Q3D Extractor application may have multiple solutions, Icepak will request the generated heat source data for the selected solution.
- **Frequency** contains available frequencies. Icepak will request that the HFSS/Maxwell/Q3D Extractor application provide the heat source data for the selected frequency.
- **Temperature feedback** enables the writing of temperature data by the Icepak solver to be sent to the Ansoft application to perform two-way coupling. This option must be enabled for two-way coupling.

**Note**

When volumetric heat losses are not available, two-way coupling can still be performed for surface heat losses by enabling the **Temperature feedback** option in the **Volumetric heat losses** panel.

5. After solving in Icepak, you can send temperature data back to the Ansoft application to solve again. Right-click the Ansoft application’s **Solution** cell. Select **Enable update** to solve again.

6. Next, solve Icepak again using this newly generated data. This process can go on indefinitely until you are satisfied with the results.

**Handling Coupling Iterations Between Ansoft and Icepak**

You can also perform manual cyclic updates of individual system components until the solution stops changing within a desired level of tolerance. For example:

- **Coupling Iteration 1**
  - Update Maxwell/HFSS/Q3D Extractor Solution cell
  - Perform EM Mapping on solid zones in Icepak
  - Update Icepak Solution cell
- Perform **Enable update** on Maxwell/HFSS/Q3D Extractor Solution cell
- Update Maxwell/HFSS/Q3D Extractor Solution cell

**Coupling Iteration 2**
- Update Icepak Setup cell
- Update Icepak Solution cell
- Perform **Enable update** on Maxwell/HFSS/Q3D Extractor Solution cell
- Update Maxwell/HFSS/Q3D Extractor Solution cell

**Coupling Iteration 3**
- Update Icepak Setup cell
- Update Icepak Solution cell
- Perform **Enable update** on Maxwell/HFSS/Q3D Extractor Solution cell
- Update Maxwell/HFSS/Q3D Extractor Solution cell

**Coupling Iteration 4**
- Update Icepak Setup cell
- Update Icepak Solution cell
- Perform **Enable update** on Maxwell/HFSS/Q3D Extractor Solution cell
- Update Maxwell/HFSS/Q3D Extractor Solution cell

...and so on.

You can perform automatic system updates (coupling iterations) using the Ansoft Feedback Iterator. Refer to Ansoft help documentation for more information on Feedback Iterator.

**ANSYS Icepak - Workbench Integration Tutorial**

To access the ANSYS Icepak - ANSYS Workbench integration tutorial, go to [http://support.ansys.com/training](http://support.ansys.com/training) and download the ANSYS Icepak Tutorial Guide.

**Mechanical APDL**

You can use ANSYS Workbench to launch the Mechanical APDL application (formerly known as the ANSYS software), and therefore to manage the various files often used and created by Mechanical APDL, especially when working with a linked analysis (for example, thermal-stress, substructuring, submodeling, and so on). It is important that you understand the types of files that the Mechanical APDL application uses and generates, because the actions you take in ANSYS Workbench will act on these files. These files fall into three broad categories: input, reference, and output.

**Input Files** Files that are consumed directly by the Mechanical APDL application. Examples include:
• Files consisting of Mechanical APDL commands, generated manually or by Mechanical APDL (log files) or by the Mechanical or Meshing applications.

• Coded input files, such as .cdb files, generated by Mechanical APDL, FE Modeler, and third-party pre-processors

• Mechanical APDL geometry files (.anf), generated by Mechanical APDL or DesignModeler

**Note**

In some cases, the Mechanical APDL solver will overwrite one of its input files with its generated output (for example, the file .rst file from a Modal system in a Modal to Response Spectrum analysis linked to a Mechanical APDL component system). If this occurs, subsequent updates of the Mechanical APDL component system will fail. To copy the correct input from an upstream system, perform a Reset operation on the Mechanical APDL component system.

**Referenced Files**  Files that are referenced by the execution of an input file. Examples include:

- Database files
- Results files
- Command macro files
- Superelement files
- Solver files
- CAD geometry files

**Output Files**  Files that are produced by all Mechanical APDL application runs. Primary output files include:

- Results file (.rst, .rth, etc.)
- Output file (.out) of the command echoes, solution information, and requested data listings
- Log file (.log) of the commands issued to the Mechanical APDL application
- Error file (.err) listing any warnings or errors encountered

**Working with a Mechanical APDL Analysis**

To add a Mechanical APDL analysis to your project, double-click the Mechanical APDL object or drag-and-drop it from the Component Systems area of the Toolbox into the Project Schematic. A Mechanical APDL system appears in the Project Schematic.

You can easily connect other systems to a Mechanical APDL system by using the **Transfer Data From New** or **Transfer Data To New** context menu options. You can also drag systems from the toolbox, or manually create links between systems. When transferring data to a Mechanical APDL system from another system, you can transfer data from the following cell sources:

- **Geometry**: transfers just the geometry in the form of an .anf file. This option is only supported for geometry that is represented as DesignModeler geometry.
• **Model (Mesh)** cell if a meshing system: transfers an input file containing only the mesh, contact, coordinate system, and named selections data

• **Setup** (Mechanical Systems): transfers an input file containing all data necessary to solve the analysis, including geometry, model, loads, materials, etc. Any supporting files needed to execute the input file will be transferred as well. Examples include pre-stress modal or random vibration.

• **Setup** (Finite Element Modeler): Transfers input file containing any finite data recognized inside Finite Element Modeler, such as mesh, materials, components, constraints, etc.

• **Solution** (Mechanical Systems): transfers the database file (.db) if it exists and result file only.

---

**Note**

For **Model**, **Setup** (Mechanical Systems), and **Solution** transfer cells, if you solve within Mechanical, you will still need to run an Update on the appropriate cell in the Mechanical system in order to obtain the correct state on the schematic.

In most cases, **Model** and **Setup** components from the same Mechanical system should not be linked to one Mechanical APDL system. Doing so will cause the Mechanical system to provide two different (and possibly conflicting) input files to the Mechanical APDL system.

---

**Important**

The Mechanical APDL system consumes all input data without unit system knowledge. You must ensure that all input data being used by the Mechanical APDL system is in a consistent unit system. See **Solving Units** for more information on unit system.

---

When transferring data from a Mechanical APDL system to another Mechanical APDL system, you can transfer four types of data:

• **Results**: transfers all results files (including .rst, .rfl, .rth, etc.)

• **Database**: transfers all database files (.db)

• **Solver**: transfers all files in the system folder

• **CDB**: transfers .cdb files

You can also transfer data to a new Finite Element Model system, which uses the .cdb file(s).

These files are simply copied to the new system if they exist; ANSYS Workbench does not generate the files. Before transferring data to a new system, be sure that you have an input file that generates the necessary files from the existing Mechanical APDL system.

When you transfer data to or from another system, right-mouse click the link connecting the systems and select **Properties**. The Properties window will open, detailing the nature of the transfer (such as Transfer CDB File).

**Note on connecting to Mechanical systems**   Named Selections and Coordinate Systems that are added to a solved Mechanical system will not be immediately reflected in downstream Mechanical APDL systems. They will be available in future solution attempts.
To open the Components workspace to select Mechanical APDL parameters, double-click the **Analysis** cell or right mouse-click and select **Edit**. From the Components workspace, you can select Mechanical APDL parameters or specify setup properties (p. 23) (such as command line options, memory settings, number of processors, etc.).

When you add an input file via the context menu, ANSYS Workbench automatically searches the file for potential parameters (**SET**, **GET**, = assignments, etc.). Those parameters are then displayed in the Properties view when that input file is selected in the Outline view. To use one of those parameters, check that parameter’s check box in the Property view and indicate whether it should be used as an input or an output parameter. Input parameters are sent to Mechanical APDL with the value specified upon Update. After the Update, ANSYS Workbench retrieves the output values from Mechanical APDL and sets those values in ANSYS Workbench.

---

**Note**

The presence of a */EXIT* command in the input file causes state and parameters to malfunction. Make sure you remove this command before adding the input file.

---

To launch the Mechanical APDL application interactively, right mouse-click and select **Edit in Mechanical APDL** or **Open in Mechanical APDL** as explained below in Mechanical APDL Context Menu Options (p. 279).

To launch the Mechanical APDL application with input and reference files specified, right mouse-click the **Analysis** cell and select **Add Input File** or **Add Reference File**. Then select **Edit in Mechanical APDL**. The Mechanical APDL application will launch in interactive mode, and the input file(s) specified will be piped to the Mechanical APDL application, and processed in the order listed. After all of these files are processed, the Mechanical APDL application remains active and you can continue your analysis using the standard Mechanical APDL application interface. Any action you take in the Mechanical APDL application will not be reflected in ANSYS Workbench state indicators or parameters.

Be aware that any time you launch the Mechanical APDL application, ANSYS Workbench does not log or record the actions that occur in the Mechanical APDL application. If you make changes in the Mechanical APDL application, be sure that the changes are reflected appropriately in the input files. To maintain connectivity (such as to read output parameters), use the Update capability, either at the project level or at the appropriate system/cell level.

To save Mechanical APDL changes from an open session, you must include a **SAVE** command in one of your input files. The ANSYS Workbench save capability does not invoke the Mechanical APDL **SAVE** command.

When you add an input file, you will see the files listed in the files detail view. Files will be processed in the order shown. You can change the order in which the files are processed by dragging the files into the proper order. To delete files, right-mouse click the file to be deleted and select **Delete**.

To stop a Mechanical APDL batch run, view the Progress window. Click the Stop button on the Progress cell.

**Mechanical APDL Context Menu Options**

When the Mechanical APDL system is active in the schematic, use the right mouse button to initiate the following **Analysis** cell actions.
Edit
Opens the Components workspace, where you can specify Mechanical APDL parameters and setup properties. This is the default action.

Edit in Mechanical APDL
Launches the Mechanical APDL application interactively and reads the input files. If the state is currently up to date, ANSYS Workbench sets the state to Update Required at this time, even if you do not make any changes in the Mechanical APDL application.

Open in Mechanical APDL
Launches the Mechanical APDL application interactively without reading any input files. Any action you take in the Mechanical APDL application will not be reflected in ANSYS Workbench state indicators.

Add Input File
Displays a Browse… dialog box to add an input file. When you add an input file, the file is immediately copied into the project directory. To make changes to this file, change the file in the project directory, not the original file. If you have a large input file and have disk space concerns, keep the file in the directory of your choice and use a separate input file to reference it (via the /INPUT command).

Add Referenced File
Displays a Browse… dialog box to add a referenced file. When you add a referenced file, the file is immediately copied into the project directory. To make changes to this file, change the file in the project directory, not the original file. If you have a large reference file and have disk space concerns, keep the file in the directory of your choice and reference it manually.

Track Solution
During an Update, this option launches the Results Tracking tool, allowing you to monitor diagnostics results of interest in real time during the solution. For more information, see the NLHIST command.

Update
Update runs the Mechanical APDL application in batch mode, processing all input files in the order listed. If you make changes in the Mechanical APDL application, be sure that the changes are reflected appropriately in the input files before running an Update. Otherwise, an Update could potentially overwrite the work you’ve done in the Mechanical APDL application.

Note
An Update will launch the Mechanical APDL application in batch mode, using all input and referenced files in the order shown in the Outline pane. After all files are processed, the Mechanical APDL application exits. Updating will capture any output parameters generated in the Mechanical APDL application and allow you to continue working in ANSYS Workbench.

Refresh
Copies the latest transfer files into the project directory. Input and referenced files are not re-copied from their original locations. If you change an upstream system after you make changes to the Mechanical APDL application, a refresh could potentially overwrite your Mechanical APDL application changes. Be sure that any changes you do in the Mechanical APDL application are reflected appropriately in the input files before running a Refresh. Only changes that occur within the schematic are captured with a Refresh Required state; ANSYS Workbench will not indicate Refresh Required for changes made directly to a file (such as manually editing an input file).
Clear Generated Data
Deletes all files on disk in the system directory except input or reference files. It will not affect any input or reference files.

Rename, Reset
Standard actions as described in Common Context Menu Options (p. 327).

Properties
Launches the Properties window, where you can define graphics settings, command line options, database and tab memory, and other settings. Be aware when selecting graphics settings that some options are potentially platform-specific and must be changed when switching platforms before running the project with Mechanical APDL in interactive mode.

Note on the solver input file generated from the Setup cell of a Mechanical APDL system
The solver input file transferred from the Setup cell contains all the commands needed to execute a complete run, including any SOLVE commands that are necessary. However, the input also contains a conditional /EOF statement to halt reading of the file and thus not execute the solve. This conditional statement will be executed when the Mechanical APDL application is invoked from the Edit in Mechanical APDL context menu option, therefore running the analysis to the point just prior to the SOLVE command. If a different behavior is desired, you can edit the input file in the Mechanical APDL system folder to obtain a different behavior or to add an additional input file containing the SOLVE command.

Mechanical Model
A Mechanical Model system consists of Engineering Data, Geometry, and Model cells. In the Mechanical application, this system corresponds to that of a Model-only system. You can use this type of system to create an analysis using a single model and multiple system analysis branches. You can also create other Mechanical Model systems that share data at any cell level (Engineering Data, Geometry, or Model). Mechanical Model systems are unfiltered (physics and solver).

The Mechanical Model system is also created when you resume a legacy database that does not have an analysis environment already defined. A Mechanical Model system may also be used as a system replacement for a Mesh system.

To create a new Mechanical Model system:
1. Choose Mechanical Model from the Component Systems section of the Toolbox. Double-click or drag the Mechanical Model system onto the Project Schematic.
2. Create or attach a geometry using the Geometry cell context menu.
3. Edit the model if necessary. Right-mouse click the Model cell and choose Edit.
4. Add a connected system either by dragging a valid analysis system from the Toolbox and dropping it on the appropriate target location, or right-mouse click the Geometry or Model cell and choose Transfer Data To New.
5. To create multiple system analysis branches, repeat step 4 with other analysis systems.

To resume an existing legacy database that contains no physics environment:
1. Choose File → Import. Browse to and select the legacy database and click Open.
2. A Mechanical Model system appears in the Project Schematic, with the legacy database loaded. Double-click the Model cell, or choose Edit from the Model cell context menu to open the Mechanical application.
3. In the Mechanical application, proceed with any necessary Model updates.

4. You can then add any valid analysis system by dragging a template from the Toolbox to the Project Schematic. Choose the appropriate drop location that shares the desired cells with the Mechanical Model system.

5. Continue with the analysis in the analysis system as you normally would.

To replace an existing Mesh system with a Mechanical Model system (or vice-versa), select Replace with and choose Mechanical Model or Mesh (respectively) from the header context menu. When a Mesh system is replaced with a Mechanical Model system, the Mechanical Model system can then be shared with any analysis system as described above.

The units setting specified in an existing system is not maintained in the replacement system. In the replacement system, you must select the units setting that you want to use.

**Model-to-Model Connections**

Multiple Mechanical Model component systems can be merged together by creating a connection between the Model cells of each component system. This allows you to build up more complicated models from smaller, simpler models. This behaves in the same way as Mesh-to-Mesh Connections (p. 287). More detailed information can be found in Assembling External Models and Mechanical Models in the ANSYS Mechanical User's Guide.

**Solution-to-Model Connections**

You can transfer a deformed geometry from a Static/Transient/Modal/Buckling/Explicit Dynamics system to a Mechanical Model or to a Mechanical Analysis system. You might want to do this to introduce imperfections to an otherwise perfect geometry to overcome convergence issues when running a nonlinear simulation.

To use the deformed mesh from a solved analysis as the initial geometry/mesh for a follow-on analysis:

1. Drag a connection from the Mechanical Solution cell to a downstream Model cell in a Mechanical system. You can create connections to multiple downstream Model cells.

2. If you want to share Engineering Data between the systems, link the Engineering Data cells as desired.

---

**Note**

If you are incorporating a deformed geometry into Model Assembly systems, you need to share the Engineering Data cell of the deformed geometry system with one or more of the Model Assembly systems in order to have the materials automatically transferred and set for the deformed geometry in the downstream system.

---

3. In the Properties view, optionally you can:

   a. Adjust the amount and direction of the deformation by setting a Scale Factor (a negative value reverses the direction of the deformation).

   b. Adjust the upstream Time settings (for Transient, Static Structural, or Explicit Dynamics systems) or the Mode (for Eigenvalue Buckling or Modal systems) for each connection to a downstream Model cell.
If you set a **User Defined Time**, the value is always interpreted as being in seconds.

c. Adjust the transfer input settings on downstream Model. The transfer settings are the same as those for **Mesh-to-Mesh Connections** (p. 287).

For more detailed information, see **Geometry from Deformation Results** in the *ANSYS Mechanical User's Guide*.

**Controlling Node and Element Numbering when Model Cells Share Data**

When you connect the Model cell of a Mechanical system to the Model cell of a downstream Mechanical system, you can use the **Renumber Mesh Nodes and Elements Automatically** property in the downstream Mechanical Model cell to control whether mesh nodes and elements are automatically renumbered to prevent conflicts. You can set the **Renumber Mesh Nodes and Elements Automatically** property on a transfer-by-transfer basis. By default automatic renumbering occurs, but you can disable the property for as many of the transfers as you want—as long as their element numbers will not conflict downstream and the **Number Of Copies** is set to 0.

**Preview Assembled Geometry**

You can quickly preview the orientation of your parts in an assembly by right-clicking on the downstream model cell and selecting **Preview Assembled Geometry**. When using this feature, Mechanical will assemble the geometry only (computationally expensive items such as the mesh are not assembled) enabling you to review the assembled geometry potentially much more quickly. This feature is useful if you are unsure about the relative positioning of your subassemblies and some transformations are required for proper alignment. A typical workflow using this feature is shown below.

To start, you need to have fully updated upstream **Model** cells connected to a downstream **Model** cell. The downstream **Model** cell will be in a state of refresh required. In this demonstration, **Box1** and **Box2** are both the same model, a rectangular prism, and you would like to have them oriented into a “T” (one oriented 90 degrees from the other). However, a translation in the positive y-direction is also needed to ensure a smooth contact between the parts. To accomplish this, you enter a value of 10m in the properties view of the **Project Schematic** to translate the Y-origin of **Box1**. As opposed to issuing a full update on the downstream **Model** cell, which loads the mesh data as well as the geometry, you first perform a geometry-only assembly by right-clicking on the downstream model cell and selecting **Preview Assembled Geometry**.
This will open the assembly in Mechanical for you to inspect. When you activate Mechanical in this way, no meshing or physics options are available.
Upon viewing the preview, you discover that the geometry is not in the proper orientation. After inspecting the gap between the parts, you determine the proper y-translation is 9.35m. After entering this data in the properties view of the Project Schematic, you can again right-click the downstream Model cell and select Preview Assembled Geometry. Mechanical will quickly update to show you the change in orientation.
You confirm that the orientation of the two parts is correct. At this point, you can issue a full update so that Mechanical will load in the mesh data and you can continue your analysis.

**Mesh**

You can use the Mesh component system to create and/or open geometry or mesh files. The Mesh component system contains a Mesh system header and two cells.

You can create a Mesh component system using any of these methods:

- Double-click the Mesh system template in the Toolbox.
- Drag-and-drop the Mesh system template onto the Project Schematic.
- Drag-and-drop a .meshdat or .cmdb file from Windows Explorer onto the Project Schematic.
- Choose **File → Import** or click the **Import** button from ANSYS Workbench and select a file of type .meshdat or .cmdb.

**Mesh Context Menu Options**

The Mesh component system contains a Mesh system header:

1. **Mesh**: Mesh system header context menu options include the following:
   - **Replace With> Mechanical Model**
   - **Refresh, Update, Duplicate, Delete, Rename, Properties**: Standard actions as described in System Header Context Menu Options (p. 332).
The Mesh component system contains two cells:

1. **Geometry** cell context menu options include the following: New Geometry, Import Geometry, Duplicate, Transfer Data From New, Transfer Data To New, Update, Refresh, Reset, Rename, Properties. For details see Geometry (p. 313).

2. **Mesh** (p. 314): Model cell context menu items include the following:

   - **Edit**: Opens the Meshing application and loads an existing geometry/mesh file.
   - **Import Mesh File**: Allows you to import read-only meshes for downstream application use. You may browse to local files using the Browse option or to files stored on an EKM repository using the Browse from Repository option. For more information on Browse from Repository, see Importing Repository Files (p. 174).
   - **Duplicate**: Duplicates the Mesh system. The Geometry cell is shared, and all data associated with the Mesh cell is copied to the second system.
   - **Transfer Data To New**: Enables the transfer of a mesh from the Mesh system into a downstream system as follows:
     - **Autodyn**: Inserts downstream Autodyn system and generates a data transfer connection (.cmdb file) from the Mesh cell to the Setup cell of the Autodyn system.
     - **CFX**: Inserts downstream CFX system and generates a data transfer connection (.cmdb file) from the Mesh cell to the Setup cell of the CFX system.
     - **FE Modeler**: Inserts downstream FE Modeler system and generates a data transfer connection (.cmdb file) from the Mesh cell to the Model cell of the FE Modelersystem.
     - **Fluent**: Inserts a downstream Fluent system and generates a data transfer connection (.msh file) from the Mesh cell to the Setup cell of the Fluent system.
     - **Mechanical APDL**: Inserts a downstream Mechanical APDL system and generates a data transfer connection (.inp file) from the Mesh cell to the Analysis cell of the Mechanical APDL system.
     - **Polyflow**: Inserts a downstream Polyflow system and generates a data transfer connection (.poly file) from the Mesh cell to the Setup cell of the Polyflow system.
   - **Update, Refresh, Clear Generated Data, Reset, Rename, Properties**: Standard actions as described in Common Context Menu Options (p. 327).

**Mesh-to-Mesh Connections**

Multiple Mesh component systems can be merged together by creating a connection between the Mesh cells of each component system. This allows you to build up more complicated meshes from smaller, simpler meshes.
For every upstream Mesh cell connected to a downstream Mesh cell, a new set of properties called Transfer Settings for [Mesh component name] appears in the Properties view of the downstream Mesh cell. In the above example, with two upstream Mesh components connected to single, downstream Mesh component, the Properties view of the downstream Mesh (cell B3) would have two new groups of properties.

Similarly, a Renumber Mesh Nodes and Elements Automatically property appears for each transfer. This property in the downstream mesh cell controls whether mesh nodes and elements are automatically renumbered to prevent conflicts. You can set the Renumber Mesh Nodes and Elements Automatically property on a transfer-by-transfer basis. By default automatic renumbering occurs, but you can disable the property for as many of the transfers as you want—as long as their element numbers will not conflict downstream and the Number Of Copies is set to 0.
### Table 13: Properties View: General Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Length Unit</td>
<td>This property sets the units for the downstream mesh assembly. After the meshes are initially assembled, this property becomes read-only. Afterwards, you will have to reset the downstream mesh cell in order to change the <strong>Length Unit</strong>.</td>
</tr>
</tbody>
</table>

### Table 14: Properties View: Transfer Settings Section

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number Of Copies</td>
<td>When set to zero (default), only the source mesh is transformed. If you specify a number of copies greater than zero, these will be in addition to the source mesh.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>For example, if you import a .cdb file with a single part and set <strong>Number Of Copies</strong> to 2, you will get 3 parts in Mechanical.</td>
<td></td>
</tr>
<tr>
<td>Renumber Mesh Nodes and Elements Automatically</td>
<td>When Mesh cells are connected, this property in the downstream Mesh cell controls whether mesh nodes and elements are automatically renumbered to prevent conflicts. <strong>If the Number Of Copies is set to 1 or greater, automatic renumbering will occur.</strong></td>
</tr>
<tr>
<td>Transform Original</td>
<td>This property is available only when <strong>Number Of Copies</strong> is set to 1 or greater. Select the check box if you want to apply the specified transformation to the source mesh as well as any copies.</td>
</tr>
<tr>
<td>Origin X/Y/Z</td>
<td>These properties allow you to translate the origin of the model along the X, Y, or Z axis. If you specify any copies, the translation will be applied relative to the previous copy (or source mesh in the case of the first copy).</td>
</tr>
<tr>
<td>Theta XY/YZ/ZX</td>
<td>These properties allow you to rotate the model about its origin in the XY, YZ, or ZX plane. If you specify any copies, the rotation will be applied relative to the previous copy (or source mesh in the case of the first copy).</td>
</tr>
</tbody>
</table>

Any change in these properties will put the downstream mesh in a state of refresh required.

You can preview the mesh transformations by right-clicking on the Mesh cell and selecting **Preview Assembled Geometry**. You should use this feature to confirm that the correct mesh transformations have been applied. For more details and an example workflow, see **Preview Assembled Geometry (p. 283)**.

**Microsoft Office Excel**

You can use Microsoft Office Excel 2013 or 2016 as a calculator in ANSYS Workbench via the "Microsoft Office Excel" component system. This feature exposes Excel ranges as input and output parameters to ANSYS Workbench; you can use these ranges to create design points and Design Exploration studies.

**Note:** The Excel add-in is included with ANSYS Workbench. It does not require DesignXplorer or any other specific ANSYS product, but it must connect to a locally installed seat of Microsoft Excel (purchased separately).

**Using Excel with ANSYS Workbench Projects** topics:
- Preparing the Excel File
- Setting Up the Excel Calculator
- Support of Units
- File management and modification of the worksheet
- Limitations
- Troubleshooting Excel Use in ANSYS Workbench

**Preparing the Excel File**

To be exposed as parameters in Workbench, the ranges must be named in Excel. The names are filtered during the addition of the Excel file to the project; only the ranges matching the prefix defined by the
Named Range Key property in the Properties view of the Analysis cell are made visible in ANSYS Workbench.

**Note**

By default, no filtering prefix is defined at either the Workbench or the project level. You set a filter by either of the following methods:

- Set a default prefix that will be used for all new projects (see Microsoft Office Excel Options (p. 28)).

- Set a prefix at the project level by entering it in the Named Range Key property in the Properties view of the Microsoft Office Excel Analysis cell.

To name a range in Excel:

1. Open the file in the Microsoft Office Excel application.

2. Right-click a cell and select the Define Name.

3. Enter the name.

4. Review and modify all the defined names in the Excel application using Formulas > Name Manager.
A named range in Excel can contain several cells; however, Workbench expects the named ranges to contain either one or two cells, the first cell being reserved for the value and the second cell being reserved for the unit string, if any. If a named range contains more than two cells, it is ignored.

You can review and modify all the defined names in the Excel application using Formulas → Name Manager.

A named range can contain several cells. Workbench expects the named ranges to contain either one or two cells, the first cell being reserved for the value and the second cell being reserved for the unit string, if any. If a named range contains more than two cells, it is ignored.

**Note**

If you added the file to the Excel system in Workbench before naming the ranges, or if you want to edit the names of the ranges after the addition of the file, you can right-click the Analysis component or the file node in the Outline and select the Open file in Excel operation. This opens the Excel file used by Workbench in Excel.

All changes performed in Excel impact the state of the data in Workbench and invalidate the results; be sure to save your changes and reload the file afterwards (when editing the Analysis cell, right-click the file node and select **Reload**).

**Setting Up the Excel Calculator**

**Adding a File**

To add a file:

1. Drag and drop a "Microsoft Office Excel" system template on to the Project Schematic.
2. Right-click the Analysis cell, select **Add File**, and browse to the Excel file that you have prepared.
3. Right-click the Analysis cell and select **Edit Configuration** to review the list of named ranges retrieved from the Excel file. For each listed named range, check the Input or Output column in order to publish the range as an input parameter or an output parameter in the Workbench project.

![Image of Microsoft Office Excel system linked to Parameter Set bar](image)

4. Return to the Project Schematic; the Microsoft Office Excel system is linked to the Parameter Set bar.

Then right-click the Analysis system and select **Edit Configuration** to review the list of named ranges retrieved from the Excel file. For each listed named range, check the Input or Output column in order to publish the range as an input parameter or an output parameter in the Workbench project. Return to the Project Schematic; the Microsoft Office Excel is linked to the Parameter Set bar.

**Macro Property Usage**

If the calculation in Excel requires the execution of a macro, select the added file in the outline and check its **Use a Macro** property in the **Properties** View. Then enter the name of the macro in the **Macro Name** property.

**Note**

If a button is used to start the calculation and you do not know the name of the macro associated with it, right-click the button and select **Assign Macro** to discover the name to use.
The project is ready to create design points and Design Exploration studies.

**Support of Units**

Units are handled by the Excel system. A valid Workbench unit string must be used and included in the named range.

For instance, if an input parameter is a length in millimeters, you can name "WB_Length" the range A1:B1 where the cell A1 contains the length value (that is, "120.5") and the cell B1 contains the unit string ("mm"). When selecting the “WB_Length” range in the Outline view, the Properties view looks like below. In this case, the Quantity Name is automatically identified as a Length.

If there are several possible Quantity Names for the same unit string, you have to select the Quantity Name in the properties of the range for the unit conversion to be performed as expected. For instance, if A1:B1 was actually a temperature in degree Celsius, the Quantity Name could be a Temperature or a Temperature Difference.

For detailed information on working with units in ANSYS Workbench, see Unit Systems in the Working with Units section of the ANSYS Workbench help.

**File management and modification of the worksheet**

When the Excel file is added to the Analysis cell of the Excel system, it is copied inside the Workbench project files. So any modification made to the original file is not seen by Workbench except if you delete and add the file again.
To modify the file copied in the Workbench project files, right-click the Analysis component, or the file node in the Outline view, and select the **Open file in Excel** operation. Once modifications are done, save the file. The state of the file in Workbench changes to Refresh Required, which indicates that data are not synchronized anymore. Results such as design points and Design Exploration systems in the Workbench project are outdated. Refresh the project to synchronize all the pieces of the project.

If a change in the Excel file was not detected by Workbench, it is possible to force a reload of the file (right-click the file node and select **Reload**).

It is not necessary to close the workbook or the Excel application to proceed with design points or Design Exploration updates. Interaction with the Excel application will be frozen during such operations but you will be able to see the performed calculations.

### Limitations

**Version limitation**

The Excel feature in ANSYS Workbench requires Microsoft Office Excel 2013 or 2016.

**Platform limitation**

The Excel feature is only available on Windows systems.

**Excel Updates with "Set as Current" operation**

In a project with retained design points, switching to a different up-to-date design point via the Set as Current menu option automatically updates the Excel system, which could be time-consuming if the spreadsheet contains macros or extensive calculations.

**Design point failure when updating project with multiple Excel systems**

If you have Office Excel 365, Office Excel 2013, or Office Excel 2016 installed on your machine and your Workbench project contains multiple Excel systems and the Excel process window is hidden, updating the project may cause design points to fail and the following exception message to display:

"We found a problem with this formula. We couldn't find a range reference or a defined name."

Workaround: Before running any update operations, open the Excel process window by right-clicking and selecting **Open File in Excel**.

This issue is documented by Microsoft. For more information, see [https://support.microsoft.com/en-us/kb/3083825](https://support.microsoft.com/en-us/kb/3083825).

**Troubleshooting Excel Use in ANSYS Workbench**

**You are requested to install the Multilingual User Interface Pack of Microsoft Office for your language**

If you run the 2007 or 2010 English version of Excel and the locale for the current user is configured for a language other than English, Excel will try to locate the language pack for the configured language. If the language pack is not found, then the error is reported and the automation of Excel, as used by the Excel as a Calculator feature, cannot be performed. To solve this issue, you have to install the Multilingual User Interface Pack of Microsoft Office for your language. As an alternative, you can also configure the locale for the current user to English.

This bug is documented by Microsoft. For more information, see [http://support.microsoft.com/kb/320369](http://support.microsoft.com/kb/320369).
Polyflow

Polyflow allows for the analysis of fluid flows with free surfaces, complex rheology (including non-Newtonian behavior with viscoelasticity), heat transfer, and chemical reactions. The usage of Polyflow involves: specifying the computation models inside Polydata, which is the module for problem setup; and running the calculations using the Polyflow solver. Polyflow also comes with several useful utilities, which can be accessed via the right-click menu on the Setup and Solution cells. For example, Polymat can be used to calculate material properties, including viscoelastic parameters based on experimental data. For more details, see the product documentation.

There are three Polyflow fluid flow analysis systems available in Workbench:

- The **Polyflow** system provides the full simulation capabilities of Polyflow.
- The **Polyflow - Blow Molding** system provides only the application-specific capabilities of Polyflow that are suited to blow molding simulations.
- The **Polyflow - Extrusion** system provides only the application-specific capabilities of Polyflow that are suited to extrusion simulations.

To use a Polyflow, Blow Molding (Polyflow), or Extrusion (Polyflow) fluid flow component system, perform the following steps:

1. Add a Polyflow, Blow Molding (Polyflow), or Extrusion (Polyflow) fluid flow component system by dragging the system from the Toolbox into the Project Schematic, or by double-clicking the system in the Toolbox. The component system has two cells: a **Setup** cell and a **Solution** cell.

2. Import a mesh by right-clicking the **Setup** cell and clicking **Import Mesh** in the context menu that opens. You can merge, scale, translate, and rotate the mesh by right-clicking the **Setup** cell and clicking **Polyfuse** in the context menu that opens.

3. You can define your preferences for Polydata by right-clicking the **Setup** cell and clicking **Preferences** and **Polydata** in the context menu that opens.

4. Double-click the **Setup** cell to open Polydata, where you can specify the computational models, materials, boundary conditions, and solution parameters. Alternatively, you can import a previously saved Polyflow data file by right-clicking the **Setup** cell and clicking **Import Polyflow Data...** in the context menu that opens. You have the option of specifying material data by right-clicking the **Setup** cell and clicking **Polymat** in the context menu that opens.

5. You can define your preferences for Polyflow by right-clicking the **Solution** cell and clicking **Preferences** and **Polyflow** in the context menu that opens.

6. Run the Polyflow calculation by right-clicking the **Solution** cell and clicking **Update** in the context menu that opens. You can check the status of the solver during or after the calculation by right-clicking the **Solution** cell and clicking **Polydiag** in the context menu that opens. You can open the listing file to see what Polyflow has done during or after the calculation by right-clicking the **Solution** cell and clicking **Listing Viewer** in the context menu that opens.

7. You can generate plots of the solution data by right-clicking the **Solution** cell and clicking **Polycurve** in the context menu that opens. You can statistically postprocess the results of the solution data by right-clicking the **Solution** cell and clicking **Polystat** in the context menu that opens.
For detailed information on working with Polyflow, see the online documentation available under the Help menu within Polyflow. In addition, see the separate Polyflow in Workbench User’s Guide.

For information on submitting Polyflow jobs to Remote Solve Manager, see Submitting Polyflow Jobs to RSM or an EKM Portal.

**Results**

Use the Results component system to launch CFD-Post, a flexible, state-of-the-art post-processor that enables easy visualization and quantitative analysis of the results of CFD simulations.

Right-click the Results cell and select Edit to open CFD-Post. From CFD-Post, select File → Load Results to load a results file from the ANSYS CFX-Solver, ANSYS Fluent, or ANSYS Polyflow.

For detailed information on working with ANSYS CFD-Post, see CFD-Post in ANSYS Workbench in the CFD-Post User’s Guide.

**AIM: Study**

When you start ANSYS AIM, it opens in the Study tab (in which you generally work). However, a Study component also appears on the Project tab. From the Project tab, you can you access the Workbench Schematic and Systems Toolbox. You can:

- Access the parameter manager.
- Explore and optimize your design using DesignXplorer.
- Import geometry data into a Study cell. A Data Import cell is created. If you have multiple geometries, you can import them into the Study cell to create additional Data Import cells or into the same Data Import cell to have multiple geometries in it.
- Transfer AIM part meshing data—as PMDB, ACMO, or MSH files—to any Mechanical or Fluent system. This process enables you to use the benefits of AIM Meshing with a Mechanical or Fluent system.

This transfer operates in a way similar to Model-to-Model Connections (p. 282). Each connection has its own Transfer Settings.

For more information on using ANSYS AIM, see ANSYS AIM Documentation.
**System Coupling**

Use a System Coupling component system to model one- and two-way multiphysics couplings for your project. Connect a System Coupling system to one or more analysis systems, or to an External Data component, to have the System Coupling system synchronize and manage the data transfer and solution.

Drag the System Coupling component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox. Connect the System Coupling component system to the participating systems (either through the **Setup** cell or the **Solution** cell). Double-click the **Setup** cell, or right-click and choose **Edit** from the context menu to display the System Coupling tab. See System Coupling Workspace in the System Coupling User's Guide for further details.

**Solution Cell Properties**

The **Solution** cell's settings are visible from the Properties view. To access these settings, right-click the **Solution** cell and select **Properties**.

Most of the settings in the Properties view are for information only, but the Command Line Options setting enables you to send command-line arguments to the system coupling service. These commands are invoked when the system coupling service is started.

To learn the syntax for the command-line arguments, see Workflows for System Coupling.

**Turbo Setup**

The Turbo Setup component is an application used to rapidly create the workflows needed for the analysis of centrifugal compressors.

The application offers no design calculation capability itself; it is purely a tool designed to facilitate the analysis of turbomachinery using the Vista TF and CFX applications.

For more information, see Turbo Setup in the TurboSystem User's Guide.

**TurboGrid**

ANSYS TurboGrid is a powerful tool that lets designers and analysts of rotating machinery create high-quality hexahedral meshes, while preserving the underlying geometry. These meshes are used in the ANSYS workflow to solve complex blade passage problems.

Drag the TurboGrid component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox.

Double-click the Turbo Mesh cell to run ANSYS TurboGrid. You can optionally connect an upstream cell to the Turbo Mesh cell to provide the geometry data. If you do not connect an upstream cell to the Turbo Mesh cell, then you can load geometry data from within the user interface of ANSYS TurboGrid.

For more information about ANSYS TurboGrid, see ANSYS TurboGrid help.

**Vista AFD**

Vista AFD is a program for the preliminary design of axial fans. It creates axial fan geometry data for use in BladeGen or BladeEditor. It also provides estimates of the performance of the axial fan. It may be used to generate a preliminary fan design before moving rapidly to a full 3D geometry model and CFD analysis.
Drag the Vista AFD component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox.

The Vista AFD component system has three cells: a Meanline cell, a Design cell, and an Analysis cell. Double-click the Meanline cell to open the cell properties, where you can specify the solution parameters, generate a solution, and view the results of a meanline analysis. If the results of the meanline calculation are satisfactory, the design (throughflow) calculation may then be performed by using the Design cell.

Optionally, before creating a BladeGen or BladeEditor model, an analysis calculation may be performed by using the Analysis cell. This uses a similar throughflow method to the design calculation but simply analyses the design created in the previous step, rather than adjusting the geometry. A significant difference between the design and analysis results indicates a potentially flawed design.

For more information about Vista AFD, see Vista AFD help.

**Vista CCD and Vista CCD with CCM**

Vista CCD is a program for the preliminary design of centrifugal compressors. It can be used in an iterative fashion to create a 1D design. The resulting geometry can be passed to BladeGen or BladeEditor. Vista CCD can be used to model an existing compressor and, if known, its measured performance at single operating points. An accurate 1D model can provide insight into the performance of the machine that goes beyond the test measurements.

Drag the Vista CCD or Vista CCD (with CCM) component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox.

The Vista CCD component system is one cell: a Blade Design cell. Double-click the Blade Design cell to open the cell properties, where you can specify the solution parameters, generate a solution, and view the results.

The Vista CCD (with CCM) component system has two cells: a Blade Design cell and a Performance Map cell. Having created a satisfactory design in Vista CCD using the Blade Design cell, you may then predict the overall performance of the designed compressor stage using the Performance Map cell.

For more information about Vista CCD, see Vista CCD help.

**Vista CPD**

Vista CPD is a program for the preliminary design of pumps. It creates impeller geometry data for use in BladeEditor. It may be used to generate an optimized 1D pump impeller design before moving rapidly to a full 3D geometry model and CFD analysis.

Drag the Vista CPD component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox.

The Vista CPD component system is one cell: a Blade Design cell. Double-click the Blade Design cell to open the cell properties, where you can specify the solution parameters, generate a solution, and view the results.

For more information about Vista CPD, see Vista CPD help.
**Vista RTD**

Vista RTD is a program for the preliminary design of radial inflow turbines. It can be used in an iterative fashion to create a 1D design. The resulting geometry can be passed to BladeGen, BladeEditor, and Vista TF. Vista RTD can also be used to model an existing turbine. An accurate 1D model can provide insight into the performance of the machine that goes beyond the test measurements.

Drag the Vista RTD component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox.

The Vista RTD component system is one cell: a Blade Design cell. Double-click the Blade Design cell to open the cell properties, where you can specify the solution parameters, generate a solution, and view the results.

For more information about Vista RTD, see Vista RTD help.

**Vista TF**

The Vista TF program is a streamline curvature throughflow program for the analysis of any type of turbomachine, but has been developed in the first instance primarily as a tool for radial turbomachinery analysis. The program enables you to rapidly evaluate radial blade rows (pumps, compressors and turbines) at the early stages of the design.

Drag the Vista TF component system from the Toolbox to the Project Schematic, or double-click the system in the Toolbox.

The Vista TF component system has three cells: a Setup cell, a Solution cell, and a Results cell. Double-click the Setup cell to open the cell properties, where you can specify the solution parameters. Double-click the Solution cell to generate a solution. Use the Results cell to view the results.

For more information about Vista TF, see Vista TF help.

**Custom Systems**

ANSYS Workbench allows you to add custom templates and provides pre-defined custom templates, such as one-way FSI and thermal-stress coupled analyses. These pre-defined templates are provided as a convenience; you could also manually create any of these systems using system drag-drop operations, context menu operations on cells, or individual cell linking. You can also create your own templates (p. 302) and add them to easily build frequently-used projects.

To use one of these predefined templates, double-click the template. Drag and drop is not available as with regular templates in the Toolbox.

Available pre-defined templates include:

- FSI: Fluid Flow (ANSYS CFX) > Static Structural
- FSI: Fluid Flow (Fluent) > Static Structural
- Pre-Stress Modal
- Random Vibration
- Response Spectrum
Thermal-Stress

**FSI: Fluid Flow (ANSYS CFX) > Static Structural**

This template enables you to perform analyses that couple the physics of Fluid Flow (ANSYS CFX) and Static Structural analyses with results provided (one-way) from the former system to the latter. When this template is used, a Fluid Flow (CFX) (p. 183) analysis system and a Static Structural (p. 194) analysis system are automatically created. The two systems share a single geometry, and the fluid-flow *Solution* cell provides data that are treated as an *Imported Load* in the static structural *Setup* cell.

Note that similar coupled systems may also be manually created between Fluid Flow (ANSYS CFX) analysis and any of the following analysis systems:

- Transient Structural (p. 198)
- Steady-State Thermal (p. 194)
- Transient Thermal (p. 199)

**FSI: Fluid Flow (Fluent) > Static Structural**

This template creates two systems: a Fluid Flow (Fluent) analysis system and a Static Structural analysis system. The *Geometry* cells for the two systems share a single geometry, and the *Solution* cell in the Fluid Flow (Fluent) system provides pressure load data to the *Setup* cell in the Static Structural system.

**Pre-Stress Modal**

This template creates two systems: an ANSYS structural static system that transfers data into an ANSYS modal system. The two systems share *Engineering Data*, *Geometry*, and *Model* cells. The structural static solution provides the necessary solver files as input to the modal *Setup* cell. See the discussion on Pre Stress analysis in the Mechanical application help for more information.

**Random Vibration**

This template creates two systems: an ANSYS modal system that transfers data into an ANSYS random vibration system. The two systems share *Engineering Data*, *Geometry*, and *Model* cells. The modal solution provides the necessary solver files as input to the random vibration setup cell. See the Random Vibration analysis discussion in the Mechanical application help for more information.

**Response Spectrum**

This template creates two systems: an ANSYS modal system that transfers data into an ANSYS response spectrum system. The two systems share *Engineering Data*, *Geometry*, and *Model* cells. The modal solution provides the necessary solver files as input to the response spectrum *Setup* cell. See the Response Spectrum analysis discussion in the Mechanical application help for more information.

**Thermal-Stress**

This template creates two systems: an ANSYS steady-state thermal system that transfers data into an ANSYS static structural system. The two systems share *Engineering Data*, *Geometry*, and *Model* cells. The steady-state thermal solution provides temperature input to the static structural *Setup* cell. See the Steady-State Thermal analysis and the Initial Temperature discussions in the Mechanical application help for more information.
**Adding a Custom System**

To add a custom system to the Toolbox, build the system to your specifications in the Project Schematic. Then right-mouse click in the Project Schematic and choose **Add to Custom**. Type in a name for your custom system and press **Enter**. The new custom template appears in the Toolbox under Custom Systems. User-defined custom templates can also be deleted by right-clicking on the template in the toolbox and selecting **Delete**.

The following animation demonstrates adding a custom system. *This animation is presented as an animated GIF in the online help. If you are reading the PDF version of the help and want to see the animated GIF, access this section in the online help. The interface shown may differ slightly from that in your installed product.*

**Design Exploration**

DesignXplorer provides you with the ability to perform in-depth Design Exploration studies. DesignXplorer is a powerful approach for designing and understanding the analysis response of parts and assemblies. It uses a deterministic method based on Design of Experiments (DOE) and various optimization methods, with parameters as its fundamental components. These parameters can come from any supported system, DesignModeler, and various CAD systems. Responses can be studied, quantified, and graphed. Using a Goal Driven Optimization method, the deterministic method can obtain a multiplicity of design points. You can explore the calculated Response Surface and generate design points directly from the surface or transfer data from other analysis systems or components to a Direct Optimization system.

Design Exploration systems available with ANSYS Workbench include the following. These systems will be available only if you have installed the ANSYS DesignXplorer product and have an appropriate license.

- **Direct Optimization**
- **Parameters Correlation**
- **Response Surface**
• Response Surface Optimization

• Six Sigma Analysis

For an overview of these systems and links to more information about them, see What is Design Exploration?

**External Connection Systems**

The External Connection Add-in enables you to integrate custom, lightweight, external applications and processes into the ANSYS Workbench Project Schematic workflow. Features exposed by the External Connection also allow you to perform automation and customization activities.

With the External Connection, you can:

• Integrate custom, lightweight, external applications.

• Define User Interface (UI) elements, such as buttons in the Workbench Toolbar or entries in custom menus, and create the scripts that enable them.

• Create new systems to facilitate interaction with the Workbench Project Schematic.

The External Connection Add-in provides an [External Connection](#) system in the [External Connection Systems](#) toolbox. The system contains a single [External Connection](#) component that acts as a proxy for the external application.

![External Connection System](image)

After you drag an External Connection cell into the Workbench Project Schematic window, the External Connection component appears in an [Edit Required](#) state, indicated by a question mark, until you update it with a Configuration file.
The figure below shows a Mesh Transfer system that consumes an upstream mesh and passes it to a downstream Fluent system. External Connection is used to create the *Generic Mesh* system.

For more information about the External Connection Add-in, see the [Workbench External Connection Add-In](#).
ANSYS Workbench Interface Reference

The following user interface components are discussed in detail:
Tabs within Workbench
Views within Tabs
Cells in Workbench
Menus in Workbench

Tabs within Workbench

Project Tab  When you open an ANSYS Workbench project, it opens to the Project tab. This is the main workspace where you’ll interact with your project and build your analysis. By default, the Project tab shows the Toolbox view and the Project Schematic view.

Application and Analysis Tabs  Some cells on the Project Schematic launch ANSYS applications that open in separate windows outside of the Workbench environment. Examples of applications that are hosted inside Workbench are Engineering Data, External Data, System Coupling, and DesignXplorer. All the cells in these systems open into separate tabs.

All the rest of the cells on the Project Schematic open tabs inside Workbench: tabs for ANSYS applications that are hosted in Workbench, and tabs corresponding to cells representing specific analysis steps. Examples of analysis steps (cells) that open tabs are the Parameter Set bar, the Parameter Set cell, and the Analysis cell in a Mechanical APDL or Excel component system.

Views within Tabs

ANSYS Workbench provides the following categories of views:
Project Schematic View
Common Views
Persistent Views

Project Schematic View

Located on the Project tab, the Project Schematic view is the main workspace for your project.

Project Schematic Properties

The Properties view of the Project Schematic has the following properties:

Notes  This property displays project notes created via the Project Schematic Add Note context menu option. For more information on adding project notes, see Project Schematic Context Menu Options (p. 333).

Update Option  This property enables you to specify whether the Update Project action will be performed as a job submitted to the Remote Solve Manager or an EKM Portal.
When this property is set to **Submit to Remote Solve Manager**, the related **RSM Queue Name**, **RSM Queue Details**, **Job Name**, **Job Submission**, **Pre-RSM Foreground Update**, and **Component Execution Mode** properties become enabled. The job name must start with an alphanumeric character, must not contain spaces or the characters ! @ $ * ? \ and must not be longer than 15 characters.

When this property is set to **Submit to Portal**, the job is submitted to an EKM Portal, which further dispatches it to Remote Solve Manager. When this option is selected, the **Portal Connection**, **Queue**, **Job Submission**, **Pre-RSM Foreground Update**, and **Component Execution Mode** properties become enabled.

When the project is sent to RSM or an EKM Portal via the **Update Project** option, only those systems above the **Parameter Set** bar will be submitted/updated remotely.

For more information, see Submitting Project Updates to Remote Solve Manager (RSM) or an EKM Portal (p. 67).

**Common Views**

Common views are ones that are included on multiple tabs, but are configured per tab (that is, changes to the view on one tab are not reflected on other tabs of the same sort, because the view contains different data on each tab).

The following common views are available:
- Toolbox View
- Toolbox Customization View
- Files View
- Outline View
- Properties View
- Table View
- Chart View
- Scene View
- Solution Information View

**Toolbox View**

On the **Project** tab, the **Toolbox** contains the different types of systems you can add to the **Project Schematic**. Systems are divided into categories that can be expanded or collapsed to show or hide the systems available in that category. You can select systems from the following system categories:

- Analysis Systems (p. 179)
- Component Systems (p. 199)
- Custom Systems (p. 300)
- Design Exploration (p. 302)
- External Connection Systems (p. 303)
For more information, see *Systems*.

**Toolbox Customization View**

The *Toolbox Customization* view enables you to specify which systems display in the *Toolbox*. For more detailed information on this view, see *Configuring the Toolbox* (p. 13).

**Files View**

The *Files* view shows a list of all files associated with the project. It enables you to see the name and type of file, the ID of the cell(s) the file is associated with, the size of the file, the location of the file, and other information. You can sort the list via drop-down menus in the column headers.

Files added to the project will appear here. Files missing or deleted from the project will be shown in red and will be marked with a “Deleted” icon. To remove deleted files from the *Files* view, right-click the line containing the deleted file and select *Remove filename from List* from the context menu. Use the *Ctrl* key to select multiple lines. See *Project File Management* for more information on working with missing or deleted files.
Right-click any of the cells and select **Open Containing Folder** to open your operating system’s file manager to the folder containing that file. In most cases, you should not edit, add, or delete a file from the operating system file manager. ANSYS Workbench will not recognize or be aware of any changes that you make directly in the file system (such as adding or removing a file). However, if used with caution, this view can be a useful way to edit files such as application input files (for example, the Mechanical APDL application input files).

Right-click any of the cells and select **File Type Filter** to choose which types of files you want to appear in the **Files** view.

Right-click one or more of the cells and select **Copy** to copy the text in the selected cell(s).

**Outline View**

When data is available for an item, the **Outline** view presents data in an outline form. You can access the **Outline** view on the **Project** tab, the **Parameter Set** tab, the **Parameters** tab, or the tab for any cell in a Design Exploration or Engineering Data system. To do so, double-click the **Parameter Set** bar or a system cell, or by right-clicking and selecting **Edit** from the context menu.
Examples of the **Outline** view include the **Outline of All Parameters** on the **Parameter Set** tab and the **Outline of Schematic** on an application tab.

For detailed information about using the **Outline** view for parameters and design points, see *Working with Parameters and Design Points* (p. 123).

**Properties View**

The **Properties** view enables you to see properties for the **Project Schematic**, systems, cells, and schematic links.

The specific items shown in the **Properties** view varies according to what you’ve selected.
In some cases, it displays basic information about the component; this information cannot be modified from the **Properties** view. For example, if you choose to view properties on a link between systems, you will see a short list of uneditable connection properties, including type and the from/to cell identifiers.

In other cases, the **Properties** view displays detailed information, some or all of which is editable. For example, if you choose either **Edit** or **Properties** from the Vista TF Setup cell, you see a fully-editable list of properties.

If more detailed information a specific **Properties** view is available, view the Quick Help for the cell for which you are viewing properties.

**Table View**

When the **Table** view is included in a tab, it allows you to view project data in table format. Examples of the **Table** view are the **Table of Design Points** on the **Parameter Set** tab and the **Table of Properties** on an **Engineering Data** tab.

<table>
<thead>
<tr>
<th>Table of Design Points</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>1</td>
<td>Name</td>
</tr>
<tr>
<td>2</td>
<td>DP 0 (Current)</td>
</tr>
<tr>
<td>*</td>
<td></td>
</tr>
</tbody>
</table>

Some tables are editable and some are not. In general, if you can add a new row, you will see an asterisk (*) in the last row. If a cell is editable, you will be able to double-click in the cell to select the content and change it. In some tables, columns may include a drop-down menu of additional actions that are available for that column. Tables for different applications and different purposes will have different features and behavior. See your application documentation for details on using tables in your specific application.

**Chart View**

When the **Chart** view is included on a tab, it enables you to view charts that have been added and generated for the project (you can add charts or new chart instances from the **Toolbox**). Each type of tab has different charts available; for example, the **Parameter Set** tab will have a different set of charts than a DesignXplorer **Parameters Correlation** tab does.

For more detailed information about using charts, see *Working with the Chart View* (p. 110).

**Scene View**

The **Scene** view is available in the Fluent system's interface. To activate the Scene view, enable **Show Solution Monitoring** from Fluent (right-click the Solution cell of a Fluent system to open the Fluent Solution Monitor). For more information, see *Monitoring Fluent Solutions in Workbench in the Fluent in Workbench User's Guide*.

**Solution Information View**

The **Solution Information** view is available in the System Coupling or ANSYS Fluent system's interface. For more information, see *System Coupling User's Guide* or *Fluent in Workbench User's Guide*. 
Persistent Views

Some views are persistent across the all the tabs. The **Messages**, **Progress**, and **Sidebar Help** views remain as you've specified as you navigate between tabs. For example, if you choose to show the **Progress** view while in the **Project** tab, it will remain visible as you move through other open tabs.

*Messages View*

The **Messages** view displays any messages you have, such as error and warning messages, solver messages, status messages, and so on. During any update (cell, system, project, design point, multiple design point), any messages that are generated will be displayed in the **Messages** view. The **Messages** view will open automatically if an error message occurs during an update, but in other situations you will need to open it manually.

You can display or hide the **Messages** view by clicking the **Show Messages** or **Hide Messages** button in the lower right corner of any ANSYS Workbench tab.

*Progress View*

The **Progress** view displays a progress bar during an update. You can display or hide the **Progress** view by clicking the **Show Progress** or **Hide Progress** button in the lower right corner of any ANSYS Workbench tab. To interrupt an update process, click the interrupt button of the **Progress** view. Be aware that not all processes can be interrupted and some processes that are interruptible may have periods where they cannot be interrupted. Because some processes can stop cleanly only at certain checkpoints, the delay between the interrupt request and the actual interruption can sometimes be lengthy.
Note

For ANSYS Mechanical, the ANSYS solver supports interruption for only the Static Structural and Transient Structural systems.

Job Monitor

The Job Monitor displays a list of updates and solutions that have been submitted to Remote Solve Manager for the current project. You can view the current status of each job, as well as a job report for any selected job. You can also perform actions on a job, such as Abort or Interrupt.

To display the Job Monitor, select Jobs → Open Job Monitor, or click on the status bar. When you launch the Job Monitor, a job monitor icon is also displayed on your taskbar, enabling you to restore the Job Monitor window if you have minimized it.

For more information, see Monitoring and Controlling RSM Jobs in Workbench (p. 93).

Cells in Workbench

The systems that you add to the Project Schematic are made up of one or more cells.

The following cells topics are discussed below:
Types of Cells
Understanding Cell States
Cell Properties

Types of Cells

The following common types of cells occur in many of the analysis and component systems available in ANSYS Workbench; how you work with them is explained below. Other cell types may be available in certain systems; see the application-specific documentation under Systems (p. 179) for these cell descriptions.

Engineering Data
Engineering Data

Use the **Engineering Data** cell with Mechanical systems or the Engineering Data component system to define or access material models for use in an analysis. To define material data, open the **Engineering Data** tab by either double-clicking the **Engineering Data** cell or right-clicking the cell and selecting **Edit** from the context menu. For more information, see **Engineering Data**.

Geometry

Use the **Geometry** cell to import, create, edit or update the geometry model used for analysis. Right-click on the cell to access these functions via the context menu. The right-click options are context sensitive and change as the state of your geometry changes, so not all of the geometry-specific options are described here will be available at all times. These options are in addition to the common options described in **Common Context Menu Options** (p. 327) and **Transfer Context Menu Options** (p. 330).

**Note**

The SpaceClaim Direct Modeler features are available only if you have SpaceClaim Direct Modeler installed and the ANSYS SpaceClaim Direct Modeler license available.

**New Geometry (or New DesignModeler Geometry/New SpaceClaim Direct Modeler Geometry)**

Launches DesignModeler or SpaceClaim Direct Modeler, where you can build a new geometry.

**Import Geometry**

Select **Browse** to open a dialog box that enables you to navigate to an existing geometry file, or select a file from the list of recently viewed files.

**Edit (or Edit Geometry in DesignModeler/Edit Geometry in SpaceClaim Direct Modeler)**

After you have attached a geometry to your system by choosing either **New Geometry** or **Import Geometry**, click **Edit** to open the model in DesignModeler or SpaceClaim Direct Modeler to modify it.

**Replace Geometry**

Select **Browse** to open a dialog box that enables you to navigate to an existing geometry file, or select a file from the list of recently viewed files to replace the currently specified file.

**Update from CAD**

Generates an existing CAD geometry using the parameter values as defined in the CAD system.

**Refresh**

Reads in all modified upstream data but does not regenerate the geometry. Enabled when the Geometry cell is in the Refresh Required state.

**Properties**

Displays a **Properties** view where you can select basic and advanced geometry properties. For a detailed description of the options available from the **Properties** view, see **Geometry Preferences** in the CAD Integration section of the ANSYS Workbench help.
Model/Mesh

The Model cell in the Mechanical application analysis systems or the Mechanical Model component system is associated with the Model branch in the Mechanical application and affects the definition of the geometry, coordinate systems, connections and mesh branches of the model definition.

When linking two systems, you cannot create a share between the Model cells of two established systems. You can generate a second system that is linked at the Model cell of the first system, but you cannot add a share after the second system has been created. Likewise, you cannot delete a link between the Model cells of two systems.

The Mesh cell in Fluid Flow analysis systems or the Mesh component system (p. 286) is used to create a mesh using the Meshing application. It can also be used to import an existing mesh file.

Edit
Launches the appropriate Model or Mesh application (the Mechanical application, Meshing, and so on.)

Setup

Use the Setup cell to launch the appropriate application for that system. You will define your loads, boundary conditions, and otherwise configure your analysis in the application. The data from the application will then be incorporated in the project in ANSYS Workbench, including connections between systems.

For the Mechanical application systems, you will see the following Setup options, in addition to the common options:

Edit
Launches the Mechanical application with the geometry loaded and with cells mapped to their respective tree locations in the Mechanical application.

For CFX systems, you will see the following Setup options, in addition to the common options:

Edit
Launches CFX-Pre.

Import Case
Imports an existing case file containing physics data, region and mesh information for your analysis.

For Fluent systems, you will see the following setup options, in addition to the common options:

Edit
Launches ANSYS Fluent.

Import Case
Imports an existing Fluent case file.

Solution

From the Solution cell, you can access the Solution branch of your application, and you can share solution data with other downstream systems (for instance, you can specify the solution from one analysis as input conditions to another analysis). If you have an analysis running as a remote process, you will see the Solution cell in a pending state until the remote process completes. See the discussion on Understanding Cell States (p. 315), below.
For the Mechanical application systems, you will see the following Setup options, in addition to the common options described earlier:

**Edit**
Launches the Mechanical application open to the Solution branch.

**Delete**
Deletes the Solution and Results cell. Deleting the solution cell makes the system a setup-only system, meaning the system will generate only an input file. It will not solve or post results. The Solution object and below are removed from the Mechanical application tree.

For CFX systems, you will see the following Solution options, in addition to the common options:

**Edit**
Launches CFX-Solver Manager.

**Import Solution**
Displays the most recent CFX-Solver Results files imported (if any) and enables you to browse for such files using the Open dialog box, where you can specify the CFX-Solver Results file to load. When the results file is loaded, the system will display only the Solution cell and the Results cell.

**Display Monitors**
Opens the ANSYS CFX-Solver Manager and shows the results of the previous run.

For Fluent systems, you will see the following Solution options, in addition to the common options:

**Edit**
Launches ANSYS Fluent.

**Import Final Data**
Enables you to select an existing Fluent data set (for example, one solved on an external cluster) into a Solution cell in a Fluent system and immediately start post-processing in CFD-Post, without the need to run the minimum of one more solver iteration. This option becomes available after importing case file into the Setup cell.

**Results**
The Results cell indicates the availability and status of the analysis results (commonly referred to as postprocessing). From the Results cell, you cannot share data with any other system.

**Understanding Cell States**

ANSYS Workbench integrates multiple applications into a single, seamless project flow, where individual cells can obtain data from and provide data to other cells. As a result of this flow of data, a cell's state can change in response to changes made to the project. ANSYS Workbench provides visual indications of a cell's state at any given time via icons on the right side of each cell.

Cell states can be divided into the following categories:
- Typical Cell States
- Solution-Specific States
- Failure States
Typical Cell States

Unfulfilled
Required upstream data does not exist. Some applications may not allow you to open them with the cell in this state. For example, if you have not yet assigned a geometry to a system, all downstream cells will appear as unfulfilled, because they cannot progress until you assign a geometry.

Refresh Required
Upstream data has changed since the last refresh or update. You may or may not need to update output data. When a cell is in this state, you can edit the cell, refresh the data, update upstream components, or update the cell.

The advantage to refreshing rather than updating a cell is that you are alerted to potential effects on downstream cells and make any necessary adjustments before you update it. This option is especially useful if you have a complex system in which an update could take significant time and computer resources.

Attention Required
All of the cell’s inputs are current. However, you must take a corrective action to proceed. To complete the corrective action, you may need to interact with this cell or with an upstream cell that provides data to this cell. Cells in this state cannot be updated until the corrective action is taken.

This state can also signify that no upstream data is available, but you can still interact with the cell. For instance, some applications support an "empty" mode of operation in which it is possible to enter the application and perform operations regardless of the consumption of upstream data.

Update Required
Local data has changed and the output of the cell must be updated.

Up to Date
An update has been performed on the cell and no failures have occurred. It is possible to edit the cell and for the cell to provide up-to-date generated data to other cells.

Input Changes Pending
The cell is locally up-to-date but may change when next updated as a result of changes made to upstream cells.

Solution-Specific States

In addition, the Solution or Analysis cell for certain solvers may support the following solution-specific states.

Interrupted, Update Required
Indicates that you have interrupted the solution during an update, leaving the cell paused in an update required state.

This option performs a graceful stop of the solver, which completes its current iteration. Although some calculations may have been performed, output parameters are not updated. A solution file is
written containing any results that have been calculated. The solve resumes with the next update command.

**Interrupted, Up to Date**

Indicates that you have interrupted the solution during an update, leaving the cell in an up-to-date state.

This option performs a graceful stop of the solver, which completes its current iteration. Output parameters are updated according to the calculations performed thus far, and a solution file is written. You can use the solution for postprocessing. For example, you can look at the intermediate result. Because the cell is already up-to-date, it is not affected by a design point update. To resume the solve, right-click and select **Continue Calculation**.

**Pending**

Signifies that a batch or asynchronous solution is in progress. When a cell enters the pending state, you can interact with the project to exit ANSYS Workbench or work with other parts of the project. If you make changes to the project that are upstream of the updating cell, then the cell is not in an up-to-date state when the solution completes.

---

**Note**

When up-to-date cells are connected to cells in a *different type of system*, the state of the up-to-date cells may change to update required. This behavior occurs because additional files have to be generated to satisfy the newly added system.

For example, assume that you have built a fluid flow system (Fluid Flow (CFX) that is up-to-date.

<p>| | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Fluid Flow (CFX)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Geometry</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Mesh</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Setup</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Solution</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Results</td>
<td>✓</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Single phase*

If you then connect the **Mesh** cell to a fluid flow system (FLUENT), the mesh files for CFX Setup are the only files that will have been generated by the update process. After connecting another system to the up-to-date **Mesh** cell, the **Mesh** cell transitions to the update required state to signify that additional files must be generated for satisfy the Fluent system.
The cells already connected to the Mesh cell will transition to the refresh required state after the Mesh cell is updated. Updating the project will unnecessarily re-update the previously up-to-date cells (CFX Setup, Solution, and Results). As such, if this is the desired project structure, it is recommended that you establish the connection to the Fluent system before updating components downstream of the Mesh in the Fluid Flow (ANSYS CFX) system.

**Failure States**

If a particular action fails, ANSYS Workbench provides a visual indication as well. Failure states are described below.

**Refresh Failed, Refresh Required**

The last attempt to refresh cell input data failed and the cell remains in a refresh required state.

**Update Failed, Update Required**

The last attempt to update the cell and calculate output data failed and the cell remains in an update required state.

**Update Failed, Attention Required**

The last attempt to update the cell and calculate output data failed. The cell remains in an attention required state.

If an action results in a failure state, you can view any related error messages in the Messages view by clicking the Show Messages button on the lower right portion of the ANSYS Workbench tab.

**Cell Properties**

Every cell in ANSYS Workbench has various properties associated with it. Most of these properties are specific to the type of system, type of cell, and state of the cell, and are generally documented with the specific application documentation. However, some cell properties are common across many cells, regardless of type of system or cell state. Those properties are described here.

To view cell properties, right-click the cell and select Properties from the context menu. The Properties view will open, showing all properties applicable to that cell in its current state. Both the property name and its current value are shown. Some properties are editable, while others cannot be edited because of the specific configuration of that project and/or cell.
Common Cell Properties

The cell properties described here are common to most cells. For information on additional cell properties, see the appropriate application documentation.

Component ID
This property shows the name of the component.

Directory Name
This property shows the directory where any information associated with this component resides. For more information on the general ANSYS Workbench directory structure, see Project File Management (p. 100).

Notes
This property displays system and cell notes created via the Add Note context menu option. For more information on adding notes, see Common Context Menu Options (p. 327).

Last Update Used Licenses
This property shows the license used by this component during the most recent update. If the component does not require a license during an update, the value will be Not Applicable.

Always Include in Design Point Update
This property is used for External Connection and CFD-Post components. It enables you to specify that a component should be included in any design point update operation, even if it does not have output parameters. If you enable this property for a component, the component will be updated when you update design points, regardless of whether parameter values will be affected.

Save Mesh Data In Separate File
This property is used by the Model cell (non-Fluid Flow analyses such as Static Structural) and by the Mesh cell (Fluid Flow analyses and Mesh components). It controls whether the mesh data is stored in a separate .acmo file, rather than being stored in the database file, when you save your project. Saving the mesh data in separate file reduces the overall file space required and reduces the possibility of disk corruption in very large database files on Linux systems.

The default setting for this field is controlled by the Save Mesh Data In Separate File setting in the Workbench Tools → Options → Mechanical panel or the Tools → Options → Meshing panel.

Menus in Workbench

The following types of menus are available in Workbench:

Menu Bar
Context Menus

Menu Bar

The Menu Bar gives you access to the following menus:

File Menu
View Menu
Tools Menu
Units Menu
Extensions Menu
Jobs Menu
Help Menu
**File Menu**

The **File** menu, you can manage your project files:

**New**
Open a new project. If you already have a project open, this action closes the current project.

**Open**
Open an existing project that had been saved previously. If you already have a project open, this action closes the current project.

**Save**
Saves the current project. If the current project has already been saved, this action will save any changes to the current location. If the current project has not already been saved, you are prompted to specify a name and location for the file.

---

**Note**

You can also save the current project via the **Save** icon underneath the **File** menu.

---

**Save As**
Saves the current project under a different name and/or location. You are prompted to specify the name and location for the file.

**Save to Repository**
Saves the current project to an EKM repository. You must have saved the project in ANSYS Workbench before you can save it to the EKM repository. In addition to the name, you can include a brief description of the project. This description will be visible when you view it in the EKM repository. You can also choose whether to include results and/or external files when you save the project by using the selections under the **Show Options** drop-down. See *Working with ANSYS Workbench and EKM (p. 157)* for more information.

If you have not previously established a connection to an EKM repository, you will be presented with a connection wizard that will allow you to set up a connection. You must have a connection already established in order to save a project to a repository.

**Open from Repository**
Opens a project saved in an EKM repository. You can also save a working copy to a local directory. See *Working with ANSYS Workbench and EKM (p. 157)* for more information.

If you have not previously established a connection to an EKM repository, you will be presented with a connection wizard that will allow you to set up a connection. You must have a connection already established in order to save a project to a repository.

**Send Changes to Repository**
Sends changes made to a previously-saved project to the EKM repository. This option is available only if the local copy is newer than the repository copy. You can explicitly select this option, or ANSYS Workbench will remind you to send local changes to the repository when the project is about to replaced.

**Get Changes from Repository**
Retrieves changes made to a project that has been previously opened from or saved to the EKM repository. If a more recent version than your local copy exists in the repository, you will be prompted and given the option to update your local copy with the version of the project in the repository. You can explicitly select this option, or ANSYS Workbench will prompt if you want to get changes from the repository.
**Manage Repository Project**
Enables access to features that monitor or change the status of a project in the repository. The permissions you have for a project in a repository control which features you can access.

**Tip**
To view your permissions for a project in the repository, right-click the project and select **Display → Permissions**.

---

**Refresh Control Status**
Synchronizes local project status with repository project status.

**Access Control Status**
Displays the **Access Control Status** dialog box, which displays the version control status, the name of the person who currently has the file checked out (if any), the version number, the name of the person whose check-in last modified the file's version number, the date the file was last modified, and any stored comments.

**Important**
When you display the **Access Control Status** dialog box, the **Manage Repository Project** menu items are refreshed with the most recent information from the repository.

---

**Alert Setting**
Enables you to specify that you will be notified by email when certain events occur (such as when the project is modified, downloaded, checked in/checked out, or when its lifecycle state is changed).

**Get Exclusive Control/Release Exclusive Control**
Controls whether you have the exclusive use of a repository project that is not under version control.

**Add to Version Control/Remove from Version Control**
Controls whether the project is under version control. When a project is under version control, changes can be made by only one user at a time.

**Check In**
Checks in a version-controlled project that you chose to keep checked out after sending changes using **Send Changes to Repository**.

**Check Out/Undo Checkout**
Controls whether you have the project checked out from a version control system.

**Launch EKM Web Client**
Select this option to launch the EKM sign-in screen to access the EKM workspace. EKM will display in your default browser using a currently established connection. If you already have connections established to more than one repository, you will be asked to select the connection to use. If you do not already have a connection established, you will see an error message. Choose **Open from Repository** to launch the EKM connection wizard to establish a connection for the first time.

**Save to Teamcenter**
Teamcenter is a software package designed for computer-aided product data management. Use this option to save the current project into the Teamcenter database. You can then open the project dataset in ANSYS.
Workbench. For more information on using the ANSYS Teamcenter connection, see the Cad Integration section of the ANSYS Workbench help.

**Import**
Imports a legacy database (p. 107) and converts it to the appropriate systems in the current project. You can also use this option to assemble multiple legacy databases into a single project.

**Archive**
Generates a single archive file that contains all project files. This archive will include the project file and all files in the `project name_files` directory with a few optional additions/exceptions that you can specify:

- Result/solution items
- Imported files external to the project
- Items in the `user_files` folder

The archive will be saved as a Workbench Project Archive (.wbpz) or a Zip (.zip/.tar.gz) file.

Previously imported external files from a restored archive directory are treated as internal files if archived again.

See Archiving Projects (p. 104) for details on archiving projects.

**Restore Archive**
Restores a previously-generated archive file. After you select the project archive to be restored, you are prompted for the name and location where the restored file(s) are to be located. After the archive is extracted, the project will open in ANSYS Workbench.

You can also extract the archive manually by using an unzip utility, and then opening the .wbpj file.

**Scripting**
Use this option to record a journal of your session, execute a journal or script, or open a Python command window. Choose one of the following options:

- **Record Journal**: Creates a journal of the ANSYS Workbench session.
- **Stop Recording Journal**: Stops recording of the current session.
- **Run Script File**: Runs a previously-created journal or script.
- **Open Command Window**: Opens a Python command window for issuing ANSYS Workbench commands.

You can also select from a list of previously-used journals.

For more information on recording journals and creating scripts for reuse, see Using Journals and Scripts (p. 98).

**Export Report**
Select this option to write out a report of the current project in .html/.htm format. The report will be written to the `user_files` directory under the project directory by default. You can control whether the report opens by default using the Options>Project Reporting (p. 21) settings.

The report contains basic project information, including:
• Export time and date
• ANSYS Workbench version number
• A graphic of the systems as shown in the project schematic
• File information
• Parameter and design point information
• System and cell information

The specific information provided will vary depending on the contents of the project. Additional information may be available from the individual applications. Not all applications provide reporting information.

**Recently Viewed Files**

Shows the four most recently-opened projects.

**Exit**

Exits and closes ANSYS Workbench. You are prompted to save any unsaved data.

**View Menu**

The **View** menu provides the following options for controlling the window layout:

**Refresh**

Updates the view.

**Reset Workspace**

Restores the current workspace layout to its default settings.

**Reset Window Layout**

Restores the original window layout.

**List of Views**

All ANSYS Workbench views are listed. You can select which view(s) you want to display. Any changes you make to views are carried forward to subsequent ANSYS Workbench sessions. For a detailed description of the individual views listed here, see **Views within Tabs (p. 305)**.

**Show Connections Bundled**

Shows multiple links connecting systems as a single link where possible. A bundled connection includes a label indicating the shared cells (for example, "2-4" indicates that cells 2, 3, and 4 are shared between systems)

**Show System Coordinates**

Shows the alphanumeric column and row headings for each system. This option is selected by default.

**Tools Menu**

The **Tools** menu provides the following project and user preference option:

**Reconnect**

Reconnects to updates that were pending when the project was closed. This option is available only if the project has cells in the Pending state.
After reconnecting to pending solution data, it is important to save the project. For a **Solution** cell update: If you decline to save the project before exiting, the intermediate solver data will be discarded and will not be accessible in future ANSYS Workbench sessions. For more detailed information, see *Exiting a Project During an RSM Solution Cell Update (p. 92).*

**Refresh Project**
- Refreshes all cells in the project that are in a Refresh Required state.

**Resume**
- Resumes design point updates that were pending when the project was closed. This option is available only if the project has design points that are paused due to cells in a Pending state.

**Update All Design Points**
- Updates all design points in a project that are in an Update Required state. This option is available only when the project contains multiple design points.

**Update Project**
- Updates all cells in the project that are in an Update Required state.

**Note**
- If you use this option and the project is being updated remotely via RSM, only the systems and cells above the **Parameter Set** bar will be submitted to RSM. If needed, DesignXplorer systems can be further updated once the remote project update is completed. For more information, see *Submitting Project Updates to Remote Solve Manager (RSM) or an EKM Portal (p. 67).*
- System Coupling systems do not support project updates that are submitted to an EKM Portal.

**Suspend Collecting RSM Results / Resume Collecting RSM Results**
- The **Suspend Collecting RSM Results** option is enabled when a Project Update or an Update All Design Points operation via RSM is in progress. If you are updating all design points, this option temporarily suspends the collection of RSM's collection of design point data.

Once you’ve suspended the collection of design point data, the **Resume Collecting RSM Results** option becomes available. You can select this option to resume the collection of RSM design point data. For more information, see *Suspending and Resuming Collection of RSM Design Point Results (p. 150).*

**Abandon Pending Updates**
- Use this option if you have a remote or background solve process (some component or components in the project were saved in a Pending state) and attempts to reconnect have failed. This option will ignore any results calculated thus far and return the project its normal state. If you use this option, you may need to manually remove processes that were not stopped or files that were not removed.

**License Preferences**
- Opens the **License Preferences for User** dialog box. Use this dialog box to specify which licenses at your site you want to be able to use, and to specify which licensing method (p. 31) to use. For details on using the **License Preferences for User** dialog box, click **Help** in the dialog box or see *Using Software Licensing in ANSYS Workbench (p. 31).*
Release Reserved Licenses
Use this option to manually release a reserved license if a job hangs or a reserved license is not released normally (for example, if you delete a project that contains pending updates using reserved licenses). Select the project for which you want to release licenses, and click Release Selected. This feature is intended only as a license recovery method and should not be used in normal operations. See Reserving Licenses for a Design Point Update (p. 151) for more information about using reserved licenses for a design point study.

Options
Defines your preferences for ANSYS Workbench. The preferences you set here are local settings and affect only you. For detailed descriptions of the Options settings, see Setting ANSYS Workbench Options (p. 16).

Units Menu
The Units provides the following options for specifying unit systems:

Display Values as Defined
The value and unit as defined in ANSYS Workbench or the original source application will be displayed. No conversion information is displayed.

Display Values in Project Units
The value will be converted for display to correspond to the selected project unit system.

Unit Systems
Displays the Unit Systems dialog box, where you can choose which unit systems to display in the Units menu and you can define custom unit systems. For details, see Configuring Units in Workbench (p. 13).

Extensions Menu
The Extensions menu provides options for managing the extensions developed for ANSYS products using ANSYS ACT.

ACT Start Page
Opens the ACT Start Page, which provides you with convenient access to ACT functionality. From this page, you can access multiple tools for both the development and execution of extensions.

Manage Extensions
Opens the Extensions Manager, which enables you to specify which extensions you want to load.

Install Extension
Installs the extension into your Application Data folder and ensures that the extension is available in the Extensions Manager.

Build Binary Extension
Compiles a binary version of an extension from the scripted version.

View ACT Console
Opens the ACT Console, which enables you to interactively test commands during the development or debugging of an extension.
**View Log File**

Opens the **Extensions Log File**, which provides messages generated by the extension. If present, warnings are shown in orange text, and errors are shown in red text.

---

**Note**

For information on how to create or modify extensions, see the **ANSYS ACT Developer's Guide**, the **ANSYS ACT XML Reference Guide**, and the **ANSYS ACT Reference Guide**.

---

**Jobs Menu**

The **Jobs** menu provides options for accessing and launching Remote Solve Manager (RSM) and monitoring RSM jobs from within Workbench.

**Enter Credentials for Remote Solve Manager**

Enables you to enter your Remote Solve Manager credentials directly from Workbench. This option gives you the ability to create and enter credentials for your primary and alternate accounts.

For more information, see **Specifying Credentials for RSM Job Submission** (p. 64).

**Launch Remote Solve Manager**

Launches the Remote Solve Manager (RSM) interface. With the RSM user interface, you can filter jobs by status, manage queues and servers of local and remote Solve Managers, monitor the progress of jobs, and delete jobs. For detailed information on running RSM, see the **Remote Solve Manager User's Guide**.

**Open Job Monitor**

Displays the **Job Monitor** dialog box, which enables you to see the status of jobs that have been submitted to Remote Solve Manager for the current project.

For more information, see **Monitoring and Controlling RSM Jobs in Workbench** (p. 93).

---

**Help Menu**

The **Help** menu provides options that allow you to access help for ANSYS Workbench or to access help for most ANSYS, Inc. products, including Installation and Licensing help. You can also view context-sensitive help and view the version information.

---

**Context Menus**

Context menu options provide capabilities that enable you to work with your existing systems or to add to and modify projects.

The following types of context menus are available in Workbench:

- **Common Context Menu Options**
- **Transfer Context Menu Options**
- **Tab Context Menu Options**
- **System Header Context Menu Options**
- **Project Schematic Context Menu Options**
- **Link Context Menu Options**
Common Context Menu Options

In addition to the menu items that are unique to each system or cell, some of the options on the context-sensitive menu are available with most systems and cells. They include:

**Edit**
Opens the cell workspace tab so you can review the data and edit as needed.

**Duplicate**
Creates a new system that is a duplicate of the selected system. All data associated with unshared cells in the system is copied to the duplicate system: all data above the cell from which the duplicate operation was initiated is shared; data at and below the cell from which the duplicate operation was initiated is copied. See Moving, Deleting, and Replacing Systems (p. 61) for more information on duplicating systems.

**Update**
Refreshes input data (see Refresh, below) and generates required output data. Any upstream cells upon which the cell is dependent will also be updated. You cannot update a cell if another update is already running on the cell or on any of the upstream cells.

- If a project contains multiple design points, the Update option updates only the current design point.
- If a project contains parametric (DesignXplorer) systems, updating a parametric system updates the design points within that system, but does not update the design points in the Parameter Set. Note, however, that parametric systems are not updated when a project update is submitted to Remote Solve Manager.
- If a system contains a coupled cell, the Update option on the coupled cell will be disabled. To update the system that contains a coupled cell, you must update the coupled system so that both the coupled cell and all cells dependent on the coupled cell can be updated.
- If a project is unsaved and any cells in your project are configured to use RSM or run in the background, you must save the project or change the solution process settings of those cells to run in the foreground before you can update.
- If you update a cell with a status of Refresh Required, the Refresh operation will be performed before the Update operation.

**Update Upstream Components**
Updates the components upstream of the cell without updating the cell itself.

The advantage to updating only the upstream components of a cell is that you will be alerted to any errors or potential effects on downstream cells and can make necessary adjustments before launching a full update. This option is especially useful when you have a complex system and the cell update could require a significant time investment and/or computer resources.

---

**Note**

In some cases, the Update, Update Upstream Components, and Refresh operations may be available while other operations, such as Clear Generated Data, Reset, Delete, and Duplicate, are still in progress. If the operation is in progress on a separate system, you can apply the Update, Update Upstream Components, or Refresh operation to the current system. However, if the operation is in progress on either the current system or a system connected to it, you cannot initiate the new operation until the in-progress operation has completed.
**Rename**  
Renames the system or cell.

**Refresh**  
Reads in all modified upstream data but does not necessarily regenerate the outputs of the cell. For instance, if the geometry changed, therefore placing the Mesh cell in a Refresh Required state, a refresh on the Mesh cell would update the geometry without generating a new mesh (which could potentially be a lengthy operation).

**Quick Help**  
Displays a quick help panel for the cell, if available. Quick help provides a brief description of how to use the cell in its current state. You can also click the blue triangle (where available) in the lower-right corner of a cell to view quick help.

**Add/Edit Note**  
Displays an editable panel where you can enter notes about a system or cell. There is no limit to the amount of text you can type into a note; as you type, the panel increases in length. You can also edit an existing note by left- or right-clicking on the green triangle in the upper right corner of a system or cell, or by editing the **Notes** field in the **Properties** view. To close the note, click outside the panel. To delete a note, delete the text within the panel or from the **Properties** view.

The content of notes is also included in project reports.

**Properties**  
Displays applicable cell properties in the **Properties** view.

**Recently Used**  
Lists all recently used files.

Two additional items that are available with most context menus are:

**Clear Generated Data**  
Removes or erases any data that the cell has generated or is to generate and store if any such data is present. This data can include mesh, input files, solver files, cached solution data, and so on. Clear may alter the state of the current cell and cells downstream from the selected cell.

**Reset**  
Removes or erases both input and output data to the cell and sets the cell state back to the default. Any reference files are removed. Reset may alter the state of cells downstream from the selected cell. If you have two systems that share cells, reset is not available from the cells that are shared, only from the source (the cell that is being shared from).

Reset clears all solution state data and cache data for all design points in the project.

---

**Important**

For some systems, these two context menu options result in specific behavior depending on the selected cell and in some cases specific system data (such as existing links). Refer to the following table for specific actions.

<table>
<thead>
<tr>
<th>Cell</th>
<th>Data</th>
<th>Clear Generated Data</th>
<th>Reset</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mechanical systems</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cell</td>
<td>Data</td>
<td>Clear Generated Data</td>
<td>Reset</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Geometry</td>
<td></td>
<td></td>
<td>Clears the geometry source and resets geometry properties to the defaults.</td>
</tr>
<tr>
<td>Model</td>
<td>Deletes mesh, input files, and</td>
<td></td>
<td>Closes the Mechanical session (if open) and deletes the .mechdb from disk. The system is in a state as if the geometry was never attached.</td>
</tr>
<tr>
<td></td>
<td>solver files. Cleans results.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setup</td>
<td>Deletes input and solver files.</td>
<td>Deletes any objects under the Environment (such as loads and supports).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cleans results.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Solution</td>
<td>Deletes solver files. Cleans</td>
<td>Sets the values in &quot;Analysis Settings&quot; back to the defaults.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>results. Input files (such as ds.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>dat, CARep.xml) are left intact.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Results</td>
<td>Cleans any solved results.</td>
<td>Deletes any results, probes, or post tools from Mechanical.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Solver files are left intact.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setup</td>
<td>Imported Temperature: One-way FSI</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>input</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cleans imported load and deletes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>transfer xml file. User</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>specifications (such as scoping)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>are intact.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setup</td>
<td>Imported Temperature: Thermal</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>stress</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Cleans imported load and deletes</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>transfer xml file. User</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>specifications (such as scoping)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>are intact.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Model</td>
<td>Link to FE Modeler</td>
<td>Deletes SYS.cmdb.</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Setup</td>
<td>Link to CFX</td>
<td>Deletes SYS.cmdb.</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Model</td>
<td>Link to Mechanical APDL</td>
<td>Deletes SYS.cdb.</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Setup</td>
<td>Link to FE Modeler</td>
<td>Deletes .mechdb.</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Model</td>
<td>Link to CFX</td>
<td>Deletes SYS.cmdb.</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Setup</td>
<td>Link to Mechanical APDL</td>
<td>No additional action required (ds.dat is the natural output from the Setup cell).</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Solution</td>
<td>Link to Mechanical APDL</td>
<td>No additional action required (file.rst is the natural output from the Solution cell).</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Mechanical APDL</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Analysis</td>
<td>Deletes ANSYS-generated files</td>
<td>Deletes all files in the Mechanical APDL System directory and resets any properties (as set in the Property view) back to the default. Any schematic input links remain intact and the needed files are copied back into the system upon Refresh. Any manually- added files (Add Input/Reference) will be deleted and removed from Outline view.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>(created during Update or Edit).</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Files added via input links or</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Add xxx File are left intact.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cell</td>
<td>Data</td>
<td>Clear Generated Data</td>
<td>Reset</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------</td>
<td>--------------------------------------------------------------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>FE Modeler</td>
<td></td>
<td>No additional action required.</td>
<td>Deletes .fedb and sets any properties (Properties view) back to the default.</td>
</tr>
<tr>
<td>Model</td>
<td>Link to Engineering Data</td>
<td>Deletes FiniteElementModelMaterials.xml.</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Model</td>
<td>Link to Mechanical Model cell</td>
<td>Deletes FEModeler-File.rsx,FEModeler-File.fedb,ACMOFile.dat.</td>
<td>No additional action required.</td>
</tr>
<tr>
<td>Model</td>
<td>Link to Geometry</td>
<td>Deletes Parasolid-File.x_t.</td>
<td></td>
</tr>
<tr>
<td>Model</td>
<td>Link to Mechanical APDL</td>
<td>Deletes ANSYSInput-File.inp.</td>
<td></td>
</tr>
<tr>
<td>Fluent</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setup</td>
<td>Link to imported case and other input files, settings, and possibly other input files</td>
<td></td>
<td>Closes the Fluent session without saving data. Deletes all internal files. Links to imported files are deleted (but the file is not deleted.) If Mesh is coming from an upstream simulation Mesh cell, the file is unregistered and might get deleted if the upstream Mesh cell no longer refers to it. All associated input parameters are deleted. Launcher settings are set to the default value.</td>
</tr>
<tr>
<td>Solution</td>
<td>Internal, link to initialization data</td>
<td>Closes the session without saving data. Deletes all files currently associated with the cell (latest available solution data). Any schematic input links will remain intact.</td>
<td>Closes the session without saving data. Deletes all files currently associated with the cell (latest available solution data). Any schematic input links will remain intact. Any imported initial solution data file will be unregistered. (Only the link is removed; the file is not deleted.) All associated output parameters are deleted. Launcher settings are set to the default values.</td>
</tr>
</tbody>
</table>

**Transfer Context Menu Options**

In addition, many cells will also include transfer options in their context menu:
Transfer Data from New...

Creates an upstream system that can provide data to the selected cell. Only those systems that can provide valid data to the selected cell are shown. When you choose a system from the options shown here, that system will appear to the left of the currently-selected system, with all appropriate connections drawn.

Transfer Data to New...

Creates a downstream system that can accept data from the selected cell. Only those systems that can accept data from the selected cell are shown. When you choose a system from the options shown here, that system will appear to the right of the currently-selected system, with all appropriate connections drawn.

Transfer Data options are available only from root cells. If a cell is derived from an upstream cell (for example, when two systems share a geometry), you can transfer data only to/from the originating cell.

Tab Context Menu Options

When you click cells on the Project Schematic, some of them open up in separate tabs. The context menu options available depend on which tabs are open. For example, if only the Project tab is open, there are no context options available. The following context menu options are available for tabs.

Note

The Project Schematic Project tab cannot be closed.

Close Tab

Available for all tabs except for the Project tab. Closes the selected tab.

Close Other Tabs

Available for all tabs when multiple tabs are open. If accessed from the Project tab, closes all other tabs. If accessed from another tab, closes all tabs except for the one selected and the Project tab.
**Close All**
Available for all tabs except for the **Project** tab. Closes all tabs (including the selected tab) except for the **Project** tab.

**System Header Context Menu Options**

The following options are available from the context menu for system headers.

![System Header Context Menu Options](image)

**Refresh**
Refreshes all cells in the selected system.

**Update**
Updates all cells in the selected system, along with any cells in upstream systems that provide data to them. To update multiple systems, you can multi-select the system header cells.

**Duplicate**
Duplicates all cells. No data will be shared between the two systems. Equivalent to issuing a duplicate on the first cell of the system.

**Replace with**
Enables you to switch the analysis or solver type for an existing system. This functionality is available only from systems that use the Mechanical application. Valid systems that can replace the existing system are listed in the context menu.

---

**Note**

If you use **Replace with** to replace a Mechanical system that has a **Section Data** cell with another Mechanical system, the new environment will be added and the original Mechanical environment (including boundary conditions and results) will be deleted.

---

**Delete**
Deletes the system from the schematic. You will be prompted to confirm the deletion before any action is taken.

**Recreate Deleted Cells**
If cells have been removed from the system by a cell-level delete operation or automatically when a self-contained file is loaded into the cell which renders upstream cells unnecessary (such as importing a case file into a CFX setup system), this operation creates new cells at the points where the previous cells were removed.

**Rename**
Renames the system.

**Properties**
Displays system properties in the **Properties** view.
Add/Edit Note
Displays an editable pane where you can enter notes about a system or cell. There is no limit to the amount of text you can type into a note; as you type, the pane increases in length. You can also edit an existing note by left- or right-clicking on the green triangle in the upper right corner of a system or cell, or by editing the Notes field in the Properties view. To close the note, click outside the pane. To delete a note, delete the text within the pane or from the Properties view.

The content of notes is also included in project reports.

Project Schematic Context Menu Options

Right-click in the white space in the Project Schematic for the following options. Not all menu options may be visible at all times, depending on the specific configuration of your project.

Resume
Resumes design point updates that were pending when the project was closed. This option is available only if the project has design points that are paused due to cells in a Pending state.

Refresh Project
Refreshes all cells in the project.

Reconnect
Reconnects to updates that were pending when the project was closed. This option is available only if the project has cells in the Pending state.

Upon opening a project, ANSYS Workbench automatically retrieves the data for any completed background update without the need for you to press the Reconnect button. If you decline to save the project before exiting, this solver data will be discarded and will not be accessible in future ANSYS Workbench sessions.
**Update All Design Points**
Perform an update for the selected entry for all design points defined in the Table of Design Points (available only if parameters are in use and multiple design points exist).

---

**Note**
System Coupling systems do not support design point updates via RSM or an EKM Portal.

---

**Update Project**
Refreshes input data and generates required output data for all cells in the project. If a project contains multiple design points, this option updates only the current design point.

---

**Note**
- If you use this option and the project is being updated remotely via RSM, only the systems and cells above the Parameter Set bar will be submitted to RSM. If needed, DesignXplorer systems can be further updated once the remote project update is completed. For more information, see Submitting Project Updates to Remote Solve Manager (RSM) or an EKM Portal (p. 67).
- System Coupling systems do not support project updates that are submitted to an EKM Portal.

---

**Add to Custom**
You can set up one or more systems with all appropriate connections that represents a project or collection of systems you frequently work with. Use this option to add this collection to your custom templates for easy reuse.

**New system type...**
Select a new type of system to add to the project. Systems added in this manner will appear as independent systems with no connections to existing systems. The choices are the same as you would see in the Toolbox.

**Show Connections Bundled**
Select this option to show multiple links connecting two systems bundled together in a single link, with a label indicating what cells are connected. For example, if cells 2, 3, and 4 are connected between two systems, the schematic would show a single line connecting the systems, labeled as “2:4” to indicate cells 2-4. This option is off by default. You can toggle between off and on by clicking the option in the context menu.

**Show System Coordinates**
Select this option to display the system row and column labels. This option is selected by default.

**Fit**
Select this option to resize the systems in the Project Schematic to better fit in the window as it is currently sized.

**Add/Edit Note**
Displays an editable panel where you can enter notes about a system or cell. There is no limit to the amount of text you can type into a note; as you type, the panel increases in length. You can also edit an existing note by editing the Notes field in the Properties view. To close the note, click outside the panel. To delete a note, delete the text within the panel or from the Notes field in the Properties view.

The content of notes is also included in project reports.
**Link Context Menu Options**

You can right-click a link to see additional context menu options:

- **Delete**
  Deletes the selected link.

- **Properties**
  Displays detailed information about the link, including the type of link, the origination cell of the link, and the destination cell. Details are shown in the **Properties** view.

---

**Note**

To properly update the state of a cell for a linked system, either open the Mechanical application or click the **Update Project** toolbar button.
ANSYS Workbench Tutorials

To access tutorials for ANSYS Workbench, go to http://support.ansys.com/training.
### Glossary

**analysis system**  
A template that has all of the cells required to complete an analysis for a particular type of physics, such as static structural.

**archive**  
Save all project files and data into a single package that can be shared, stored, and reused.

**cell**  
A part of a system that represents a discrete task in the process of completing the overall analysis. Typical cells include **Engineering Data, Geometry, Model** or **Mesh, Setup, Solution, and Results**.

**component system**  
A system template that has the cells necessary to complete only a portion of a complete analysis. Often these systems are task-oriented (for example, a system to create a geometry or to produce a mesh), or are associated with a particular application.

**component update**  
An update of a single component (or cell) within a system in an ANSYS Workbench project. For example, an update of the **Analysis** cell within a project is a component update.

A **Solution** cell update is the only component update currently supported by Remote Solve Manager.

**context menu**  
A context-sensitive list of options available from a cell or other component, accessed via a right-mouse click.

**custom system**  
A system template that has all of systems necessary to complete a coupled analysis, such as FSI or thermal-stress.

**data-integrated application**  
An application that has a separate interface from the ANSYS Workbench project window but that still communicates with ANSYS Workbench.

**Design Exploration**  
Systems in the Design Exploration group are used to access DesignXplorer functionality. These systems connect to the Parameter Set bar in order to drive parametric studies by varying project parameters.

**design point**  
A set of input parameter values and corresponding output parameter values that make up a single solved instance of a project.

**design point update**  
An update of one or more design points in an ANSYS Workbench project. You can update a single design point, a selected set of design points, or all of the design points in a project. During a design point update, solution data is updated only where output parameters have been defined.

Design point updates can be submitted to Remote Solve Manager.

**downstream**  
In the Project Schematic, data flows from top-to-bottom within systems and from left-to-right between systems. A cell is said to be downstream if it is below a cell in the same system, or to the right of a cell in a separate system. Downstream cells use data from upstream cells as input.

**links**  
Systems in the Project Schematic that are dependent on each other in some manner are connected with links. Links with a square terminator
indicate that data is shared between the two cells connected by the link, and links with a round terminator indicate that data is transferred from the upstream to the downstream cell.

**parameter**

A property of a model that can be varied (input parameter) or the result of varying such a property (output parameter). Custom input or custom output parameters can be defined by a constant value; derived parameters are defined by an expression of other parameters (for example, \( P2+3*P3 \)).

**project**

The project is the full collection of systems, components, data, and their connections that you create to achieve an overall CAE goal.

**Project Schematic**

A region of the ANSYS Workbench project window where you will construct and interact with your project. Projects are represented as connected systems displayed in a flowchart form that allows engineering intent, data relationships, and the state of the analysis project to be understood at a glance.

**project update**

An update of an entire ANSYS Workbench project. All of the systems, components, and design points in the project are updated.

**refresh**

An action that reads in all modified upstream data but does not necessarily regenerate the outputs of the cell.

**systems**

A collection of cells that together perform a dedicated task. Types of systems include analysis systems, component systems, and custom systems.

**Toolbox**

A region of the ANSYS Workbench interface, located on the left side of the interface, from which you can choose systems or other components to add to the project. The Toolbox is context-sensitive, meaning the options that appear will change based on what is selected elsewhere in the interface.

**update**

An action that updates data in a particular system or cell with any new information that has been added to the project since the last update and regenerates the outputs.

**upstream**

In the **Project Schematic**, data flows from top-to-bottom within systems and from left-to-right between systems. A cell is said to be upstream if it is above a cell in the same system or to the left of a cell in a separate system. Upstream cells provide their output data to downstream cells.
Appendix A. Product Improvement Program

The specific data that the ANSYS Product Improvement Program collects is described below.

**General Features**

The following feature-specific data is collected:

- Workbench product version
- Country/Region/Time Zone

**Hardware**

The following machine-specific data is collected:

- CPU type
- Number of processors
- Amount of physical memory
- Type of graphics card
- Operating system

**Sessions**

During a session the following is collected:

- Number of:
  - New users
  - Unique users
  - Sessions
- Licenses used by Systems in the Project Schematic
- Number, types, and connectivity of Systems in the Project Schematic
Index

A
ABAQUS Material Keywords, 233
Add/Edit Note, 328
adding a system, 47, 179, 330
analysis systems, 179, 306
   building, 51
ANSYS ACT, 23
ANSYS AIM, 297
ANSYS Product Improvement Program, 1
ANSYS Workbench
   Configuring, 13
ANSYS Workbench interface, 305
   tabs, 305
   views, 305
APIP (see ANSYS Product Improvement Program)
Appearance options, 17
Aqwa
   hydrodynamic diffraction analysis, 189
   hydrodynamic response analysis, 189
archiving projects, 100, 104, 320
AUTODYN analysis, 179, 183, 200
charts, 63
   chart properties, 111
   chart types, 110
   chart zoom, pan, and rotate, 114
   saving, 115
   using the triad, 114
   viewing, 110
clear generated data, 326, 328
command window
   journaling, 100
county window
   journaling, 100
context menu
   link options, 335
   Project Schematic options, 333
   system Schematic options, 332
   tab options, 331
   transfer options, 330
context menus
   common options, 326
   custom parameters, 123
custom systems, 179, 300, 306
customizing, 13
D
data transfer, 47, 56, 330
defining geometry, 52
delete, 326
deleting a system, 61
design Assessment analysis, 179-180
design Exploration, 302, 306
design Exploration options, 24
design points, 123, 134
   activating, 134, 139
   dpall subdirectory, 102
   exporting, 134, 139
   file management, 100
   running multiple, 134
   states, 155
   update order, 137
   updating, 136
   using an EKM Portal, 144
   using RSM, 144
   viewing a table, 310
DesignModeler to Icepak, 260
dp0 subdirectory, 101
dpall subdirectory, 102
duplicate, 326
duplicating a system, 59
C
CDB files
   can be a master mesh in External Data systems, 211
cells, 305
cell states, 315
   common states, 316
   failure states, 318
   solution-specific states, 316
clear generated data, 328
context menu items, 312
displaying properties, 328
Engineering Data, 312
Geometry, 312
Model/Mesh, 312
reset data, 328
Results, 312
Setup, 312
Solution, 312
CFX analysis, 179, 183
   component system, 203
   CFX options, 24
Release 18.2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential information of ANSYS, Inc. and its subsidiaries and affiliates.
duplicating systems, 327

E
Eigenvalue Buckling analysis, 179, 182
EKM
creating a connection, 157
in ANSYS Workbench, 157
launching from ANSYS Workbench, 159
managing connections, 159
monitoring jobs submitted to an EKM Portal, 93
options , 25
submitting Fluids jobs using an EKM Portal, 82
submitting project updates using an EKM Portal, 67
submitting solutions using an EKM Portal, 71
submitting solutions using EKM
submitting Mechanical jobs, 76
updating design points using an EKM Portal, 144
using in ANSYS Workbench, 65
Electric analysis, 179, 182
Engineering Data
component system, 203
Engineering Data cell, 312-313
Engineering Data options, 28
errors
troubleshooting, 119
Excel as a Calculator, 290
exiting
during RSM design point update, 144
during RSM Solution cell update, 92
Explicit Dynamics analysis, 179, 183
Explicit Dynamics analysis (AUTODYN), 200
Explicit Dynamics analysis (LS-DYNA Export), 203
expressions
in parameters, 124
Extensions
options , 23
External Connection Systems, 303
External Data component system, 204
External Data systems
CDB files as a master mesh, 211
External Model component system, 225
Extrusion (Polyflow) analysis, 186
component system, 296

F
file management, 100, 103-107
project directories, 100
dp0 subdirectory, 101
dpall subdirectory, 102
user_files subdirectory, 101
File menu, 320
files
viewing, 307
Finite Element Modeler
component system, 234
Fluent (with Fluent Meshing) analysis
component system, 235
Fluent analysis, 179, 185
component system, 235
Fluent options, 25
Fluid Flow analysis, 179, 183, 185-186
Fluid Flow analysis workflow, 54
FSI analysis, 300

G
generating reports, 21, 322
grouping
geometry
defining, 52
Geometry
component system, 236
Geometry cell, 312-313
Geometry Import options, 29
Graphics Interaction options, 19

H
harmonic acoustics analysis, 187
Harmonic Response analysis, 179, 188
help, 117, 328
Help menu, 326
Hydrodynamic Diffraction analysis, 179, 189
Hydrodynamic Response analysis, 179, 189

I
ICEM CFD
component system, 236
Icepak, 256
context menu options, 258
postprocessing results, 263
properties, 260
tutorial, 276
imported mesh, 55
importing
importing legacy databases, 107
importing files, 100, 103
importing legacy databases, 320
Internal Combustion Engines, 190
interrupting an update, 311
IronPython, 100
Iterations
Ansoft and Icepak, 275

J
Job Monitor, 312
job monitoring, 93
Jobs
- monitoring, 312
- journaling, 322
  - command window, 99
  - console window, 100
  - definition, 98
  - playing a journal, 99
  - preferences, 98
  - recording, 99
  - uses, 98

Journals and Logs options, 19
- journals and scripts, 98

L
- legacy databases
  - importing, 107
- License preferences, 323
- licenses
  - releasing Mechanical during batch runs, 27, 77
- Licensing, 31
- linking a system, 56
- links
  - context menu options, 335
  - LS-DYNA analysis, 203

M
- Magnetostatic analysis, 179, 190
- managing project files, 100
  - archiving projects, 104
  - file types, 106
  - importing files, 103
  - importing legacy databases, 107
  - project locking, 105
  - recovering projects, 104
- MAPDL supported material commands, 231
- Mechanical analysis workflow, 53
- Mechanical APDL
  - options, 23
- Mechanical APDL component system, 276
- Mechanical Model component system, 281
- Mechanical options, 27
- Menu Bar, 305
- menus, 305
- Mesh component system, 286
- Meshing options, 28
- messages
  - viewing, 311
- Microsoft Office Excel component system, 290
- modal acoustics analysis, 191
- Modal analysis, 179, 192
- Modal analysis (Samcef), 179, 192
- Model/Mesh cell, 312, 314
- monitoring jobs, 93
- monitoring RSM jobs, 312
- moving a system, 61

N
- NASTRAN Material Cards, 231
- new project, 320

O
- open a new project, 320
- Options, 16, 323
  - Appearance, 17
  - CFX, 24
  - Design Exploration, 24
  - Engineering Data, 28
  - Extensions, 23
  - Fluent, 25
  - Geometry Import, 29
  - Graphics Interaction, 19
  - Journals and Logs, 19
  - Mechanical, 27
  - Mechanical APDL, 23
  - Meshing, 28
  - Project Management, 17
  - Project Reporting, 21
  - Regional and Language options, 19
  - Repository, 25
  - Solution Process, 21

parameters, 123
- chaining, 124-125
- custom, 124
- derived parameters, 123
- expressions, quantities, and units, 124-125
- input parameters, 123
- output parameters, 123
- Parameter tab, 123
- viewing, 308
- playing a journal, 99
- Polyflow analysis, 179, 186
- component system, 296
- Portal
  - creating a connection, 157
  - in ANSYS Workbench, 157
  - managing connections, 159
  - monitoring jobs submitted to an EKM Portal, 93
  - submitting Fluids jobs using an EKM Portal, 82
  - submitting project updates using an EKM Portal, 67
  - submitting solutions using an EKM Portal, 71
  - updating design points using an EKM Portal, 144
  - using in ANSYS Workbench, 65
postprocessing Icepak results, 263
Pre-Stress Modal analysis, 300
preferences, 16
  journaling, 98
  license, 323
Progress view, 311
project
  archiving, 100, 104, 320
  file management, 100
    archiving projects, 104
    importing files, 103
    importing legacy databases, 107
    locking projects, 105
    recovering projects, 104
  file types, 106
  importing, 100, 103, 320
    importing legacy databases, 107
    locking projects, 105
  open, 320
  recovery, 100, 104
  saving, 320
Project Management options, 17
Project Reporting options, 21
project reports, 115
Project Schematic, 305
  context menu options, 333
Project Tab, 47
properties, 326, 328
  viewing, 309
Python, 100

Q
quick help, 326, 328

R
Random Vibration analysis, 179, 192, 300
recently used files, 328
recording a journal, 99
recovering projects, 100, 104
refresh, 326
Regional and Language options, 19
Remote Solve Manager, 63
rename, 326
replacing a system, 61
Reports, 21, 322
Repository
  options, 25
reset, 326
reset data, 328
Response Spectrum analysis, 179, 193, 300
Results cell, 312, 315
Results component system, 297
retained design points, 139
Rigid Dynamics analysis, 179, 193
RSM
  monitoring jobs, 93, 312
  submitting Fluids jobs using RSM, 82
  submitting project updates using RSM, 67
  submitting solutions using RSM, 71
  submitting Mechanical jobs, 76
  using in ANSYS Workbench, 63
S
saving, 320
scripting, 322
  definition, 100
setting journaling preferences, 98
setting license preferences, 323
Setup cell, 312, 314
single license sharing, 31
Solution cell, 312, 314
Solution Process options, 21
solve manager, 67, 71
states, 315
  common states, 316
  design points, 155
  failure states, 318
  solution-specific states, 316
Static Structural analysis, 179, 194
Static Structural analysis (Samcef), 179, 194
Steady-State Thermal analysis, 179, 194
surface data
  format for External Data, 212
system categories, 305
System Coupling
  component system, 298
systems, 179, 199, 300, 306
  adding, 47, 179, 330
  component, 199
  deleting, 61
  dependent (connected), 56
  duplicating, 59
  duplicating systems, 327
  independent, 56
  linking, 56
  moving, 61
  naming, 50
  renaming, 50
  replacing, 61
types of, 179
updating systems, 327
Tabs
  Project Tab, 47
tabs, 305
text files
    importing into Mechanical APDL, 204, 225
thermal results from Icepak to Mechanical, 264
Thermal-Electric analysis, 179, 195
Thermal-Stress analysis, 300
Throughflow analysis, 198
Toolbar
  File menu, 320
  Help menu, 326
  Tools menu, 323
    Options, 16
  Units menu, 325
View menu, 323
Views
  messages, 311
  outline view, 308
  progress, 311
  properties, 309
  table, 310
  viewing files, 307
Toolbar, 13, 305-306
Tools menu, 323
Topology Optimization analysis, 195
transfer data, 330
Transient Structural, 198
Transient Structural analysis, 179
Transient Thermal analysis, 179, 199
troubleshooting, 119
TurboGrid analysis, 298
Tutorial
  Icepak in Workbench, 276
Tutorials, 337
types of parameters, 123
Units
  base and common units, 15
  configuring, 13
  custom unit systems, 16
  in parameters, 124
  menu, 325
  predefined unit systems, 15
  selecting, 325
update, 326
updating design points, 136
  activating and exporting, 139
  update order, 137
  using an EKM Portal, 144
using RSM, 144
updating systems, 327
user_files subdirectory, 101
using ANSYS Workbench, 63, 306
  adding a system, 47
  building analyses, 51
  charts, 63
  deleting a system, 61
  duplicating a system, 59
  EKM Portal, 65
  journals and scripts, 98
  linking a system, 56
  moving a system, 61
  naming systems, 50
  parameters and design points, 123
  project reports, 115
Remote Solve Manager, 63
replacing a system, 61
using an EKM Portal, 67, 71
using an EKM Portal to submit Fluids jobs, 82
using EKM or Cloud Portal
  submitting Mechanical jobs, 76
using RSM, 67, 71
  submitting Mechanical jobs, 76
using RSM to submit Fluids jobs, 82
Using ANSYS Workbench
  adding a system, 179
  using the command window
    journaling, 99
View menu, 323
views, 305, 323
  parameters and design points, 123
  viewing a table of design points, 310
  viewing charts, 110
  viewing files, 307
  viewing messages, 311
  viewing progress, 311
  viewing properties, 309
  viewing the outline, 308
Vista AFD analysis, 298
Vista CCD analysis, 299
Vista CPD analysis, 299
Vista RTD analysis, 300
Vista TF analysis, 300
Window layout, 323
workflow
  Fluid Flow analysis, 54
Index

Mechanical analysis, 53